jventura

[22/07/2013] Eco CM7 - A minimalist cm7 build

Recommended Posts

jventura    145

Hi there,

 

Hello, Can I install Effem (FM Radio application) from CM9 to this rom?

 

Effem app does not work in CM7, because the FM radio framework in the source code is different from CM7 to CM9..

 

Thanks for this rom, I just flashed it to my GF's phone and seems nice. If remember right, the cm7 is best for our blades because the kernel supports it natively or something like that, compared to later cms?

When I had blade long ago, I used always the latest CM from konstat.

 

The ZTE Blade kernel comes from Android 2.1 or 2.2, I don't remember, so it has nothing to do with CM7/Android 2.3. However, if you want stability and speed, I recommend Eco CM7 or Eco CM9 (if you want a more modern look and feel). I'm with Eco CM7 on my Blade for the past 6/7 months and everything is still running smooth and stable..

Share this post


Link to post
Share on other sites
MaK11-12    1

Could someone please provide a working link to the rom please? The link in the first post is down.

Share this post


Link to post
Share on other sites
jventura    145

Could someone please provide a working link to the rom please? The link in the first post is down.

 

Hi there,

 

I've updated the ROM and Gapps links in the first page..

 

 

Edited by jventura

Share this post


Link to post
Share on other sites
MaK11-12    1

Hi there,

 

I've updated the ROM and Gapps links in the first page..

 

Could you upload it to a better host like mediafire please?

multiupload takes me to the iLivid website to download some malware to do with video converting.

Share this post


Link to post
Share on other sites
Elio Lopes    0

Could you upload it to a better host like mediafire please?

multiupload takes me to the iLivid website to download some malware to do with video converting.Rom

Eco-CM7-20130722-stable-blade -https://www.dropbox.com/s/kfcgg3izlp1cjks/Eco-CM7-20130722-stable-blade.zip

gapps-gb-20110828-signed          -https://www.dropbox.com/s/uvoiwwdi4twogs3/gapps-gb-20110828-signed.zip

LiveWallpapers_EcoCM7               -https://www.dropbox.com/s/jqmspjajpfp0cx9/LiveWallpapers_EcoCM7.zip

Themes_EcoCM7                          -https://www.dropbox.com/s/kkfvfpy0om6anyk/Themes_EcoCM7.zip

Assortment_EcoCM7                     -https://www.dropbox.com/s/589gcf6wlzrn7t1/Assortment_EcoCM7.zip

Share this post


Link to post
Share on other sites
dandreye    0

Many thanks to jventura for this wonderful ROM. 

 

After LiveWallpapers and CM Themes installation my battery etc have all turned blue. Is their colour user configurable now? If so where do I change it back to green? If not is there any way to roll back to the system state with green ones? Will resetting to factory defaults help or re-flashing the ROM is the only option left?

 

Thanks in advance!

 

 

Update: the app called Themes among those installed did the job.

Edited by dandreye

Share this post


Link to post
Share on other sites
dandreye    0

Could anyone please upload the 3 launchers elsewhere, e.g. at dropbox? These links are all enforcing iLivid instead of the corresponding content described:

 
and:
Edited by dandreye

Share this post


Link to post
Share on other sites
dandreye    0

Another question: one of the guides on setting the language that isn't displayed among those in Language & Keyboard assumes adding it manually into something like [/system]/etc/customize/default.xml or [/system]/etc/customize/CID/default.xml. I cannot find customize directory anywhere (using ES File Explorer with "Display hidden files" enabled). Which file do I add it into in this ROM? I do know there are several locale apps out there, just want to understand if there's a way to add a "missing" language w/o any of them.

Share this post


Link to post
Share on other sites
darkglobe87    0

Play store no longer working on this. ROM flashed as in OP. Play store works until play services installs in background, then all I get is a white screen. 200mb /system so space hopefully isn't the issue. 

All wipes completed. No other issues in ROM, just no play store whatsoever once it finishes updating. Can someone please help advise me why? This old hunk of junk is the only phone I have since my daily driver went for a swim!

 

UK TPT updated Gen2 OSF. 

Also Konstat's CM 10.1 ROM is the only one I've found without this problem but the ROM is unusable for me. Have tried Swedish Snow RLS7 and Eco CM9. Neither work.

 

Thanks!

Share this post


Link to post
Share on other sites
dandreye    0

Hi All,

Does anyone happen to know how to prevent automatic Google Play Services installation with EcoCM7? It makes it into the smartphone now and then, eating up all storage. 

I already tried unchecking automatic app updates checkbox in Google Play Market and even in global settings but surprisingly it didn't help. 

If there's no way to block its installation is there perhaps a dummy or lightweight version of it that I could install instead, preventing its automatic updates somehow?

 

Many thanks in advance!

Edited by dandreye

Share this post


Link to post
Share on other sites
darkglobe87    0

I forget what I did but I think I froze Google services framework. the play services will appear when it downloads try to catch it before it fully installs I think

Share this post


Link to post
Share on other sites
dandreye    0
On 11/1/2016 at 11:50 AM, darkglobe87 said:

I forget what I did but I think I froze Google services framework. the play services will appear when it downloads try to catch it before it fully installs I think

I really wish I followed your advice back then: this way I wouldn't run into the same issue shortly after expanding internal memory, which took me a while to sort out as sadly such old stuff doesn't attract much attention anymore. Looks like all 9.x.x versions of Google Play Services behave this way while the 8.x.x ones that I tried so far are fine (which however autoupdate to 9.4.52 pretty soon, causing the issue). According to my research the problem seems to be on since at least mid-April 2016, I guess about the time the first Google Play Services 9.x.x releases came out.

To all who get no further than white screen in Google Play Market with this ROM: freezing Google Play Services (e.g. in Titanium Backup) followed by clearing Google Play Market data can be used as a workaround. Alternatively they all point at some microG GmsCore (instead of Google Play Services) but I haven't tried it myself.

Edited by dandreye

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.