david_inuk

Battery & wifi issues

6 posts in this topic

Hi

Thanks to Pauls excellent review, I have purchased one of these.

However, this battery is seriously messed up!

After being charged to 100%, the battery crashes by 10% within half an hour!!

If this keeps up, this phone wont last an afternoon, never mind a day. And I am coming from a Galaxy S2, which has a terrible battery too!!

Is there something wrong with my phone, or is this usual???

Also, I keep losing connectivity when connected via wifi. The connection stays alive, but it wont connect to the internet until I disconnect and reconnect.

Any ideas??

Thanks a million!!

0

Share this post


Link to post
Share on other sites

You probably have a defective handset. Mine works fine with battery (usually 2 days) en WiFi.

0

Share this post


Link to post
Share on other sites

Have you charged the battery for 8 hours the first time as explained in the manual? Make sure GPS, Bluetooth, 3G, Wifi... aren't running when they don't need to be. Make sure no heavy apps are secretly running in the background. Test the phone for a couple of days (let it deplete, and charge 100%), i think Android needs to adjust to your battery. The amount shown might not be the actual amount used. If all this doesn't work, your device is probably bust. Which wouldn't surprise me.

Honestly, i don't get all the good reviews this phone is getting, because vital stuff doesn't seem to be working. I'm going to try and resell the phone as soon as i get another one. Currently eyeballing the Xiaomi Mi Two.

0

Share this post


Link to post
Share on other sites

What do you call "vital functions" that do not work? The phone, both SIMs work, 3G on either SIM, screen, Android, WIFI etc. I dislike some of the choices made (like the ON-OFF button), but it works fine for me.

0

Share this post


Link to post
Share on other sites

What do you call "vital functions" that do not work? The phone, both SIMs work, 3G on either SIM, screen, Android, WIFI etc. I dislike some of the choices made (like the ON-OFF button), but it works fine for me.

Bluetooth is a joke. Using this phone handsfree in a car is no-go. That's vital to me. Apparently this has been reported to Acer two months ago, but when you contact customer service, they seem to be clueless about the problem as well as about when a possible software update might come. Other phones with the same chipsets do not have the same issues. So it's a software issue, easily corrected, but Acer doesn't seem to think it's important enough of a feature.

0

Share this post


Link to post
Share on other sites

Ok, but that is not something everybody uses and hence I don't see that as vitall. Annoying, yes, but only a dealbreaker for some.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.