• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.
Sign in to follow this  
Followers 0

Screen won't stay lit on G300

8 posts in this topic

Posted · Report post

My wife has a G300 ascend which suddenly switched off while she was playing a game and was unresponsive to any input. I removed the battery and when it booted up the huawei logo flashed breifly then went out. I then randomly stabbed the buttons and the backlight flashed on enough for me to see the lock screen but too quickly for me to input anything. I left the battery out for a few days but the display doesn't want to light at all now, although you can hear the volume change noise when you press the vol rocker button and the 3 keys light up below the display, so I'm assuming it booted OK.

It's not been dropped and the only bit of software fiddling that has been done to this phone was a firmware update about a month ago, but its been fine since that, until now.

Any ideas?

0

Share this post


Link to post
Share on other sites

Posted · Report post

flash another rom on it and see if it works

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Will it boot into stock recovery? Pull battery out for a few secs then replace and boot with volume UP-held down as well as power (keep holding both buttons for several secs after phone begins to startup). Do you get the recovery menu?

Edited by Hogweed
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Tried booting to stock recovery, felt it vibrate, but screen stayed black. It does boot in the normal way because I can hear the sound when using increase/decrease volume buttons, but as there is no back light so I can't see anything on the display. If I connect it to my PC Hi Suite tells me USB debugging is not switched on and windows can access some basic files (document, driver, autorun.inf and mobile partner.ico)

Is it possible that the back light has just failed or is it more likely to be the software controlling it?

Edited by Sgt.Cupid
0

Share this post


Link to post
Share on other sites

Posted · Report post

I would say definitely the back light. Return it immediately.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Unfortunately it's out of warranty, was hoping you guys on here, who have far more knowledge than me, would help to fix it. Is there any way of getting into the phone settings via PC ?

Also, if it is a back light failure, can it be replaced or would it mean a complete new screen? And where could I get a job like that done?

0

Share this post


Link to post
Share on other sites

Posted · Report post

Would something like mymobiler work? Back light is usually a separate component. You had it more than a year already?!

0

Share this post


Link to post
Share on other sites

Posted · Report post

Thanks Frodo, not aware of mymobiler so i've installed it but it doesn't see the G300. I don't think USB debugging or Unknown source were enabled before phone went tits up. :(

I tried shining a torch at the display and can just make out the home screen. Is there any little trick to illuminate the screen from the front just enough to see the touchscreen 'buttons' so I can get into the menu?

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.