KonstaT

[DEV][ROM][24.7.] CyanogenMod 10.1 (Android 4.2.2)

Recommended Posts

GGEuDraco    0

EDIT - Found the answer myself - flashing a new TPT, as there was indeed not enough space in /system. I think KonstaT might need to patronise us on that point for any newbies/occasional hackers in future :)

---

Hey guys, MoDaCo lurker turned newbie to the forums. Been interested in updating from my tried and trusty Swedish Snow [thanks for that, KonstaT], but facing some problems - Status 7 problems.

When flashing the latest CM10.1 zip file on CWM [KonstaT's v6.0.2.7], I'm getting the symlink error that aborts the installation. The log says that it's failing to symlink /system/xbin/[multiple files] to busybox: Out of memory. I've done the usual things: redownloading the zip, MD5 hash checking, wiping every single thing that CWM touches, using adb sideload [error:closed].

The only weird thing I've done is make a 2GB partition on the SD card using [the same version of] CWM, in order to set up link2sd.

Anything else I need to say to help/butter up KonstaT and his excellent work otherwise? ;)

Edited by GGEuDraco

Share this post


Link to post
Share on other sites
matcho13579    51

Don't use CWM to partition your SD card - the second partition (if I remembered it right) is ext2 and this ROM is able to use ext4, which is way more better than ext2...also you can install recovery image with TPT when repartitioning your internal memory

Share this post


Link to post
Share on other sites
elrond_bs    84

Well, it is written exactly below the download links: :)

You'll need at least 160mb system partition for the ROM and gapps to fit. Both gen1->gen2 and G2 TPTs are available at Amphoras' TPT Helper.

BTW, you don't need to waste 2 GB to ext, 1 GB should be enough (I use 800MB and still have 150 free with all apps linked, but no dalvik or data). Also matcho13579 is right, CWM sucks for creating partitions, use card reader and MiniTool Partition Wizard (it's free) on your computer to create ext4. And if you don't need to control what part of each app will be linked to ext, you don't need link2sd - try Mounts2SD or CronMod. They are a little more reliable.

Edited by elrond_bs

Share this post


Link to post
Share on other sites
peetu20    104

Well, it is written exactly below the download links: :)

BTW, you don't need to waste 2 GB to ext, 1 GB should be enough (I use 800MB and still have 150 free with all apps linked, but no dalvik or data). Also matcho13579 is right, CWM sucks for creating partitions, use card reader and MiniTool Partition Wizard (it's free) on your computer to create ext4. And if you don't need to control what part of each app will be linked to ext, you don't need link2sd - try Mounts2SD or CronMod. They are a little more reliable.

I have never had any problems with creating ext partition from recovery :)

Share this post


Link to post
Share on other sites
пенис    14

I have never had any problems with creating ext partition from recovery :)

Have always had nothing else but problems to use CWM in partitioning sd-card.

The best way to manage all kind of disks is Minitool Partition Wizard. ;)

Share this post


Link to post
Share on other sites
monstrmprz    0

Hi!

I used cm10.1-20130329 Konsta rom, but i want to replace! I download 05.14 rom and i wipe dalvik cache, Install zip from sdcard->choose zip from sdcard->I choose the 05.14 rom->yes but when i choose yes and trying to install the ROM the recovery is shutting down and the recovery return to main menu :( okay, i choose mounts and storage menu, and i format system,data,cache,boot, and retry install the rom, but again doesn't work :( But when install the 03.29 rom, the setup is work fine! I do not understand...

UPDATE: bad MD5, retry download, work :)

Edited by monstrmprz

Share this post


Link to post
Share on other sites
GGEuDraco    0

Well, it is written exactly below the download links: :)

Maybe so, but I assumed that /system and /data are folders - not partitions. Therefore, the flashable zip sorts out the sizes of chunks of internal memory. It's been over two years since I last did a TPT, and it was done a lot differently [the sanfranciscoandroid.co.uk way, which was a lot more blackbox].

...MiniTool Partition Wizard (it's free) on your computer to create ext4....try Mounts2SD or CronMod. They are a little more reliable.

I'd prefer a partition tool that doesn't dig its nasty little bloaty files deep into my Windows Registry ;) so that's gparted-live for me. To me, saying things like cron makes me think of low-level Linux command-line commands; sounds more scary than L2S - I'll check the XDA thread on it anyways.

Not my intention to sound like a newbie - just that some people need to be kept up to date with new ideas/developments that's now standard practice.

Edited by GGEuDraco

Share this post


Link to post
Share on other sites
peetu20    104

Please read post #1. This thread is not a sandbox for noobies. :P

:D

Share this post


Link to post
Share on other sites

lush rom, very smooth. many thanks KonstaT :)

Share this post


Link to post
Share on other sites
dreis911    61

Maybe so, but I assumed that /system and /data are folders - not partitions. Therefore, the flashable zip sorts out the sizes of chunks of internal memory. It's been over two years since I last did a TPT, and it was done a lot differently [the sanfranciscoandroid.co.uk way, which was a lot more blackbox].

But, were you doing a TPT, flashing a ROM or both?

Share this post


Link to post
Share on other sites
gunapriyan    18

Konsta,

I am unable to make conference call....When i tried it shows "Unable to make conference"

How can i fix this issue my friend.

Share this post


Link to post
Share on other sites
monstrmprz    0

I formatted my sdcard(16Gb).I used minitool partition wizard. Here are the partitions: FAT32 primary, 12Gb, ext4 primary 2 Gb, but when i choose the "choose zip from sdcard" recovery say: "E:Can't mount /sdcard/" wtf.. but my computer(win7) sees the 12GB partition and i can copy data to the partition...please help :S

I do not know what to do...I formatted the sdcard with minitool,that the whole is a partition(fat32) and "E:Can't mount /sdcard/". I tried format to do the same with the original win7 partition wizard and nothing happened, "E:Can't mount /sdcard/". My sdcard is broken? But my computer still sees the 16GB fat32 partition and work fine..or the card reader in my blade broken?

NICE.I tried with my old 2gb sdcard and works fine..but my computer only sees 12GB of 16GB :///

Edited by monstrmprz

Share this post


Link to post
Share on other sites
peetu20    104

I formatted my sdcard(16Gb).I used minitool partition wizard. Here are the partitions: FAT32 primary, 12Gb, ext4 primary 2 Gb, but when i choose the "choose zip from sdcard" recovery say: "E:Can't mount /sdcard/" wtf.. but my computer(win7) sees the 12GB partition and i can copy data to the partition...please help :S

I do not know what to do...I formatted the sdcard with minitool,that the whole is a partition(fat32) and "E:Can't mount /sdcard/". I tried format to do the same with the original win7 partition wizard and nothing happened, "E:Can't mount /sdcard/". My sdcard is broken? But my computer still sees the 16GB fat32 partition and work fine..or the card reader in my blade broken?

NICE.I tried with my old 2gb sdcard and works fine..but my computer only sees 12GB of 16GB :///

I think u must format the fat32 partition to LOGIGAL, not primary, ext4 is fine as primary :)

If u still do not get it working, just go to advanced in recovery, and format sd card, and at all I highly recommend to do partitions for sdcard with recoverys option, no need to play with minitool or gparted :D

Share this post


Link to post
Share on other sites
matcho13579    51

I think u must format the fat32 partition to LOGIGAL, not primary, ext4 is fine as primary :)

If u still do not get it working, just go to advanced in recovery, and format sd card, and at all I highly recommend to do partitions for sdcard with recoverys option, no need to play with minitool or gparted :D

no no no no no....both of the partition must be primary or they will not work

Share this post


Link to post
Share on other sites
monstrmprz    0

I think u must format the fat32 partition to LOGIGAL, not primary, ext4 is fine as primary :)

If u still do not get it working, just go to advanced in recovery, and format sd card, and at all I highly recommend to do partitions for sdcard with recoverys option, no need to play with minitool or gparted :D

no no no no no....both of the partition must be primary or they will not work

Thank you peetu20 and matcho1357, but in my blade choose mounts and storage menu->format sdcard->

Recovery:

Formatting /sdcard...

Error mounting /sdcard!

Skipping format..

Done.

Now i format sdcard with minitool fat32 PRIMARY, but just sees 12GB of 16GB(original max=14.9GB). Now i running chkdsk and search sector errors with win7, but i think my sdcard is dead :(

Share this post


Link to post
Share on other sites
elrond_bs    84

Could be damaged SD card. :(

But always format both partitions as Primary and MiniTool PW is better than Clockworkmod.

Share this post


Link to post
Share on other sites
monstrmprz    0

Okay.:/ Chkdsk is done: No problem with the disc. That's awesome.. Thank you to everybody! :)

Yeeeeees I did it! :D i was stupid, last formatting i used 3 partition, fat32,ext4 and linux swap..up to now i connect the sdcard with the recovery mount option, but now find my card reader and now see the 3 partition yeeeeeeeees :D I formatting the sd card to fat32 primary, size=12.4GB and + 1.5GB ext4 +s2e on cm10 works fine :)

Edited by monstrmprz

Share this post


Link to post
Share on other sites
elrond_bs    84

Why do you even try to format without card reader?? :blink:

...use card reader and MiniTool Partition Wizard (it's free) on your computer to create ext4...

Share this post


Link to post
Share on other sites
peetu20    104

Why do you even try to format without card reader?? :blink:

It may be that blade doesnt allow it, or it may cause issues for the system. When I tried to use minitool with blade, I couldnt manage partitions... those were invisible :(

Share this post


Link to post
Share on other sites
I900-Nutzer    1

Hiho!

Short Question: what is the best I/O-Scheduler for this ROM? The Default which is BFQ?

Thx! Best Way to test this out?

Thx!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.