• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

[DEV][ROM][24.7.] CyanogenMod 10.1 (Android 4.2.2)

3452 posts in this topic

Posted (edited)

So, I just downloaded this ROM and tried to install it with CWM 6.0.2.7... Didn't work, it aborted and said something like "Status 7". I tried downloading CM10 (4.1.2 version). Happend the same thing there...I wiped data/factory reset first, and also did a wipe dalvik cache. What am I doing wrong?

The problem is in the CWM, install other CWM. With me couldn´t read the sd card and i realize it was a CWM issue, install other and try it. Sorry my English.

Edited by fazbarulho
0

Share this post


Link to post
Share on other sites

Posted (edited)

Lower class cards generally have faster random read/write so would actually be better with small files (cache etc)

OFFTOPIC:

Actually, it's seems to be true only for some particular cards - Benchmark Results: Random Reads And Writes.

The apps in the ext partition are not small files (typically between 200KB and 40MB), dalvik cache is a little below that, but still usually above 256KB (from what I've seen in my apps).

So higher class card is better.

Edited by elrond_bs
0

Share this post


Link to post
Share on other sites

Posted (edited)

OFFTOPIC:

Actually, it's seems to be true only for some particular cards - Benchmark Results: Random Reads And Writes.

The apps in the ext partition are not small files (typically between 200KB and 40MB), dalvik cache is a little below that, but still usually above 256KB (from what I've seen in my apps).

So higher class card is better.

Yea those results are a mixed bag really, there is a decent thread on xda about it (don't have link atm) and the general consensus is that random r/w tests (4KB files) are faster on class 4 and 2. Apparently the way higher class cards work increases latency, to achieve greater sequential throughput? Also reliability of class 10 cards is a serious point, I've had several cards of different brands die after 6-12 months, could just be unlucky though (wasn't using them for swap either)

Edit: here's the badger: http://forum.xda-developers.com/showthread.php?p=15269669#post15269669 I'm interested in what people think. :)

Edited by 99x
0

Share this post


Link to post
Share on other sites

Posted

It's so much of a mixed bag that the only conclusion can be that the class ratings are utterly worthless (unless you use the FAT filesystem and write megabyte-sized files). This is my experience after working with various embedded boards and the Raspberry Pi.

1

Share this post


Link to post
Share on other sites

Posted

Konsta, Thanks for your continuous development in 10.1.....I shall be happy if you include some Paranoid Features in 10.1. if possible.

0

Share this post


Link to post
Share on other sites

Posted (edited)

Umm, okay idk why is this happening.. But, when I am charging I do not disconnect when it shows 'Charged'. I keepit connected and then, open Battery Calibrator. It also shows your battery mV. I keep the charger connected till it reaches 4200mV and I get an amazing battery life! On very high usage, I am getting around 5-6 hours!

edited...

when will modaco implemet flood control for forum posts...

and some ppl will now say im spamming...:X

Edited by vNa5h
0

Share this post


Link to post
Share on other sites

Posted

Umm, okay idk why is this happening.. But, when I am charging I do not disconnect when it shows 'Charged'. I keepit connected and then, open Battery Calibrator. It also shows your battery mV. I keep the charger connected till it reaches 4200mV and I get an amazing battery life! On very high usage, I am getting around 5-6 hours!

It is implemented in that way for a reason...

when the battery is charged to 100% it is never completely charged and vice versa when it reaches 0%

Pl dont do it more often...

reduces the battery life...

0

Share this post


Link to post
Share on other sites

Posted

Awesome job as always Konstat! After upgrading from your CM10 build I got an average Antutu score of 2600 as opposed to 2300 :)(although who knows how antutu really works :-D)..

just 2 quick questions...:

- I could find neither performance nor developer options, hence I do not know how enable USB debugging(presume this will be added

- The chronus home is really an improvement. It basically just doubles the lockscreen and is quite laggy. Plus I could not find a way to disable chronus only... either 2 lockscreens or none.

I presume that all of the above is already on your list, and am looking forward to your next release..

Oh, one thing which happens with CM10 as well sometimes..: Sometimes after rotation, the whole screen is squeezed into the navigation bar at the bottom and the rest of the display is greyed out. Have you run into this? Can I help with soe logs or something to get this fixed?

Thanks for sharing,

G

0

Share this post


Link to post
Share on other sites

Posted (edited)

Awesome job as always Konstat! After upgrading from your CM10 build I got an average Antutu score of 2600 as opposed to 2300 :)(although who knows how antutu really works :-D)..

just 2 quick questions...:

- I could find neither performance nor developer options, hence I do not know how enable USB debugging(presume this will be added

- The chronus home is really an improvement. It basically just doubles the lockscreen and is quite laggy. Plus I could not find a way to disable chronus only... either 2 lockscreens or none.

I presume that all of the above is already on your list, and am looking forward to your next release..

Oh, one thing which happens with CM10 as well sometimes..: Sometimes after rotation, the whole screen is squeezed into the navigation bar at the bottom and the rest of the display is greyed out. Have you run into this? Can I help with soe logs or something to get this fixed?

Thanks for sharing,

G

To get Development options in CM10.1, go to settings -> about phone -> tap rapidly on build number. You will get all the options including performance settings.

Check System --> Clock Widget for Chronus widget settings.

Edited by anantk
0

Share this post


Link to post
Share on other sites

Posted

Hey KonstaT, something for you ;-)

I have successfully made vsync events (i.e. Project Butter) work. This was never really implemented correctly for MDP 3.00 in the MSM7x27, but the hardware can do it, and after a bit of reading code and hacking around, it seems to work just fine! It feels a little bit smoother with vsync event timing enabled, especially touch latency appears to be reduced. But I have no good way to measure this.

The most important bits can be found in my kernel tree, but the device tree requires some additional updates, too.

Please test this, if you can.

1

Share this post


Link to post
Share on other sites

Posted (edited)

To get Development options in CM10.1, go to settings -> about phone -> tap rapidly on build number. You will get all the options including performance settings.

Check System --> Clock Widget for Chronus widget settings.

Hahaha - I was wondering about that, I did download No-Frills CPU Control and when I opened it I saw my previous CPU settings were preserved from CM10 so figured the support had to be there somewhere, thanks for the tip.

Edited by snarkavenger
0

Share this post


Link to post
Share on other sites

Posted

You call that a tip? :lol: It is repeatedly asked and answered on every page. This is a change by Google, and even Google search (for developer options in 4.2) will reveal it. May be even now, someone will ask it again, just after my post. :D

0

Share this post


Link to post
Share on other sites

Posted

Is it just me or the lock screen on the ZTE blade is too small?

0

Share this post


Link to post
Share on other sites

Posted

Is it just me or the lock screen on the ZTE blade is too small?

The pattern unlock is tiny compared to cm10, the clock is bigger though so might just be normal layout

0

Share this post


Link to post
Share on other sites

Posted

Is it just me or the lock screen on the ZTE blade is too small?

unlock pattern was small until 15. 1. release, now it's normal.

0

Share this post


Link to post
Share on other sites

Posted (edited)

Hi, Is there any way to solve this problem? It's a game Plague Inc.. For solving the problem would be very happy. Thank you.

ytujazem.jpg

Edited by peta809
0

Share this post


Link to post
Share on other sites

Posted

Konsta, I am facing a problem. That is my phone is getting slow while various operations. How to solve it?

0

Share this post


Link to post
Share on other sites

Posted

Konsta, I am facing a problem. That is my phone is getting slow while various operations. How to solve it?

Konsta already answered your problem:

...I'm really not interested in hearing whining about non-working things (and questions when they will be fixed), actually I couldn't care less if you have issues with this ROM....

1

Share this post


Link to post
Share on other sites

Posted (edited)

Ganster, KonstaT,

I tested Bluetooth HID devices (mouse and keyboard paired good, connection can not be established)

Build cm-10.1-20130119-KonstaKANG-blade.zip

it works perfectly in cm-10-20130108-KonstaKANG-blade.zip ([DEV][ROM][8.1.] CyanogenMod 10 (Android 4.1.2)).

How to debug trouble?

Edited by Ilmin
0

Share this post


Link to post
Share on other sites

Posted

Ganster, KonstaT,

I tested Bluetooth HID devices (mouse and keyboard paired good, connection can not be established)

Build cm-10.1-20130119-KonstaKANG-blade.zip

it works perfectly in cm-10-20130108-KonstaKANG-blade.zip ([DEV][ROM][8.1.] CyanogenMod 10 (Android 4.1.2)).

How to debug trouble?

On PC:

adb logcat > log.txt

On phone:

logcat > /sdcard/log.txt

0

Share this post


Link to post
Share on other sites

Posted

To get Development options in CM10.1, go to settings -> about phone -> tap rapidly on build number. You will get all the options including performance settings.

Check System --> Clock Widget for Chronus widget settings.

Thanks anantk for the quick reply... I found the thing with the dev options on another thread, quite hidden I would say :)

However my issue with chronus, its not about the widget itself. I am annoyed by the 2 lockscreens. I uninstalled the chronus widget completely as I have no use for it. But still I get either 2 lockscreens in sequence(with "screen lock = slide), or none(screen lock = none).

Do you know a way of tweaking this to have lock screen appearance just like in 4.1?

Merci,

G

0

Share this post


Link to post
Share on other sites

Posted (edited)

Thanks anantk for the quick reply... I found the thing with the dev options on another thread, quite hidden I would say :)

However my issue with chronus, its not about the widget itself. I am annoyed by the 2 lockscreens. I uninstalled the chronus widget completely as I have no use for it. But still I get either 2 lockscreens in sequence(with "screen lock = slide), or none(screen lock = none).

Do you know a way of tweaking this to have lock screen appearance just like in 4.1?

Merci,

G

I also would like just for a simple lockscreen with a pattern.

Anyways...Thanks Konstat for this great rom

Edited by Mike69pt
0

Share this post


Link to post
Share on other sites

Posted

Thanks a lot KonstaT, for all the time that you've spent and all the work you've done! : )

0

Share this post


Link to post
Share on other sites

Posted

I also would like just for a simple lockscreen with a pattern.

Anyways...Thanks Konstat for this great rom

Lock screen policy app on Google play. Install it and deactivate widgets and camera. Job done.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.