• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

[DEV][ROM][24.7.] CyanogenMod 10.1 (Android 4.2.2)

3452 posts in this topic

Posted · Report post

I m facing a strange problem .. My phone when plugged to the charger,it doesn't show any increment on the indicator . If charged when phone is switched off then it charges, what should I do ?? BTW great work @konsta

0

Share this post


Link to post
Share on other sites

Posted · Report post

Happy to see KonstaT back, can't wait to try out this rom

0

Share this post


Link to post
Share on other sites

Posted · Report post

Great Job KonstaT! Long live the blade!

0

Share this post


Link to post
Share on other sites

Posted · Report post

ROM is stable and smooth. I had only one phone restart, when my blade was in my pocket ;p

I am very surprised by the smoothness of the interface... it is smoother than any JB ROM!

Generally there are no problems :)

Merry Christmas for all of you! ;>

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Wrong thread, good work Konstat and Hyvää joulua. :)

Edited by Snap.IT
0

Share this post


Link to post
Share on other sites

Posted · Report post

Hi KonstaT!

I tried all versions of your 4.1.2 port from 2012.08.21, but in all of them the voip bug still exists, so i can't upgrade to newer versions, i must use the 2012.08.21 release.

But now i tried this 4.2.1 port and surprise, the voip works well! So i immediately upgrade to this. Thank you for your great work!

0

Share this post


Link to post
Share on other sites

Posted · Report post

merry xmas folks. well done konstat - i've been watching your github with anticipation, just did a custom build but noticed there's a shedload of patches to apply to lose 40mb+ of cyanogenmod/google cruft again.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Hi KonstaT,

You are the best judge for this CM 10.1 ZTE ROM development.

But could you please check URL http://forum.xda-developers.com/showthread.php?t=1836116, where users are having JB ROM on their Sony Xperia X8 mobile, which is less powerfull than our ZTE Blade mobile with native USB tethering, Native WIFI tethering and even FM Radio functionality working.

0

Share this post


Link to post
Share on other sites

Posted · Report post

great job KonstaT.

thank you. :D

0

Share this post


Link to post
Share on other sites

Posted · Report post

Don't know mmaybe it'd be helpful for KonstaT. In http://www.modaco.co...-now-available/ devs worked on porting BT for 4.2 Android. They has success and now BT works on CM 10.1 ROMs for Advent Vega tablet.

Well, I've been looking for a device with working bluetooth on a non-Broadcom bluetooth hardware. Maybe I somehow missed the 'success' part as it seems that bluetooth is still an issue for them?

Google changed the bluetooth stack completely in 4.2 and the new bluedroid is developed by Broadcom. There's also a Qualcomm based solution in AOSP (for Nexus 4) but it is only partially open and for much newer Atheros chip (Atheros WCN3660?) than what we have. I did manage to make little progress with bluetooth using the qcom stuff, but pretty much only sign of life that it's giving is a wakelock (good old msm_serial_hs_dma that some might remember from ICS). I've actually broken bluetooth intentionally in the release build, I'm sure people prefer a device that can enter deep sleep preperly. :P

Might have to wait until someone comes up with a bluez based solution (CAF already had it done once but it's reverted again) or try hacking the Broadcom stuff at some point. Either way I suspect that sorting out bluetooth is going to take weeks rather than days.

Hi KonstaT!

I tried all versions of your 4.1.2 port from 2012.08.21, but in all of them the voip bug still exists, so i can't upgrade to newer versions, i must use the 2012.08.21 release.

But now i tried this 4.2.1 port and surprise, the voip works well! So i immediately upgrade to this. Thank you for your great work!

It seems that it's something in upstream CyanogenMod code that's causing your issue. I'm glad it's working for you but I haven't done anything to fix/break it. ;) All device specific audio stuff is pretty much the same than it is in 4.1.

But could you please check URL http://forum.xda-dev...d.php?t=1836116, where users are having JB ROM on their Sony Xperia X8 mobile, which is less powerfull than our ZTE Blade mobile with native USB tethering, Native WIFI tethering and even FM Radio functionality working.

Sorry, but that's exactly the kind of stuff that I don't need. Especially not cross-posted on several thread, and especially not after you've already posted that same thing before and someone has already given you a valid answer. Device you're referring to has completely different wifi hardware and it has completely different FM hardware!

Then there's certain difference between some things not listed as 'not working' or someone claiming it's working - and it actually working. :P If you'd bothered to search the thread you linked, you would have know that it doesn't have working USB tethering (and their bugtracker has exactly the same logcat on this issue that I used to have on Blade).

I, on the other hand, did manage to sort some old USB related issues. ;)

post-834050-0-88146800-1356463099_thumb.post-834050-0-72784000-1356463123_thumb.

Merry Christmas equally to everyone (if you celebrate it). :)

4

Share this post


Link to post
Share on other sites

Posted · Report post

Hi KonstaT,

You are the best judge for this CM 10.1 ZTE ROM development.

But could you please check URL http://forum.xda-developers.com/showthread.php?t=1836116, where users are having JB ROM on their Sony Xperia X8 mobile, which is less powerfull than our ZTE Blade mobile with native USB tethering, Native WIFI tethering and even FM Radio functionality working.

What is the point of this post?

You're referring to another forum where they have another phone with other hardware working?

How do you imagine that that is helpful at all?

This is like referring to Nexus 4 and proclaim that they have FM radio working just fine so KonstT should look into that and upgrade everyones Blade with other hardware.

It's not just that you're being daft about it, it's that this has been repeated constantly for several hundred of pages in four threads.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Well, I've been looking for a device with working bluetooth on a non-Broadcom bluetooth hardware. Maybe I somehow missed the 'success' part as it seems that bluetooth is still an issue for them?

Google changed the bluetooth stack completely in 4.2 and the new bluedroid is developed by Broadcom. There's also a Qualcomm based solution in AOSP (for Nexus 4) but it is only partially open and for much newer Atheros chip (Atheros WCN3660?) than what we have. I did manage to make little progress with bluetooth using the qcom stuff, but pretty much only sign of life that it's giving is a wakelock (good old msm_serial_hs_dma that some might remember from ICS). I've actually broken bluetooth intentionally in the release build, I'm sure people prefer a device that can enter deep sleep preperly. :P

Might have to wait until someone comes up with a bluez based solution (CAF already had it done once but it's reverted again) or try hacking the Broadcom stuff at some point. Either way I suspect that sorting out bluetooth is going to take weeks rather than days.

It seems that it's something in upstream CyanogenMod code that's causing your issue. I'm glad it's working for you but I haven't done anything to fix/break it. ;) All device specific audio stuff is pretty much the same than it is in 4.1.

Sorry, but that's exactly the kind of stuff that I don't need. Especially not cross-posted on several thread, and especially not after you've already posted that same thing before and someone has already given you a valid answer. Device you're referring to has completely different wifi hardware and it has completely different FM hardware!

Then there's certain difference between some things not listed as 'not working' or someone claiming it's working - and it actually working. :P If you'd bothered to search the thread you linked, you would have know that it doesn't have working USB tethering (and their bugtracker has exactly the same logcat on this issue that I used to have on Blade).

I, on the other hand, did manage to sort some old USB related issues. ;)

post-834050-0-88146800-1356463099_thumb.post-834050-0-72784000-1356463123_thumb.

Merry Christmas equally to everyone (if you celebrate it). :)

Very nice. :)

God Jul!

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

can anyone remember the settings to fix colour banding, 16-bit alpha should be on as well as dither+blur fixes as i recall, but doesn't seem to help. also seems bloody slow, are there gfx acceleration problems perhaps?

Edited by sej7278
0

Share this post


Link to post
Share on other sites

Posted · Report post

can anyone remember the settings to fix colour banding, 16-bit alpha should be off and dither+blur fix on as i recall, but doesn't seem to help. also seems bloody slow, are there gfx acceleration problems perhaps?

It's a pre-alpha ROM, what the hell did you expect? A perfect version in one release, read the bloody OP and stop whining about it, either patch it or shut up.

1

Share this post


Link to post
Share on other sites

Posted · Report post

It's a pre-alpha ROM, what the hell did you expect? A perfect version in one release, read the bloody OP and stop whining about it, either patch it or shut up.

whoaaaa, take a chill pill. i'm only asking not whining! konstat's not really said much about what we should expect - should it be up to cm10 levels (which from the working/not working lists it seems like it) or should it be considered alpha.

looking at it /data/property/persist.sys.* are being ignored as things like dithering/alpha/nobootanimation settings just don't work, that's all. i can't find anything on gerrit about it, and they don't seem to have changed how it works in aosp, so i'm just wondering if its a problem with the rom.

also to *me* it seems a lot slower than cm10, and i noticed on github konstat mentioned that gfx acceleration has changed (back to pre-ics methods?) so i was just wondering if we can get some background info on that.

3

Share this post


Link to post
Share on other sites

Posted · Report post

And here begins the flame wars, ball sucking..yada yada

0

Share this post


Link to post
Share on other sites

Posted · Report post

It's a pre-alpha ROM, what the hell did you expect? A perfect version in one release, read the bloody OP and stop whining about it, either patch it or shut up.

I don't want to start a fight, but it has to be said that your response was out of order. Add to that, sej has made massive contributions to the development of CM on the Blade since the beginning, and deserves respect for that. If a team is going to fix this, I want sej on that team!

3

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

it seems to me that the settings parts of alpha/blur/dithering are merged, but the frameworks/native bits aren't, which explains why the properties are being set but do naff all:

see the commit from cm10: http://review.cyanog....org/#/c/19532/

10.1 branch doesn't have it: https://github.com/C.../surfaceflinger

apologies to konstat, i hadn't realised how behind cm10 the cm10.1 commits are, after a few hours looking through the code the whole of cm10.1 seems alpha especially for older/non-aosp hardware, its a miracle it even boots on anything other than nexus4 as it is! the surfaceflinger patches won't apply anyway as there's no concept of dithering in the code yet.

Edited by sej7278
1

Share this post


Link to post
Share on other sites

Posted · Report post

can someone post best settings for battery and performance like the 4.1 please i know this is new and things might change, i just not sure what to do is smatass 2 ondemand and the rest the best take weeks check. Great work never thought a phone with 2.1 eclair could ever run 4.2.1 amazing.

0

Share this post


Link to post
Share on other sites

Posted · Report post

konstat - how are you getting your apk's down in size - i've done the usual reverting of the .asrc compression patch and trimming dictionaries, wallpaper, ringtones, videoeditor, cmupdater, bootanimation; and i've got optipng/pngcrush/zipalign installed, but my /system is still going to be 145mb.

the main diff seems to be your apk's are smaller on disk - the contents in them are the same size (roughly) as mine when decompressed, and oddly enough my rom zip size is a couple of megs smaller than yours!

main culprits seem to be system/app and system/framework are about 5mb each smaller than mine.

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Great work! I was thinking of bying a new phone before this release... :D

Is there any change of making OTG work in this version?

I know it works with some kernel's:

http://www.modaco.co...-usb-host-mode/

http://sven.killig.d...Blade/usb_host/

Another thing... how can I make a "barebone"... Meaning: is it safe to just remove all the apps I don't need from de rom image before flashing?

Happy... whatever... :D

Edited by pceuforia
0

Share this post


Link to post
Share on other sites

Posted · Report post

Is there any way to move apps to SD?

S2E doesn't work at all...

Still, looks a solid version for ZTE!

Keep up the good work!

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.