• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

[DEV][ROM][24.7.] CyanogenMod 10.1 (Android 4.2.2)

3452 posts in this topic

Posted · Report post

Hi! I have started to use Bluetooth (turned on all the time) and notice battery drain. I have used BetterBatteryStats to collect statistics and found that “msm_serial_hs_dma” wakelock was held all the time. Do anyone have the same situation?

I use 6.3. build on zte libra

PS I found solution for similar problem on another device http://blog.cryptomi...d-deep-sleep/ May it help?

Same problem here, bluetooth drains battery. Also, i have some random pairing issues that i didn't had with previous version of this rom.

Thank for you work KonstaT

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

I have problem discovering Bluetooth devices too. I tried several times and had to reboot to see another device. not libra nor another phone found each other before reboot

Edited by ashvedov
0

Share this post


Link to post
Share on other sites

Posted · Report post

I have problem discovering Bluetooth devices too. I tried several times and had to reboot to see another device. not libra nor another phone found each other before reboot

Same problem for me
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

I'd like to OTG my Logitech K400. Anyone knows if this is possible? Didn't work for me.

Edited by greg121
0

Share this post


Link to post
Share on other sites

Posted · Report post

Hi

First of all , I wanna thank Konsta for his great work.

Now , this ROM is the best of all previous ones I used , but I have a problem.

There is a system process , netd , that is eating from 50 to 80% of my CPU constantly. I used watchdog to monitor it.

Tried to disable almost everything in the network settings - Wifi,mobile data , syncing , background data. Then I put the phone in Flight Mode , but this continues.

Problem is the battery drains pretty quickly and the phone becomes very laggy.

The only solution I have found is to switch it off and power it on again. This gives me about 2-3 hours of normal operation.

Is there someone that can help me up with this problem , cause I really like the ROM :)

Thanks in advance

0

Share this post


Link to post
Share on other sites

Posted · Report post

Hi

First of all , I wanna thank Konsta for his great work.

Now , this ROM is the best of all previous ones I used , but I have a problem.

There is a system process , netd , that is eating from 50 to 80% of my CPU constantly. I used watchdog to monitor it.

Tried to disable almost everything in the network settings - Wifi,mobile data , syncing , background data. Then I put the phone in Flight Mode , but this continues.

Problem is the battery drains pretty quickly and the phone becomes very laggy.

The only solution I have found is to switch it off and power it on again. This gives me about 2-3 hours of normal operation.

Is there someone that can help me up with this problem , cause I really like the ROM :)

Thanks in advance

Reflash whole ROM again, and remember to wipe everything, /system too.

If this doesnt help, download ROM and gapps again. And check md5 sum at the konstaTs first post. If it mismatches, download again, until it matches

0

Share this post


Link to post
Share on other sites

Posted · Report post

It was my 10th flash mate - the only thing I did not wipe was the battery stats. Two days later did it , cause wanted to test if it was the problem.

MD5s were in check. Can someone here at least tell me what this process netd is responsible for?

From the web it seems that it has something to do with the mobile networks switching and etc. May be the problem is in my operator's network , cause the phone constantly goes between GPRS and EDGE (I use it only in 2G mode , never 3G because my data is limited to 128kbps and there is no point).

Thanks

0

Share this post


Link to post
Share on other sites

Posted · Report post

It was my 10th flash mate - the only thing I did not wipe was the battery stats. Two days later did it , cause wanted to test if it was the problem.

MD5s were in check. Can someone here at least tell me what this process netd is responsible for?

From the web it seems that it has something to do with the mobile networks switching and etc. May be the problem is in my operator's network , cause the phone constantly goes between GPRS and EDGE (I use it only in 2G mode , never 3G because my data is limited to 128kbps and there is no point).

Thanks

Battery drain can be caused by bad gsm signal level. Phone uses more power to send signal to base station. Edge and gprs aslo needs more power in that case.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Coming from a CM9 nightly, this ROM is amazing with regards to battery life. Previously, for my usage, the battery lasted for around 30 to 32 hours; now, it is a minimum of 56 hours, once even barely reaching the 64 hour mark. My usage pattern hasn't changed, and my settings are all similar since the day I bought this mobile. Have to hand over the credit to the ROM. My Blade isn't retiring any time soon.

0

Share this post


Link to post
Share on other sites

Posted · Report post

It was my 10th flash mate - the only thing I did not wipe was the battery stats. Two days later did it , cause wanted to test if it was the problem.

MD5s were in check. Can someone here at least tell me what this process netd is responsible for?

From the web it seems that it has something to do with the mobile networks switching and etc. May be the problem is in my operator's network , cause the phone constantly goes between GPRS and EDGE (I use it only in 2G mode , never 3G because my data is limited to 128kbps and there is no point).

Thanks

About the process, I don't know, but is your partition large enough to fit the ROM + GApps?

That would be around 160MB. Is that what you have?

0

Share this post


Link to post
Share on other sites

Posted · Report post

I have problem discovering Bluetooth devices too. I tried several times and had to reboot to see another device. not libra nor another phone found each other before reboot

Try to remove DSP Manager (for example, rename '/system/app/DSPManager.apk' to '/system/app/DSPManager.old' using ES File Explorer in root access mode). It solved Bluetooth issue on my Blade.

0

Share this post


Link to post
Share on other sites

Posted · Report post

If I change the background processes limit, it will be reset after reboot. With no background processes my phone lasts for 3-4 days (overclocked to 700 mhz). The limit did not reset on previous ROM versions. The latest ROM was flashed on top of previous version with cache and dalvik cache wiped.

Does anyone have this issue?

0

Share this post


Link to post
Share on other sites

Posted · Report post

About the process, I don't know, but is your partition large enough to fit the ROM + GApps?

That would be around 160MB. Is that what you have?

Yup , the firmware I used a year ago was for 160mb system partition and 2 mb cache. I did remove some language packs though , but it looked like it could have been flashed straight without deleting them.

Is there someone that can tell me what is the NETD process responsible for ?

0

Share this post


Link to post
Share on other sites

Posted · Report post

Yup , the firmware I used a year ago was for 160mb system partition and 2 mb cache. I did remove some language packs though , but it looked like it could have been flashed straight without deleting them.

Is there someone that can tell me what is the NETD process responsible for ?

I still don't know what netd process is, but, taka a look at this: http://code.google.com/p/cooper-cyanogen/issues/detail?id=59

Can you kill the process too?

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

(sorry for my bad language, english isn't my native)

Hi! Thanks for that great ROM. This was my first ROM change and it was really easy to change it :)

I have 2 issues with the radio. First, i can't save stations, but it's not a big problem. Second, when the radio is on and somebody calls me (or i call somebody), i can hear the radio during the phonecall. It's not shut/mute itself (like in the official 2.2 rom). Is there any solution for that?

Edited by Homeye
0

Share this post


Link to post
Share on other sites

Posted · Report post

does anyone have automatic clock bug?

0

Share this post


Link to post
Share on other sites

Posted · Report post

I'm experiencing a problem with my ADATA MicroSDHC 16GB card (class 4).

I tried the new card in my laptop. Formatted fine (FAT32 - just like the old one)

I'm guessing you formatted in Windows. Format it in the phone, if you want an sdext partition, format in recovery. Windows and some tools on Windows will create a bad format that only Windows can reliably use. Trashed a 16Gb partition trying to repartition with Minitool Partition Wizard not so long ago after forgetting that rule...

0

Share this post


Link to post
Share on other sites

Posted · Report post

does anyone have automatic clock bug?

Yes ive got that had to switch it off and set manually.
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

I'm guessing you formatted in Windows. Format it in the phone, if you want an sdext partition, format in recovery. Windows and some tools on Windows will create a bad format that only Windows can reliably use. Trashed a 16Gb partition trying to repartition with Minitool Partition Wizard not so long ago after forgetting that rule...

I repartitioned numerous of SD cards for Android smartphones using PC and not trashed a single one, so there's no problem with Windows or software...

Edited by matcho13579
1

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

What about to include the effem fm radio app into next build (has stations)? The CM10 build has included that. I dont know if i can only use the effem.app from CM 10 here (or need some libs, other things too). (screenshoots of CM10 blade with that radioapp at pages 25+26 of CM 10 thread).

https://github.com/g...ages_apps_Effem

Edited by mitchde
0

Share this post


Link to post
Share on other sites

Posted · Report post

Is it possible to get the ZTE Blade support into the official CM 10.1?

I don't know what the procedure is to get all the ZTE specific stuff into the official sources.

I know Konstat is probably busy with real life stuff, but it would be great if could get more regular updates.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Is it possible to get the ZTE Blade support into the official CM 10.1?

I don't know what the procedure is to get all the ZTE specific stuff into the official sources.

I know Konstat is probably busy with real life stuff, but it would be great if could get more regular updates.

Don't think this gonna happen and the updates are pretty regular, right now the ROM is almost perfect. To me it seems everything is working.

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

There is bug with FM radio. When FM radio is playing and I'm receiving call, FM radio didn't stop play. And when I'm unpluging my headphones to answer the call (because I dont have headphones with mic), I dont have any sound, because FM radio is working and thinking, that headphones are plugged.

Sorry for my english. I hope, developer will understand. :)

P.S For correctly sound working, after using FM radio I must stop the radio with | | button and exit from radio with Back button.

Edited by rrewolf
0

Share this post


Link to post
Share on other sites

Posted · Report post

Hi KonstaT,

Could you please confirm that this commit is part of last build?

The list of merged but not credited commit suggests it, but I'd just like to be sure, because I get the exact same message I used to have before this option was enabled.

Thanks again for your work & help!

0

Share this post


Link to post
Share on other sites

Posted · Report post

Is it possible to get the ZTE Blade support into the official CM 10.1?

I don't know what the procedure is to get all the ZTE specific stuff into the official sources.

I know Konstat is probably busy with real life stuff, but it would be great if could get more regular updates.

ARMv6 devices won't be supported beyond CM7.

There's instructions in the third post. Nothing stopping you from updating twice a day if you want. :P

Hi KonstaT,

Could you please confirm that this commit is part of last build?

The list of merged but not credited commit suggests it, but I'd just like to be sure, because I get the exact same message I used to have before this option was enabled.

Thanks again for your work & help!

I don't think so. It was reverted right after it was merged.

3

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.