Site Notice - We are currently investigating an issue with missing download links. Apologies for any inconvenience caused. PaulOBrien

  • Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

[DEV][ROM][24.7.] CyanogenMod 10.1 (Android 4.2.2)

3452 posts in this topic

Posted · Report post

Thank you KonstaT for your work ;-)

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

so you gave in and started forking a bunch of repo's then? i was wondering how we were going to get around the determination of the cyanogenmod guys to not support devices with under a gig of ram, nice job! i'll have a look around the sources later, i gotta try to backport the option to disable the bootanimation as its so slow and the usual echo command doesn't seem to do it.

had to uninstall and reinstall s2e as it lost its settings.

Edited by sej7278
0

Share this post


Link to post
Share on other sites

Posted · Report post

New ClockWorkMod 6.0.2.7 build. Everything seems to work ok. Edit. adb sideload doesn't work (kernel needs to be updated with new usb gadget stuff for that).

recovery-clockwork-6.0.2.7-blade.zip

http://www.mediafire...yrd5yo28dnl73ga

md5:a55cdaa43241d7d84daa6583d4e4f4d3

recovery.img

md5:e0f4c71adb4fb267bb16808695a1b09d

2

Share this post


Link to post
Share on other sites

Posted · Report post

so you gave in and started forking a bunch of repo's then? i was wondering how we were going to get around the determination of the cyanogenmod guys to not support devices with under a gig of ram, nice job! i'll have a look around the sources later, i gotta try to backport the option to disable the bootanimation as its so slow and the usual echo command doesn't seem to do it.

Yeah, there was no other choice. I'll still try to get stuff usefull for everyone to get merged upstream CyanogenMod and hopefully get rid some of those forks. I'm not going to fork projects that get updated every day (e.g. frameworks/base and settings), I'll probably just later publish patches for features that I've added. AndroidARMv6 project is a bit too chaotic for my OCD but there's definately some nice work being done there. ;)

0

Share this post


Link to post
Share on other sites

Posted · Report post

Happy New Year KonstaT :)

Congratulations for your hard work doing awesome ROM's for ZTE Blade. It still lives on and I still using daily side by side to my Nokia Lumia 800.

Wanna see my friends faces to show them that I have Jelly Bean 4.2.1 :P

I'll try CM10.1 to see how performs on my Blade. But unfortunately I need bluetooth working, for using my wireless headset when I driving, so I'll try a bit and roll back to CM10

Thank you very much.

Kindly Regards from Portugal :)

0

Share this post


Link to post
Share on other sites

Posted · Report post

Does anyone is experience problems with the touchscreen?

I've been using Konsta since cm9 and i had to replace de screen months ago. Everything was fine until a couple of weeks when the screen started to behave strangely (no response, pressing a button activates other buttons, zoom when swipe)

So what i want to ask you is if someone is experience this or its an hardware issue?

Thanks

0

Share this post


Link to post
Share on other sites

Posted · Report post

What the community is doing is amazing, the armv6 project is awesome! Open source is a beauty :D

0

Share this post


Link to post
Share on other sites

Posted · Report post

Thanks KonstaT and devs for the great work!

Downloading and testing...

0

Share this post


Link to post
Share on other sites

Posted · Report post

Does anyone is experience problems with the touchscreen?

Thanks

Do you face same issues with other roms?

0

Share this post


Link to post
Share on other sites

Posted · Report post

Sweet, thanks for the new build! Is it possible to port that "headset plugged in" to cm10? If so, how can i do it?

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Do you face same issues with other roms?

haven't tried other. i started to face this issues in the last build of Konsta's cm10. Did a full wipe, installed the cm10.1 but this issue stands...

i even cleaned inside the phone (screen and digitizer) because there were some dust in there

Edited by ernopiros
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Yeah, there was no other choice. I'll still try to get stuff usefull for everyone to get merged upstream CyanogenMod and hopefully get rid some of those forks. I'm not going to fork projects that get updated every day (e.g. frameworks/base and settings), I'll probably just later publish patches for features that I've added. AndroidARMv6 project is a bit too chaotic for my OCD but there's definately some nice work being done there. ;)

its actually easier to some degree - less manual patches to apply, and since armv6/512mb has absolutely zero support from cyanogenmod now, why not fork it all?

my OCD tells me to delete a few more wallpapers/dictionaries and restore apollo (i don't use it, but i have nothing against it) and get rid of that fecking bootanimation - pretty but i'd prefer 20secs off my boot time and 1.5mb in /system

all we need in frameworks/base is to fix the F1_NewVoicemail.ogg typo and optionally the two reviews from gerrit i guess?

s2e is messing about royally for some reason, only seems to work every other boot, it seems its losing its settings or not installing properly or something. i might try a wipe of /sd-ext and /data as it was fine with 21/12

gonna try a self-build now. happy new year!

edit: bugger, it seems taking the CM bootanimation out, still leaves the default android one, echo 1 > /data/property/persist.sys.nobootanimation does nothing either, looking at the init.goldfish.sh script, we have to add one of these to system.prop "ro.kernel.android.bootanim=0" or "debug.sf.nobootanimation=1"

edit 2: seems colour banding is back in my build like konstat's 21/12 build, but the 01/13 build was fine.....?

Edited by sej7278
1

Share this post


Link to post
Share on other sites

Posted · Report post

nothing shows in "Manage and restore backups" in ROM manager.

Anybody face this?

0

Share this post


Link to post
Share on other sites

Posted · Report post

nothing shows in "Manage and restore backups" in ROM manager.

Anybody face this?

none of the cwm6's support rommanager, use cwm touch or the hardware keys, ditch rommananger.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Merged commits not mentioned in the changelog.

1.1.2013 changelog:

  • backported USB gadget driver from msm-3.0 kernel (thanks to WaylandACE)
    • fixed native USB tethering
    • fixed issues with apps failing because of borked usb0 interface (e.g. network speedtest apps)
    • switched to wpa_supplicant_8
    • added power hal and boostpulse support to ondemand governor
    • Quick Settings: Swipe to switch (1)
    • Add persistent notification when headphones are plugged in (1)
    • CyanogenMod clock widget - Chronus (merged)

    21.12.2012 changelog:

    [*]new world order

    ulo kahein ka sala ini deer bad update kita ae te kuch bhi non working mein se workin ni kia

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

I've been using this rom since a week... no probs, its working fine :)

Edited by sameen.asil
0

Share this post


Link to post
Share on other sites

Posted · Report post

Does anyone is experience problems with the touchscreen?

I've been using Konsta since cm9 and i had to replace de screen months ago. Everything was fine until a couple of weeks when the screen started to behave strangely (no response, pressing a button activates other buttons, zoom when swipe)

So what i want to ask you is if someone is experience this or its an hardware issue?

Thanks

I've been using this rom since a week, no touch screen probs at all, its working fine...maybe your cell has some hardware probs....

0

Share this post


Link to post
Share on other sites

Posted · Report post

edit: bugger, it seems taking the CM bootanimation out, still leaves the default android one, echo 1 > /data/property/persist.sys.nobootanimation does nothing either

edit 2: seems colour banding is back in my build like konstat's 21/12 build, but the 01/13 build was fine.....?

It seems that the property needs to be renamed. Using debug.sf.nobootanimation doesn't disable it either. I now uploaded patches for additional features and there's two for that (1,2).

Is this color banding some OLED specific issue because I've never had any problems with it? I have locally this but I didn't push it to github because it seems to be somewhat wip.

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

It seems that the property needs to be renamed. Using debug.sf.nobootanimation doesn't disable it either. I now uploaded patches for additional features and there's two for that (1,2).

Is this color banding some OLED specific issue because I've never had any problems with it? I have locally this but I didn't push it to github because it seems to be somewhat wip.

i don't think its oled-specific, although i do have an oled. people used to moan about it in cm7/9 and i never noticed it, but since 10/10.1 i have. tom_g explained it once long ago - it should be set to 2 for our devices (fix blur+dither) and indeed is in the system.prop, but the code isn't there to do anything with it i guess (without your surfaceflinger patch).

as far as nobootanimation goes, it seems that the code to chose it is hacked together in the init script and should be in the cpp as you have done (as you can then use settings app rather than build flags).

i'll have a go at merging in some of the patches in a bit.

Edited by sej7278
0

Share this post


Link to post
Share on other sites

Posted · Report post

I can confirm that color banding thing. It was present in 21/12 build but today's build is fine with a tft screen.

0

Share this post


Link to post
Share on other sites

Posted · Report post

wow,so cool

0

Share this post


Link to post
Share on other sites

Posted · Report post

I've been testing pretty much every one of Konstat's releases of 4.0, 4.1, and now 4.2 since about July and very impressed with the progress for what is now a relatively underpowered phone! Kudos to all involved.

:)

I've never bothered upgrading CWM from 5.0.0.5 (I think it is; could be 5.0.5.0: currently upgrading to latest ROM so can't check!). Is there any advantage to upgrading it to 6.0.2.7? OK, I don't currently have touch support but I'm not convinced I'd trust that enough to use it! ;)

I'm fairly happy testing ROMs because I know I can go back to a backup from before installation. My current CWM seems to do all that I need so is there any point in touching it?

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

It seems that the property needs to be renamed. Using debug.sf.nobootanimation doesn't disable it either. I now uploaded patches for additional features and there's two for that (1,2).

Is this color banding some OLED specific issue because I've never had any problems with it? I have locally this but I didn't push it to github because it seems to be somewhat wip.

colour banding is fixed with that patch (rebased, attached) on my oled. fw_native.patch.zip

the bootanimation patches work but result in just a black screen whilst booting, but it does boot 20secs faster....

ah, it seems that s2e doesn't work on the first boot after doing a nandroid, although first boot after other recovery operations (install zip) seems fine. a reboot seems to fix it anyway. not your recovery.

Edited by sej7278
0

Share this post


Link to post
Share on other sites

Posted · Report post

Awesome ROM, hard bricked my SGS 2 with some buggy rom so had to switch back to my trusty blade...

Great to have 4.2 running on it, makes the downgrade less painful :)

Not asking ETAs, but I am wondering about the video hw decoding.

Will it be hard to port Ganster's patch that fixed this for cm9&10 to this ROM?

Thanks for all the hard work Konsta!

0

Share this post


Link to post
Share on other sites

Posted · Report post

great work !!

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.