MoDaCo is undergoing planned maintenance. Site functionality may be reduced - follow @modaco or @paulobrien on Twitter for updates.

  • Announcements

    • Reminder - MoDaCo position on illegal content

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such software
      Nintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)


      CUSTOM ROMS

      You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not be hosted directly in topic via the MoDaCo attachment system
      ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)
      ROMs must give full credit to the original author
      This decision has been taken in light of the huge amount of interest in this area of device customisation within the community, and member feedback! Please note that custom ROM discussion should be kept in specific device sub-areas, (e.g. Kaiser.MoDaCo.com for Kaiser based devices). ISSUES If you have any issues with this policy, please contact me directly via PM. P
    • Support MoDaCo by signing up to a MoDaCo Silver or Gold membership

      To sign up to an annual MoDaCo Silver subscription which will eliminate all ads from the site (as well as giving you access to the MoDaCo Online Kitchens for Android) for only £9.99 using PayPal, Credit or Debit Card, ensure you are logged in to the site, and then click the link below, which will take you directly to the subscription store! You can also sign up to an annual MoDaCo Gold subscription for £29.99, which adds the benefits listed below! PURCHASE A MODACO SUBSCRIPTION - FREE Titanium Backup Mobile for Android worth $5.99! - FREE 1 year PrivateInternetAccess.com worth $39.95! - FREE 1 year LastPass Premium worth $12! - FREE CalcConvert for Pocket PC from Binaryfish worth $17.95! - FREE Calendar Bar for Pocket PC from OmegaOne worth $9.99! - FREE CamerAware for Pocket PC and Smartphone from MoDaCo worth £19.99 / $30! - FREE Chronos for Pocket PC from ActiveKitten worth $14.95! - FREE CodeWallet Pro for Smartphone and Pocket PC from DeveloperOne worth up to $24.95! - FREE Concentrix for Pocket PC from eSoft Interactive worth $9.95! - FREE FlexMail for Pocket PC and Smartphone from WebIS worth up to $59.90! - FREE FTouchSL for Pocket PC from Vekoff s.r.o. worth 10 euro / $12.50! - FREE Jewel Challenge for Pocket PC from eSoft Interactive worth $9.95! - FREE John Cody's Alerts Pro for Smartphone from Omnisoft worth $14.95! - FREE LingvoSoft Talking Dictionary 2008 English <-> Dutch for Pocket PC from Lingvosoft worth $49.95! - FREE LingvoSoft Talking Dictionary 2008 English <-> French for Pocket PC from Lingvosoft worth $49.95! - FREE LingvoSoft Talking Dictionary 2008 English <-> German for Pocket PC from Lingvosoft worth $49.95! - FREE LingvoSoft Talking Dictionary 2008 English <-> Italian for Pocket PC from Lingvosoft worth $49.95! - FREE LingvoSoft Talking Dictionary 2008 English <-> Spanish for Pocket PC from Lingvosoft worth $49.95! - FREE LingvoSoft Dictionary English <-> Dutch for Smartphone from Lingvosoft worth $49.95! - FREE LingvoSoft Dictionary English <-> French for Smartphone from Lingvosoft worth $49.95! - FREE LingvoSoft Dictionary English <-> German for Smartphone from Lingvosoft worth $49.95! - FREE LingvoSoft Dictionary English <-> Russian for Smartphone from Lingvosoft worth $49.95! - FREE LingvoSoft Dictionary English <-> Turkish for Smartphone from Lingvosoft worth $49.95! - FREE Note2Self for Pocket PC and Smartphone from WebIS worth up to $19.90! - FREE Opera 8.60 for Pocket PC and Smartphone from Opera Software worth up to $48! - FREE Pocket Informant for Pocket PC and Smartphone from WebIS worth up to $59.90! - FREE Pocket Launcher for Pocket PC and Smartphone from Conduits worth $9.95! - FREE PTab for Pocket PC and Smartphone from z4soft worth up to $60! - FREE Resco Explorer for Pocket PC and Smartphone from Resco worth up to $49.90! - FREE Safemode for Pocket PC from monocube worth $12.95 - FREE SplashPhoto for Pocket PC and Smartphone from SplashData worth up to $59.90! - FREE Sprite Backup for Pocket PC and Smartphone from Sprite Software worth $29.95! - FREE Teksoft Glyphs UI for Pocket PC and Smartphone from Teksoft €9.95! - FREE Teksoft HeadsetRemote for Pocket PC and Smartphone from Teksoft €4.95! - FREE Traffic Jam for Pocket PC from eSoft Interactive worth $9.95! - FREE unlock (1 per year) from imei-check.co.uk - DISCOUNT of 10% at MoDaCo FairDeal - DISCOUNT of 10% at Semsons.com - FORUM - AD FREE SITE - FORUM - custom rank / title - FORUM - double competition entries - FORUM - double post attachment space - FORUM - no search flood control - FORUM - priority event registration - FORUM - triple PM space
    • Reminder: Selling items on the forum directly is not allowed

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspensions / ban.

[DEV][ROM][24.7.] CyanogenMod 10.1 (Android 4.2.2)

3452 posts in this topic

Posted · Report post

For people having issues with S2E, have you tried INT2EXT as posted on the xda site? There was a mention of it in one of these 10.1 ROM threads a while back; i'm currently using it on pac rom android version 4.2.2 and it works fine, My blade reports 512mb of /data.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Yeah, seems to happen on my other device as well. I've narrowed it down to some change between 23rd and 24th but I have no obvious suspect what might have caused it.

Thank you for confirming this bug.

One other interesting bug that I have, even after a full wipe, is this one. If anyone can also confirm it, please tell me.

This happens when you try to connect to a protected wireless network or when you modify a working network. This bug doesn't always happen to me.

The popup is completely misplaced and unreadable

Thank you ;)

post-812759-0-38300800-1364332438_thumb.

2

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Yes, these are graphic glitches that happen sometimes in CM10 & CM10.1, I think it might be because they use hacks to achieve hardware acceleration. Rotate the phone to fix or close and return to the same window. It shouldn't happen very often.

Edited by elrond_bs
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

One other interesting bug that I have, even after a full wipe, is this one. If anyone can also confirm it, please tell me.

This happens when you try to connect to a protected wireless network or when you modify a working network. This bug doesn't always happen to me.

The popup is completely misplaced and unreadable

I am investigating this bug at the moment. It is most definitely connected to the DECIDE_TEXTURE_TARGET hack (which speeds up composition). It looks like SurfaceTexture sometimes confuses the TEXTURE_2D and TEXTURE_EXTERNAL_OES targets and tries to rebind a texture to the other target, which isn't allowed. A texture can only be bound to a single target. This usually appears in logcat:


E/Adreno200-ES20( 243): <qgl2DrvAPI_glBindTexture:642>: GL_INVALID_OPERATION

E/Adreno200-ES11( 243): <glEGLImageTargetTexture2DOES:469>: GL_INVALID_OPERATION

E/SurfaceTexture( 243): [InputMethod] updateTexImage: error binding external texture image 0x2916 (slot 1): 0x502

However, I can't seem to reliably reproduce this at all. It just happens... sometimes, and with various surfaces. I can't trigger it with the wifi configuration pane like some people. Where else are you guys and gals seeing it often?

Edited by daemond
2

Share this post


Link to post
Share on other sites

Posted · Report post

I am investigating this bug at the moment. It is most definitely connected to the DECIDE_TEXTURE_TARGET hack (which speeds up composition). It looks like SurfaceTexture sometimes confuses the TEXTURE_2D and TEXTURE_EXTERNAL_OES targets and tries to rebind a texture to the other target, which isn't allowed. A texture can only be bound to a single target. This usually appears in logcat:


E/Adreno200-ES20( 243): <qgl2DrvAPI_glBindTexture:642>: GL_INVALID_OPERATION

E/Adreno200-ES11( 243): <glEGLImageTargetTexture2DOES:469>: GL_INVALID_OPERATION

E/SurfaceTexture( 243): [InputMethod] updateTexImage: error binding external texture image 0x2916 (slot 1): 0x502

However, I can't seem to reliably reproduce this at all. It just happens... sometimes, and with various surfaces. I can't trigger it with the wifi configuration pane like some people. Where else are you guys seeing it often?

Hey, I know that bug in wifi settings too. The same bug comes when I do followin with any app:

I open the app, and I rotate the phone to landscape about 1sec after opening app. Then statusbar gets graph glitches like in screenshot on top. And the whole app stays black, until I go to home and access agai to the app. Seems that this happens while app is opening, and you try to rotate phone.

i meet this bug everyday with any app. But I have learned that I need to wait some secods before I can rotate i.d browser

0

Share this post


Link to post
Share on other sites

Posted · Report post

I am investigating this bug at the moment. It is most definitely connected to the DECIDE_TEXTURE_TARGET hack (which speeds up composition). It looks like SurfaceTexture sometimes confuses the TEXTURE_2D and TEXTURE_EXTERNAL_OES targets and tries to rebind a texture to the other target, which isn't allowed. A texture can only be bound to a single target. This usually appears in logcat:


E/Adreno200-ES20( 243): <qgl2DrvAPI_glBindTexture:642>: GL_INVALID_OPERATION

E/Adreno200-ES11( 243): <glEGLImageTargetTexture2DOES:469>: GL_INVALID_OPERATION

E/SurfaceTexture( 243): [InputMethod] updateTexImage: error binding external texture image 0x2916 (slot 1): 0x502

However, I can't seem to reliably reproduce this at all. It just happens... sometimes, and with various surfaces. I can't trigger it with the wifi configuration pane like some people. Where else are you guys and gals seeing it often?

I get it often in YouTube. Launch YouTube (make sure it was closed last time, not "minimized" like when you press home, not back), choose any video and rotate it (to landscape) right after it starts playing, then back to portrait - green and other colors should appear on the top of the screen.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Thank you for confirming this bug.

One other interesting bug that I have, even after a full wipe, is this one. If anyone can also confirm it, please tell me.

This happens when you try to connect to a protected wireless network or when you modify a working network. This bug doesn't always happen to me.

The popup is completely misplaced and unreadable

Thank you ;)

Im not complaning about it, just wanna report the same bug i use 4.1.2 daemond rom, and also i notice after full wipe this glich happens every time in whatsapp when starting for first time.Not big drama for me, but if could be fixed it will be great.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Anyone else experiencing really bad battery drain on this release? I'm not sure what the problem is because the last version had really good battery life for me and the only change I have made is from Link2SD to S2E. Any help would be much appreciated.

0

Share this post


Link to post
Share on other sites

Posted · Report post

this is an awesome ROM.its so surprising how good it is.nyc work..

0

Share this post


Link to post
Share on other sites

Posted · Report post

Thanks again for your amazing work Konstat! : )

0

Share this post


Link to post
Share on other sites

Posted · Report post

I am investigating this bug at the moment. It is most definitely connected to the DECIDE_TEXTURE_TARGET hack (which speeds up composition). It looks like SurfaceTexture sometimes confuses the TEXTURE_2D and TEXTURE_EXTERNAL_OES targets and tries to rebind a texture to the other target, which isn't allowed. A texture can only be bound to a single target. This usually appears in logcat:


E/Adreno200-ES20( 243): <qgl2DrvAPI_glBindTexture:642>: GL_INVALID_OPERATION

E/Adreno200-ES11( 243): <glEGLImageTargetTexture2DOES:469>: GL_INVALID_OPERATION

E/SurfaceTexture( 243): [InputMethod] updateTexImage: error binding external texture image 0x2916 (slot 1): 0x502

However, I can't seem to reliably reproduce this at all. It just happens... sometimes, and with various surfaces. I can't trigger it with the wifi configuration pane like some people. Where else are you guys and gals seeing it often?

most of the time it appears on wifi settings, but also sometimes when after a boot ,the lockscreen is seen in the status bar and blank screen area, only when pattern unlock is selected.

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Hi guys and thanks for the work!

I found a serious bug for me:

After clean install, wipe everything, i installed from play store Google Maps. If I use Maps first it works ok but after leaving app 3G doesn't work. Browser stalls and after a while the 3G signal (connection) is down. Reboot the phone and works normal.

This is show stopper for me.

Please help!

Using latest build and Blade gen 2.

Edit: wifi off all the time, google apps installed in CWM when ROM was installed, after 3G/HSDPA fail i was trying airplane mode & back but no effect until phone is restarted.

IT SEEMS A GPS-3G bug, if GPS is off and Maps is using only network localisation it's ok, no 3G fail.

Edited by tulpina
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

So if somebody ask more info about an undocumented feature, will banned, and the community can be rude with him. Can you remove this pie thing in the next release? I don't like it. Unnecessary and only appears once from hundreds of try. If I want to play a game I will download one.

DSP gone away on high CPU load, what can we do?

Battery drain problem seems solved in this release (with turned off haptic and audio event feedbacks and using link2sd).

Edited by zamiere
0

Share this post


Link to post
Share on other sites

Posted · Report post

Whining about pie options is wasting time. cata simi: Please stop that and solve problems by yourself!

@Cata_Simi

Yes, stop whining & trolling or you'll get ban.anas.

At least get the troll's nickname right if your going to feed him/her. :P

Thank you for confirming this bug.

Yeah, it seems that it was this commit that caused it.

I am investigating this bug at the moment. It is most definitely connected to the DECIDE_TEXTURE_TARGET hack (which speeds up composition). It looks like SurfaceTexture sometimes confuses the TEXTURE_2D and TEXTURE_EXTERNAL_OES targets and tries to rebind a texture to the other target, which isn't allowed. A texture can only be bound to a single target. This usually appears in logcat:


E/Adreno200-ES20( 243): <qgl2DrvAPI_glBindTexture:642>: GL_INVALID_OPERATION
E/Adreno200-ES11( 243): <glEGLImageTargetTexture2DOES:469>: GL_INVALID_OPERATION
E/SurfaceTexture( 243): [InputMethod] updateTexImage: error binding external texture image 0x2916 (slot 1): 0x502
[/code]

However, I can't seem to reliably reproduce this at all. It just happens... sometimes, and with various surfaces. I can't trigger it with the wifi configuration pane like some people. Where else are you guys and gals seeing it often?

Yeah, that's pretty much what I've figured out. I think also Ganster looked into this at some point. It might be as simple as moving that one glDisable() outside the ifdefs (or just in case glDisable() both modes before glEnable() when using DECIDE_TEXTURE_TARGET). The thing is that now it's how it is in the original CAF ICS commit and this was never an issue on ICS. But like said, there's no reliable way to reproduce this. I'm running DECIDE_TEXTURE_TARGET on both of my devices and I've seen this issue like three times this year.

So if somebody ask more info about an undocumented feature, will banned, and the community can be rude with him. Can you remove this pie thing in the next release? I don't like it. Unnecessary and only appears once from hundreds of try. If I want to play a game I will download one.

You'd have to have been here longer to understand. User I was referring to is a known troll and he/she has already used several fake profiles with similar nicknames as actual forum members.

Clearly you have no idea what CyanogenMod is. I don't generally add or remove features and I'm not even supposed to. Great, you don't want to use pie controls. Is unticking the settings box too difficult for you?

4

Share this post


Link to post
Share on other sites

Posted · Report post

At least get the troll's nickname right if your going to feed him/her. :P

Yeah, it seems that it was this commit that caused it.

Yeah, that's pretty much what I've figured out. I think also Ganster looked into this at some point. It might be as simple as moving that one glDisable() outside the ifdefs (or just in case glDisable() both modes before glEnable() when using DECIDE_TEXTURE_TARGET). The thing is that now it's how it is in the original CAF ICS commit and this was never an issue on ICS. But like said, there's no reliable way to reproduce this. I'm running DECIDE_TEXTURE_TARGET on both of my devices and I've seen this issue like three times this year.

You'd have to have been here longer to understand. User I was referring to is a known troll and he/she has already used several fake profiles with similar nicknames as actual forum members.

Clearly you have no idea what CyanogenMod is. I don't generally add or remove features and I'm not even supposed to. Great, you don't want to use pie controls. Is unticking the settings box too difficult for you?

I can swear that his/her name were cata simi earlier....

His so childish..

0

Share this post


Link to post
Share on other sites

Posted · Report post

He/she has both nicks Cata_Simi & Sata_Cimi

But pls stop that.!!!!!! :angry2:

0

Share this post


Link to post
Share on other sites

Posted · Report post

He/she has both nicks Cata_Simi & Sata_Cimi

But pls stop that.!!!!!! :angry2:

Thats right!

Lets try to use brains, and talk about things what are suitable here

0

Share this post


Link to post
Share on other sites

Posted · Report post

Great work konstaT

Pie controls not work for me :angry:

get a life dude, rather than spending all day on this forum with fake id's and useless ques. that tell others how dumb u are

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

You'd have to have been here longer to understand. User I was referring to is a known troll and he/she has already used several fake profiles with similar nicknames as actual forum members.

Clearly you have no idea what CyanogenMod is. I don't generally add or remove features and I'm not even supposed to. Great, you don't want to use pie controls. Is unticking the settings box too difficult for you?

Well that is not entirely true, he/she copied my nickname (cata_simi) to Sata_Cimi and My profile picture and keeps trolling and refered to my posts sometimes. I reported him several times!

I am trying to be as serious and helping as posible. You can follow my posts (not Sata_Cimi's)

Now I hope to not get banned for this but once you identify him, He can be funny sometimes

Edited by Cata_Simi
0

Share this post


Link to post
Share on other sites

Posted · Report post

Well that is not entirely true, he/she copied my nickname (cata_simi) to Sata_Cimi and My profile picture and keeps trolling and refered to my posts sometimes. I reported him several times!

I am trying to be as serious and helping as posible. You can follow my posts (not Sata_Cimi's)

Now I understand,,

This sata cimi seems to be some troll. Good that you reported of him/her!

0

Share this post


Link to post
Share on other sites

Posted · Report post

Can I somehow enable a clear button to notification drawer?

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

HEY guys STOP talking about him!

Modaco is not a good place for that.

Edited by adipec
0

Share this post


Link to post
Share on other sites

Posted · Report post

Hey guys. Loving the latest iteration of this rom. Great work Konsta.

My only problem is Evernote is now showing as incompatible in the play store for me. Any suggestions?

0

Share this post


Link to post
Share on other sites

Posted · Report post

Guys, if you don't like a users post then ignore the user and report the post. Replying just makes you as bad as the troll.

Post have been removed.. again <sigh>

1

Share this post


Link to post
Share on other sites

Posted · Report post

@Konstat

Hey konstat and hi to everyone on the Blade Community :P !

So i have an ZTE Blade (Gen1 that i've upgraded to Gen2) which is running the good old Swedish Snow ROM , but since JB ROM's have been vastly improved and with few to none bugs , i wan't to upgrade my Blade from 2.3.5 directly to 4.2.2 .

BUT , i need to change to partitions and i don't know how to do that . Can you help me with the upgrade process Konstat?

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.