hotwire74

G300 Ear Speaker not working

Recommended Posts

I am running Infusion B05 and the ear speaker has stopped working on my G300. Calls work fine via external speaker. I have updated to B07 and the problem remains so it must be hardware. Is this a common fault on this handset (no water damage btw). I bought it second had through ebay and am in the UK - do Huawei repair if you don't have the original receipt? If they do what is the best way to revert the phone back to a stock rom without clockwork?

If they don't does anyone know how easy a repair this is? I can't see anywhere that sells replacement ear speakers assuming its definately that.

Thanks in advance.

Share this post


Link to post
Share on other sites

Hello, I'm on CM10 and was just on the phone to a mate and suddenly the ear piece speaker went silent. Tried a reboot and am about to try a different rom but it doesn't look good. Did you get anywhere with this? Seemed like a sudden hardware failure or something.

Cheers, Ben.

Share this post


Link to post
Share on other sites

For anyone who's interested I've gone back to CM9 and the speaker is working fine again. Must have been a software glitch.

Cheers, Ben.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.