MoDaCo is undergoing planned maintenance. Site functionality may be reduced - follow @modaco or @paulobrien on Twitter for updates.

  • Announcements

    • Reminder - MoDaCo position on illegal content

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such software
      Nintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)


      CUSTOM ROMS

      You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not be hosted directly in topic via the MoDaCo attachment system
      ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)
      ROMs must give full credit to the original author
      This decision has been taken in light of the huge amount of interest in this area of device customisation within the community, and member feedback! Please note that custom ROM discussion should be kept in specific device sub-areas, (e.g. Kaiser.MoDaCo.com for Kaiser based devices). ISSUES If you have any issues with this policy, please contact me directly via PM. P
    • Support MoDaCo by signing up to a MoDaCo Silver or Gold membership

      To sign up to an annual MoDaCo Silver subscription which will eliminate all ads from the site (as well as giving you access to the MoDaCo Online Kitchens for Android) for only £9.99 using PayPal, Credit or Debit Card, ensure you are logged in to the site, and then click the link below, which will take you directly to the subscription store! You can also sign up to an annual MoDaCo Gold subscription for £29.99, which adds the benefits listed below! PURCHASE A MODACO SUBSCRIPTION - FREE Titanium Backup Mobile for Android worth $5.99! - FREE 1 year PrivateInternetAccess.com worth $39.95! - FREE 1 year LastPass Premium worth $12! - FREE CalcConvert for Pocket PC from Binaryfish worth $17.95! - FREE Calendar Bar for Pocket PC from OmegaOne worth $9.99! - FREE CamerAware for Pocket PC and Smartphone from MoDaCo worth £19.99 / $30! - FREE Chronos for Pocket PC from ActiveKitten worth $14.95! - FREE CodeWallet Pro for Smartphone and Pocket PC from DeveloperOne worth up to $24.95! - FREE Concentrix for Pocket PC from eSoft Interactive worth $9.95! - FREE FlexMail for Pocket PC and Smartphone from WebIS worth up to $59.90! - FREE FTouchSL for Pocket PC from Vekoff s.r.o. worth 10 euro / $12.50! - FREE Jewel Challenge for Pocket PC from eSoft Interactive worth $9.95! - FREE John Cody's Alerts Pro for Smartphone from Omnisoft worth $14.95! - FREE LingvoSoft Talking Dictionary 2008 English <-> Dutch for Pocket PC from Lingvosoft worth $49.95! - FREE LingvoSoft Talking Dictionary 2008 English <-> French for Pocket PC from Lingvosoft worth $49.95! - FREE LingvoSoft Talking Dictionary 2008 English <-> German for Pocket PC from Lingvosoft worth $49.95! - FREE LingvoSoft Talking Dictionary 2008 English <-> Italian for Pocket PC from Lingvosoft worth $49.95! - FREE LingvoSoft Talking Dictionary 2008 English <-> Spanish for Pocket PC from Lingvosoft worth $49.95! - FREE LingvoSoft Dictionary English <-> Dutch for Smartphone from Lingvosoft worth $49.95! - FREE LingvoSoft Dictionary English <-> French for Smartphone from Lingvosoft worth $49.95! - FREE LingvoSoft Dictionary English <-> German for Smartphone from Lingvosoft worth $49.95! - FREE LingvoSoft Dictionary English <-> Russian for Smartphone from Lingvosoft worth $49.95! - FREE LingvoSoft Dictionary English <-> Turkish for Smartphone from Lingvosoft worth $49.95! - FREE Note2Self for Pocket PC and Smartphone from WebIS worth up to $19.90! - FREE Opera 8.60 for Pocket PC and Smartphone from Opera Software worth up to $48! - FREE Pocket Informant for Pocket PC and Smartphone from WebIS worth up to $59.90! - FREE Pocket Launcher for Pocket PC and Smartphone from Conduits worth $9.95! - FREE PTab for Pocket PC and Smartphone from z4soft worth up to $60! - FREE Resco Explorer for Pocket PC and Smartphone from Resco worth up to $49.90! - FREE Safemode for Pocket PC from monocube worth $12.95 - FREE SplashPhoto for Pocket PC and Smartphone from SplashData worth up to $59.90! - FREE Sprite Backup for Pocket PC and Smartphone from Sprite Software worth $29.95! - FREE Teksoft Glyphs UI for Pocket PC and Smartphone from Teksoft €9.95! - FREE Teksoft HeadsetRemote for Pocket PC and Smartphone from Teksoft €4.95! - FREE Traffic Jam for Pocket PC from eSoft Interactive worth $9.95! - FREE unlock (1 per year) from imei-check.co.uk - DISCOUNT of 10% at MoDaCo FairDeal - DISCOUNT of 10% at Semsons.com - FORUM - AD FREE SITE - FORUM - custom rank / title - FORUM - double competition entries - FORUM - double post attachment space - FORUM - no search flood control - FORUM - priority event registration - FORUM - triple PM space
    • Reminder: Selling items on the forum directly is not allowed

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspensions / ban.

[DEV][ROM][2014-06-16] CyanogenMod 10 (Continuation of KonstaT's work)

850 posts in this topic

Posted · Report post

High daemond:

GROSSARTIG !!!

A real great work.

After applying the btfix for my blade, no problems with bt-streaming - as in version before...

Also can switch on/off BT how I want now:-)...

Thanks for the praise. :) But why do you need a separate bluetooth fix? What does this do? Why hasn't it been incorporated into most ROMs?

What exacty this line means?

Nothing important. The build type mostly affects naming.

where i can get a compiled version (.apk) effem radio app ? would it work on android 2.3.7 CM ? i try to compile but found few errors. com.stericsson.hardware.fm library is absent in all sdk ?

and what target of sdk

android:targetSdkVersion="?"

The app will never work on CM7. It uses many APIs that are only available on ICS and later, and of course it relies on the new FM API.

The new FM app Effem is not good as it supposed to be. However, thanks a lot for the excellent work!

This post is not as good as it should have been.

8

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

New build is up on the first post. Changelog below.

Thanks again for your work :)

The new FM app Effem is not good as it supposed to be. However, thanks a lot for the excellent work!

No comments...

Edited by ilopez85
0

Share this post


Link to post
Share on other sites

Posted · Report post

But why do you need a separate bluetooth fix? What does this do? Why hasn't it been incorporated into most ROMs?

Hello Daemond,

my problem is, that i can only switch on BT once. When stopping BT later im am not able to start it again. The BT-ON-Switch won´t get blue... Also the grey switch (when off) is too dark. It seems, that BT was totally unlocable...

Today also my bt-fix won´t help me for this problem. These BT on/off probs i had with my Blade also on several CM7 Versions. There the fix helps...

Perhaps an other app disturbs.... so i let BT on whole time :-)(

By the way: the DSP-settings don´t show any effect on my Blade. No difference with Equalizer or bass-boost. I tried the equalizer-app from market; this works...

Thanks for asking

P.

0

Share this post


Link to post
Share on other sites

Posted · Report post

The new FM application (Github) is now ready for general consumption. It's called Effem. ;) Here's what it looks like:

ZDfoGUm.pngiCpSJb2.pngy5zTVCY.png

It's simple, but clean and hopefully aesthetically pleasing for most people. All important features are supported. Automatic seeking, manual seeking (long press), station saving, headphone detection, and RDS support including radio text.

I'm currently compiling a clean build of the whole ROM and will upload it in a few hours.

Installed effem on cm 10.1 from KonstaT. Works fine but volume control isn't working. Any ideas?

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

You are using modified version of the app (for 4.2), so you shouldn't bother the original author. Also, please don't post same question in multiple threads, except if you are developer trying to improve the app.

Edited by elrond_bs
0

Share this post


Link to post
Share on other sites

Posted · Report post

But why do you need a separate bluetooth fix? What does this do? Why hasn't it been incorporated into most ROMs?

Hi Daemond,

i tried KONSTATs 4.2.2 Release - there the Bluetooth is switchable without any problems on my Blade.

Perhaps you can change the BT related data vom 4.2.2 to your 4.1.2...

greetings

P.

0

Share this post


Link to post
Share on other sites

Posted · Report post

No - Android 4.2 contains an entirely new bluetooth stack. It's nothing that's easy to change.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Hi All,

i've noticed issue with audio routing and the new effem app. Let me try to describe it briefly :

If i stop listening radio by pressing the stop button, then unplug the headset and close the app, sound keep routed to the headset indstead of speaker ... the only way is then to reboot the blade...

is there any workaround ?

Anyway, great work Daemond, and may thanks to keep our blade alive...

Bonne soirée ..:)

0

Share this post


Link to post
Share on other sites

Posted · Report post

Hey guys. Needing help over here.

Today I installed the current version posted on the first page (the NIGHTLY build) and the menus/UI seem to be fluid and fairly fast. However, it's not connecting to a mobile network operator. Going to "Settings -> More -> Mobile networks -> Network operators", it detects the available mobile operators in the area. After I select specifically my operator (vodafone PT) a notification says "Registered on network", but right after that I get another one in the notification bar saying I have no service.

I can receive text messages, but if I try to make phone calls or send any messages it complains with "Mobile network not available". My device is a ZTE Blade Gen2. Can anyone help me?

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Hey guys. Needing help over here.

Today I installed the current version posted on the first page (the NIGHTLY build) and the menus/UI seem to be fluid and fairly fast. However, it's not connecting to a mobile network operator. Going to "Settings -> More -> Mobile networks -> Network operators", it detects the available mobile operators in the area. After I select specifically my operator (vodafone PT) a notification says "Registered on network", but right after that I get another one in the notification bar saying I have no service.

I can receive text messages, but if I try to make phone calls or send any messages it complains with "Mobile network not available". My device is a ZTE Blade Gen2. Can anyone help me?

umm no problems here with tmn reinstall rom by doing factory reset , wipe cache, advanced format dalvik cache and , and mounts and storage , then format system

make sure you have installed gapps too

Edited by lunario
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

umm no problems here with tmn reinstall rom by doing factory reset , wipe cache, advanced format dalvik cache and , and mounts and storage , then format system

make sure you have installed gapps too

I tried the steps you mentioned multiple times and with different versions of the rom. Google Play is working, the wireless works normally, I just can't get a signal from the mobile operator. I also tried with a Uzo SIM card (another operator here) and it didn't work either. My guess is that something might be wrong with the antenna configurations or something like that, but I don't know what to do now...

Edited by irish.bluewood
0

Share this post


Link to post
Share on other sites

Posted · Report post

I tried the steps you mentioned multiple times and with different versions of the rom. Google Play is working, the wireless works normally, I just can't get a signal from the mobile operator. I also tried with a Uzo SIM card (another operator here) and it didn't work either. My guess is that something might be wrong with the antenna configurations or something like that, but I don't know what to do now...

Try a different sd card for the TPT. I have encountered a similar problem and the fault was the sd card.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Hi All,

i've noticed issue with audio routing and the new effem app. Let me try to describe it briefly :

If i stop listening radio by pressing the stop button, then unplug the headset and close the app, sound keep routed to the headset indstead of speaker ... the only way is then to reboot the blade...

is there any workaround ?

Anyway, great work Daemond, and may thanks to keep our blade alive...

Bonne soirée .. :)

I have the same problem here.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Hi there!

I wasn't have any issue until yesterday: my phone breaked up and then made a automatically boot. But when I was to use it again, my phone didn't recognized sd card. Then I went to storage and didn't appear the option to "install sd card". I turned off the phone, removed the battery and sd card and put them again. I turned it on and the phone wasn't recognizing sd card again. Then, I tried my sd card on another phone and was working and I put a different sd card on my phone and didn't recognized it ...

Also I went to recovery menu and appeared the error "can't mount sd card" and finally tried to connect phone via usb and doesn't work, but only charges...

Any thoughts? Thanks!

ps: I connect the sd card to the pc via adaptor and it's "working" perfectly ...

0

Share this post


Link to post
Share on other sites

Posted · Report post

Hi there!

I wasn't have any issue until yesterday: my phone breaked up and then made a automatically boot. But when I was to use it again, my phone didn't recognized sd card. Then I went to storage and didn't appear the option to "install sd card". I turned off the phone, removed the battery and sd card and put them again. I turned it on and the phone wasn't recognizing sd card again. Then, I tried my sd card on another phone and was working and I put a different sd card on my phone and didn't recognized it ...

Also I went to recovery menu and appeared the error "can't mount sd card" and finally tried to connect phone via usb and doesn't work, but only charges...

Any thoughts? Thanks!

ps: I connect the sd card to the pc via adaptor and it's "working" perfectly ...

A few months ago the same happened to me but it turns out it was a bad sd card giving its firts gliches. After a couple of weeks it went crazy in the pc also. Giving I/O errors in linux console.

0

Share this post


Link to post
Share on other sites

Posted · Report post

sqlite3 /data/data/com.android.providers.settings/databases/settings.db "INSERT INTO secure (name,value) VALUES ('device_provisioned','1');"

Does this still work to make the home button work?

0

Share this post


Link to post
Share on other sites

Posted · Report post

A few months ago the same happened to me but it turns out it was a bad sd card giving its firts gliches. After a couple of weeks it went crazy in the pc also. Giving I/O errors in linux console.

Sd card works on another phone, so I guess the problem is really on the phone... In fact, two months ago I bought another sd card because I was having issues and with this sd card it fixed the problem. But what I think is weird is the fact that in storage doesn't appear the option to install sd card ...

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

sqlite3 /data/data/com.android.providers.settings/databases/settings.db "INSERT INTO secure (name,value) VALUES ('device_provisioned','1');"

Does this still work to make the home button work?

Last time I checked, it did (few months ago). Just try it, won't break anything.

If it doesn't work, check if your system is at least 160MB and if you installed the correct gapps from page 1 here. These are the most likely reasons for your home button not to work. :)

Edited by elrond_bs
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Sd card works on another phone, so I guess the problem is really on the phone... In fact, two months ago I bought another sd card because I was having issues and with this sd card it fixed the problem. But what I think is weird is the fact that in storage doesn't appear the option to install sd card ...

My old sd card also worked on another phone. Did you try another card on the phone since this happened?

EDIT: BTW, daemond... you rule.

Edited by zeekzar
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

My old sd card also worked on another phone. Did you try another card on the phone since this happened?

EDIT: BTW, daemond... you rule.

Yes I've already tried, but the phone doesn't recognize any of them

Edited by pt123
0

Share this post


Link to post
Share on other sites

Posted · Report post

Yes I've already tried, but the phone doesn't recognize any of them

Then I rest my case and I can't see other options. Good luck.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Thanks anyway.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Hello!

I have since some weeks problems with memory management.

My Blade slows down extremly and most times i get a "system ui has stopped".

I use Nova Launcher instead Trebuchet.

Playing with Z-Ram doesn´t help.

Reinstalling with formating all partitions also not.

Does anyone have the same problems?

Greeting,

Nr5

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.