• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

[DEV][ROM][2014-06-16] CyanogenMod 10 (Continuation of KonstaT's work)

850 posts in this topic

Posted

I've noticed small issues with button backlight in new release, random switch on/off when screen is off and keep on while charging.

Huh, seems to work fine here. The backlight reliably switches off when the screen is switched off. But there has been an update to the lights library, so breakage is possible.

Daemond, i've been wondering, can the FM Radio audio be routed to the speaker? I have seen it in several devices, for exemple the Galaxy s2,3 and both s4 versions (gt-i9505 and gt-i9500), and also we can put the audio from calls, skype, viber, etc to the speaker. So maybe the FM Radio can be routed too, with a little work, if you have the time/patience for it of course. :)

This does not appear to be possible due to the way FM audio is injected into the audio mixer.

0

Share this post


Link to post
Share on other sites

Posted

I've noticed small issues with button backlight in new release, random switch on/off when screen is off and keep on while charging.

Huh, seems to work fine here. The backlight reliably switches off when the screen is switched off. But there has been an update to the lights library, so breakage is possible.

I noticed the same problem but I solved it after making a clean cache and dalvik-cache... but I see that the update did not resolve to stay the notification light on when I get a message whatsapp with off-screen preview. Is there any way to fix it?

Thank you very much for your great work!

0

Share this post


Link to post
Share on other sites

Posted

First congratulations for the great job, the best room I've ever experienced in my ZTE Blade.

I just have a problem my GPS takes a lot to fix and sometimes doesn´t fixed at all. I use Fasterfix and GPS test but still nothing.

Not sure if it's possible to do something or if it is hardware problem.

Thank you and continue with the great work.

0

Share this post


Link to post
Share on other sites

Posted

Better than 10.1, Bluetooth always work when needed. GPS works without problem, choosing internal GPS module not necessary but doesn't change anything if selected. I installed it with full clear.

0

Share this post


Link to post
Share on other sites

Posted (edited)

Button backlight issue (after full wipe installation):

http://www.youtube.com/watch?v=ymcxggALrqE&feature=youtu.be

Does that may have some relation to partial wakelocks of applications or anything similar?

============================================================================================================================

About light sensor (TAOS TSL2771) and auto-brightness values I think maybe the problem is that the sensor is misconfigured, this is an example of how it's configured the G300 sensor (Capella Microsistems CM3602) on which auto brightness works properly:

https://github.com/K...config.xml#L134

And this is the same file in our BLADE:

https://github.com/g.../config.xml#L79

I don't know what is the maximum range of the TSL2771, In ZTE's kernel appears 65535000, 10240 in cm10 (more reasonable) and 27000 in apps like Quick System Info Pro or Hardware Info. But it's set to 3000 in the config.xml file.

============================================================================================================================

"Offtopic" (useful things)

Apollo versions from F-Droid (1.0 works on 2.3+ and 1.1 on 4.0+):

http://f-droid.org/r...m.andrew.apollo

CronMod INT2EXTV2+ (A2SD script):

http://d-h.st/yDh

Edited by ilopez85
2

Share this post


Link to post
Share on other sites

Posted

Button backlight issue (after full wipe installation):

http://www.youtube.com/watch?v=ymcxggALrqE&feature=youtu.be

Does that may have some relation to partial wakelocks of applications or anything similar?

Does this happed with other roms? Is it possible that its a hardware failure? Because I dont have such problems.

0

Share this post


Link to post
Share on other sites

Posted

Does this happed with other roms? Is it possible that its a hardware failure? Because I dont have such problems.

Only with 14.5 versions (cm10 and maybe cm10.1), in cm-10-20130328-NIGHTLY-blade it works fine.

0

Share this post


Link to post
Share on other sites

Posted

I do only flash new build and for me all is OK. I don't observe any problem with Button backlight like @ilopez85

So maybe You must do another full wipe. On previous I have problem with deep sleep, and then do another full wipe and for now all is OK.

0

Share this post


Link to post
Share on other sites

Posted (edited)

I update my previous build to new version and i have the same thing

any solution? (no full wipe sugestion) ;P

Button backlight issue (after full wipe installation):

http://www.youtube.com/watch?v=ymcxggALrqE&feature=youtu.be

Does that may have some relation to partial wakelocks of applications or anything similar?

============================================================================================================================

About light sensor (TAOS TSL2771) and auto-brightness values I think maybe the problem is that the sensor is misconfigured, this is an example of how it's configured the G300 sensor (Capella Microsistems CM3602) on which auto brightness works properly:

https://github.com/K...config.xml#L134

And this is the same file in our BLADE:

https://github.com/g.../config.xml#L79

I don't know what is the maximum range of the TSL2771, In ZTE's kernel appears 65535000, 10240 in cm10 (more reasonable) and 27000 in apps like Quick System Info Pro or Hardware Info. But it's set to 3000 in the config.xml file.

============================================================================================================================

"Offtopic" (useful things)

Apollo versions from F-Droid (1.0 works on 2.3+ and 1.1 on 4.0+):

http://f-droid.org/r...m.andrew.apollo

CronMod INT2EXTV2+ (A2SD script):

http://d-h.st/yDh

Edited by 222nobrak
0

Share this post


Link to post
Share on other sites

Posted

I update my previous build to new version and i have the same thing

any solution? (no full wipe sugestion) ;P

Settings -> Advanced Options -> Unselect Button backlight

It's a temporary solution but with virtual buttons, the backlight function is not useful.

0

Share this post


Link to post
Share on other sites

Posted

Okay here, thanks for the ROM

0

Share this post


Link to post
Share on other sites

Posted

Hi all - have S2E installed & some games/apps and have moved apps & data to SDCard.

Still have only 50Mb free - can't update FB via GPLAY. Any ideas ??

0

Share this post


Link to post
Share on other sites

Posted

Hi all - have S2E installed & some games/apps and have moved apps & data to SDCard.

Still have only 50Mb free - can't update FB via GPLAY. Any ideas ??

Remember to tick all boxes from s2e, try to wipe cache and download some app and figure what eats ur space.
0

Share this post


Link to post
Share on other sites

Posted

@up and of course reboot phone after that.

0

Share this post


Link to post
Share on other sites

Posted

Can you guys tell me please how to install S2E on my phone for this version of software? Do I only have to download it from Play Store or do I have to flash something? Thank you!

0

Share this post


Link to post
Share on other sites

Posted (edited)

Install from Play Store, it's incompatible only with 4.2 (CM10.1), not 4.1 (CM10 - this ROM).

Edited by elrond_bs
0

Share this post


Link to post
Share on other sites

Posted (edited)

Button backlight issue (after full wipe installation):

http://www.youtube.com/watch?v=ymcxggALrqE&feature=youtu.be

Does that may have some relation to partial wakelocks of applications or anything similar?

============================================================================================================================

About light sensor (TAOS TSL2771) and auto-brightness values I think maybe the problem is that the sensor is misconfigured, this is an example of how it's configured the G300 sensor (Capella Microsistems CM3602) on which auto brightness works properly:

https://github.com/K...config.xml#L134

And this is the same file in our BLADE:

https://github.com/g.../config.xml#L79

I don't know what is the maximum range of the TSL2771, In ZTE's kernel appears 65535000, 10240 in cm10 (more reasonable) and 27000 in apps like Quick System Info Pro or Hardware Info. But it's set to 3000 in the config.xml file.

============================================================================================================================

"Offtopic" (useful things)

Apollo versions from F-Droid (1.0 works on 2.3+ and 1.1 on 4.0+):

http://f-droid.org/r...m.andrew.apollo

CronMod INT2EXTV2+ (A2SD script):

http://d-h.st/yDh

same problem with me, the buttons light up and go out on their own, and the phone is't in sleep mode. when I press a button the phone turns. the problem is only wiht this rom cm-10-20130514

Edited by masterlud
0

Share this post


Link to post
Share on other sites

Posted

Install from Play Store, it's incompatible only with 4.2 (CM10.1), not 4.1 (CM10 - this ROM).

Install from first or second of this thread.

0

Share this post


Link to post
Share on other sites

Posted (edited)

Very good job bro!

This ROM is awesome!

THX!

Update: Sorry guys, but dont working well the automatic backlight, and a button backlight.

Update2: button backlight working now. I use the "Hot reboot"

Edited by Smithy986
0

Share this post


Link to post
Share on other sites

Posted

Very good job bro!

This ROM is awesome!

THX!

Update: Sorry guys, but dont working well the automatic backlight, and a button backlight.

Auto brightness hasn't worked that great on any custom ROM :)

0

Share this post


Link to post
Share on other sites

Posted

Auto brightness hasn't worked that great on any custom ROM :)

Any good app?

(Swedish RLS7 working on)

0

Share this post


Link to post
Share on other sites

Posted

Autobrighness works for me with Velis Auto Brightness (free at PlayStore), but last 2 versions give me problems so I use an old version.

0

Share this post


Link to post
Share on other sites

Posted (edited)

If there are other language files in this ROM. Where can I find them and how can I remove them?

I would like to make this ROM as small as possible.

-Henrik

Edit: I found some main.dict files in the LatinIME file, are these the ones I should remove?

Edited by NorwegianLabel
0

Share this post


Link to post
Share on other sites

Posted (edited)

LatinIME is a keyboard, you can squeeze some space by deleting unnecessary dicts

Edited by matcho13579
0

Share this post


Link to post
Share on other sites

Posted (edited)

I confirm the bug with backlight for hardware keys in latest version - sometimes it stays ON for a while after the screen is tuned off (both for timeout and manual OFF). deamond, could you please take a look on this? I tried replacing with the old lights.blade.so, but no effect. It drains battery, even if not much and it's annoying (sometimes mixes with the green or red light for missed calls/sms, making them harder to recognize).

Edited by elrond_bs
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.