• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

[DEV][ROM][1.11.] CyanogenMod 10 (Android 4.1.2)

558 posts in this topic

Posted · Report post

New build up. Nothing major, just couple of small bugfixes and enabled/disabled few features.

I've been mostly trying to make hardware vsync events work (needed for full 'project butter'). I'm still not quite sure I got everything working on the kernel side so I didn't include it yet (doesn't seem to make much of a difference). We already have fake vsync events, boostpulse to increase touch responsiveness and triple buffering working though.

cm-10-20130129-KonstaKANG-atlas40.zip

http://www.mediafire.com/?11yf7z2d21axab4

md5:93ce9b9b85ec37c64223a80a1f3fa340

-build wpa_supplicant from source

-fix muted microphone during calls

-change button backlight behaviour

-enable expanded destktop feature

0

Share this post


Link to post
Share on other sites

Posted · Report post

Bugreport section: Sometimes the status bar freezes, and i cant go to my notifications. I have no idea about the causes of this bug, but its really bad that i have to restart my phone 3 times a day. Please fix this if possible.

That's never happened to me but I think I've read about that issue on other msm7x27a devices.

You can try using gpu composition instead of mdp. Try changing


debug.composition.type=mdp
[/CODE] to
[CODE]
debug.composition.type=gpu

in system/build.prop.

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

thanks for answer konstat

i am trying to use the camera 4.2 (NEXUS camera)...its nice and big screen...

if you want to have 4.2 camera, just flash it in cwm ( http://d-h.st/aIy ) I found it in google, and its working. :) Edited by x6itru
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

if you want to have 4.2 camera, just flash it in cwm ( http://d-h.st/aIy ) I found it in google, and its working. :)

thanks

it work ok now with this rom 29/1

Edited by merc1800k
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

web tv not working...in original rom and cm9 work perfect...

if it easy check it pls

pls can you make bigger call screen?(i mean the photo when call a contact)

thanks

ps find at store play ant1 tv

Edited by merc1800k
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Don't have a logcat for the wifi-problem...

But I reinstalled the rom and this time I also did a format of system. Now the wifi works. Before CM10 I installed Choffas rom. Then I also had to format system. Seems like it might be that a wipe is not enough .

Edited by wewen
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Installed and testing :) I Love it :)

Edit1:Some applications is a little slow especially when typing. For example the emailapp. And also the Handelsbanken app has some lagg.

Edit2: Notification bar does not work in ADW EX. After 2 reboots it worked again.

Edit3: I think my keyboard problem comes from using the AnySoftKeyboard instead of stock, but i like SVORAK :). I changed to stock and have no problems anymore with the keyboard. Also the battery indicator is not there if full. I cannot see what is using up the battery

Edit4: Sometimes I cannot answer the phone, I have no clue under what circumstances :( But the Ring in the answer screen does not respond to touch.

Edited by dorren
0

Share this post


Link to post
Share on other sites

Posted · Report post

Second version working !

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

  • after 1 day test rom
  • something wrong because no play web tv(in other rom-original-aurora borealis work fine)
  • if it possible a small 2G - 3G at the top of the mobile singnal
  • if it possible more loud at speaker...play mp3 and ringtones very low
  • screen bigger photo for contacts when call me..

thanks konstat for the rom...keep walking !!!

Edited by merc1800k
0

Share this post


Link to post
Share on other sites

Posted · Report post

much faster and smoother in the UI now, than Aurora borealis.

I had some bug/crash/freeze where the notification bad wouldn't respond to anything and the clock/battery info was frozen too, it was right in the settings so I assume it froze for some reason. reboot fixed it.

apart from that I haven't found any bugs yet.

woul it be possible to make the device show up as a mass storage instead of the MTP thing?

and any way to use the ISO (install mode) from stock to mount any iso, and hopefully boot from? that would be sweet.

0

Share this post


Link to post
Share on other sites

Posted · Report post

much faster and smoother in the UI now, than Aurora borealis.

I had some bug/crash/freeze where the notification bad wouldn't respond to anything and the clock/battery info was frozen too, it was right in the settings so I assume it froze for some reason. reboot fixed it.

apart from that I haven't found any bugs yet.

woul it be possible to make the device show up as a mass storage instead of the MTP thing?

and any way to use the ISO (install mode) from stock to mount any iso, and hopefully boot from? that would be sweet.

Settings / storage / menu and adjust from there to USB.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Settings / storage / menu and adjust from there to USB.

oooh! nicely hidden setting there, kind of. thanks alot!

0

Share this post


Link to post
Share on other sites

Posted · Report post

anyone have that problem??

when someone cal me ring 2 times and stop ringing..i chance sound but the same...

anyone?

0

Share this post


Link to post
Share on other sites

Posted · Report post

anyone have that problem??

when someone cal me ring 2 times and stop ringing..i chance sound but the same...

anyone?

I have had it also.

And sometimes my ear turns on the airplane mode and the call ends, but i guess that is the proximity sensor that needs calibration. I will look in the menyes for that :)

I had another case of not beeing able to answer now, but when pressing the powerbutton two times and then answering it works.

/Erik

0

Share this post


Link to post
Share on other sites

Posted · Report post

pls konstat it is easy to tell me the files to use for camera 4.2 in last rom?

lib and apps pls

thanks

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

really nice rom ;) almost as smooth&fast as nexus7 heh :D the only one small bug that i've noticed is that proximity sensor isnt working yet in calls :P ps. it will be nice if we will get 4.2.1 :P

Edited by x6itru
0

Share this post


Link to post
Share on other sites

Posted · Report post

I have had it also.

And sometimes my ear turns on the airplane mode and the call ends, but i guess that is the proximity sensor that needs calibration. I will look in the menyes for that :)

I had another case of not beeing able to answer now, but when pressing the powerbutton two times and then answering it works.

/Erik

really nice rom ;) almost as smooth&fast as nexus7 heh :D the only one small bug that i've noticed is that proximity sensor isnt working yet in calls :P ps. it will be nice if we will get 4.2.1 :P

Yeah, I've had problems with proximity too. Still not sure if everyone have this issue though. It's stange since all other sensors work and I think it worked out-of-the-box in my CM9 builds.

You can calibrate proximity under Settings -> Advanced -> Calibrate proximity sensor and it will work until the next reboot. We're using a prebuilt sensors lib from the stock ROM and it doesn't know how to read that calibration data. I've been trying to build sensors lib from source and proximity/light sensors works great but acceleration/magnetic/orientation doesn't. :/

I boot my phone so often that I made a simple script that calibrates proximity sensor automatically on every reboot. Save this as 09proximity to /system/etc/init.d (or /data/local/userinit.d if you want it to survive ROM updates) and make it executable (775 permissions).


#!/system/bin/sh
# Calibrate ZTE atlas40 proximity sensor at boot

/system/bin/prox_cal -c[/CODE]

1

Share this post


Link to post
Share on other sites

Posted · Report post

First, thanks for ROM.

I can also confirm "Sometimes the status bar freezes, and i cant go to my notifications" and phone ringing only 1 time when someone calling me.

0

Share this post


Link to post
Share on other sites

Posted · Report post

KonstaT, what kind of battery life do you get out of your Blade III running CM10 ?

How does it compare to the Blade "1" running your same release (i.e. your latest CM10) ?

I've read nice reviews of the Blade 3, but most of them talk about lags and slowdowns in the interface. I'm pretty sure that using a custom ROM totally solves these issues though (can you confirm ?), but I wonder how CM10 impacts the good battery life that all the reviewers agree on.

0

Share this post


Link to post
Share on other sites

Posted · Report post

First, thanks for ROM.

I can also confirm "Sometimes the status bar freezes, and i cant go to my notifications" and phone ringing only 1 time when someone calling me.

Changing composition type to gpu probably fixes the notification freeze (see this post). You can enable repeating ringtone by adding these lines to your /system/build.prop. Or just use a longer ringtone. ;)


ro.telephony.call_ring.multiple=false
ro.telephony.call_ring.delay=3000[/CODE]

KonstaT, what kind of battery life do you get out of your Blade III running CM10 ?

How does it compare to the Blade "1" running your same release (i.e. your latest CM10) ?

I've read nice reviews of the Blade 3, but most of them talk about lags and slowdowns in the interface. I'm pretty sure that using a custom ROM totally solves these issues though (can you confirm ?), but I wonder how CM10 impacts the good battery life that all the reviewers agree on.

Lol, I have no idea. I don't have much experience on regular use with this device. I think my battery has never gone below 75% with CyanogenMod. It spends too much time connected to USB when I'm debugging it. :P Maybe someone else can comment on that.

I spent few days with the stock based ROM and I was impressed with the battery performance. Even the custom kernel didn't seem to trash it. I'd say battery life in my use was at least twice as good as with my old Blade (which has a two years old battery).

I haven't experienced any UI slowdowns with the ROMs I've used. It still has the normal 'Android lag' in few places (multi-tasking view, notification area in jellybean) and few skipped frames every now and then, but that's just something that you should expect from a cheap low performing hardware. In general msm7x27a performance should pretty much match the performance of high-end devices from over two years ago (Nexus S, Galaxy S).

0

Share this post


Link to post
Share on other sites

Posted · Report post

Lol, I have no idea. I don't have much experience on regular use with this device. I don't think my battery has never gone below 75% with CyanogenMod. It spends too much time connected to USB when I'm debugging it. :P Maybe someone else can comment on that.

I spent few days with the stock based ROM and I was impressed with the battery performance. Even the custom kernel didn't seem to trash it. I'd say battery life in my use was at least twice as good as with my old Blade (which has a two years old battery).

I haven't experienced any UI slowdowns with the ROMs I've used. It still has the normal 'Android lag' in few places (multi-tasking view, notification area in jellybean) and few skipped frames every now and then but that's just something that you should expect from a cheap low performing hardware. In general msm7x27a performance should pretty much match the performance of high-end devices from over two years ago (Nexus S, Galaxy S).

OK thanks for sharing your views on the device.

I think there are better (hardware-wise) devices in this same price range, but most of them are not widely distributed and will never have CM support (because the manufacturers won't release source codes).

Once you've tasted custom ROMs (and JB), it's hard the be stuck on original ROMs (most of which will never be upgraded to JB).

BTW, is project butter fully working on this device ? Does it make a noticeable difference ? (I believe it is since you don't mention it in the "not working" list)

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

i am trying to install original rom (update.zip) via cwm and say fail singnature.....

it is possible to install it?

Edited by merc1800k
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

How can i open system/build.prop file? Win explorer shows only sdcard directory. Using terminal emulator? How?

What's good working wifi-hotspot application? I tried severals, but nothing worked.

Edited by Qstom
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

How can i open system/build.prop file? Win explorer shows only sdcard directory. Using terminal emulator? How?

What's good working wifi tethering application? I tried severals, but nothing worked.

root explorer or adb command ;p

adb pull /system/build.prop

and push after edit

adb push /system/build.prop

Edited by x6itru
0

Share this post


Link to post
Share on other sites

Posted · Report post

BTW, is project butter fully working on this device ? Does it make a noticeable difference ? (I believe it is since you don't mention it in the "not working" list)

It's working other than that there's still fake vsync events instead of hw. It's not listed because it makes no difference what so ever.

i am trying to install original rom (update.zip) via cwm and say fail singnature.....

it is possible to install it?

Sounds a lot like CyanogenMod related issue... :P

In CockWorkMod thread:

Do not use this recovery to flash official updates from ZTE website! You need to repack them for ClockWorkMod or use the stock recovery to install.

How can i open system/build.prop file? Win explorer shows only sdcard directory. Using terminal emulator? How?

What's good working wifi-hotspot application? I tried severals, but nothing worked.

Root Explorer is great but it costs few euros. ES file explorer is free.

Wifi tether for root users works for me.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.