• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

[JB] [4.2.2] CyanogenMod 10.1 [ROM]

3412 posts in this topic

Posted · Report post

Issues:

  • Bluetooth MAC address is wrong under the 109808 baseband
  • Random Bluetooth oddities, sometimes screws around when turning it off
  • No overclocking on 109808 yet

45

Share this post


Link to post
Share on other sites

Posted · Report post

Change Log:

Changes in nightly builds since R4:

  • Reverted the change to memory sizes, caused reboots (thanks kra1o5)
  • Removed power HAL, improves battery life (thanks kra1o5)
  • Fixed VOIP audio routing, e.g Viber (thanks ezeteze)
  • Possible "fix" for signal drops? Maybe...

    28/04/2013 - R4
    • Revert to 2030 RIL, should still work on 109808 baseband
    • Switched back to noop scheduler, makes a massive performance difference
    • Caved to peer pressure and reduced mdp/adsp memory sizes, saves 15mb RAM
    • Disable CPU idle, improves battery (thanks kra1o5)
    • Changed backlight values (thanks kra1o5)
    • Enabled volume rocker wake setting
    • Enabled expanded desktop setting
    • Set max background apps to 10
    • Reverted lights HAL changes
    • Fixed device hardware keys value
    • Enabled screen on when USB unplugged
    • Minor clean ups

      02/04/2013 - R3
      • CM now works on both basebands (in a single zip) with some minor caveats:
        • Bluetooth MAC address is wrong under the 109808 baseband, since the serial number of the device is used for it, which differs from the MAC address on 109808. A solution is still being found.
        • No overclocking on 109808 yet.
        • Fixed "adb root" locking adb until the USB was replugged
        • Fixed Wi-Fi tethering (thanks kra1o5)
        • Changes to power HAL which was apparently causing a lot of the battery drain
        • Major changes to Bluetooth - shouldn't crap out anymore but there may still be a few oddities (such as disabling), still working on it.
        • Minor optimisations
        • Switch to filesystem mounter (Jelly Bean style) instead of manually mounting partitions
        • Removed some junk Qualcomm LTE services and other crap
        • Changes to Lights HAL - should fix all bugs with blinking
        • Completely new kernel based on the latest Huawei release, used the opportunity to fix some minor irritants
        • Fixed light sensor
        • Fixed weird bugs that appeared in R2 after the 4.2.2 merge

          16/02/2013 - R2

          • Update to Android 4.2.2 (MR1.1), things to note:

            • ADB now requires you to approve the PC you're using it at on the device
            • Bluetooth is a little more temperamental than on 4.2.1. When disabling, "Bluetooth Share" will force close.
              • [*]Stuff and things are faster in kilofasts

                [*]Voice call changes

                [*]Lockscreen lag fixed

                [*]Minor KGSL tweaks

                [*]Fix an error in the video driver and a load of kmsg spam

                [*]Minor changes to power profile for battery stats (thanks kra1o5)

                [*]Remove MR0 audio blobs, fix audio properly (thanks adfad666)

                [*]Add extra check in power HAL to ensure governor is ondemand

                27/01/2013 - R1

                  [*]Initial release.

47

Share this post


Link to post
Share on other sites

Posted · Report post

Cool!

1

Share this post


Link to post
Share on other sites

Posted · Report post

Awesomesauce.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Very nice work Dazzozo!

Thank's!

0

Share this post


Link to post
Share on other sites

Posted · Report post

WOW

0

Share this post


Link to post
Share on other sites

Posted · Report post

I'm gonna try this very very very soon :D

0

Share this post


Link to post
Share on other sites

Posted · Report post

Come on people, please try it and post some feedback here :) ! I got fed up with 3G reboots so my bootloader is locked at the moment, otherwise I wold give it a chance immediately.

1

Share this post


Link to post
Share on other sites

Posted · Report post

Probably worth mentioning: a fix was found for the third party cameras purely because the new camera in 4.2 initially didn't work for the same reason as third party cameras on CM9 and CM10.

The "fix" (hack) actually modifies CM source. The change will make its way back to CM9 and CM10 for the next builds.

The pano is also usable again, I don't know why, I didn't change anything to improve it. CM10.0 just had a funny with it but with CM10.1 it works fine...

Unless it was the same "fix".

0

Share this post


Link to post
Share on other sites

Posted · Report post

Thanks !

0

Share this post


Link to post
Share on other sites

Posted · Report post

great work Daz!

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

97 111 users are viewing this...

You lucky **** :lol:

Edited by kyan31
0

Share this post


Link to post
Share on other sites

Posted · Report post

Woooow thanks !

0

Share this post


Link to post
Share on other sites

Posted · Report post

Sweet. Thanks a lot Dazzozo

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Lol my connection dropped from 600 Kbps to 50 17 <_<

There must be a TON of people downloading this.

Edited by kyan31
0

Share this post


Link to post
Share on other sites

Posted · Report post

downloading :D tks Daz

0

Share this post


Link to post
Share on other sites

Posted · Report post

Can't wait! But really slow on the new google apps download - 10 hours remaining?!?!?

0

Share this post


Link to post
Share on other sites

Posted · Report post

I sold my G300 yesterday :(

0

Share this post


Link to post
Share on other sites

Posted · Report post

Can't wait! But really slow on the new google apps download - 10 hours remaining?!?!?

Yeah, goo.im does that. :P

0

Share this post


Link to post
Share on other sites

Posted · Report post

Thanks Dazzozo :)

0

Share this post


Link to post
Share on other sites

Posted · Report post

Can't wait! But really slow on the new google apps download - 10 hours remaining?!?!?

Use DAP download manager. It can multiply your download speed up to 60x

Right now, I am actually using my phone to tether internet to my laptop, and I usually get 400-600 Kbps when downloading.

0

Share this post


Link to post
Share on other sites

Posted · Report post

I sold my G300 yesterday sad.png

But-why-meme.png

WHY?

1

Share this post


Link to post
Share on other sites

Posted · Report post

Updated OTA from R5 and a few problems

Play Store broken wont launch

Apex Launcher broken

Link2SD unable to recreate mount script to apps on sd

Hope its just me?

0

Share this post


Link to post
Share on other sites

Posted · Report post

Is everyone flashing this OTA over CM10, or clean install/full wipes?

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.