kashmiri

B952: Stuck on stock

7 posts in this topic

Stock B952 has "locked" my phone so that no flashing/upgrade to non-stock is possible, irrespective of what I try.

History in brief: Initially on stock B882, flashed to B892 (stock), then B927 (leaked stock), then B936 (stock), now on official stock B952. Never a single problem during flashing. After each flashing I (re-)rooted the phone (via adb), just in case.

A few days back I tried to flash Dazzozo's CM10.1 via (stock) recovery. No success. I read that I needed CM recovery. So, tried to flash CM recovery via fastboot - upload to phone went fine, then "no permissions to write the image". Same result with other third-party recovery images. Tried to "fix permissions" using ROM Manager, but all I get is an error message.

Reflashed stock B952 - the process went smoothly as always.

My uneducated guess is the bootloader is locked - but have no way of confirming or denying this. Attempts to unlock the bootloader using unlock scripts fail with the same "writing error" message.

I have no idea what to do now. Shall I downgrade to GB and then try to install CM??? Sounds crazy.

Any advice/help would be warmly appreciated.

k.

Edited by kashmiri
0

Share this post


Link to post
Share on other sites

Yeah, it does sound like you just have a locked bootloader.

The plan of action;

  1. root the phone
  2. unlocked bootloader
  3. Install Clockworkmod recovery
  4. Install 10.1 or any other rom of your choice

I'll help get you started; use this to get root and then unlock BL. https://docs.google....-aeM/edit?pli=1

Once that is done, you'll need to get clockworkmod installed. There are a load of guides in the stickies that should help but if you get stuck post here.

Edit: fixed info. had wrong order on root/unlock.

Edited by Cyda
0

Share this post


Link to post
Share on other sites

Thanks for reply. Unfortunately, that's not really working. First, I can't even connect to phone when in the prompt mode (power + vol down): "no device found". My computer only sees the phone in recovery mode (power + vol up). Then, the result is a "segmentation fault":

Clipboard01.png

0

Share this post


Link to post
Share on other sites

Boot the phone up so it is on and working. The make sure USB debugging is enabled and that you have the Windows drivers installed correctly, then connect USB cable and run the root.bat. That should then gain root access, then you can run the bootloader.bat and hopefully it should work. Sorry for not making that clearer, its been a while since I rooted mine.

0

Share this post


Link to post
Share on other sites

Phone is rooted, USB debugging enabled. Running root again, will see in a moment.

0

Share this post


Link to post
Share on other sites

You are a genius! Run root again, then recovery flashed fine.

Now, it seems that was a wrong recovery (CM 5) because the phone does not start to recovery on start + vol up. Stuck on HW logo...

Trying to flash other recoveries (CM 6, open recovery, etc.), hope one of them will be working...

0

Share this post


Link to post
Share on other sites

Cyanogen Recovery 6 working, now updating to Dazzozo's 10.1.

Man, after my two nights of fighting with the phone you rescued me in just two sentences!

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.