• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

[ROM][ICS] Stock+ ROM [B960 - R6 | Updated: 06-03]

1233 posts in this topic

Posted (edited) · Report post

i've managed to install this topic rom and working great but something is not installed:

"App drawer > No-Frills CPU > Set Governor to SmartassV2, set I/O scheduler to noop and for nice performance boost set the Max clock frequency to 1.152Ghz."

--none No-Frills in my app.

"Added a fix for 800x480 video recording"

--still max vga recording

anything to do to get all the enhancement?

The No-Frills CPU app is included with the rom, no idea why it isn't showing for you but it is there. The only way I can think that it wouldn't be there is if you did a factory reset AFTER installing the rom.

As for the video recording, this has been mentioned a few times in this thread, it says VGA but the output video is 800x480.

Well I haven't installed LinkInt or Volume+ yet, just restored from All Backup: ampDroid, 2g/3g widget, Wifi/3G widget and Silent mode widget. Already I've had a few FCS/not responding with ampDroid, Gmail has started acting up when refreshing and I can't seem to play videos either with Video Player or ES, even though I've got 170MB free. I tend to get a couple of seconds and then I get a Media_Server_Error. I've tried selecting files in ES Explorer and trying both players and just get "Sorry, unsupported media type" with flv files and with avi files I don't even get a choice of player, it just says "Sorry, this video cannot be played".

I've had a bit better luck starting play via ampDroid. With Android FFmpeg HD profile the internal player fails after a couple of seconds but with External player (ES) it plays but is very out-of-sync and choppy. With FFmpeg HQ, medium or LQ it fails after a couple of seconds even with ES Player. With VLC Direct or HD profile I just get a black screen. With VLC HQ, medium or LQ it again stops after a couple of seconds. HTTP Live Streaming HD didn't work (black screen) so I then skipped to HTTP Live Streaming LQ profile and that seemed to be OK and in sync (only tested for about 15-20s though). I then tested HTTP Live Streaming medium and that seemed OK too.

I'm using my 54Mbps WiFi router, with the video files on my PC but the AVI I'm testing with only has a bitrate of 986kbps.

If you are trying to avoid issues I would avoid restoring a backup from All backup. I have hard of cases of it restoring as many problems as it does apps. If you want a true test of the rom do a fresh install and install the apps from the play store and don't try to restore data from old roms via backup apps. Then you can properly test the rom.

Edited by Cyda
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

If you are trying to avoid issues I would avoid restoring a backup from All backup. I have hard of cases of it restoring as many problems as it does apps. If you want a true test of the rom do a fresh install and install the apps from the play store and don't try to restore data from old roms via backup apps. Then you can properly test the rom.

Yeah fair enough, I was just trying to avoid having to setup ampDroid all over again as I wanted to watch TV and it's my only remote control at the moment ;) I can't imagine the three widgets would cause any problems restoring from backup as they don't really have any settings but I'll do a fresh install. How can I completely uninstall ampDroid and the widgets and their data so that I can install them fresh from the store? I don't want to do yet another fresh install if avoidable just to uninstall four apps, as I'll lose the settings changes and home icon rearranging that I've done today.

I doubt the video playback problems will be any better after doing that though as I couldn't play them even with the pre-installed ES Explorer/player. Maybe that's not a very good player but I did try MX and VLC before and couldn't find any way to browse video files on the LAN with those but I think I can use ES Explorer to browse and then get MX or VLC to play the video files when I select them.

EDIT: I found I could Clear All Data for each app and then uninstall it, so I did that for ampDroid and the three widgets I'd restored and did a fresh install of ampDroid and I'll see how it goes.

Edited by doveman
0

Share this post


Link to post
Share on other sites

Posted · Report post

The No-Frills CPU app is included with the rom, no idea why it isn't showing for you but it is there. The only way I can think that it wouldn't be there is if you did a factory reset AFTER installing the rom.

errm i don't remember to make this reset AFTER :wacko:

About the vidz,i will try asap,thanks again for all the work behind the release.

0

Share this post


Link to post
Share on other sites

Posted · Report post

I think I can use ES Explorer to browse and then get MX or VLC to play the video files when I select them.

Thats how I do it. CIFSManager & mobo player are also good for this. I wouldn't expect ES file explorer to play all videos I think it handles normal avis ok but will fall down on a lot of codecs.

0

Share this post


Link to post
Share on other sites

Posted · Report post

it's normal imei sv change when installing this rom?

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Cyda, Can you fix Dead Trigger/ShadowGun issue, in CM ROMs is fixed it ;)

Edited by marcioo
0

Share this post


Link to post
Share on other sites

Posted · Report post

best way to combat this is to change the sleep policy, in the build.prop add these lines to the bottom (if already there edit them)

pm.sleep_mode=1

ro.ril.disable.power.collapse=0

with theses settings you should experience no more than 3 - 5%

or

pm.sleep_mode=0

ro.ril.disable.power.collapse=0

or

pm.sleep_mode=1

ro.ril.disable.power.collapse=1

you will have to try them all to see witch gives best results for you, first one is what i normally use

Thanks tillaz.....

is this the same problem which was discussed earlier in this thread.....wifi sleep policy??

like this.... I mean the wifi/advanced/Keep Wifi on/ "never" system setting..... which seems not to work on this ROM?

I have been using an app to achieve deep sleep overnight, with wifi switching off after screen off for a certain time period, I have set 30 secs.

I would like to see a solution which does not require an app, so thank you.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Got up this morning and tested Gmail and had the old problem of it saying "No connection. Please retry" and having to refresh several times. Then I tried ampDroid and that stopped responding as well, so I'm not doing very well here :(

I often see things "Restarting" in the apps list, when I checked this morning it was DSP Manager.

I don't use 2G/3G as I'm not on a data plan, so I'm just using WiFi at home.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Guys could you help me please. After I turn off USB storage I lost my ringtone. It says "default" in settings and there's no sound when my phone is ringing. I need to set ringtone again. What's the problem?

0

Share this post


Link to post
Share on other sites

Posted · Report post

Got up this morning and tested Gmail and had the old problem of it saying "No connection. Please retry" and having to refresh several times. Then I tried ampDroid and that stopped responding as well, so I'm not doing very well here :(

I often see things "Restarting" in the apps list, when I checked this morning it was DSP Manager.

I don't use 2G/3G as I'm not on a data plan, so I'm just using WiFi at home.

I have this too, with the sync on this error comes up less

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

best way to combat this is to change the sleep policy, in the build.prop add these lines to the bottom (if already there edit them)

pm.sleep_mode=1

ro.ril.disable.power.collapse=0

with theses settings you should experience no more than 3 - 5%

.....snip....snip

you will have to try them all to see witch gives best results for you, first one is what i normally use

OK tillaz.....

I have modified the /system/build.prop, with your first values, bolded above.....

[Just a little advice, for those who are not comfortable directly modifying this file, there is a good app, from JRummy, Build Prop Editor....

you can make back-ups, which are stored in /mnt/sdcard/romtoolbox/build.prop-backups folder....but don't worry, you can restore from within the App!!!]

Just initially, and with the Better WiFi on/off app disabled, [which I am successfully using to implement the missing WiFi Sleep when Screen Off in this ROM]

This does not actually switch WiFi Off when screen goes Off. [ I leave the WiFi/Advanced/Keep Wi-Fi on during sleep setting at Never, as usual]

That is just on a half-hour test period, so maybe it does something else??

Can this be used in conjunction with the Better WiFi nn/off App??

I will do a test over a longer period, like over-night, and report here.

Thanks for this, IP

Edited by irishpancake
0

Share this post


Link to post
Share on other sites

Posted · Report post

OK tillaz.....

I have modified the /system/build.prop, with your first values, bolded above.....

Just a little advice, for those who are not comfortable directly modifying this file, there is a good app, from JRummy, Build Prop Editor....

you can make back-ups, which are stored in /nt/sdcard/romtoolbox/build.prop-backups folder....but don't worry, you can restore from within the App!!!

Just initially, and with the Better WiFi on/off app disabled, [which I am successfully using to implement the missing WiFi Sleep when Screen Off in this ROM]

This does not actually switch WiFi Off when screen goes Off. [ I leave the WiFi/Advanced/Keep Wi-Fi on during sleep setting at Never, as usual]

That is just on a half-hour test period, so maybe it does something else??

Can this be used in conjunction with the Better WiFi nn/off App??

I will do a test over a longer period, like over-night, and report here.

Thanks for this, IP

those settings are for how the CPU is handled once the screen is off, it wont have an effect on the WiFi radio

pm.sleep_mode=0 -> Power Collapse Suspend

pm.sleep_mode=1 -> Power Collapse (Provides best power savings)

pm.sleep_mode=2 -> Apps Sleep

pm.sleep_mode=3 -> Slow Clock and Wait for Interrupt

pm.sleep_mode=4 -> Wait for Interrupt

EDIT:

you can add this to the build.prop to use less battery when on wifi

wifi.supplicant_scan_interval=150

1

Share this post


Link to post
Share on other sites

Posted · Report post

This does not actually switch WiFi Off when screen goes Off. [ I leave the WiFi/Advanced/Keep Wi-Fi on during sleep setting at Never, as usual.

Wow, I didn't even know about that setting. I want to use e-mail/chat/SIP apps on my G300 and it's not much use if the WiFi is disabled whenever the phone sleeps as I have Data disabled!

I checked and this was set to Never so I've changed it to Always now which I presume is what I need to use, although obviously that's going to drain the battery more. I assume that Data drains the battery more than WiFi though, so getting on a data plan and using Data instead of WiFi for my apps would only drain the battery quicker.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Wow, I didn't even know about that setting. I want to use e-mail/chat/SIP apps on my G300 and it's not much use if the WiFi is disabled whenever the phone sleeps as I have Data disabled!

I checked and this was set to Never so I've changed it to Always now which I presume is what I need to use, although obviously that's going to drain the battery more. I assume that Data drains the battery more than WiFi though, so getting on a data plan and using Data instead of WiFi for my apps would only drain the battery quicker.

It won't matter.... Never is Always anyway... cos it doesn't work on this rom as intended!!

This was the point of my post, I'm like a dawg with a bone over this issue ;-)

Keeping wifi on during sleep set to "Never" could mean using mobile data.... if 3G is enabled, you could fallback to your mobile data, hence the warning (increases data usage) is my understanding.

I wouldn't lose any sleep over it... heh heh

0

Share this post


Link to post
Share on other sites

Posted · Report post

those settings are for how the CPU is handled once the screen is off, it wont have an effect on the WiFi radio

pm.sleep_mode=0 -> Power Collapse Suspend

pm.sleep_mode=1 -> Power Collapse (Provides best power savings)

pm.sleep_mode=2 -> Apps Sleep

pm.sleep_mode=3 -> Slow Clock and Wait for Interrupt

pm.sleep_mode=4 -> Wait for Interrupt

EDIT:

you can add this to the build.prop to use less battery when on wifi

wifi.supplicant_scan_interval=150

Thanks tillaz... you anticipated my next question... the wifi scan interval!! ...

I have seen it mentioned elsewhere as a battery saving setting, so I will add that in too...what is the default??

I don't have the phone atm, but last I looked, after adding the other mods, and allowing sleep for a few hours, there seemed to be a definite improvement in the battery stats, looking to the graph anyway....

but I will check after a longer sleep period tomorrow, sorry Thurs..

Chemo tomorrow!!! Yuck!!

0

Share this post


Link to post
Share on other sites

Posted · Report post

I have this bugs (little bugs):

- On dead trigger and shadowgun dont work well

- After a while, the light my buttons dont work, I have to reboot to fix it.

0

Share this post


Link to post
Share on other sites

Posted · Report post

It won't matter.... Never is Always anyway... cos it doesn't work on this rom as intended!!

This was the point of my post, I'm like a dawg with a bone over this issue ;-)

Keeping wifi on during sleep set to "Never" could mean using mobile data.... if 3G is enabled, you could fallback to your mobile data, hence the warning (increases data usage) is my understanding.

I wouldn't lose any sleep over it... heh heh

Ah gotcha! That's cool for me then as I don't want/need it to work and want it on Always anyway :)

So I could just try adding

pm.sleep_mode=1

ro.ril.disable.power.collapse=0

wifi.supplicant_scan_interval=150

to build.prop then but I'm not really clear on whether sleep_mode=1 will allow apps to continue to scan for incoming Wi-Fi data (i.e. chat messages, SIP calls) or not?

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Looking for a little help. I've noticed lately, that it takes awhile for my phone to find it's head after coming off deep sleep. (not sure if this relates to the discussion over the last few days or not)

The clock settings are:

Max: 1.152 Ghz

Min: 320 mhz

Gov: smartassV2

Scheduler: sio

Also thinking that perhaps the phone is too full.

SD card: 17% free

Ext.SD (using the Link2int): 65% free

Internal: 12% free

Thanks in advance

Edited by Colossae3.23
0

Share this post


Link to post
Share on other sites

Posted · Report post

Ah gotcha! That's cool for me then as I don't want/need it to work and want it on Always anyway smile.png

So I could just try adding

pm.sleep_mode=1

ro.ril.disable.power.collapse=0

wifi.supplicant_scan_interval=150

to build.prop then but I'm not really clear on whether sleep_mode=1 will allow apps to continue to scan for incoming Wi-Fi data (i.e. chat messages, SIP calls) or not?

it will

sleep_mode=0 won't

0

Share this post


Link to post
Share on other sites

Posted · Report post

Looking for a little help. I've noticed lately, that it takes awhile for my phone to find it's head after coming off deep sleep. (not sure if this relates to the discussion over the last few days or not)

The clock settings are:

Max: 1.152 Ghz

Min: 320 mhz

Gov: smartassV2

Scheduler: sio

Also thinking that perhaps the phone is too full.

SD card: 17% free

Ext.SD (using the Link2int): 65% free

Internal: 12% free

Thanks in advance

this normally happens when the Min clock speed is to two low, think smartass puts it on the lowest possible when off

try changing to ondemand, and see if it still happens,

or get an app that monitors you clock speeds and see what its on when in deep sleep, if its lower than 320 mhz that might be why

0

Share this post


Link to post
Share on other sites

Posted · Report post

Looking for a little help. I've noticed lately, that it takes awhile for my phone to find it's head after coming off deep sleep. (not sure if this relates to the discussion over the last few days or not)

The clock settings are:

Max: 1.152 Ghz

Min: 320 mhz

Gov: smartassV2

Scheduler: sio

Also thinking that perhaps the phone is too full.

SD card: 17% free

Ext.SD (using the Link2int): 65% free

Internal: 12% free

Thanks in advance

I've got the same settings except I'm using noop as advised, instead of sio, so I guess you could try that as I don't have the problem you report.

My ext SD is pretty much full but my 2.05GB internal is empty at the moment as I haven't got round to setting up Link2int yet. Not sure how you check the % free on all locations.

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

it will

sleep_mode=0 won't

Great, thanks.

On another matter, looking at PimpMyRom it has options to Enable HW acceleration and Force GPU Rendering which are both currently shown as OFF and I wonder if enabling them would improve the phone's performance?

It also has an option to Detect Current Value for the WiFi Scan Interval but just says "Current Value Not Found".

EDIT: Looking at build.prop, I see a persist.wifi_scan_interval=149 as well as wifi.supplicant_scan_interval=150 (which I just set). I thought PimpMyRom might have created the former as I did set the slider to 149 (although didn't Apply, so didn't expect it to do anything) but using "Detect Current Value" shows 150 now, so that seems to be linked to the wifi.supplicant_scan_interval and not this other setting.

Edited by doveman
0

Share this post


Link to post
Share on other sites

Posted · Report post

this normally happens when the Min clock speed is to two low, think smartass puts it on the lowest possible when off

try changing to ondemand, and see if it still happens,

or get an app that monitors you clock speeds and see what its on when in deep sleep, if its lower than 320 mhz that might be why

that seems better, I'll keep an eye on it. Thanks

0

Share this post


Link to post
Share on other sites

Posted · Report post

those settings are for how the CPU is handled once the screen is off, it wont have an effect on the WiFi radio

pm.sleep_mode=0 -> Power Collapse Suspend

pm.sleep_mode=1 -> Power Collapse (Provides best power savings)

pm.sleep_mode=2 -> Apps Sleep

pm.sleep_mode=3 -> Slow Clock and Wait for Interrupt

pm.sleep_mode=4 -> Wait for Interrupt

This technical blog post busts the myth of pm.sleep_mode, and states "adding this value to your build.prop will have no effect at all". There's nothing about the ril power collapse setting, but there's a comment that seems to suggest that it'll have no effect either. I'd guess that 0 was the default anyway.

Anyone got empirical evidence that these do have any effect?

As Winston Churchill once said: "don't believe anything you read on the Internet". ;)

0

Share this post


Link to post
Share on other sites

Posted · Report post

I've got the same settings except I'm using noop as advised, instead of sio, so I guess you could try that as I don't have the problem you report.

My ext SD is pretty much full but my 2.05GB internal is empty at the moment as I haven't got round to setting up Link2int yet. Not sure how you check the % free on all locations.

I got the percentages from the Link2SD app, that comes along when you flash the Link2int zip
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.