• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

[DEV][ROM][17.9.] CyanogenMod 10.1 (Android 4.2.2)

972 posts in this topic

Posted

Isn't /system /boot /data enough? I really don't know what those other 20 partitions are good for ... radio doesn't work anyways xD

Err, not FM radio. GSM/HSPA mobile radio.

No, that would only be enough for the very final part of loading Android and its filesystems (nothing too special there). There's a series of bootloaders that are responsible for loading core systems before loading actual OS. I guess you could compare this to BIOS on your computer. Internal nand has a separate partition for each of these. My educated guess is that these are loaded in the order that they are in the nand. Qualcomm's bootloader loads OEM's (ZTE's) bootloader which loads radio firmware and eMMC bootloader which again loads boot.img where android partitions are mounted in ramdisk.


1 8192 mmcblk0p1 /qcsblhd_cfg
2 8192 mmcblk0p2 /qcsbl
3 8192 mmcblk0p3 /oemsbl
4 1 mmcblk0p4
5 8192 mmcblk0p5
6 8192 mmcblk0p6
7 8192 mmcblk0p7
8 16384 mmcblk0p8
9 32768 mmcblk0p9
10 16384 mmcblk0p10 /persist
11 8192 mmcblk0p11 /cefs
12 8192 mmcblk0p12
13 65536 mmcblk0p13 /amss
14 8192 mmcblk0p14
15 8192 mmcblk0p15 /emmcboot
16 16384 mmcblk0p16 /boot
17 16384 mmcblk0p17 /recovery
18 16384 mmcblk0p18 /splash
19 409600 mmcblk0p19 /system
20 8192 mmcblk0p20 /misc
21 307200 mmcblk0p21 /cache
22 2621440 mmcblk0p22 /data
23 188416 mmcblk0p23
[/CODE]

0

Share this post


Link to post
Share on other sites

Posted

Err, not FM radio. GSM/HSPA mobile radio.

No, that would only be enough for the very final part of loading Android and its filesystems (nothing too special there). There's a series of bootloaders that are responsible for loading core systems before loading actual OS. I guess you could compare this to BIOS on your computer. Internal nand has a separate partition for each of these. My educated guess is that these are loaded in the order that they are in the nand. Qualcomm's bootloader loads OEM's (ZTE's) bootloader which loads radio firmware and eMMC bootloader which again loads boot.img where android partitions are mounted in ramdisk.


1	 8192 mmcblk0p1 /qcsblhd_cfg

2	 8192 mmcblk0p2 /qcsbl

3	 8192 mmcblk0p3 /oemsbl

4 1 mmcblk0p4

5	 8192 mmcblk0p5

6	 8192 mmcblk0p6

7	 8192 mmcblk0p7

8	 16384 mmcblk0p8

9	 32768 mmcblk0p9

10	 16384 mmcblk0p10 /persist

11	 8192 mmcblk0p11 /cefs

12	 8192 mmcblk0p12

13	 65536 mmcblk0p13 /amss

14	 8192 mmcblk0p14

15	 8192 mmcblk0p15 /emmcboot

16	 16384 mmcblk0p16 /boot

17	 16384 mmcblk0p17 /recovery

18	 16384 mmcblk0p18 /splash

19	 409600 mmcblk0p19 /system

20	 8192 mmcblk0p20 /misc

21	 307200 mmcblk0p21 /cache

22 2621440 mmcblk0p22 /data

23	 188416 mmcblk0p23

Oh, god :D why can't it all be stored on a single partition?? Is ubuntu for phones gonna use this scheme too?? xD I know that this is not about CM10.1 but imo there are only 12 pages .. we need to discuss this to make Blade 3&this ROM more popular :D

0

Share this post


Link to post
Share on other sites

Posted

Oh, god :D why can't it all be stored on a single partition?? Is ubuntu for phones gonna use this scheme too?? xD I know that this is not about CM10.1 but imo there are only 12 pages .. we need to discuss this to make Blade 3&this ROM more popular :D

Like I tried to explain, this has nothing to do with Android (or any other OS) you're running.

Hardware implementation in Ubuntu for phones is nothing but Android (actually CM10.1) fork. You're just chrooting Ubuntu image. Very lame if you ask me but it allows them to easily support wide range of devices.

0

Share this post


Link to post
Share on other sites

Posted

ROM could be two, one of them would be internal storage not the other. or aroma installer

0

Share this post


Link to post
Share on other sites

Posted

In File Manager I have: Internal Storage (/storage/sdcard0) and SD card (storage/sdcard1). I removed the sdcard from the phone ... why is it there?? Also, the second doesn't have write permissions, but it basically redirects anything to /storage/sdcard0 ...Did I do anything wrong ?

0

Share this post


Link to post
Share on other sites

Posted (edited)

positive development: ext4 is supported for SD card; no need for FAT at all.

# grep sdcard /proc/mounts

/dev/block/vold/179:33 /mnt/fuse/sdcard ext4 rw,dirsync,nosuid,nodev,noexec,noatime,user_xattr,barrier=1,data=ordered 0 0

tmpfs /mnt/fuse/sdcard/.android_secure tmpfs ro,relatime,size=0k,mode=000 0 0

/dev/fuse /storage/sdcard0 fuse rw,nosuid,nodev,relatime,user_id=1023,group_id=1023,default_permissions,allow_other 0 0

Otila, plz tell me how exactly did u get that ext4 to work? I've been trying this for a few days now ... did u use adb shell / busybox / sdcard reader ? It just doesn't show up the card if I format it to ext4.... :(((

Also what is the internal sdcard doing there? I don't wanna have any internal sd card ....

Edited by plantroon
0

Share this post


Link to post
Share on other sites

Posted

Dear KonsaT,

First, let me thank you for your efforts for Blade III developement.

The 4/18 CM10.1 ROM is very fast and fluid and I think one can live without bluetooth, so it is a very nice ROM indeed.

BUT, I have one major complaint. As others have already pointed out, the way this ROM handles sd card is rather... strange. For me, who uses Play Music as my only music app, this current configuration renders my phone unusable as a music player. Play Music downloads music to the internal storage, which is only 2.5 Gb minus the 1 Gb of apps I have already installed. Also, many other apps (95%) use said internal space for cacheing and data storing purposes. This way there is almost no point in having an external sd card slot.

The argument which you told others in this thread (that we should use the copy function) is unfortunately invalid. If we had only one e.g. 16 GB partition, it would be no problem, every data could go to the remaining ~13 GB of storage (music, camera pics, app cache etc). But we only have 2.5 GB of internal storage and having everything in internal storage is not the way our device should behave.

I have not much experience in developing/compiling custom roms, but I trust it would be an easy fix. I understand you have a different opinion in this case, but at least please make it an option somehow for us to have it the old way.

Thank you and best regards,

1amarr

0

Share this post


Link to post
Share on other sites

Posted (edited)

@1amarr I just wanted to point out the same thing ... I noticed that when I downloaded some bigger games ... the sd card remained empty .. everything was in internal storage, I tried to do a lot of things but I just can't get it working ...

This should be fixed asap ...

Hmm ... I started having this problem after 4/18 update ... I had it everything working before and when I started some games/apps they started redownloading data ... then I realised it uses different location .. and I don't remember what I did after this :D

Edited by plantroon
1

Share this post


Link to post
Share on other sites

Posted

ROM could be two, one of them would be internal storage not the other. or aroma installer

Absolutely not. This is not some winzipped ROM. I upload a single update zip that directly comes out of the build process.

Dear KonsaT,

First, let me thank you for your efforts for Blade III developement.

The 4/18 CM10.1 ROM is very fast and fluid and I think one can live without bluetooth, so it is a very nice ROM indeed.

BUT, I have one major complaint. As others have already pointed out, the way this ROM handles sd card is rather... strange. For me, who uses Play Music as my only music app, this current configuration renders my phone unusable as a music player. Play Music downloads music to the internal storage, which is only 2.5 Gb minus the 1 Gb of apps I have already installed. Also, many other apps (95%) use said internal space for cacheing and data storing purposes. This way there is almost no point in having an external sd card slot.

The argument which you told others in this thread (that we should use the copy function) is unfortunately invalid. If we had only one e.g. 16 GB partition, it would be no problem, every data could go to the remaining ~13 GB of storage (music, camera pics, app cache etc). But we only have 2.5 GB of internal storage and having everything in internal storage is not the way our device should behave.

I have not much experience in developing/compiling custom roms, but I trust it would be an easy fix. I understand you have a different opinion in this case, but at least please make it an option somehow for us to have it the old way.

Thank you and best regards,

1amarr

Google Music is not available in my country, but I've always thought the whole point of it was that it's cloud based and you don't need to store the music on your device. :o Any mp3s you've stored on your external sdcard will of course work just fine with Google Music and other music players (and media files will work just fine with Gallery/etc).

With all my apps installed I still have 2GB available on my internal storage. I keep music, photos, videos, ROMs, ClockWorkMod backups, etc on my external sdcard. I don't have any problem with the size of the internal storage.

No, you don't understand. It's currently implemented in the only correct way. It is not broken - there is nothing to fix.

https://android.goog...torage/index.md

Only other possible solutions is that I revert it back to the previous implementation (only external sdcard) and take crap from the ones who want to utilize the internal storage.

This should be fixed asap ...

Dude, you have no idea what you're talking about. There's nothing that needs to fixed asap. You wan't something fixed or working the way you like it, you better do it yourself!

0

Share this post


Link to post
Share on other sites

Posted

Ok then...but plz tell me how do I disable that internal storage and make it store photos,videos,odb data and other stuff on the external sdcard?? Internal sdcard is rely useless on blade 3

0

Share this post


Link to post
Share on other sites

Posted

Ok then...but plz tell me how do I disable that internal storage and make it store photos,videos,odb data and other stuff on the external sdcard?? Internal sdcard is rely useless on blade 3

0

Share this post


Link to post
Share on other sites

Posted

Ok then...but plz tell me how do I disable that internal storage and make it store photos,videos,odb data and other stuff on the external sdcard?? Internal sdcard is rely useless on blade 3

Camera -> Settings -> Storage

By definition "Secondary external storage must not be writable by apps." because of the multi-user support in Android 4.2.

https://android.googlesource.com/platform/docs/source.android.com/+/master/src/tech/storage/index.md

0

Share this post


Link to post
Share on other sites

Posted

Otila, plz tell me how exactly did u get that ext4 to work? I've been trying this for a few days now ... did u use adb shell / busybox / sdcard reader ? It just doesn't show up the card if I format it to ext4.... :(((

I partitioned it in Linux, just one primary partition, then created filesystem with mkfs.ext4.

The gallery might have started working with ext4, too, maybe, ;) if I had hacked a bit.

0

Share this post


Link to post
Share on other sites

Posted

another reboot (this time I was not even using wifi and not changing wifi settings).


[04-22 10:45:28.441] [21: krpcserversd]LHX_RPC __msm_rpc_read prog= 0x30000015 proc= 0x00000002

[04-22 10:45:28.922] wake lock unknown_wakeups, expired

[04-22 10:45:28.922] [8646: kworker/u:2][cpufreq] [1]change policy freq from (3c000,f6180) to (f6180,f6180)

[04-22 10:45:28.922] [15746: kworker/u:3]PM: Syncing filesystems...

[04-22 10:45:28.922] [15746: kworker/u:3]sync done.

[04-22 10:45:28.922] [8646: kworker/u:2]suspend: enter suspend

[04-22 10:45:28.922] [15746: kworker/u:3]PM: Syncing filesystems...

[04-22 10:45:28.922] [15746: kworker/u:3]sync done.

[04-22 10:45:28.922] [8646: kworker/u:2]zte_console vt_move_to_console BEGIN: SUSPEND console 0 ----> 62!!!!

[04-22 10:45:28.922] [8646: kworker/u:2]zte_console vt_move_to_console DONE!!!!

[04-22 10:45:28.922] [8646: kworker/u:2]PM_SUSPEND_PREPARE

[04-22 10:45:28.922] [160: rild]pm_monitor_read enter

[04-22 10:45:28.922] [160: rild]pm_monitor_read exit

[04-22 10:45:28.972] [8646: kworker/u:2]Freezing user space processes ...

[04-22 10:45:28.972] [115: akmd8962_new]akm8962 0-000c: Get Open returns error (-512).(elapsed 0.02 seconds) done.

[04-22 10:45:28.992] [8646: kworker/u:2]Freezing remaining freezable tasks ... (elapsed 0.01 seconds) done.

[04-22 10:45:29.012] [8646: kworker/u:2]Suspending console(s) (use no_console_suspend to debug)

[04-22 10:45:29.012] [8646: kworker/u:2]rtc_suspend, rtc time 0113 03 22 10 45 30

[04-22 10:45:29.012] [8646: kworker/u:2]rtc_suspend, rtc sec 1366627530

[04-22 10:45:29.012] [8646: kworker/u:2]radio-tavaruatavarua_suspend: radio suspend

[04-22 10:45:29.012] [8646: kworker/u:2]

[04-22 10:45:29.012] [8646: kworker/u:2]msm_pm_set_max_sleep_time(): Requested 30000000000 ns Giving 983058 sclk ticks (= 30 s)

[04-22 10:45:29.022] [8646: kworker/u:2]msm_batt_suspend: enter

[04-22 10:45:29.022] [8646: kworker/u:2]msm_batt_suspend: exit

[04-22 10:45:29.022] [8646: kworker/u:2]PM: suspend of devices complete after 10.680 msecs

[04-22 10:45:29.022] [8646: kworker/u:2]power_suspend_late return 0

[04-22 10:45:29.022] [8646: kworker/u:2]PM: late suspend of devices complete after 0.335 msecs

[04-22 10:45:29.025] [8646: kworker/u:2]msm_pm_enter(): sleep limit 0

[04-22 10:45:29.025] [8646: kworker/u:2]msm_pm_power_collapse(): idle 0, delay 983058, limit 0

[04-22 10:45:29.025] [8646: kworker/u:2]msm_pm_power_collapse(): msm_pm_collapse returned 1

[04-22 10:45:29.025] [8646: kworker/u:2]record_sleep_awake_time(): APP keep: 0.604 s !!!!!!!!!!awake lcd on for 0 s 0 %

[04-22 10:45:29.025] [8646: kworker/u:2]msm_pm_enter(): return 0

[04-22 10:45:29.025] [8646: kworker/u:2]timekeeping_resume,0

[04-22 10:45:29.025] [8646: kworker/u:2]PM: early resume of devices complete after 0.396 msecs

[04-22 10:45:29.025] [8646: kworker/u:2]msm_batt_resume: enter

[04-22 10:45:29.025] wakeup wake lock: rpcrotuer_smd_xprt

[04-22 10:45:29.025] [8646: kworker/u:2]ZHY:charger_status= invalid,charger_type= no charger,battery_status= good ,batt_status= not charing,batt_level= good,batt_vol= 3987,batt_temp= 31,batt_cap= 74,allow2shutdown(1?y;n)= 1

[04-22 10:45:29.025] [8646: kworker/u:2]msm_batt_resume: exit

[04-22 10:45:29.025] [8646: kworker/u:2]radio-tavaruatavarua_resume: radio resume

[04-22 10:45:29.025] [8646: kworker/u:2]

[04-22 10:45:58.420] [8646: kworker/u:2]timekeeping_inject_sleeptime,29

[04-22 10:45:58.420] [8646: kworker/u:2]rtc_resume, rtc time 0113 03 22 10 46 00

[04-22 10:45:58.420] [8646: kworker/u:2]rtc_resume, rtc sec 1366627560

[04-22 10:45:58.420] [8646: kworker/u:2]rtc_resume, old_system 1366627528

[04-22 10:45:58.420] [8646: kworker/u:2]rtc_resume, new_system 1366627529

[04-22 10:45:58.420] [8646: kworker/u:2]rtc_resume, sleep_time 29

[04-22 10:45:58.420] [8646: kworker/u:2]PM: resume of devices complete after 5.920 msecs

[04-22 10:45:58.420] [8646: kworker/u:2]Resume DONE in suspend_devices_and_enter line 234

[04-22 10:45:58.420] [8646: kworker/u:2]record_sleep_awake_time(): APP keep: 29.395 s !!!!!!!!!!sleep!!!!!!!! modem awake 29 seconds 966 %o

[04-22 10:45:58.420] [8646: kworker/u:2]PM: modem can't enter TCXO_SHUTDOWN cause of clients: 0x800 (Ignore 0x4 for APROC)while APP enter SUSPEND

[04-22 10:45:58.420] [8646: kworker/u:2]Restarting tasks ... done.

[04-22 10:45:58.420] [8646: kworker/u:2]pm_state_changed 398

[04-22 10:45:58.420] [8646: kworker/u:2]PM_POST_SUSPEND

[04-22 10:45:58.420] [160: rild]pm_monitor_read enter

[04-22 10:45:58.420] [160: rild]pm_monitor_read exit

[04-22 10:45:58.420] [8646: kworker/u:2][PM] additional wakeup info:

[04-22 10:45:58.420] [8646: kworker/u:2] wakeupreason:0x8

[04-22 10:45:58.420] [8646: kworker/u:2] rpc_prog:0x30000089

[04-22 10:45:58.420] [8646: kworker/u:2] rpc_proc:0x4

[04-22 10:45:58.420] [8646: kworker/u:2]WAKEUP INFO2013-04-22 10:45:58 <UTC> resume

[04-22 10:45:58.420] [8646: kworker/u:2]WakeupReason:TIMER RpcProg:VBATT_REMOTE RpcProc:0x4 SmdPortName:RPCCALL GpioInfo:0x72

[04-22 10:45:58.420] [8646: kworker/u:2]

[04-22 10:45:58.420] [8646: kworker/u:2]zte_console vt_move_to_console BEGIN: RESUME console 62 ----> 0!!!!

[04-22 10:45:58.420] [8646: kworker/u:2]zte_console vt_move_to_console DONE!!!!

[04-22 10:45:58.420] [8646: kworker/u:2]suspend: exit suspend, ret = 0 (2013-04-22 10:45:58.430319345 UTC)

[04-22 10:45:58.420] [8646: kworker/u:2]suspend: pm_suspend returned with no event

[04-22 10:45:58.420] [8646: kworker/u:2][cpufreq] [0]change policy freq from (f6180,f6180) to (3c000,f6180)

[04-22 10:45:58.420] [8646: kworker/u:2]active wake lock mmc1_detect

[04-22 10:45:58.420] [8646: kworker/u:2]active wake lock alarm_rtc, time left 99

[04-22 10:45:58.420] [8646: kworker/u:2]active wake lock alarm, time left 499

[04-22 10:45:58.420] [8646: kworker/u:2]active wake lock unknown_wakeups, time left 50

[04-22 10:45:58.420] [8646: kworker/u:2]suspend: abort suspend

[04-22 10:45:59.340] [21: krpcserversd]LHX_RPC __msm_rpc_read prog= 0x30000015 proc= 0x00000002

[04-22 10:45:59.410] wake lock alarm_rtc, expired

[04-22 10:45:59.410] [15746: kworker/u:3][cpufreq] [1]change policy freq from (3c000,f6180) to (f6180,f6180)

[04-22 10:45:59.410] [8646: kworker/u:2]PM: Syncing filesystems...

[04-22 10:45:59.410] [15746: kworker/u:3]suspend: enter suspend

[04-22 10:45:59.410] [15746: kworker/u:3]zte_console vt_move_to_console BEGIN: SUSPEND console 0 ----> 62!!!!

[04-22 10:45:59.410] [15746: kworker/u:3]zte_console vt_move_to_console DONE!!!!

[04-22 10:45:59.410] [15746: kworker/u:3]PM_SUSPEND_PREPARE

[04-22 10:45:59.410] [160: rild]pm_monitor_read enter

[04-22 10:45:59.410] [160: rild]pm_monitor_read exit

[04-22 10:45:59.410] [8646: kworker/u:2]sync done.

[04-22 10:45:59.410] [8646: kworker/u:2]PM: Syncing filesystems...

[04-22 10:45:59.410] [8646: kworker/u:2]sync done.

[04-22 10:45:59.430]

[04-22 10:45:59.430] SMSM: Modem SMSM state changed to SMSM_RESET.

[04-22 10:45:59.430] [8646: kworker/u:2]Notify: start reset

[04-22 10:45:59.460] [15746: kworker/u:3]Freezing user space processes ...

[04-22 10:45:59.460] [115: akmd8962_new]akm8962 0-000c: Get Open returns error (-512).(elapsed 0.02 seconds) done.

[04-22 10:45:59.480] [15746: kworker/u:3]Freezing remaining freezable tasks ... (elapsed 0.01 seconds) done.

[04-22 10:45:59.501] [15746: kworker/u:3]Suspending console(s) (use no_console_suspend to debug)

qcsbl main start!

0

Share this post


Link to post
Share on other sites

Posted

I partitioned it in Linux, just one primary partition, then created filesystem with mkfs.ext4.

The gallery might have started working with ext4, too, maybe, ;) if I had hacked a bit.

From the same doc I already posted couple of times. "Android supports devices with external storage, which is defined to be a case-insensitive and permissionless filesystem." Ext file systems won't work in ClockWorkMod either.

https://android.goog...torage/index.md

another reboot (this time I was not even using wifi and not changing wifi settings).

Looks like it's rather something modem related. Is that from your build or from a build that I've released?

I still haven't experience a single random reboot on either CM10 or CM10.1...

0

Share this post


Link to post
Share on other sites

Posted (edited)

Somebody can help me, I using zte acqua v880e ROM 18.4 atlas40.. sdcard not mount but sdext ok cuz i using link2sd..

u0_a38@android:/ $ su

u0_a38@android:/ # grep /storage /proc/mounts

tmpfs /storage tmpfs rw,relatime,mode=050,gid=1028 0 0

tmpfs /storage/emulated tmpfs rw,nosuid,nodev,relatime,mode=050,gid=1028 0 0

/dev/block/vold/179:33 /storage/sdcard1 vfat rw,dirsync,nosuid,nodev,noexec,relatime,uid=1000,gid=1015,fmask=0702,dmask=0702,allow_utime=0020,codepage=cp437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro 0 0

/dev/fuse /storage/emulated/0 fuse rw,nosuid,nodev,relatime,user_id=1023,group_id=1023,default_permissions,allow_other 0 0

/dev/fuse /storage/emulated/0/Android/obb fuse rw,nosuid,nodev,relatime,user_id=1023,group_id=1023,default_permissions,allow_other 0 0

/dev/fuse /storage/emulated/legacy fuse rw,nosuid,nodev,relatime,user_id=1023,group_id=1023,default_permissions,allow_other 0 0

/dev/fuse /storage/emulated/legacy/Android/obb fuse rw,nosuid,nodev,relatime,user_id=1023,group_id=1023,default_permissions,allow_other 0 0

ock/vold/179\:32 <

Disk /dev/block/vold/179:32: 16.0 GB, 16009658368 bytes

255 heads, 63 sectors/track, 1946 cylinders

Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System

/dev/block/vold/179:32p1 1 1667 13384765+ c Win95 FAT32 (LBA)

/dev/block/vold/179:32p2 1667 1916 2000000 83 Linux

/dev/block/vold/179:32p3 1916 1947 249666 82 Linux swap

u0_a38@android:/ #

u0_a38@android:/ # /dev/block/mmcblk0

sh: /dev/block/mmcblk0: can't execute: Permission denied

126|u0_a38@android:/ #

Edited by anuat02
0

Share this post


Link to post
Share on other sites

Posted

Somebody can help me, I using zte acqua v880e ROM 18.4 atlas40.. sdcard not mount but sdext ok cuz i using link2sd..

/dev/block/vold/179:33 /storage/sdcard1 vfat rw,dirsync,nosuid,nodev,noexec,relatime,uid=1000,gid=1015,fmask=0702,dmask=0702,allow_utime=0020,codepage=cp437,iocharset=iso8859-

Looks like it's mounted just fine. Mount points are just different than in the previous release.

Internal emulated storage: /sd-internal = /mnt/sd-internal = /storage/sdcard0 = /data/media

External SD card: /sdcard = /mnt/sdcard = /storage/sdcard1

0

Share this post


Link to post
Share on other sites

Posted

From the same doc I already posted couple of times. "Android supports devices with external storage, which is defined to be a case-insensitive and permissionless filesystem." Ext file systems won't work in ClockWorkMod either.

https://android.goog...torage/index.md

Looks like it's rather something modem related. Is that from your build or from a build that I've released?

I still haven't experience a single random reboot on either CM10 or CM10.1...

Well, I guess I tried that ext4 stuff before reading documentation, I did not guess vfat is the only supported fs.

It is from my build, but I have not made modifications to the source code (yet).

We use the device differently; if your ZTE hasn't rebooted this way, it doesn't prove CM does not have bugs. For example, I run busybox-ntpd, does it matter?

0

Share this post


Link to post
Share on other sites

Posted

Looks like it's mounted just fine. Mount points are just different than in the previous release.

Internal emulated storage: /sd-internal = /mnt/sd-internal = /storage/sdcard0 = /data/media

External SD card: /sdcard = /mnt/sdcard = /storage/sdcard1

I also have /storage/emulated/0 in CM File Manager ... also, the previous release of this ROM did not do this ... So you basically changed it? I noticed that CM10 got the same change, didn't it? The new CWM is changed as well: there is some /storage/media crap in mounts menu .... so u basically changed every single piece of ur work to make it work like Google wants it ?

If Google wants this, it's their fault cos it sucks ... it's a personal device, not a multi-user PC ... why don't they solve it the unix-way of managing user accounts? let's hate google ...

It's rly a pain having Real Racing 3 / GTA Vice City / GTA 3 sd data in the internal storage...

0

Share this post


Link to post
Share on other sites

Posted (edited)

Well, I guess I tried that ext4 stuff before reading documentation, I did not guess vfat is the only supporta/..

It is from my build, but I have not made modifications to the source code (yet).

We use the device differently; if your ZTE hasn't rebooted this way, it doesn't prove CM does not have bugs. For example, I run busybox-ntpd, does it matter?

Edited by anuat02
0

Share this post


Link to post
Share on other sites

Posted

Looks like it's mounted just fine. Mount points are just different than in the previous release.

Internal emulated storage: /sd-internal = /mnt/sd-internal = /storage/sdcard0 = /data/media

External SD card: /sdcard = /mnt/sdcard = /storage/sdcard1

Tq cuz reply.. My sdcard not mount if using cwm n all data just put in sd-ext internal not to sdcard/android/data/.. If just using sdext internal data not enough for large game data..my sd-ext internal just 2.5gb but now sdcard 12gb n sdext4 2gb.. What should I do now..

0

Share this post


Link to post
Share on other sites

Posted

Tq cuz reply.. My sdcard not mount if using cwm n all data just put in sd-ext internal not to sdcard/android/data/.. If just using sdext internal data not enough for large game data..my sd-ext internal just 2.5gb but now sdcard 12gb n sdext4 2gb.. What should I do now..

what says command "echo $EXTERNAL_STORAGE" in adb shell?

0

Share this post


Link to post
Share on other sites

Posted

what says command "echo $EXTERNAL_STORAGE" in adb shell?

u0_a38@android:/ $ su

u0_a38@android:/ # echo $EXTERNAL_STORAGE

/storage/emulated/legacy

u0_a38@android:/ #

0

Share this post


Link to post
Share on other sites

Posted

and what's there?

0

Share this post


Link to post
Share on other sites

Posted

and what's there?

u0_a38@android:/ $ su

u0_a38@android:/ # echo $EXTERNAL_STORAGE

/storage/emulated/legacy

u0_a38@android:/ #

Nothing happen just this... :-)

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.