• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

[DEV][ROM][17.9.] CyanogenMod 10.1 (Android 4.2.2)

972 posts in this topic

Posted

Isn't there any ÙSB Mass Storage anymore in 18.4. build like there was in 29.3.?

0

Share this post


Link to post
Share on other sites

Posted

Isn't there any ÙSB Mass Storage anymore in 18.4. build like there was in 29.3.?

It's going google way to support the future devices with terabytes of internal memory :) if u have 29.3 build, could u plz give me a link to it or upload it for me ?? :D

0

Share this post


Link to post
Share on other sites

Posted

It's going google way to support the future devices with terabytes of internal memory :) if u have 29.3 build, could u plz give me a link to it or upload it for me ?? :D

Just because it's a stupid idea grown in Google's head it doesn't make the idea good ;-)

Having integrated memory with just one partition for data and SD card of course has advantages if you e.g. like having 400 apps installed or require incredibly fast access speeds, but apart from that I can only see disadvantages (at least for the user):

- You cannot increase the amount of memory.

- Sometimes access is even slower because the manufacturer just used crappy chips. Otherwise you could just get a faster card and with a bit of luck...

- In case of warranty you have to save your data somehow. If you had an SD card you could just take it out and put into in the replacement.

- If your phone breaks completely (like my Nexus S did) all your data is lost with no way of getting it back. With an SD card you could just put it in a PC and you're done.

- If you had an SD card you could use multiple ones if you e.g. want to have a movie collection with you for a long journey.

- This is not a built-in memory problem, but a unified partition one: You can't use USB mass storage mode and have to rely on MTP/PTP. Some say it works for them but for me it never really did. UMS just works EVERYWHERE. You can take a 15 y.o. PC, it works. MTP is like "good luck". I can't use it on 75% of my Macs because Google's File Transfer doesn't support them, and on the one it runs, it's verryyyy buggy and a real pain for big data transfers. On Windows the explorer is very likely to freeze when doing a transfer. So the only way you could use then is ADB. It works very well. You can even transfer big amounts without a breakdown, but it's nothing for "dumb" users, because you have to use the command line and it's goddamn slow. Sometimes I think I would've typed the bytes faster.

Anyway: If there is a goddamn SD card available, we should definitely try to get UMS alive as long as possible!

If you want to go back to 29.3. you could try this:

It worked for me but I'm not sure how long the file will stay online. So grab it as long as it's there.

Good luck!

Cheers,

landapfel.

0

Share this post


Link to post
Share on other sites

Posted

http://forum.zteblad...om-konstat.html ... those seem to be working :) .. but you loose more than u gain if you use older version of CM 10.1 on Blade 3 now :D Aurora Borealis is a way to go for stability/speed imho ... did not try though (cos I can't find my Blade 3 .. it's somewhere in da house xD silent mode enabled)

http://www.mediafire.com/?r4vf8vexjb2ibez this is the latest which had proper external storage support :) KonstaT plz put that link on a visible place so that ppl get a working thing ... I still don't get why u changed it :(((

0

Share this post


Link to post
Share on other sites

Posted

um why do i keep getting errors trying to build cm10.1, i have done as the tutorial said and i cant seem to get it to work :/

http://pastebin.com/6hB8Aqum

its not giving me errors when i do "repo sync", and i cant find the error anywhere else so what am i doing wrong?

0

Share this post


Link to post
Share on other sites

Posted

Use the command lunch and you will get a list of devices to build for, if the atlas40 does not show up, check you have the local_manifest.XML set up correctly.

0

Share this post


Link to post
Share on other sites

Posted

um why do i keep getting errors trying to build cm10.1, i have done as the tutorial said and i cant seem to get it to work :/

http://pastebin.com/6hB8Aqum

its not giving me errors when i do "repo sync", and i cant find the error anywhere else so what am i doing wrong?

Have you got your build environment setup correctly? Only LTS versions of Ubuntu are officially supported by Google.

http://soupdawg.wordpress.com/2013/04/07/how-to-configure-ubuntu-13-04-raring-ringtail-for-properly-compiling-android-roms/

0

Share this post


Link to post
Share on other sites

Posted

Have you got your build environment setup correctly? Only LTS versions of Ubuntu are officially supported by Google.

http://soupdawg.word...g-android-roms/

i did a fresh install of ubuntu and i followed the enviroment setup that you linked and i keep getting the same error :(

what am i doing wrong

http://pastebin.com/H0d9NLbR

0

Share this post


Link to post
Share on other sites

Posted

3/29 ROM is already CM 10.1, right? It has the sdcard working properly (not properly according to Google though) ... So it's just one of few things changed in 4/18 but CM10.1 sources are the same??

0

Share this post


Link to post
Share on other sites

Posted

3/29 ROM is already CM 10.1, right? It has the sdcard working properly (not properly according to Google though) ... So it's just one of few things changed in 4/18 but CM10.1 sources are the same??

Please stop the f*cking whining already! That's all you've done in your last 15 posts and you're only spamming this thread. You only make yourself look like a fool and seem like an ungrateful little brat.

As it says in the first post this ROM is for advanced users only, it's very clear that it doesn't include you. This ROM is also fully open source and there's instructions on how to build in the third post. If you want something "fixed" or working the way you like it today, you better do it yourself!

There's a changelog in the second post with a gerrit link to merged commits. On a regular day 10-100 commits are merged to CM upstream. You do the math how much CyanogenMod has changed in about three weeks.

2

Share this post


Link to post
Share on other sites

Posted

Hi, I just bought the ZTE Blade 3 and I would like to know what features work on this mod before i install it. Is bluetooth already working? Is this mod much quicker than the original Ice Cream Sandwich? What is the most stable/ working version of this mod? No need to be the newest 4.2.2 android, but some jelly bean.

0

Share this post


Link to post
Share on other sites

Posted (edited)

Hi, I just bought the ZTE Blade 3 and I would like to know what features work on this mod before i install it. Is bluetooth already working? Is this mod much quicker than the original Ice Cream Sandwich? What is the most stable/ working version of this mod? No need to be the newest 4.2.2 android, but some jelly bean.

Hello, this mod is great if you are an advanced user. Bluetooth isn't working on any CM10.1 for this chipset yet and won't most probably work any soon. However, it works on CM10. FM radio doesn't work but who needs that?? Other than that everything works fine and cyanogenmod always feels faster than stock ROMs. Overall performance is definitely better.

If you want the most stable mod for ZTE Blade 3, go for Aurora Borealis. It's a modified version of stock ROM (android 4.0.4) and everything works. Moreover it's faster and ZTE's bloatware is removed. I've been using it for quite a while and it's great. I know this is not Jelly Bean which u want...

KonstaT made all those awesome mods available for our device (now he hates me cos I'm a troll and spammer) I don't recommend you to download the very latest build of this mod (4/18) beause you will not be able to use your SD card properly (if you have one) and everything will be stored in the internal memory. Download 3/29 build where it works properly: http://www.mediafire...r4vf8vexjb2ibez ... enjoy!

Edited by plantroon
0

Share this post


Link to post
Share on other sites

Posted

As it says in the first post this ROM is for advanced users only, it's very clear that it doesn't include you.

How many of those do u think that exists in this forum?

0

Share this post


Link to post
Share on other sites

Posted

KonstaT made all those awesome mods available for our device (now he hates me cos I'm a troll and spammer) I don't recommend you to download the very latest build of this mod (4/18) beause you will not be able to use your SD card properly (if you have one) and everything will be stored in the internal memory.

And you're still doing it after you've been asked to stop. I simply ignored you before and it only lead you constanly whining about the same thing for over dozen posts!

SD card is working properly in the build that is in the first post (older builds are not recommended nor supperted). You can access it with included file manager or via USB-storage. You can store any files on your SD card and these files are visible to Android's media scanner. It's simply a false claim if you say that you can only store data on internal storage (I have 2gb of 2,5gb available on internal storage and 4gb of 16gb available on external SD card). Regular users will have no issues what so ever with this!

I now realize there are issues if you want to play the latest state of the art 3D games that require several gigabytes worth of external data to be downloaded. All I can say is that a low performance cheap Chinese crap-end device is the wrong device for gaming purpose to begin with and you really shouldn't expect anything else.

I added mount point for internal storage because there was strong demand for it. Like I've already said few times, I personally never preferred it so I don't have any problem reverting it (like I have). What I didn't expect was the amount crap and constant whining I got from people who simply don't know how to use their device or can't find find their SD card because it's mounted to different place than before...

How many of those do u think that exists in this forum?

At least it's good start if you know how to read (and understand what you read) and bother to search solutions to possible problems yourself. Part of it is also understanding that you are running bleeding edge, mostly untested, software on your device.

1

Share this post


Link to post
Share on other sites

Posted

Thank God, there is someone like you (and I really mean it), to provide me with such a wonderful bleeding edge untested software to run in my crappy Chinese device, until the day comes, that I will be able to pay more money and buy a super duper wow device. For now I will be your guinea pig, so you can work on your magic. ;-)

1

Share this post


Link to post
Share on other sites

Posted

thanks!

I tried to replace these files, But failed!

It still not work with GSM.

The good news is that now have a dual SIM CM10 source. http://www.3rdos.com/2013/05/03/

So, Let us wait for the good news together!

0

Share this post


Link to post
Share on other sites

Posted (edited)

freezes at startup (doing all wipes)

He pulled out the stickHangs on updating

Restart (take out the battery ...)

Hangs on the update again

(1 GHz processor 1 core ZTE Blade 3, 1 SIM Card)

Restart (take out the battery ...)

Application Optimization (update) runs to the endreboot

Hangs on the splash screen switching Cyanogen Mod

Restart (take out the battery ...)

Hangs on the choice of language

and so

normally do not put that to do?

Was originally unlocked from the operator ..

CWM recovery 6.0.2.7 (6.0.3.1 not as it should be put)

Sorry for Bad English!!!

Edited by Djcrabik
0

Share this post


Link to post
Share on other sites

Posted

thanks!

I tried to replace these files, But failed!

It still not work with GSM.

The good news is that now have a dual SIM CM10 source. http://www.3rdos.com/2013/05/03/

So, Let us wait for the good news together!

That's quite interesting. Phone/messaging/settings/etc is usable but device specific stuff needs to be sorted first (that's for a Huawei device).

There's a second rild process that needs to be added to ramdisk (init.atlas40.rc) for the second SIM card. It's possible that RIL class also needs some modifications.


service ril-daemon1 /system/bin/rild -c 1
class late_start
socket rild1 stream 660 root radio
socket rild-debug1 stream 660 radio system
user root
disabled
group radio cache inet misc audio sdcard_rw qcom_oncrpc diag

on property:ro.multi.rild=true
start ril-daemon1
[/CODE]

Also add ro.multi.rild=true to build.prop. I don't have a dual-SIM device to test any of this.

freezes at startup (doing all wipes)

He pulled out the stickHangs on updating

Restart (take out the battery ...)

Hangs on the update again

(1 GHz processor 1 core ZTE Blade 3, 1 SIM Card)

Restart (take out the battery ...)

Application Optimization (update) runs to the endreboot

Hangs on the splash screen switching Cyanogen Mod

Restart (take out the battery ...)

Hangs on the choice of language

and so

It seems that there are other people with similar issue. This is not an issue I can reproduce so there's not much I can do about it. It's up to you to find similarities between devices that have this issue (e.g. hardware/software revision). You might want to try updating to a different official ZTE firmware first. My device was sold with B08 and I haven't flashed any official update packages (that also change your radio firmware/bootloaders/etc).

1

Share this post


Link to post
Share on other sites

Posted

Everything seems to be working fine so far. Didn't test bluetooth, guessing it's pointles, having in mind you said it doesn't work.

Works really smooth, great performance, better RAM management & etc. Only thing I didn't like is the laggy camera, there's a huge delay between taking a snap and image processing.

Kudos to everyone who worked on it!

0

Share this post


Link to post
Share on other sites

Posted

Please help

i put cm-10.1-20130418-KonstaKANG-atlas40 on mad sd card and instaled it with adb rebot recovery and instalation went ok.i reboot it and then i got cyanogenmod icon on my cell screen and icon was rooling and rooling and phone wont start..i cant make it work,and i cant conect it now on my computer because it cant boot..

please help

0

Share this post


Link to post
Share on other sites

Posted

Can you boot back into clockworkmod recovery? If so wipe data etc and try and reflash the ROM.

0

Share this post


Link to post
Share on other sites

Posted (edited)

Can you boot back into clockworkmod recovery? If so wipe data etc and try and reflash the ROM.

not any more,i somehow end on FTM screen..now i cant go in recovery mode..

Edited by Ko blazen
0

Share this post


Link to post
Share on other sites

Posted

Please help

i put cm-10.1-20130418-KonstaKANG-atlas40 on mad sd card and instaled it with adb rebot recovery and instalation went ok.i reboot it and then i got cyanogenmod icon on my cell screen and icon was rooling and rooling and phone wont start..i cant make it work,and i cant conect it now on my computer because it cant boot..

please help

And let me guess, you didn't wipe data/factory reset.

Iirc you can do a factory reset in the stock (FTM) recovery as well.

0

Share this post


Link to post
Share on other sites

Posted

And let me guess, you didn't wipe data/factory reset.

Iirc you can do a factory reset in the stock (FTM) recovery as well.

no i didnt wipe data..is that a problem?can i do it now somehow?

0

Share this post


Link to post
Share on other sites

Posted

no i didnt wipe data..is that a problem?can i do it now somehow?

You need to wipe data every time you install a different ROM.

Like I already said, power on with volume up pressed and you'll get to the stock recovery menu. You can do a factory reset reset or install your stock ROM update.zip that you've placed on your SDcard.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.