• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

Wifi issue on Acqua with Blade III ROMs

87 posts in this topic

Posted · Report post

Discussion about wifi issues on ZTE Acqua when using Blade III ROMs.

Does wifi work on your device? Wifi doesn't work?

  • What is your stock firmware version?
  • Where/when did you purchase your device?

Current suggested workaround is to flash official German or Slovak firmware before flashing e.g. CyanogenMod. Does this work for you?

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Hi

Wifi doesn't work on mine, it's a TMN SMART A15 (Acqua) I bought this phone 1 month ago.

KonstaT how can it be possible? (The workaround) if before flashing e.g CyanogenMod we format the system,etc, and nothing remains from the old ROM.

Thanks :)

Edited by Di0g0
0

Share this post


Link to post
Share on other sites

Posted · Report post

Lol, and I thought that if I opened a new thread I wouldn't have to answer same questions several times. :P I already answered you this twice!

There is a bunch of low level firmware included in official updates (radio firmware, bootloader). These will stay on your device no matter which custom ROM you install.

You can't wipe your baseband or bootloader with ClockWorkMod. If you could, your device would never ever boot again.

papars now posted a flashable zip that contains this low level firmware that is normally only included in official updates (not in custom ROMs).

http://www.modaco.co...20#entry2098001

0

Share this post


Link to post
Share on other sites

Posted · Report post

i have the portuguese variant, the TMN smart a15 but i had the medion recovery before i flashed the CWM.

wifi is working fine.

next saturday when i have time i will try the slovak and the greek recoveries to see if the wifi still works.

if until then someone uploads the portuguese recovery i will try that too.

0

Share this post


Link to post
Share on other sites

Posted · Report post

@perez1311

I honestly hope that every time you've written recovery, you've actually meant firmware. :P Did you flash the German update?

Recovery partition makes no difference what so ever! You have ClockWorkMod there, it doesn't matter what was there initially or yesterday - it's completely gone and overwritten with CWM.

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

@perez1311

I honestly hope that every time you've written recovery, you've actually meant firmware.

Recovery partition makes no difference what so ever! You have ClockWorkMod there, it doesn't matter what was there initially or yesterday - it's completely gone and overwritten with CWM.

I think perez1311 is referring to what you're thinking KonstaT...

Edited by Di0g0
0

Share this post


Link to post
Share on other sites

Posted · Report post

@perez1311

I honestly hope that every time you've written recovery, you've actually meant firmware. :P Did you flash the German update?

Recovery partition makes no difference what so ever! You have ClockWorkMod there, it doesn't matter what was there initially or yesterday - it's completely gone and overwritten with CWM.

yes, by recovery i mean flashing the original recovery and then flash the original zip from zte, sorry if i wasn't too clear.

0

Share this post


Link to post
Share on other sites

Posted · Report post

I also have a TMN Smart a15 (Acqua). I bought him 1 month and a half ago and it came with ICS 4.0.4.

I've flashed my device with your both CyanogenMod Roms (4.1.2 and 4.2.2), for Blade III of course, and the Wi-Fi always work.

If anyone need some help from me, for anything, just ask!

0

Share this post


Link to post
Share on other sites

Posted · Report post

I've made CWM flashable zips for updating the non standard partitions in the ZTE AQCUA.

Use with caution. WARNING if this procedure fails then you will end up with a brick!!!!

The reason for these files is to "fix" a problem with non working wifi if you install the Blade III CM10.x versions.

I repeat. If you have installed Blade III CM10.x and the wifi is working DO NOT install these files. Please DON'T.

The files are taken from the original update files (from the ZTE web site).

What is flashed:

"qcsbl.mbn" at "/dev/block/mmcblk0p2"

"fat.bin" at "/dev/block/mmcblk0p13"

"qcsblhd_cfgdata.mbn" at "/dev/block/mmcblk0p1"

"OEMSBL.MBN" at "/dev/block/mmcblk0p3"

"EMMCBOOT.MBN" at "/dev/block/mmcblk0p15"

Splash / Recovery partition or other part of the ROM is not touched.

I note of warning. If you want to experiment with any of the emmc partitions make sure the files you flash onto them fit. If you try to flash a bigger file then unpredictable things will happen!

German B04 partitions: https://dl.dropbox.com/u/17982603/ZTE-Acqua-German-B04-ICS-Partitions.zip

Slovak B07 partitions: https://dl.dropbox.com/u/17982603/ZTE-Acqua-Slovak-B07-ICS-Partitions.zip

0

Share this post


Link to post
Share on other sites

Posted · Report post

What is the difference between the slovak and german?

"WARNING if this procedure fails then you will end up with a brick!!!!" - There is a lot of possibility? :S

Thanks

0

Share this post


Link to post
Share on other sites

Posted · Report post

Only ZTE knows the differences.

As for brick, I have done several times my phone and it worked without problem. But I do not like flashing bootloaders, anything can go wrong.

0

Share this post


Link to post
Share on other sites

Posted · Report post

I found a "difference" between Greek and Slovak special partitions.

I'm using ICS (B07) for months now. I had the Greek special partitions but I had flashed the Slovak main ROM.

A couple of days now I have flashed the full Slovak official ROM (the official zip with all the bells and whistles) in order to start using CM10.x and I notice this:

The wifi does not wake up after overnight charge. It is shown as enabled but will not find any network. I have to momentarily switch it off and on to get it working.

Maybe I should test the German ROM and later test CM10.x

1

Share this post


Link to post
Share on other sites

Posted · Report post

I found a "difference" between Greek and Slovak special partitions.

I'm using ICS (B07) for months now. I had the Greek special partitions but I had flashed the Slovak main ROM.

A couple of days now I have flashed the full Slovak official ROM (the official zip with all the bells and whistles) in order to start using CM10.x and I notice this:

The wifi does not wake up after overnight charge. It is shown as enabled but will not find any network. I have to momentarily switch it off and on to get it working.

Maybe I should test the German ROM and later test CM10.x

papars, you where one of the "non working wifi" with ZTE Acqua. Now you have a working wifi with CM10.

Can you explain how to make it work step by step because i´m not understanding about the flashing partitions you have posted above please?

I´m gonna install CWM today, no matter what... and want to try your steps because at least thats a working guarantee :D

0

Share this post


Link to post
Share on other sites

Posted · Report post

papars, you where one of the "non working wifi" with ZTE Acqua. Now you have a working wifi with CM10.

Can you explain how to make it work step by step because i´m not understanding about the flashing partitions you have posted above please?

I´m gonna install CWM today, no matter what... and want to try your steps because at least thats a working guarantee :D

I want test this to!! :) please give us a step by step guide....

0

Share this post


Link to post
Share on other sites

Posted · Report post

Guys is easy.

Copy the zip files (do not extract) in the sd card.

Install CWM - check the relevant tread.

Then enter CWM and install the German or the Slovak partitions before you load CM10.x (using the option "install zip from sdcard")

It only takes 3 -4 seconds to install the partitions.

Reboot.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Guys is easy.

Copy the zip files (do not extract) in the sd card.

Install CWM - check the relevant tread.

Then enter CWM and install the German or the Slovak partitions before you load CM10.x (using the option "install zip from sdcard")

It only takes 3 -4 seconds to install the partitions.

Reboot.

After that install the CM10.X? Or I flash the partitions with the CM10.X installed?

0

Share this post


Link to post
Share on other sites

Posted · Report post

it doesn't matter.

0

Share this post


Link to post
Share on other sites

Posted · Report post

it doesn't matter.

I'v tested and i stiil have no wifi connections :S i tried both of zip files :S

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

I'v tested and i stiil have no wifi connections :S i tried both of zip files :S

Wich rom you had before doing all? The Portuguese one or you try de German or Slovak?

I´ve done everything as said above, i allready have cwm working but no wifi with CM10 and German official partitions.

Edited by _InCoGnIt_
0

Share this post


Link to post
Share on other sites

Posted · Report post

Wich rom you had before doing all? The Portuguese one or you try de German or Slovak?

I´ve done everything as said above, i allready have cwm working but no wifi with CM10 and German official partitions.

And wich rom you had before ? (The same question for you..)

0

Share this post


Link to post
Share on other sites

Posted · Report post

And wich rom you had before ? (The same question for you..)

The Medion rom from Germany. I will try with the Slovak rom next.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Ok leave the feedback here :P

0

Share this post


Link to post
Share on other sites

Posted · Report post

Wich rom you had before doing all? The Portuguese one or you try de German or Slovak?

I´ve done everything as said above, i allready have cwm working but no wifi with CM10 and German official partitions.

Before all i have the portuguese rom... i don´t have any one... :S Can you give me that?

0

Share this post


Link to post
Share on other sites

Posted · Report post

Before all i have the portuguese rom... i don´t have any one... :S Can you give me that?

You have them all in the stock roms thread.

0

Share this post


Link to post
Share on other sites

Posted · Report post

After installing the rom from Medion, and then again CM10.1 have the WIFI running at 50% ... loool

It takes a long time to connect, and the connection is always unstable and falling ... when it loses the connection, I have to disconnect and reconnect the WIFI to work again, after that works "normally" ...

Well it is always better than not having WiFi connections at all ...

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.