• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

Downgrade & upgrade from recovery

106 posts in this topic

Posted

Which GB rom are you guys using?

0

Share this post


Link to post
Share on other sites

Posted (edited)

Edit: I rebooted again and now the network is working on my restored Stock+. So I'll try installing AtomicMod again and a few reboots and see if that works. However if anybody has any further advice please comment. Thanks a lot.

Original post follows:

Any ideas about this one... I seem to have lost my network and cannot make/receive calls even though System Settings > About Phone > Status claims that I am connected. I can make/receive calls with my SIM in another phone so it's not a SIM/network issue.

Here's exactly what I did...

I was on Stock+ R2

I did a CWM 6.0.2.7 Nandroid backup

I rebooted into Stock+ and did factory reset

I booted back into CWM 6

I flashed the downgrade zip from the first post

I rebooted into the CWM 5 that this zip installed

I wiped/formatted everything

I flashed the AtomicMod GB ROM

AtomicMod booted and I could see that the phone was now on the GB baseband

It looked OK and ostensibly (according to System Settings > About Phone > Status) was on my operator's network but I could not make/receive calls

So I thought I'd backtrack...

I booted into CWM 5 and flashed the upgrade zip from the first post

I then flashed CWM 6

I booted into CWM 6 and restored my Stock+ backup

I booted into this and the original ROM setup was present and correct but again I could not make/receive calls

Any suggestions on how to proceed? Ultimately my intention is to go to AtomicMod (ideally on GB baseband?) but obviously the first step is to restore the ability to make/receive calls.

I'd appreciate some help - thanks a lot.

:-(

Edited by dalyer
0

Share this post


Link to post
Share on other sites

Posted

How do I do this though?

I have downloaded the file in the original link, but then what do I do?

I really don't know where to start.

0

Share this post


Link to post
Share on other sites

Posted (edited)

Okay, I've done something.

I downloaded CWM. Downloaded the file in the OP to my SD card... did all the things in CWM, but now my phone is stuck on the Huawei logo screen at start.

My phone won't even boot up now. :(

What do I do?

Edited by ThomasCobb
0

Share this post


Link to post
Share on other sites

Posted

It's not clear what you are trying to do.

My previous post explains the steps for using the "downgrade" zip in the first post to get from ICS to GB (in this case AtomicMod),

If that's the sort of think that you need to do then follow the steps.

They assume that you have already unlocked the bootloader, installed CWM and rooted.

Installing just the downgrade zip and rebooting probably won't do much (as you have discovered).

After installing the downgrade zip you still need to install a GB ROM.

If you phone is not booting properly then it is almost certainly recoverable but you need to be clearer on what you are trying to do so that people can help you.

I think you may be posting in different threads as well which is confusing.

0

Share this post


Link to post
Share on other sites

Posted

Has anyone got success with 'upgrade to ICS' zip?

 

I'm on GB AtomicMod rom and have TWRP 2.6.0.0 as recovery, want to go for JB SlimBean v8 ROM. Today attempted to flash 'upgrade to ICS' to get 2030 baseband but is getting failed.

 

I initially thought of corrupted file, so downloaded twice but having the same problem. So not sure what I'm doing wrong here.

0

Share this post


Link to post
Share on other sites

Posted (edited)

In case it helps the MD5 checksum for the upgrade zip is:

E52EAD10A68ECE597D24EB00C6F0194A

Maybe check that to be sure that the zip is intact.

Sometimes security software will block or corrupt downloads.

Note that after installing the upgrade zip you have the unofficially unlocked bootloader so you probably want to do an official bootloader unlock to avoid problems when running ICS or JB and this will most likely require you to do a force update to stock ICS B952 first anyway:

http://www.modaco.com/topic/362821-tutorial-how-to-officially-unlock-the-bootloader-with-definitions/

Edited by dalyer
0

Share this post


Link to post
Share on other sites

Posted

In case it helps the MD5 checksum for the upgrade zip is:

E52EAD10A68ECE597D24EB00C6F0194A

Maybe check that to be sure that the zip is intact.

Sometimes security software will block or corrupt downloads.

Note that after installing the upgrade zip you have the unofficially unlocked bootloader so you probably want to do an official bootloader unlock to avoid problems when running ICS or JB and this will most likely require you to do a force update to stock ICS B952 first anyway:

http://www.modaco.com/topic/362821-tutorial-how-to-officially-unlock-the-bootloader-with-definitions/

 

Thanks, Dalyer. MD5 you shared helped to confirm the zip I downloaded was corrupt. After several more attempts, I managed to get a complete copy and MD5 matched.

 

I went ahead with this upgrade zip and worked, don't see any problems or difference in comparison to stock ICS update, will monitor though.

0

Share this post


Link to post
Share on other sites

Posted

Good stuff. I just installed the downgrade myself last night while installing GB B895-superslim-v1 and after some initial teething problems (unable to make/receive calls or send/receive texts until  I rebooted a few times) it's all working well now. I'm on the 109808 baseband, GB bootloader, GB RIL (?) and superslim-v1 and so far so good... :D

0

Share this post


Link to post
Share on other sites

Posted

I apologise in advance for my stupidity; I did not read things properly and now I think my phone is bricked. 

I was on a JB custom ROM (Electra) with 109808 baseband. 
There is a ROM, SlimBean, that I wanted to try, but it requires a 2030.

The update.app method was not working (update failed), so I was rapt to see these patches. 

 

I booted in my CWM6 and installed the Upgrade-B952.zip ZIP (thinking it would get me to the 2030 baseband) and rebooted the phone. 

Since then, my screen doesn't even turn on. All I get, with/without any combination of Vol+/-, when I press the power button is the three lights behind the menu/home/back buttons that blink a few times...

I'm boned right? I've made a brick, haven't I?

Or is someone on here able to bring my brick back from the dead? 

Thanks in advance.

JuLo

0

Share this post


Link to post
Share on other sites

Posted

Have you done full wipes after flsshing upgrade zip?

Have you flashed another rom after upgrade?

If youre stuck then download official b952 from huawei, put it sd card and force flash it using volum up down and power button

0

Share this post


Link to post
Share on other sites

Posted

Nope. That's where I went wrong. 
I flashed the Upgrade-B952.zip and that's it. (stupidly hoping it would change the baseband on my currently installed ROM)

The official b952 from huawei does not work. 
I tried holding Vol+ and vol- before turning it on, but the screen doesn't turn on... :-(

0

Share this post


Link to post
Share on other sites

Posted

Try getting into cwm again and repeat the process

0

Share this post


Link to post
Share on other sites

Posted

Thanks for trying, but as mentionned before the screen does not turn on, so no cwm possible.

I was hoping someone had some magical way of loading a recovery or bootloader without having the screen on (e.g. Boot from sd or something)

0

Share this post


Link to post
Share on other sites

Posted

Have you tried removing the battery for a while?

0

Share this post


Link to post
Share on other sites

Posted

Thanks for trying, but as mentionned before the screen does not turn on, so no cwm possible.

I was hoping someone had some magical way of loading a recovery or bootloader without having the screen on (e.g. Boot from sd or something)

 

If debugging was already enabled in the developer options then maybe you could get ADB to talk to it and flash CWM or whatever in case that helps?

 

You can get ADB here:

 

http://www.modaco.com/topic/362821-tutorial-how-to-officially-unlock-the-bootloader-with-definitions-relock-guide-included/

 

and seach the forum and elsewhere for info about how to use it to flash a recovery image etc.

 

Hope this helps.

0

Share this post


Link to post
Share on other sites

Posted

Yep. The battery was charged at 100% and I removed it for 30 mins+ (my walk home), to no avail.

I also tried ADB, but no love. I think the whole device (not just the screen) doesn't turn on...

I think I really did brick it...
LIke this guy: http://www.modaco.com/topic/362501-huawei-ascend-g300-bricked-help/
But unlike this guy, I didn't keep my receipt and won't be able to use warranty... :-(
I didn't even think it was possible to get to that point,...

 

0

Share this post


Link to post
Share on other sites

Posted

Sounds like a spontaneous hardware (e.g. maybe main board?) failure as reported by others a few times?

I doubt that it was firmware/software changes that caused this - or that they can cause such a failure (short of overclocking to burnout or something like that!?)?

0

Share this post


Link to post
Share on other sites

Posted (edited)

That's unfortunate! Well, thanks everyone for the suggestions...
Now I have to decide if I should buy another G300 or buy something else altogether... Undecided...

Just to be sure, what should have happened when I just flashed that ZIP without flashing a ROM afterwards, knowing that I already had a multi baseband ROM installed prior to that?

Edited by the_julo
0

Share this post


Link to post
Share on other sites

Posted

Worst case the phone would not boot and you would have to flash your way out of the problem.

But if the hardware is actually dead then I am pretty sure that this was not the fault of an incorrect flash and it must be an unfortunate coincidence that the hardware failed now...

If you can't get it working again and are looking at a new phone there are better phones available now and I personally wouldn't buy another G300.

See the China Phone thread for example:

 

http://www.modaco.com/topic/359664-offtopic-china-phone-discussion-20032013/

 

Hope this helps.

0

Share this post


Link to post
Share on other sites

Posted (edited)

^im moving on from g300 too. Ordered my new phone from china. ZTE V967S, for 131$ and free shipping you get a 5" inch quad core, 1gb ram, 2500mah battery.. and decent community support on xda

Edited by Dovahpig
0

Share this post


Link to post
Share on other sites

Posted (edited)

I'm still waiting on my Haier W910. "Just" a dual core but I like the look of the Snapdragon SoC that it uses and there are some claims that it may match or come close to some quad core SoCs (due to its Krait CPUs and maybe GPU) and 28nm LP fabrication used should be good for clock speed and/or battery usage. I'll be passing my G300 onto my gf and in preparation I've installed and have been running superslim-v1 GB which is quite pleasant to use. I think it will suit her well as a replacement for the Vodafone Smart 3/Alcatel V975 that she got and then broke not too long ago... :-| But I certainly wouldn't go out looking for a new or second hand G300 at this point in time (unless it was for a very knock down price!) as there is much better value and spec available for the same sort of price.

Edited by dalyer
0

Share this post


Link to post
Share on other sites

Posted

Does this zips really works? i´m afraid flashing aind brik my phone....i'm really afraid :s

is this secure? :s
 

0

Share this post


Link to post
Share on other sites

Posted

I've used it to successfully switch between ICS/JB and GB (ROMs and baseband).

I was on the 2030 baseband and Stock+ ICS and flashed the downgrade to go to the 19808 baseband and GB superslim.

I also went in the other direction.

And back again as I am now settled on GB superslim.

I had no problems other than a transient one where I had no carrier network coverage but reboots or reflashes eliminated that.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.