• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

[DEV][ROM] CyanogenMod 10.1 (Android 4.2.2) for ZTE V9

158 posts in this topic

Posted (edited) · Report post

this is a CyanogenMod 10.1 based ROM for ZTE V9 - the resistive screen model. it is based on KonstaT's http://www.modaco.co...01-android-422/ for ZTE Blade and all the same caveats apply here. please read all of KonstaT's first 3 posts before trying the below. In particular please note that this is not an official CyanogenMod rom and expect it to eat all your data and brick your v9. you have been warned. having said that, it works fine for me :)

 

NOTE - this rom is obsolete - please use my cm10.2 rom instead.

cm-10.1-20130715-PenguinKANG-v9.zip

md5sum ecb9fe6d8c554ffe0ec29fe24ad5fa98

see the KonstaT page for gapps.

NOTE:

- you will need >196MB in /system to flash this rom (my .au Optus v9 has 220MB), and initial boot will take ~5mins

- this ROM is for the resistive screen V9's only. capacative V9c touch screens don't work.

- in general cm10.1 is bigger and maybe a little bit slower than cm7 but it has more shiny features, so you pays yer money and takes yer choice. there is also my cm10 rom which is somewhere in between.

Working

everything seems to work. specifically all those listed on KonstaT's page.

AFAICT the only thing that's regressed from cm7 on V9 is

- multi-touch (pinch to zoom) emulation from cm7 makes the default browser go crazy on cm10.1, so it's disabled

Issues

known issues specific to this ROM

- pre-surfaceflinger boot animation is wrong aspect and off centre

- ElectronBeam power-on animation doesn't work (power-off does)

known issues from upstream (AOSP or CM or KonstaT or ZTE or ...)

- AOSP keyboard gesture typing doesn't (won't ever?) work on armv6 devices

- the voice search app works but perhaps not in the way it's supposed to (something armv7-only again)

- no movie preview images

- bluetooth scanning works but is unreliable

- livewallpapers don't work

suggestions and patches are welcome for all the above issues!!

Bluetooth

ah, bluetooth. sigh. there goes a week of my life. so the best way to scan to find a new bt device is to turn on bt from the main Settings screen and wait until bt is on for a few seconds before going to the Bluetooth devices screen. if scanning doesn't start immediately on that screen then it has failed, so go back to Settings and turn off bt and try again. be patient. scanning works about 30%-50% of the time using this method. once paired, bluetooth devices are ok - it's only this initial scanning stuff that's dodgy.

Building

- all sources are on my github

- build instructions (see also KonstaT's 3rd post)

ChangeLog

2013-07-15

  • security update that includes cm10.1.2
2013-07-09
  • update to latest CyanogenMod (includes Privacy Guard, Privacy Guard Manager, and cm10.1.1)
  • fix native bluetooth tethering (thanks to zeelog)
2013-05-21
  • fix usb id string to allow usb mounting again (my fault. thanks to falcon4fun for noticing this problem)
  • now that lowmemorykiller is fixed, set dalvik config back to 128MB
  • trim kernel fb allocation to actual used size (saves 744kB of ram)
2013-05-08 - the Lorenzo "smooth as butter, t-boned by Marquez" special edition
  • lowmemorykiller improvements - greatly improved responsiveness
  • nfs, cifs back into kernel, but as modules
2013-05-07
  • re-enable limiting number of processes via sys.mem.max_hidden_apps (CM folks reverted it)
  • allow Kernel Same-page Merging (KSM) which can save ~15MB of ram at the expense of background scanning
  • back to smartassV2 governor
  • use a lower 32MB dalvik profile
  • allow a choice of no wallpaper to save ram in Trebuchet
2013-04-19
  • workaround slow wifi reconnections due to ar6000.ko binary module by using 5s wpa_supplicant scan timeout instead of 30s - please let me know if this causes wifi scan problems - 10s might be a safer default, but 5s works fine for me
  • doubled the area of the home/menu/back buttons - now extends well above and to the side of the silver printed icons
  • took nfs and smb support out of the kernel as ram and cpu is scarse
  • max hidden apps set to 10
  • other updates from CM and KonstaT
2013-04-01
  • use Android 'legacy' VelocityTracker strategy which means less random jumps from the touchscreen
  • improve kernel msm_ts touchscreen driver - ignore noisy landing/takeoff touches, use real pressure
  • PIE, navbar, and partition info from cm10.1 upstream and KonstaT patches
  • FM volume control should be fixed
  • Effem (FM radio app) included
  • my statusbar/flingtracker fix is now upstream in cm (also fixed in Android 5)
  • zoomhack (pinch to zoom) improved in kernel msm_ts, but it's still not ready for daily use
  • changed default cpu governor back to ondemand as the VelocityTracker and msm_ts fixes seemed to improve lag & interactivity
2013-03-24
  • fix for the StatusBar / SystemUI hang - turned out to be an AOSP bug with events that report identical times
2013-03-22
  • initial release
  • changed governor to smartassV2
  • backported uhid driver from 3.8 kernel so that BT keyboard etc. work
  • ...
Many thanks to all those working on CyanogenMod and armv6 and especially to KonstaT and legaCyMod Edited by PlaguedByPenguins
4

Share this post


Link to post
Share on other sites

Posted · Report post

Thank you very much for your hard work!

0

Share this post


Link to post
Share on other sites

Posted · Report post

Thank you very much for your hard work!

no worries.

with this update the annoying StatusBar hang should now be fixed.

that's the last serious issue that I know of (famous last words :) )

no need to wipe if you've already installed the first ROM.

1

Share this post


Link to post
Share on other sites

Posted · Report post

hi, im new and i have a ZTE V9. i need information how i install this rom. thks

0

Share this post


Link to post
Share on other sites

Posted · Report post

hi, im new and i have a ZTE V9. i need information how i install this rom. thks

Assuming you already have Root Access and that this is going to be a clean install and you have a backup of your SD Card.

1 - Reboot in to Clockwork Recovery

1.1 Power Button -> Reboot -> Reboot -> Recovery -> OK

2 - Cleaning Tablet (Menu navigation is done by the Volume buttons and confirmation is done by the Power button)

2.1 Wipe Data/Factory Reset -> Yes

2.2 Mounts And Storage -> Format /boot -> Yes

2.3 Mounts And Storage -> Format /system -> Yes

2.4 Advanced -> Wipe Dalvik Cache -> Yes

2.5 Advanced -> Wipe Battery Stats -> Yes

3 - Partition SD Card (All the information in the SD Card Will Be Lost)

3.1 Advanced -> Partition SD Card -> 512MB -> 32MB -> Yes

4 - Copy ROM and Gapps to SD Card

4.1 Mounts And Storage -> Mount USB Storage

4.2 Copy ROM and Gapps from your Computer to your SD Card

4.3 Unmount

5 Flash ROM and Gapps

5.1 Install Zip from SD Card -> Choose Zip from SD Card -> Choose the ROM -> Yes

5.2 Install Zip from SD Card -> Choose Zip from SD Card -> Choose the Gapps -> Yes

5.3 Reboot System Now

0

Share this post


Link to post
Share on other sites

Posted · Report post

no worries.

with this update the annoying StatusBar hang should now be fixed.

that's the last serious issue that I know of (famous last words :) )

no need to wipe if you've already installed the first ROM.

Lets hope that it is true ;)

The future updates will be on the base of performance boosts, since everything is working now.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Assuming you already have Root Access and that this is going to be a clean install and you have a backup of your SD Card.

1 - Reboot in to Clockwork Recovery

1.1 Power Button -> Reboot -> Reboot -> Recovery -> OK

2 - Cleaning Tablet (Menu navigation is done by the Volume buttons and confirmation is done by the Power button)

2.1 Wipe Data/Factory Reset -> Yes

2.2 Mounts And Storage -> Format /boot -> Yes

2.3 Mounts And Storage -> Format /system -> Yes

2.4 Advanced -> Wipe Dalvik Cache -> Yes

2.5 Advanced -> Wipe Battery Stats -> Yes

3 - Partition SD Card (All the information in the SD Card Will Be Lost)

3.1 Advanced -> Partition SD Card -> 512MB -> 32MB -> Yes

4 - Copy ROM and Gapps to SD Card

4.1 Mounts And Storage -> Mount USB Storage

4.2 Copy ROM and Gapps from your Computer to your SD Card

4.3 Unmount

5 Flash ROM and Gapps

5.1 Install Zip from SD Card -> Choose Zip from SD Card -> Choose the ROM -> Yes

5.2 Install Zip from SD Card -> Choose Zip from SD Card -> Choose the Gapps -> Yes

5.3 Reboot System Now

Hi! I have tried all of thoose things you mentioned, but still i cant get this rom to work properly.

Some problems i have:

Android.phone.process hangs,

Market loads very slow if even at all and i cant download anything,

sd-card takes very long time to acess from filemanager,

Overall performance is really slow, take about 10 sec to enter the appdrawer, settings etc.

No matter how many full wipes and clean installs i do, the problems still exist :S Any ideas on what i am missing? could my recovery partion be corrupt? :S

0

Share this post


Link to post
Share on other sites

Posted · Report post

Hi! I have tried all of thoose things you mentioned, but still i cant get this rom to work properly.

Some problems i have:

Android.phone.process hangs,

Market loads very slow if even at all and i cant download anything,

sd-card takes very long time to acess from filemanager,

Overall performance is really slow, take about 10 sec to enter the appdrawer, settings etc.

No matter how many full wipes and clean installs i do, the problems still exist :S Any ideas on what i am missing? could my recovery partion be corrupt? :S

Update the recovery.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Have you made S2E work with this ROM? I really dislike link2sd.

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Update the recovery.

Ok, will try that. Is there any newer recovery than cwm 5.0.2.8 rustorg for our tablet? I have that one.

Edited by bamsebiffen
0

Share this post


Link to post
Share on other sites

Posted · Report post

Have you made S2E work with this ROM? I really dislike link2sd.

there's an enormous amount of discussion about s2e on KonstaT's blade thread and all of that should be applicable to this rom.

I actually don't use either of s2e or link2sd so can't help with their issues. I have a custom hard-coded hack of my own to bind mount a subdir of partition 3 of the sdcard onto /data from init.rc, which is a kinda silly thing to do from some points of view, but works well for me. it's not something I'd ship or recommend for others to try though.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Hi! I have tried all of thoose things you mentioned, but still i cant get this rom to work properly.

Some problems i have:

Android.phone.process hangs,

Market loads very slow if even at all and i cant download anything,

sd-card takes very long time to acess from filemanager,

Overall performance is really slow, take about 10 sec to enter the appdrawer, settings etc.

No matter how many full wipes and clean installs i do, the problems still exist :S Any ideas on what i am missing? could my recovery partion be corrupt? :S

kinda sounds like your internal flash or sdcard is slow or dying to me... anything in logcat or dmesg?

also, are you sure your /system partition was >190MB before flashing this rom?

0

Share this post


Link to post
Share on other sites

Posted · Report post

kinda sounds like your internal flash or sdcard is slow or dying to me... anything in logcat or dmesg?

also, are you sure your /system partition was >190MB before flashing this rom?

Im not 100% sure it is 190mb or more, but i cant remember that i have changed the partition ever. And originally it should be like 220mb if gen2 and android 2.2 right? But i have done alot of flashes and modifying on it over the past. Is there an easy way to check partition size?? any program/app that i can use to repartition the tablet? Btw cm7 runs awesome on my tablet, no problems, everything is working fine there. I really hope i will find out what im doing wrong/what is wrong, because i have this rom on my blade and i love it :)

0

Share this post


Link to post
Share on other sites

Posted · Report post

i have a problem... the keyboard doesnt appear when i try to write something...so i cant use my gmail,playstore etc... the installation of the rom and google apps was great! what can i do?

0

Share this post


Link to post
Share on other sites

Posted · Report post

Is there an easy way to check partition size??

fire up the Terminal, type df and look to see what the Size column says for /system.

mine is 220MB, but I have no idea what other people's are. certainly 160MB is common on blades (a very similar device to a v9) which isn't sufficient for this rom.

i have a problem... the keyboard doesnt appear when i try to write something...so i cant use my gmail,playstore etc... the installation of the rom and google apps was great! what can i do?

can you check your /system size too please? also, are you sure you wiped first?

in Settings -> Language & input, under Keyboard & Input Method -> Default, does it say Android Keyboard (AOSP)?

mine is "English (US) - Android Keyboard (AOSP)"

0

Share this post


Link to post
Share on other sites

Posted · Report post

system size was ok,and i did the wipe... i have done it many times before... i had this problem with some other rom too... it says English (US) - Android Keyboard (AOSP) in settings too,the problem is something else but i cant find out what is it... mmm somethin else i would like to ask... is there any link for the latest recovery for zte?

0

Share this post


Link to post
Share on other sites

Posted · Report post

fire up the Terminal, type df and look to see what the Size column says for /system.

mine is 220MB, but I have no idea what other people's are. certainly 160MB is common on blades (a very similar device to a v9) which isn't sufficient for this rom.

Ok thanks for the help. I did return my zte light back to stock using a guide by kallt kaffe and rerooted it and installed your rom. Did check my partition and now it was 220mb system, so all is ok :) But i really don't think the systempartition was the problem because i still got the same problems. But the funny thing is it took about 30min-1hour of the rom up and runing and then suddenly it got fast as hell! Now everything works as it should :)

So if you get problems, a bit of patience (one hour or so) could solve alot :)

Yeah the Zte blade has alot of tpt's that you could change your patition with :) I have that phone and have done some tpt's throughout the years :) But i think the original partition for the blade is 220 mb system if your'e on 2.2 and higher.

0

Share this post


Link to post
Share on other sites

Posted · Report post

above is a 2013-04-01 rom with a bunch of fixes/improvements and also new features from upstream.

I'm not sure how useful navbar and PIE are to us folks with 'hardware' buttons and large screens, but hey, they certainly are shiny.

1

Share this post


Link to post
Share on other sites

Posted · Report post

above is a 2013-04-01 rom with a bunch of fixes/improvements and also new features from upstream.

I'm not sure how useful navbar and PIE are to us folks with 'hardware' buttons and large screens, but hey, they certainly are shiny.

Once again great work!

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

good job buddy..:D

link of gapps please?

Edited by naifah
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

anyone can review this rom?

Edited by naifah
0

Share this post


Link to post
Share on other sites

Posted · Report post

link of gapps please?

same as the KonstaT rom.

0

Share this post


Link to post
Share on other sites

Posted · Report post

same as the KonstaT rom.

thanks..i will try later,btw keep post penguin..

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.