• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

XMOD: MoDaCo Toolkit for Xposed Framework

373 posts in this topic

Posted

Bizarre, I'll look at that!

P

If I get time tonight I'll wipe and reinstall MCR Jr10 as its dirty flash from stock 4.2.2 at the moment.

0

Share this post


Link to post
Share on other sites

Posted

I just can't get this to work at all. Stock Rom now. None of the module's work from the tool box on HTC one. Individual ones do.

At a dead end.

0

Share this post


Link to post
Share on other sites

Posted

Stock or CM Dieter? Removing battery meter doesn't work on CM as there is a menu option in CM to do it.

Should work on stock...

P

Hello Paul,

JR10 on Nexus 4 and JR16 on Galaxy Nexus. On both devices none of the mods are working. Both ROMs baked with circle meter and running Franco kernel.

Dieter

0

Share this post


Link to post
Share on other sites

Posted

Interestingly this worked perfectly just enabling rotation on my HTC Evo3D. Struggling with the N4! :-)

0

Share this post


Link to post
Share on other sites

Posted

Ok. I got it to work.

Using root explorer went to /mnt/asec/modaco.xposed.toolkit-1 folder.

Changed permissions for the pkg.apk and then installed the pkg.apk. this over writes the toolkit and puts it into /data/data/com.modaco.xposed.toolkit.

Reboot and all selected modules work on HTC one.

This was done on a stock Rom and trickdroid Rom on two different devices.

Hope this helps you Paul figuring what going on.

0

Share this post


Link to post
Share on other sites

Posted

Ok. I got it to work.

Using root explorer went to /mnt/asec/modaco.xposed.toolkit-1 folder.

Changed permissions for the pkg.apk and then installed the pkg.apk. this over writes the toolkit and puts it into /data/data/com.modaco.xposed.toolkit.

Reboot and all selected modules work on HTC one.

This was done on a stock Rom and trickdroid Rom on two different devices.

Hope this helps you Paul figuring what going on.

Ah ha! Then I know the issue and it'll be fixed in the next release, thanks for your help!

P

0

Share this post


Link to post
Share on other sites

Posted

Version 5 is now online!

New in version 5 - bugfix: Fixed an issue with app installing to SD card. new module - HTC One: Don't disable ADB - ADB WILL NOT be disabled on boot if the device has a secure lockscreen configuration. DANGER: This is a potential security risk - handle with care!

P

0

Share this post


Link to post
Share on other sites

Posted

Did you ever happen to do the disable security lockscreen with vpn setup?

0

Share this post


Link to post
Share on other sites

Posted

That's coming in a future update!

P

0

Share this post


Link to post
Share on other sites

Posted

Installed new version and still not much joy getting the modules enabled on Nexus 4 MCR. Have you had chance to test Paul?

0

Share this post


Link to post
Share on other sites

Posted

Yes, seems to be working OK on my Nexus 4. Could you uninstall then reinstall version 4? Which module(s) specifically are you enabling without any luck?

P

0

Share this post


Link to post
Share on other sites

Posted

Rotation in particular. Just on its own. I had joy if I enabled hide battery in the past but even that wasn't easy.

I still need to wipe and start a fresh as it worked perfect on my Evo so I think its an option that its my ROM :-D

Thanks for checking

0

Share this post


Link to post
Share on other sites

Posted

Update never worked for me. Uninstalled. Installed new version. Did not install to data/app, nor did modules work.

Installed the pkg.apk and installs to data/app and all ok.

0

Share this post


Link to post
Share on other sites

Posted

OK, installed. v. 5. Still not working. Perhaps it would be better to get the whole thing working, before adding features.

At the moment I pay for an app, I am out of being a beta tester. All I wanted was the duplicate meter removed.

And what if the mod is already selected in the kitchen? Say NFC enabled via kitchen, what happens when I deselect it in the toolbox?

0

Share this post


Link to post
Share on other sites

Posted

OK, installed. v. 5. Still not working. Perhaps it would be better to get the whole thing working, before adding features.

At the moment I pay for an app, I am out of being a beta tester. All I wanted was the duplicate meter removed.

And what if the mod is already selected in the kitchen? Say NFC enabled via kitchen, what happens when I deselect it in the toolbox?

I'm running it on a multitude of devices here and it's fully functional. I'm sorry you're having issues and I'm happy to try and help.

I'm guessing you wouldn't choose the same option in the kitchen and toolkit, but if you do, in this instance, nfc will stay modded of course.

First things to check are to ensure that Xposed is installed correctly, then check the toolkit isn't installed to sd if your device supports it (in settings, apps).

P

0

Share this post


Link to post
Share on other sites

Posted

There appears to be an issue with installing apps from the Play Store where they get installed to /mnt/asec, which breaks the link to Xposed.

This is the first Xposed module to be deployed via the Play Store so this is a previously unseen bug.

I'll liaise with the Xposed developer as soon as possible and hopefully we can get a fix!

P

(details - http://code.google.com/p/android/issues/detail?id=34880)

0

Share this post


Link to post
Share on other sites

Posted (edited)

There appears to be an issue with installing apps from the Play Store where they get installed to /mnt/asec, which breaks the link to Xposed.

This is the first Xposed module to be deployed via the Play Store so this is a previously unseen bug.

I'll liaise with the Xposed developer as soon as possible and hopefully we can get a fix!

P

(details - http://code.google.com/p/android/issues/detail?id=34880)

I wonder if this is why I have problems too :-)

I reflashed my phone and wiped it and installed xposed framework, the toolkit, added all rotation and no joy so far :-S

Ah. Yes following the instructions to install PKG.apk it works now

Edited by lanlith
0

Share this post


Link to post
Share on other sites

Posted

Hello Paul, even when I repeat myself: Both devices are Nexus without SD cards. Xposed framework is functional and toolbox 5 is installed and activated. I have tried with all mods activated and only the meter activated. No reaction, nada, niente. I didn't bake a new ROM, but used the one with most mods already enabled, except the meter. I don't have the toolbox in /data/apps and when I look at the comments, I'm not the only one having problems.

0

Share this post


Link to post
Share on other sites

Posted

If the toolkit is not working for you, please consider posting the content of /data/xposed/debug.log ('adb shell cat /data/xposed/debug.log') in pastebin so I can look for errors - I am pretty sure it is the Google but mentioned above which the Xposed framework is not prepared for (this is the first Xposed module to be deployed via the Play Store).

Dieter - you're clearly not happy with your purchase and although i'm doing everything in my power to resolve the issue at this stage (as I hope you can see), if you'd prefer a refund let me know and i'll action that for you.

P

0

Share this post


Link to post
Share on other sites

Posted

Also, 'adb shell pm list packages -f' will list install locations of packages, check the 'com.modaco.xposed.toolkit' line to see if it's /data/app or /mnt/asec.

I've posted about the issue in the Xposed thread on XDA if you want to track any replies.

P

0

Share this post


Link to post
Share on other sites

Posted

Hello Paul, even when I repeat myself: Both devices are Nexus without SD cards. Xposed framework is functional and toolbox 5 is installed and activated. I have tried with all mods activated and only the meter activated. No reaction, nada, niente. I didn't bake a new ROM, but used the one with most mods already enabled, except the meter. I don't have the toolbox in /data/apps and when I look at the comments, I'm not the only one having problems.

Have you tried copying out the pkg.apk from /mint/asec/ toolkit folder and installing? Seems to vastly improve things on my N4 (no sdcard obvs.)

0

Share this post


Link to post
Share on other sites

Posted

I have temporarily unpublished the app to prevent purchases until I a resolution to the Play Store deployment issue.

P

0

Share this post


Link to post
Share on other sites

Posted

Have you tried copying out the pkg.apk from /mint/asec/ toolkit folder and installing? Seems to vastly improve things on my N4 (no sdcard obvs.)

Yes, that will fix it - and confirms the root cause (Play Store installing to that location and the Xposed Framework expecting the module to be in /data/app).

P

0

Share this post


Link to post
Share on other sites

Posted

Yes, that will fix it - and confirms the root cause (Play Store installing to that location and the Xposed Framework expecting the module to be in /data/app).

P

Worked for me so was hoping Dieter could use this fix too!

0

Share this post


Link to post
Share on other sites

Posted

I'm hoping I can fix it so he can update his review. ;)

P

Dieter Schröder on Apr 2, 2013 at 7:15 PM

Doesn't work at all See subject. Waste of time and money.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.