• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

Help! Wifi problems

21 posts in this topic

Posted · Report post

All of a sudden my phones decided to not connect to any WiFi networks at all.

All I get now is just connecting... Saved. connecting... Saved. and this just goes on forever.

Nothing out of the ordinary has been done to the phone, was working fine this morning, hasnt been dropped, has barley been used apart from texting and phone calls, since I got home ive just got no WiFi anymore.

Done the usual battery out etc, no differnce, last thing i want to do is flash a new rom as I loose everything unless its an OTA update :(

G300 on CM9.1

Any help would be smashing :D thank youuuu!!!

0

Share this post


Link to post
Share on other sites

Posted · Report post

Fix permissions

If that fails wipe both caches

0

Share this post


Link to post
Share on other sites

Posted · Report post

This happend to me on stock rom too, but there should help different thing - just restart both devices - phone and wifi router too. (swith off/on) and try to connect again.

It works anytime I got this problem

0

Share this post


Link to post
Share on other sites

Posted · Report post

Turns out it was the router (though hardwired devices were fine) it was my laptop that finally figured out the Wifi Key was wrong (even though it wasnt)

So nice of the phone to actually tell me!

Cheers for the replies :)

0

Share this post


Link to post
Share on other sites

Posted · Report post

Hello, newbie android user here!

I would like to bump this thread since it's kinda similar to my problem.

It seems that I cannot obtain IP when I enable WPA2-PSK and unfortunately i have to disable the password protection and hide my SSID

since some neighbors are joining my free wifi (not that it's a bad thing).

With iphone, everything works fine.

A friend of mine who has an android phone, can't join my password protected wifi, while in his home wifi everything works fine.

I did some research and I found out that it's a common (!) thing.

Some said that setting up a static IP, will fix the problem. Not mine though.

I am running out of ideas, any help?

0

Share this post


Link to post
Share on other sites

Posted · Report post

Restart the router, and may I ask which router you are using?

0

Share this post


Link to post
Share on other sites

Posted · Report post

I did it several times.

My router is Siemens SL2-141.

I could blame my router but I got this problem only with android phones.

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

What ROM are you using?

Also can use these manual settings and see if they work

IP address: 192.168.1.96

Subnet mask: 255.255.255.0

Default gateway: (the IP of your router) Usually:

192.168.1.254 or

192.168.1.1

DNS server 1: (Same as default gateway)

DNS server 2: 8.8.8.8 (just in case your router does not like being a DNS server)

Edited by george109
0

Share this post


Link to post
Share on other sites

Posted · Report post

I am on CM 9.1

I don't have the Default Getaway option but Network prefix length.

Thnx again.

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Sorry! It should be gateway, not default gateway (Thats a windows option! :P)

Gateway -> (IP of your router, Proably in the manual below) for me, it is 192.168.1.254 According to the manual, your gateway should be 192.168.1.1

Network Prefix Length -> 24

Anyway, try looking at the manual for the router, I have found it for you here -> http://www.iad.cz/pr...User_Manual.pdf

Try using that to log in to the router, and look at the event logs... If you can post them here, (just copy and paste) The forum software should (in theory) format all the text for you...

The only other thing that i could recommend is a factory reset, if that does not work for you...

Edited by george109
0

Share this post


Link to post
Share on other sites

Posted · Report post

Thank you so much for your effort.

I tried to set up again the static IP but no luck.

After searching google, I found a forum with a thread similar to my problem, so one guy suggested this:

1. Turn Off Wi-Fi.

2. Use Root Explorer.

3. Go to data/misc/dhcp.

4. Delete the only file on this directory.

5. Now you will connect to Wi-Fi.

I tried this, knowing that deleting files might cause problems and YES it worked!

0

Share this post


Link to post
Share on other sites

Posted · Report post

Thats fine, and well done on getting it working :)

0

Share this post


Link to post
Share on other sites

Posted · Report post

Thank you so much for your effort.

I tried to set up again the static IP but no luck.

After searching google, I found a forum with a thread similar to my problem, so one guy suggested this:

1. Turn Off Wi-Fi.

2. Use Root Explorer.

3. Go to data/misc/dhcp.

4. Delete the only file on this directory.

5. Now you will connect to Wi-Fi.

I tried this, knowing that deleting files might cause problems and YES it worked!

in the folder there are no files. What else can I do? WiFi just does not turn on

0

Share this post


Link to post
Share on other sites

Posted · Report post

What do you mean the Wifi does not turn? Does it fail when you turn it on?

0

Share this post


Link to post
Share on other sites

Posted · Report post

What do you mean the Wifi does not turn? Does it fail when you turn it on?

wifi switch does not switch to the "on"
0

Share this post


Link to post
Share on other sites

Posted · Report post

Have you tried a different rom or going back to stock?

I had problems with my Samsung I5500 but it was really common problem with 2.2 froyo.

Does it come up with an error? Also have got cwm on the phone you could try fix permissions.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Have you tried a different rom or going back to stock?

I had problems with my Samsung I5500 but it was really common problem with 2.2 froyo.

Does it come up with an error? Also have got cwm on the phone you could try fix permissions.

Yes, I have tried different rom. it all started with [iCS] MeijaICS [b952 4.0.3] FINAL Version [30/03/13] then Mokeeos now lightning rom
0

Share this post


Link to post
Share on other sites

Posted · Report post

Have you dropped or get water inside it? Only thing I think of something has been damaged on the motherboard hence why it does not turn on. Have you still got a warranty on the phone?

0

Share this post


Link to post
Share on other sites

Posted · Report post

for guarantees will have to move on stock rom?

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

http://forum.xda-developers.com/showthread.php?t=1928012[/CODE]

Check the list find the rom for country. Don't tell them if it is unlocked...

Edited by sharkyo01
0

Share this post


Link to post
Share on other sites

Posted · Report post

Thank you. I will try

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.