Sign in to follow this  
Followers 0
kyan31

[JB][CM10.1]★Electra ROM For The Huawei Ascend G300★ ✰UPDATED 02/05/2013✰ ★V3★

1,189 posts in this topic

Just flash these:

http://www.solidfile...m/d/b841187b41/ - ELECTRA V3

http://www.solidfile...m/d/b80edaa098/ - PATCH

http://www.solidfile...m/d/a0ef54fb89/ - GAPPS

Just flash these straight after each other, and you'll be good to go.

Thanks for the quick response - have flashed as you directed and so far it's looking (and more importantly behaving) very well - good job sir!

The only thing I am a little confused by is I seem to be missing a camera option - have installed it on my own and my wife's phone and neither have a camera app of any kind.

I performed a full format clean install (but came from CM10.1) Any ideas?

Thanks again.

Richy.

0

Share this post


Link to post
Share on other sites

Thanks for the quick response - have flashed as you directed and so far it's looking (and more importantly behaving) very well - good job sir!

The only thing I am a little confused by is I seem to be missing a camera option - have installed it on my own and my wife's phone and neither have a camera app of any kind.

I performed a full format clean install (but came from CM10.1) Any ideas?

Thanks again.

Richy.

The camera app is installed on the data partition, so there is a very rare chance that the camera will not install on first boot - this seems to be your situation :huh:

Luckily, the camera apk installs like any other app, so I'll send you the apk tomorrow afternoon. Just use a play store alternative while your waiting :)

0

Share this post


Link to post
Share on other sites
Just downloaded V4, What is mobile broadcasts settings. I know its for emergancy alerts but what does it actually do?? Also does it work in the UK

I assume you mean V3? Anyway, the broadcast app is for warning you about weather changes and natural disasters happening around you. I suspect this app only works in the US, I could be wrong, but this means its just a waste of space on the phones system partition. I'll make a flashable zip to remove the mobile broadcast apk tomorrow if you wish to get rid of it.

0

Share this post


Link to post
Share on other sites

Kyan I flashed your rom again yesterday and , today i'm getting some random reboots I don't know why :l It's kinda anoying .. because I like this Rom ... there's some fix for that ? I know some roms are getting this too

0

Share this post


Link to post
Share on other sites
Kyan I flashed your rom again yesterday and , today i'm getting some random reboots I don't know why :l It's kinda anoying .. because I like this Rom ... there's some fix for that ? I know some roms are getting this too

If there was a fix, you would have it already ;)

Apparently its due to the graphic libraries crashing, that's what Kra1o5 said so he's probably experimenting with a fix.

0

Share this post


Link to post
Share on other sites

Kyan make some new update :P

The best rom, the fastest :)

0

Share this post


Link to post
Share on other sites

Kyan I flashed your rom again yesterday and , today i'm getting some random reboots I don't know why :l It's kinda anoying .. because I like this Rom ... there's some fix for that ? I know some roms are getting this too

As recommended by killuminatii, I installed wolfscript and the reboots and crashes stopped (and everything's smoother too, and my antutu score jumped by 1k)...

http://forum.xda-developers.com/showthread.php?p=36257870

Make sure you follow the wolfscript instructions to the letter - and make a backup in case it all goes pear-shaped. ;)

0

Share this post


Link to post
Share on other sites

If there was a fix, you would have it already ;)

Apparently its due to the graphic libraries crashing, that's what Kra1o5 said so he's probably experimenting with a fix.

Is this the reason why things like flash and TVCatchup don't work? Because of bad graphic libraries?

0

Share this post


Link to post
Share on other sites

Is this the reason why things like flash and TVCatchup don't work? Because of bad graphic libraries?

Yes

0

Share this post


Link to post
Share on other sites

Thanks for the quick response - have flashed as you directed and so far it's looking (and more importantly behaving) very well - good job sir!

The only thing I am a little confused by is I seem to be missing a camera option - have installed it on my own and my wife's phone and neither have a camera app of any kind.

I performed a full format clean install (but came from CM10.1) Any ideas?

Thanks again.

Richy.

Here is the camera apk, its the exact one that is in Electra. Just install it like any other apk, put it on your SD card and select it :)

http://www.solidfiles.com/d/f4dc42afb4/

0

Share this post


Link to post
Share on other sites

Is it possible to make FM radio working on this rom?

0

Share this post


Link to post
Share on other sites

On V3, what are the best settings for system tweaks in electra settings?

What does max events do?

Also what are the nighttime sleep policies?

Do i use Power collapse or Power collapse suspend?

Thanks for the update, Loving it!!!

Also thanks for changing the bluetooth icon too! :)

0

Share this post


Link to post
Share on other sites

Is it possible to make FM radio working on this rom?

You can use Spirit FM. It works for me :)

Edited by george109
0

Share this post


Link to post
Share on other sites
On V3, what are the best settings for system tweaks in electra settings?

What does max events do?

Also what are the nighttime sleep policies?

Do i use Power collapse or Power collapse suspend?

Thanks for the update, Loving it!!!

Also thanks for changing the bluetooth icon too! :)

There are no best settings, its just what you prefer. I'm guessing the sleep policy adjuster is to customise when and how the phone goes to 'deep sleep', and everything else you asked is explained in the System Manager :)

Edited by kyan31
0

Share this post


Link to post
Share on other sites

If there was a fix, you would have it already ;)

Apparently its due to the graphic libraries crashing, that's what Kra1o5 said so he's probably experimenting with a fix.

ok kyan thank you for the response :) btw keep the good work ! :)

As recommended by killuminatii, I installed wolfscript and the reboots and crashes stopped (and everything's smoother too, and my antutu score jumped by 1k)...

http://forum.xda-dev....php?p=36257870

Make sure you follow the wolfscript instructions to the letter - and make a backup in case it all goes pear-shaped. ;)

i'll try it :D if trully works today when i get home i'll install it :) because i have some crashes sometimes and reboots ..

0

Share this post


Link to post
Share on other sites

You can use Spirit FM. It works for me :)

Yes, but i do not like it... Is it possible to make original huawei fm?

0

Share this post


Link to post
Share on other sites

Installing Wolfscript didn't seem to fix the rebooting issues for me, is there any adittional step? Some configuration on both the ROM and Wolfscript I missed?

I really like the ROM tough

0

Share this post


Link to post
Share on other sites

Yes, but i do not like it... Is it possible to make original huawei fm?

Sadly, No. Huawei's radio only works on ICS and not Jelly Bean. It Force Closes as soon as you open it... (I have tried it)

0

Share this post


Link to post
Share on other sites

Kyan, have you checked lattitude yourself?

I have been using it all day today just to see if there were any bugs, and it seems to work fine. It reported my location accurately at different intervals, all without FCs. Are you sure you installed Electra with FULL WIPES?

Thanks in advance ;)

0

Share this post


Link to post
Share on other sites

I'm sure i did it. (Full wipes). It seems i need to reinstall all again... Is there any back'up program to keep all email exchange settings, and other messages or settings alive after reflash? Google sync.isin use. Thanx!

0

Share this post


Link to post
Share on other sites

I have been using it all day today just to see if there were any bugs, and it seems to work fine. It reported my location accurately at different intervals, all without FCs. Are you sure you installed Electra with FULL WIPES?

Thanks in advance ;)

It only crashes when i'm trying to click on the place off current my friends location.

I'll try to send a log. :)

Edited by Arūnas
0

Share this post


Link to post
Share on other sites

Installing Wolfscript didn't seem to fix the rebooting issues for me, is there any adittional step? Some configuration on both the ROM and Wolfscript I missed?

Yeah, unfortunately I seem to have spoken too soon. While crashes after video/audio playback seem to be gone, my phone rebooted itself six times today for what seemed to be no reason at all... :( Also (and more seriously if the truth be told) twice today when people phoned me the screen stayed black and all LEDs stayed unlit - the only way I could answer the calls was to press the power button (which silenced the ring and switched the screen on, allowing me to answer normally).

I don't blame kyan for any of this incidentally... He's done an awesome job with the ROM. Some Googling earlier suggests that most of the issues are inherant to CM 10.1 and affect all ROMs based on it and not just Electra.

0

Share this post


Link to post
Share on other sites

Yeah, unfortunately I seem to have spoken too soon. While crashes after video/audio playback seem to be gone, my phone rebooted itself six times today for what seemed to be no reason at all... :( Also (and more seriously if the truth be told) twice today when people phoned me the screen stayed black and all LEDs stayed unlit - the only way I could answer the calls was to press the power button (which silenced the ring and switched the screen on, allowing me to answer normally).

I don't blame kyan for any of this incidentally... He's done an awesome job with the ROM. Some Googling earlier suggests that most of the issues are inherant to CM 10.1 and affect all ROMs based on it and not just Electra.

I don't blame him either, i think he's done a great job... but to be honest i'm getting really tired of fiddling with ROMs, i've been through a few and can't seem to find one that works 100%

I'd really like the ROM to work fine, it's almost perfect, but for me the problem isn't just the reboots, i've had several issues on CM10.1, mainly:

- Sound too loud on conversations

- When placing a call no call is made/ no tone / call screen but nothing happens

- Despite having cell reception people calling me received "phone off" voice message

- Following unplanned reboots phone behaves erraticaly, can't receive sms

And Kyan, sorry about the rant, I know it isn't any of your fault, keep up the good work

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.