• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.
Sign in to follow this  
Followers 0

[Resolved]Not able to Reset Xolo X900

19 posts in this topic

Posted (edited)

Hi friends,

I am not able to reset my x900.it gives error "sd card has been removed".I rooted my x900,then had enabled SD Card.Then i unrooted,Got an 37mb update on Mobile Update App,tried to install the update but the loading bar gets half way, then the install stops and the Android image becomes led down with a red exclamation mark.Need your help friends..

have attached the error image i am getting.

post-1011001-0-79984500-1367495313.jpg

Edited by xperahul
0

Share this post


Link to post
Share on other sites

Posted (edited)

If you swapped the storage around then it can't find the SD card. You can't update from the base ICS rom AND have the SD card working. I presume you also need root to keep the SD card but am not 100% on that.

You need to stick it back on Xolo ICS and decide which is more important to you. try:- fastboot.exe -i 0x8087 flash update update.zip from the cmd prompt(you do have it on the phones root?).

Edited by BlueMoonRising
1

Share this post


Link to post
Share on other sites

Posted (edited)

thanks BlueMoonRising for ur reply.i dont need sd card.i just want to reset the phone.its giving signal problems so xolo care told me to reset it.

yes i have update.zip on root

Edited by xperahul
0

Share this post


Link to post
Share on other sites

Posted

fastboot.exe -i 0x8087 flash update update.zip from the cmd prompt in the C:\SanDiego\tools folder then. That should reinstall a basic Xolo ICS for you.

1

Share this post


Link to post
Share on other sites

Posted (edited)

fastboot.exe -i 0x8087 flash update update.zip from the cmd prompt in the C:\SanDiego\tools folder then. That should reinstall a basic Xolo ICS for you.

should i keep update.zip file in tools folder?

i got error:cannot load 'update.zip'

also is it possible to undo swap card option?

Edited by xperahul
0

Share this post


Link to post
Share on other sites

Posted

You should have update.zip (the Xolo ICS rom) in 3 locations, the root of your phone, the bricked folder on your PC and the Xolo folder again on your PC.

1

Share this post


Link to post
Share on other sites

Posted

You should have update.zip (the Xolo ICS rom) in 3 locations, the root of your phone, the bricked folder on your PC and the Xolo folder again on your PC.

ok.i copied update.zip into all 3 folders,after executing the above command,again i got same error:update not found,then i copied update file into tools folder and executed the above command,now its showing waiting for device.

0

Share this post


Link to post
Share on other sites

Posted

Ahh, sorry I didn't check the path on that. :blush:

Be patient and wait for it to pick up the phone and then let it do it's stuff.

I have to go now so if anybody else could step in if he needs anymore help please.

Otherwise try http://www.modaco.com/topic/358489-toolaio-tool-for-san-diego-and-xolo/page__st__940 from Ricky's post @ 28 January 2013 - 05:14 PM and on. Just read through it.

1

Share this post


Link to post
Share on other sites

Posted

Ahh, sorry I didn't check the path on that. :blush:

Be patient and wait for it to pick up the phone and then let it do it's stuff.

I have to go now so if anybody else could step in if he needs anymore help please.

Otherwise try http://www.modaco.co...o/page__st__940 from Ricky's post @ 28 January 2013 - 05:14 PM and on. Just read through it.

ok..thanks alot for ur help..

0

Share this post


Link to post
Share on other sites

Posted

OK

Here's what to do:

1.open windows task manager by pressing ctrl-alt&del and click on the processes tab and end the ADB process.

2.now copy c:/sandiego/xolo/update.zip to c:/sandiego/tools

3.boot phone into fastboot and connect it to pc

4.go to c:/sandiego hold down shift and right mouse click on the tools folder and choose "open command windows here"

5.type: fastboot -i 0x8087 devices (to make sure the device is connected)

6.type: fastboot -i 0x8087 erase cache (wait till its finished)

7.type: fastboot -i 0x8087 flash update update.zip ( now it will flash the update

2

Share this post


Link to post
Share on other sites

Posted (edited)

OK

Here's what to do:

1.open windows task manager by pressing ctrl-alt&del and click on the processes tab and end the ADB process.

2.now copy c:/sandiego/xolo/update.zip to c:/sandiego/tools

3.boot phone into fastboot and connect it to pc

4.go to c:/sandiego hold down shift and right mouse click on the tools folder and choose "open command windows here"

5.type: fastboot -i 0x8087 devices (to make sure the device is connected)

6.type: fastboot -i 0x8087 erase cache (wait till its finished)

7.type: fastboot -i 0x8087 flash update update.zip ( now it will flash the update

Step 4 should be C:\SanDiego\tools of course. There is a shortcut to the cmd prompt already in there.

If I remember rightly you may need to run step 5 a few times before the phone is recognised, just type it in the first time and if no success hit the up arrow and enter. Rinse and repeat until the device comes up.

Edited by BlueMoonRising
1

Share this post


Link to post
Share on other sites

Posted

Step 4 should be C:\SanDiego\tools of course. There is a shortcut to the cmd prompt already in there.

If I remember rightly you may need to run step 5 a few times before the phone is recognised, just type it in the first time and if no success hit the up arrow and enter. Rinse and repeat until the device comes up.

when i get into fastboot(i.e by powering off and pressing vol down+power key),i get droidboot with android logo,but the below line is not moving,its stuck,is it normal..?

0

Share this post


Link to post
Share on other sites

Posted

I get this,what message should i get if my phone is detected

Microsoft Windows [Version 6.1.7601]

Copyright © 2009 Microsoft Corporation. All rights reserved.

C:\SanDiego\tools>fastboot -i 0x8087 devices

usage: fastboot [ <option> ] <command>

commands:

update <filename> reflash device from update.zip

flashall flash boot + recovery + system

flash <partition> [ <filename> ] write a file to a flash partition

erase <partition> erase a flash partition

getvar <variable> display a bootloader variable

boot <kernel> [ <ramdisk> ] download and boot kernel

flash:raw boot <kernel> [ <ramdisk> ] create bootimage and flash it

devices list all connected devices

reboot reboot device normally

reboot-bootloader reboot device into bootloader

options:

-w erase userdata and cache

-s <serial number> specify device serial number

-p <product> specify product name

-c <cmdline> override kernel commandline

-i <vendor id> specify a custom USB vendor id

-b <base_addr> specify a custom kernel base address

-n <page size> specify the nand page size. default:

2048

C:\SanDiego\tools>

0

Share this post


Link to post
Share on other sites

Posted

Sorry, never actually tried that myself. It doesn't actually tell you anything so the screen you're getting is correct as far as it goes. I tried fastboot -i 0x8087 reboot and it rebooted mine so it can see it.

And the bar at the bottom should not be doing anything.

1

Share this post


Link to post
Share on other sites

Posted

Sorry, never actually tried that myself. It doesn't actually tell you anything so the screen you're getting is correct as far as it goes. I tried fastboot -i 0x8087 reboot and it rebooted mine so it can see it.

And the bar at the bottom should not be doing anything.

thanks a ton BlueMoonRising..u got me out of this..tried ur steps,now my xolo is working fine..

0

Share this post


Link to post
Share on other sites

Posted

thanks a ton BlueMoonRising..u got me out of this..tried ur steps,now my xolo is working fine..

Excellent, glad for you.
1

Share this post


Link to post
Share on other sites

Posted

3.boot phone into fastboot and connect it to pc

How to connect in fastboot mode.. if my screen is dead

0

Share this post


Link to post
Share on other sites

Posted

C:\SanDiego\tools>fastboot -i 0x8087 erase cache

erasing 'cache'... OKAY [ 2.070s]

finished. total time: 2.070s

C:\SanDiego\tools>fastboot -i 0x8087 flash update update.zip

sending 'update' (306355 KB)... OKAY [ 21.830s]

writing 'update'... OKAY [ 21.440s]

finished. total time: 43.280s

Flashed the file, but still my phone is dead

0

Share this post


Link to post
Share on other sites

Posted (edited)

C:\SanDiego\tools>fastboot -i 0x8087 erase cache

erasing 'cache'... OKAY [ 2.070s]

finished. total time: 2.070s

C:\SanDiego\tools>fastboot -i 0x8087 flash update update.zip

sending 'update' (306355 KB)... OKAY [ 21.830s]

writing 'update'... OKAY [ 21.440s]

finished. total time: 43.280s

Flashed the file, but still my phone is dead

Replied to in http://www.modaco.com/topic/362367-how-to-manually-fixbrick-with-aio-tool-installed/. Don't post the same message in multiple threads, it just confuses things. Edited by BlueMoonRising
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.