Simon O

USB storage not sticking & app corruption on B171

Recommended Posts

Simon O    396

I'll do my best to explain this. Every time I connect the USB cable to my G510 I get a popup asking how to connect to the PC. Normal behavior. Ideally I want to use Media device (MTP) as this doesn't require the internal & external sd to be unmounted but the setting isn't sticking so if you reboot the phone it will go back to the old USB storage.

There is a problem with this.. I'm finding that the phone isn't always cleanly unmounting the internal & external SD storage so quite often it's corrupting app data for any applications you have on these. Anything that is installed to android_secure is placed on the sd.

This isn't normal. If you connect with USB storage then you should be given a prompt about running apps may be terminated and it should also cleanly unmount the drives. It looks like the phone is performing a force-unmount which is causing corruption.

So has anyone else had this same problem? Anyone notice downloaded apps disappearing?

Whenever I get root I'll have to dig into this and try and find a solution. The whole way the device manages internal and external SD is wrong IMO.

Share this post


Link to post
Share on other sites
Andymac1969    58

I don't get any warning about the SD card being unmounted, but I haven't noticed any downloaded apps going missing, I did have problems getting the icon for Super SU, but I think that is more to do with a problem with the APP

Share this post


Link to post
Share on other sites
jimwormold    8

I'll do my best to explain this. Every time I connect the USB cable to my G510 I get a popup asking how to connect to the PC. Normal behavior. Ideally I want to use Media device (MTP) as this doesn't require the internal & external sd to be unmounted but the setting isn't sticking so if you reboot the phone it will go back to the old USB storage.

There is a problem with this.. I'm finding that the phone isn't always cleanly unmounting the internal & external SD storage so quite often it's corrupting app data for any applications you have on these. Anything that is installed to android_secure is placed on the sd.

This isn't normal. If you connect with USB storage then you should be given a prompt about running apps may be terminated and it should also cleanly unmount the drives. It looks like the phone is performing a force-unmount which is causing corruption.

So has anyone else had this same problem? Anyone notice downloaded apps disappearing?

Yes, I've had a few disappear, and now that you mention it, it happened after connecting to the computer. I hadn't really thought about it until now, but you're right, there is something not quite right about how it does it.

Share this post


Link to post
Share on other sites
ZolaIII    98

I had a problem when i changed to new SD card a 3 or 4 aps disappeared bat that happened only once!

Af corse i replicated contains from old one!

Edited by ZolaIII

Share this post


Link to post
Share on other sites
moochermick    18

Whenever I reboot my calendar widget disappears and the tasker icon is moved to a new screen which is added. Very strange and annoying.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.