• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.
Sign in to follow this  
Followers 0

How to increase/boost volume of earpiece/front speaker ?

8 posts in this topic

Posted (edited) · Report post

Hello

First of all I want to tell you that I am rookie in this field [rooting, updating, etc], so please excuse if sometimes I will say some funny things. :D

I have the feeling that sound of the earpiece is too low [also headset has same problem], even I have the volume for call in set to maximum level. I would like to boost this one. There are a lot of applications in the market, but all of them are able only to increase/boost external speaker.

I understood that there is in the “system” some files with volume setting where you can change parameters for the maximum volume of the call in from 5 to 6, let’s say. I understood that you can damage the earpiece, but I won’t increase with many steps, just one or two. How can I do this ? The phone should be rooted for this operation ?

Or, maybe, is there other “magic” simple solution for this issue?

Thank you!

Edited by radu_sergiu
0

Share this post


Link to post
Share on other sites

Posted · Report post

Hello

First of all I want to tell you that I am rookie in this field [rooting, updating, etc], so please excuse if sometimes I will say some funny things. :D

I have the feeling that sound of the earpiece is too low [also headset has same problem], even I have the volume for call in set to maximum level. I would like to boost this one. There are a lot of applications in the market, but all of them are able only to increase/boost external speaker.

I understood that there is in the “system” some files with volume setting where you can change parameters for the maximum volume of the call in from 5 to 6, let’s say. I understood that you can damage the earpiece, but I won’t increase with many steps, just one or two. How can I do this ? The phone should be rooted for this operation ?

Or, maybe, is there other “magic” simple solution for this issue?

Thank you!

There was a similar problem posted on Modaco for the Huawei P1 (U9200) :

http://www.modaco.co...-stock-ics-403/

This may be a completely different problem but it does seem curious the same symptom from the same manufacturer. I don't understand what this fix does but perhaps one of the clever folk here could say if this fix or a similar one would fix your problem.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Thanks. But in this solution i have to root my phone and to update a file from other model. It seems a little bit risky.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Thanks. But in this solution i have to root my phone and to update a file from other model. It seems a little bit risky.

That's only complete solution!

You can enhance volume in multimedia bi using players that supports amplification like Winamp, MX... Bat that won't solve the sistem volume problem.

Becoss the sistem volume is heavily limited the results are really good in such aps!

0

Share this post


Link to post
Share on other sites

Posted · Report post

Ok.i got it. I will try to apply this solution toghether with a friend who knows how to deal with this stuff. So, the steps are rooting and after that finding that audio file and update it. Tkanks a lot.

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

I just root my phone and I saw that the path etc/huawei does not exist. So i can not apply that method. But in the folder etc/ there are some files which I think they are related with audio setting (this is only my supposition). The name of files is audiofilters.csv. Maybe someone know how to play with parameters in there. I read on Internet that you should increase the numbers of the steps in file system/build.prop in order to increase the volume of the earpiece.

So, I iserted the line ro.config_vc_call_vol_steps=10 at the end of the file [we don't have this line in our file]. First, I was surprised that the phone is still working after reboot. [loool] Second, the line is doing nothing for earpiece volume, only it increases the numbers of steps when you hit the volume buttons.

If there is someone which is happy with earpiece voume, can you post that file in order to compare the setting. [maybe there are different becasue of the firmware].

I will attach mine.

AudioFilter.zip

Edited by radu_sergiu
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Tray to find the trade about that for the G300 it's basically the same thing so it should work! And Soc additional parts are the same!

Cud you tray to extract & rename the av lib from MH player, the one that is 5 Mb.

& replace the system one! Du the backup before! I didn't rooted the phone yet so i can't du this myself! System /libs/libavcodec. so

Edited by ZolaIII
0

Share this post


Link to post
Share on other sites

Posted · Report post

if someone upload ur roms root folder with everything in it i would try to check for solution

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.