vache

[CM10][4.1.2] Unofficial builds (v7)

290 posts in this topic

#include

/*

* Your warranty is now void.

*

* I am not responsible for bricked devices, dead SD cards,

* thermonuclear war, or you getting fired because the alarm app failed. Please

* do some research if you have any concerns about features included in this ROM

* before flashing it! YOU are choosing to make these modifications, and if

* you point the finger at me for messing up your device, I will laugh at you.

*/

Sources (device/vendor tree - kernel/ramdisk) : https://github.com/Vachounette

ROM (v7) : https://docs.google.com/file/d/0BwYKbOD16O6Pcmd3SDRQYTBOYnc/edit?pli=1

GApps : http://acer.shreps.f...S1zaWduZWQuemlw

How To :

Put ROM & GApps on your external SD

Reboot to recovery

Format data/factory reset

Flash ROM

Flash GApps

Reboot

Know Issues :

GPS

You tell us

Current Dev' :

davidevinavil

Vache

Shr3ps

If you want to help us to make it better, you're welcome :)

v7 :

New kernel maybe solved random reboots

Playstore fixed

v5 :

camera 7.7 mpixel

video camera 1080p

eco mode forced off at boot

better auto backlight values

torch avaiable now into notification toggle

v3 :

Fix boot

v2 :

Fix hardware playback

Fix NFC

Edited by vache
3

Share this post


Link to post
Share on other sites

Awesome! Well done to you all for getting this far. I'm donwloading it now and will report back anything I find.

John

0

Share this post


Link to post
Share on other sites

Thank you very much for this great work.I have installed it in my cm and first impression is awesome.In which videos device crashes? I am playing for some hour now,mp4 videos with mx player and it work great.Thank you again,please continue to support device

0

Share this post


Link to post
Share on other sites

MX Player uses software decoder, if you try to play video with Galery app (that uses hardware decoder) it will not work.

0

Share this post


Link to post
Share on other sites

Hi,

Looks nice !

Do you know if it is compatible with the cpu-1 Cloudmobiles (aka Belgian and Romanian ones) ?

0

Share this post


Link to post
Share on other sites

Cause you need an unlocked bootloader, no.

0

Share this post


Link to post
Share on other sites

Are you sure ? :( There's nothing about unlocked bootloader in your howto.

0

Share this post


Link to post
Share on other sites

Hi,

Looks nice !

Do you know if it is compatible with the cpu-1 Cloudmobiles (aka Belgian and Romanian ones) ?

I got cpu-3 and bought my S500 from Belgium

Anyway, thank you Vache for all the great tutorials to root, unlock and install CWM on my S500

And the dev team working on this ROM Thank you guys :)

0

Share this post


Link to post
Share on other sites

I got cpu-3 and bought my S500 from Belgium

Lucky you. I really wish I could have known about this cpu thing before buying my S500.

0

Share this post


Link to post
Share on other sites

MX Player uses software decoder, if you try to play video with Galery app (that uses hardware decoder) it will not work.

i am playing with hw encoder and it doesnt reboot.My videos are mp4 360p downloaded from tubemate app

0

Share this post


Link to post
Share on other sites

i am playing with hw encoder and it doesnt reboot.My videos are mp4 360p downloaded from tubemate app

MX Player doesn't handle hardware decoding in the same way compared to Google Gallery.

Anyway the new version (0603-v2) should fix this video/audio decoding

0

Share this post


Link to post
Share on other sites

Awesome development for the cloudmobile !

0

Share this post


Link to post
Share on other sites

No Camera app in V2!

And Torch isn't working anymore

Edited by simoneser
0

Share this post


Link to post
Share on other sites

for me the kernel doesn't boot up... they show acer dmd 1.2 logo and then restart

0

Share this post


Link to post
Share on other sites

for me the kernel doesn't boot up... they show acer dmd 1.2 logo and then restart

I have the same problem.

I then compiled it myself, but I couldn't even get past the white acer logo. :(

Is this the correct local_manifests.xml?


<manifest>

  <project path="device/acer/swing" name="Vachounette/acer_s500_cm10_device_tree" revision="master" />

  <project path="vendor/acer/swing" name="Vachounette/acer_s500_cm10_vendor" revision="master" />

  <project path="kernel/acer/swing" name="Vachounette/kernel_s500_cm10" revision="master" />

  <project path="device/acer/swing/ramdisk" name="Vachounette/acer_s500_Cm10_ramdisk" revision="master" />

</manifest>

or should the paths be different?

0

Share this post


Link to post
Share on other sites

i have the baseband of official JB, is possible that is this the problem?

0

Share this post


Link to post
Share on other sites

I think it's due to the 1890mhz max default speed of the CPU.

Even the old Liquid S1 had the same problem: some models couldn't handle the custom kernel with the higher speed

0

Share this post


Link to post
Share on other sites

this kernel is set at 1890 at boot?

0

Share this post


Link to post
Share on other sites

Hello.In v2 version camera doesnt open.Also in both versions my device doesnt go to deep sleep and i have big battery drain in standby mode.

0

Share this post


Link to post
Share on other sites

for me the kernel doesn't boot up... they show acer dmd 1.2 logo and then restart

Could you test this one : http://d-h.st/qU3

0

Share this post


Link to post
Share on other sites

I have the same problem.

I then compiled it myself, but I couldn't even get past the white acer logo. :(

Is this the correct local_manifests.xml?


<manifest>

<project path="device/acer/swing" name="Vachounette/acer_s500_cm10_device_tree" revision="master" />

<project path="vendor/acer/swing" name="Vachounette/acer_s500_cm10_vendor" revision="master" />

<project path="kernel/acer/swing" name="Vachounette/kernel_s500_cm10" revision="master" />

<project path="device/acer/swing/ramdisk" name="Vachounette/acer_s500_Cm10_ramdisk" revision="master" />

</manifest>

or should the paths be different?

Packed boot.img is not working atm. You have to repack it yourself or take the ROM one.

0

Share this post


Link to post
Share on other sites
I think it's due to the 1890mhz max default speed of the CPU.

Even the old Liquid S1 had the same problem: some models couldn't handle the custom kernel with the higher speed

No, this can't be it, I'm currently running cirrus rom at 1890 without problems.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.