robt77

[DEV][ROM][CM10+AOKP+PA] PAC-man ROM v19.3.0 (updated 16/7/13)

Recommended Posts

I cant add new Access Point Names.Everytime i go to mobile network/apn it just returns me to the last screen and now i dont have internet.Is there anyway i can add them indirectly?Do i have to do a factory reset on cm10 before instaling pac?

Everything else works just fine and overall its a great rom.Tnx for your time and effort

Share this post


Link to post
Share on other sites
robt77    34

To be honest I don't know anything about APNs. Before installing any different ROMs you should wipe data before flashing the ROM. I would suggest to do a full wipe and then reinstall to see if that fixes the problem.

I cant add new Access Point Names.Everytime i go to mobile network/apn it just returns me to the last screen and now i dont have internet.Is there anyway i can add them indirectly?Do i have to do a factory reset on cm10 before instaling pac?

Everything else works just fine and overall its a great rom.Tnx for your time and effort

Share this post


Link to post
Share on other sites

To be honest I don't know anything about APNs. Before installing any different ROMs you should wipe data before flashing the ROM. I would suggest to do a full wipe and then reinstall to see if that fixes the problem.

I did that.What wanted to know is if i didnt do a full wipe,will i be able to keep the old settings?

Share this post


Link to post
Share on other sites
robt77    34

As this is a three in one ROM I don't if the dirty flashing will work. You can try and see if it works?

Share this post


Link to post
Share on other sites
epyloxias    10

And something extra from my 2day experience witn PacMan : Sometimes after 5 minutes or so, I get forceclosed from wifi... Ofcourse it "revives" but... Is that some kind of bug I guess?

Share this post


Link to post
Share on other sites
papars    10

No FC with wifi, but many times it looses connection and then refuses to reconnect unless I switch off and on wifi.

Share this post


Link to post
Share on other sites
robt77    34

Thanks for your comments :D I will say it again, all credit to KonstaT he did all the work for Jelly Bean on our devices, I just compiled the ROM, am working on 4.2.2 but running into issues that I hope I will resolve

Edited by robt77

Share this post


Link to post
Share on other sites
johny_pg1    5

This room is awesome and only drawback for me is speed its very slow on my device and i dont know why

my favorite is browser i absolutely love it but its slow,and i wanted to ask you can you make a build of pacman similar to this one,i mean to look like it not to port the whole thng

http://forum.xda-developers.com/showthread.php?t=1978991

Share this post


Link to post
Share on other sites

As this is a three in one ROM I don't if the dirty flashing will work. You can try and see if it works?

I just tried dirty flashing it over my old cm10 and it worked.I still cant add new apns but the old ones are still there and that is all i really needed.No other issues but the clock force closing at startup and i have to unlock and then lock the sim pin so i can get signal. Im just glad that i can finally enjoy this awesome rom with mobile internet.

Tnx a lot for the rom again i was waiting for something like this for a long time. :)

Edited by Something Wierd

Share this post


Link to post
Share on other sites
papars    10

I'm trying to figure out my wifi has problems from time to time. I look in logcat and I see these lines:

E/WifiHW  (108): Failed to open wlan fw path param (No such file or directory)

E/SoftapController(108): Softap fwReload - failed: -1

E/WifiStateMachine(375): Failed to reload STA firmware java.lang.IllegalStateException: command '157 softap fwreload wlan0 STA' failed with '400 157 Softap operation failed (No such file or directory)'

W/CommandListener(108): Failed to retrieve HW addr for wlan0 (No such device)

D/CommandListener(108): Setting iface cfg

E/WifiStateMachine(375): Unable to change interface settings: java.lang.IllegalStateException: command '159 interface setcfg wlan0 0.0.0.0 0 down' failed with '400 159 Failed to set address (No such device)'

then few seconds later these:
WifiStateMachine(375): Failed to set country code gr

WifiStateMachine(375): Failed to set frequency band 0

While looking at logcat these also pop up very frequently:
E/Trace   (18875): error opening trace file: No such file or directory (2)

E/Sensors (375): sensor_hal set_prox_threshold_data error


E/rmt_storage(123): write_log_file: [MyTag]open: fd=-1

E/rmt_storage(123): block rmt_storage client thread


GlsClient-query(676): requestFailed

QC_MP3DEC(8207): component_init[0x4117f008]component init: role = OMX.qcom.audio.decoder.mp3

and also a list of bluetooth related errors but BT seems to be working fine. (at least pairing with my car)

Share this post


Link to post
Share on other sites
papars    10

Some observations.

The "error opening trace file" is related to gapps. Is it related to the ROM or is a general gapps issue? Can somebody check this?

gapps also throw several warnings related to "face unlock".

The "failed to set country code gr" is strange. My locale is set to gr but wifi region is set europe from the relevant settings menu.

Share this post


Link to post
Share on other sites
Muztek    0

I tryed to test this rom but unfortunly the keyboard gav me FC all time so i couldn't log in to google :(

Share this post


Link to post
Share on other sites
mc9662    1

I got the same message about the ASOP keyboard closing so I downloaded the Google Keyboard from here and saved it to my SD card

http://android.sc/of...e-for-download/

then I went to File Explorer to install the apk, you need to allow non market apps to be able to install in Settings

Now you can change the new Google Keyboard to be the default one, and when that's done you can go to Settings> Apps> All> Android Keyboard, and choose to stop and Disable it - that gets rid of the ASOP Keyboard errors

Hope that helps....

Edited by mc9662

Share this post


Link to post
Share on other sites
papars    10

After several days with this ROM on a Acqua I must say that it runs quite well.

Things I notice:

a. Battery. It can barely last a day with minimal use.

b. Wifi. Sometimes it just doesn't want to connect. Turn off/on will fix this.

c. Phone needs reboot from time to time. It starts by becoming sluggish - eventually it will reboot on its own, but while reaching this point it would be impossible to use.

Other problems I did not had with original ROM.

i. Widget locker 80% of the times just shows the background. Widgets are there but not shown. A quick press of the on button will bring back correct lock screen.

ii. Many times I find the phone unlocked in my pocket and I don't get how this can happen. I have a swipe to unlock and a pattern enabled. Soft keys and volume do nothing when phone is locked. I have the feeling that when a message arrives (missing call, SMS, email) the phone shows a pop up and unlocks. I can't replicate though...

I might try CM10 to see if I get an improvement.

Share this post


Link to post
Share on other sites
kogos    38

Any chance of having pacman for blade 3 updated? Konstat fixed fm radio on cm10, any chance to merge these changes to pacman?

Share this post


Link to post
Share on other sites
robt77    34

I did try the other day and failed completely: ( not had much time since then but will try again over the weekend.

Share this post


Link to post
Share on other sites
robt77    34

Well updated device but still won't build the FM radio for my pacman cm10 ROM. When I try to build pacman 4.2 it looks if it is building with the radio but I am still getting build errors I can't get past

Share this post


Link to post
Share on other sites
KonstaT    3,949

Well updated device but still won't build the FM radio for my pacman cm10 ROM. When I try to build pacman 4.2 it looks if it is building with the radio but I am still getting build errors I can't get past

Regarding FM, you'll need similar device manifest update and patches for 4.1 as I released for 4.2 (1,2,3). I haven't uploaded that stuff anywhere yet but it's almost identical to 4.2. FM is still somewhat wip in cm10 when in cm10.1 it's pretty much perfect. I also have another libaudio update for cm10 but I haven't had time to make a clean cm10 build to see if anything is any better.

I'm not sure what I'm going to do cm10 sources anyway. I plan to keep it open source of course but I'm not sure if I'm going to release bunch of patches or push cm10 sources to legaCyMod repo as well. Now that cm10 has been practically dead for about a half an year I wouldn't have worry about constantly merging branches to keep them up to date.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.