• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

SAMSUNG I8000 (OMNIA2) ANDROID CM6NEW ROM V1

246 posts in this topic

Posted

on the first post i have many kernels. you choose which one fits you.you can experiment other kernels if you want and can boot. yes i tested original kernel is a little ugly in the beggining (white squares on booting) but the fastest ever tested

0

Share this post


Link to post
Share on other sites

Posted

Argentinos

I´ve been trying to download v4, but link is dead as i can read

"Download error

This file ( ROM and Tools.rar ) has been removed because we have received a legitimate complaint and/or determined that the file violated our Terms of Service

is there any other place where i can download or can your reupload the file?

thank u

0

Share this post


Link to post
Share on other sites

Posted

i do not know what is wrong with the service. try again. i think it is fixed

0

Share this post


Link to post
Share on other sites

Posted (edited)

On step 6 i wrote the following :

create a ) one partition primary fat32 (the sum of sd-card's mb minus 1533 mb), b ) one partition primary ext4 for our android sized 1333 mb ,

c ) one partition primary linux swap with the rest 200 mb

This means on your occasion about 6049.8 mb fat32 primary, 1333 mb for you ext4 primary and the remaining for the linux swap primary

But instead this you did 1.6 fat32, 1.3 ext4, 4.7 linux-swap

Developers say that if linux swap is bigger than 250 mb it can cause you problems on android not to be able to read your sd card

i also experienced this problem before. plus do not name your fat32 partition (as sdcard or other) as you have to do using the ext4.tar.gz autoinstaller procedure. just format the partitions defining only their size, filesystem and type (primary). Do not name them. i believe after doing these steps your ROM will work perfectly as on others.

see on the following picture an example how your sd card should look after formation

Hello Argentinos,

ive just installed successifully your v4 on my 8gb SDcard, BUT i always have the message warning of the damaged SDcard...

Ive partitioned like you said with "This means on your occasion about 6049.8 mb fat32 primary, 1333 mb for you ext4 primary and the remaining for the linux swap primary" but that seem not work for me :(

any help?

Edited by t4yr3l
0

Share this post


Link to post
Share on other sites

Posted

Hello Argentinos,

ive just installed successifully your v4 on my 8gb SDcard, BUT i always have the message warning of the damaged SDcard...

Ive partitioned like you said with "This means on your occasion about 6049.8 mb fat32 primary, 1333 mb for you ext4 primary and the remaining for the linux swap primary" but that seem not work for me :(

any help?

yes. easy i think. settings are exactly as i said. just because of many sd card formations your fat partition is broken. this means that you can boot on android, but get the message you said. simple solutions are

1. boot on windows mobile, set usb mode to sd card and through windows disk doctor utility repair your sd card fat system. i hope you know how to do this.

2. if you do not with to see wm again you can also activate usb storage on android and do the same with disk doctor

3. third option is to remove sd card, place it on sd card reader and again the same with disk doctor

next time you will boot on windows you will not get this message

0

Share this post


Link to post
Share on other sites

Posted

Argentinos, I'm trying v4 and great, but it's normal that sometimes get hung and android force closing?

0

Share this post


Link to post
Share on other sites

Posted

it depends. what are you doing when hung ? what you mean hung ? an application force close or android reboots ? second happens when memory/resources are totally drained. it is android's last defense. first can happen since this ROM is beta. closer to complete, but still beta. try to install a third party app from play store to manage your resources. do not load it very much. only has 168 mb RAM . it is not galaxy S4.

now i am trying to help dni123 and spiderman1961 on android 2.3 porting for our phone. when have some time, i will work on v5, more improved, more steady. but for now you must wait or try to edit the ROM yourself.

0

Share this post


Link to post
Share on other sites

Posted

I installed V4 a few days ago following the instructions (16GB SD First partition FAT32, 1333MB ext4 and 188MB swap) and started fine.

After testing for three days I was delighted with Android with only minor problems, but the last time I started Android and it went to sleep, phone never woke up.

I took off the battery and restarted haret from WM, but phone freezed while booting after a few cyanogenmod logos and white squares.

I thought that I (for some unknown reason) had corrupted ext4 partition, so I imagerecovered again and made a try, but unfortunately with the same result over and over again.

I am stuck and don't know what else to do.

Have you any suggestion?

Thanks in advance

0

Share this post


Link to post
Share on other sites

Posted

Makes no sense. just your phone run out of battery and then can not boot again. it happened many times on my phone (battery run out) but after wm and haret i was able to enter android again. When you write "imagerecovered again", you mean you reflashed my ROM again ? MY ROM or another backup you kept ? In case you did my ROM i guess the ext4 partition is damaged. so in this case using minitool erase (not just format) only ext4 and swap partitions. after erasing, create again ext4 and swap. then flash CM6NEW v4 ROM again. boot using haret and everything will be ok again.

i wonder what could cause this problem ? you installed some apps and which ones ? you did other modifications ? if problem insists changing kernel (zimage) could be a nice idea. try this kernel http://www.mediafire.com/download/6dc5wjo6b499nad/CM6B2kernel.rar it is slower but more tested on your device 16GB. I hope i helped.

Working on 2.3 project i got much more experience on android, so maybe CM6NEW V5 will be better and with less problems.until then enjoy current ROM !!

1

Share this post


Link to post
Share on other sites

Posted

It just hangs for a few seconds, then back completely normal. Okay wait for upcoming releases more stable and thanks in advance for the hard work they do.

1

Share this post


Link to post
Share on other sites

Posted

Hi argentinos, thanks for your fast response.

Battery was full loaded,

I deleted the two partitions (ext4 and swap) and created it again copying your ROM V4 without any modifications and freezed loading Android.

The only thing I did not do was erasing the partitions. I will do it and let you know whether it works or not.

I'll try the other kernel if the previous step does not work.

Thanks again

0

Share this post


Link to post
Share on other sites

Posted

Makes no sense. just your phone run out of battery and then can not boot again. it happened many times on my phone (battery run out) but after wm and haret i was able to enter android again. When you write "imagerecovered again", you mean you reflashed my ROM again ? MY ROM or another backup you kept ? In case you did my ROM i guess the ext4 partition is damaged. so in this case using minitool erase (not just format) only ext4 and swap partitions. after erasing, create again ext4 and swap. then flash CM6NEW v4 ROM again. boot using haret and everything will be ok again.

i wonder what could cause this problem ? you installed some apps and which ones ? you did other modifications ? if problem insists changing kernel (zimage) could be a nice idea. try this kernel http://www.mediafire...CM6B2kernel.rar it is slower but more tested on your device 16GB. I hope i helped.

Working on 2.3 project i got much more experience on android, so maybe CM6NEW V5 will be better and with less problems.until then enjoy current ROM !!

I've just wiped the partitions writing zeroes, did a surface test (no errors), deleted the partitions, created the ext4 and swap again, and flashed your ROM once more with Imagerecover.

Again it freezes showing a white square.

So I copied the other kernel you mentioned to My Storage, run Haret and message "Android for Onmia II loading" appeared instead of the ugly chinese logo of the previous kernel, and afterwards appeared the cyanogenmod logo rotating but after a few minutes hangs again.

I don't know what else I can do. Perhaps try V3.

By the way, I created with Minitools the primary Linux partition as ext4 as recommended, but after flashing the ROM, I opened Minitools again and Linux partition was ext3. Can you explain that?

Thanks for your interest.

0

Share this post


Link to post
Share on other sites

Posted

no matter if hangs again. reboot and enter haret again. on first boot always android needs more time due to customizations. i do not know what to think. maybe some problem with your fat partition. try to backup your data, wipe all sd card and then make formations again. since old kernel can boot and new one can not i guess new kernel is corrupted. try to download the kernel again, place on storage and reboot android.

about ext3/ext4 are similar systems. by linux are recognised as almost the same. do not worry. which version of mnitool you are using ?

0

Share this post


Link to post
Share on other sites

Posted

no matter if hangs again. reboot and enter haret again. on first boot always android needs more time due to customizations. i do not know what to think. maybe some problem with your fat partition. try to backup your data, wipe all sd card and then make formations again. since old kernel can boot and new one can not i guess new kernel is corrupted. try to download the kernel again, place on storage and reboot android.

about ext3/ext4 are similar systems. by linux are recognised as almost the same. do not worry. which version of mnitool you are using ?

I`m using the latest version 8 of Minitool Partition Wizard

I will follow your advice, perhaps is a problem with my FAT32 partition, even though I chkdsk under Windows and corrrected all the errors.

I'll let you know.

Thanks

0

Share this post


Link to post
Share on other sites

Posted

I`m using the latest version 8 of Minitool Partition Wizard

I will follow your advice, perhaps is a problem with my FAT32 partition, even though I chkdsk under Windows and corrrected all the errors.

I'll let you know.

Thanks

disks consistency and MBR are quite different. even is the partition has no faults if your mbr is broken, no matter how hard you try formating or repairing you will get nothing. You didn't changed anything on your storage, right ? a windows mobile new ROM flashing or hard reset etc can affect android ROM booting too. in case you did or in case everything else fails try install everything (android) from beginning. You kept your phone next to magnetic devices ? magnetism is verified can affect our phone very easily. many people reported damaged windows mobile ROM after exposing their phone next to devices produce mangetism. android is even more sensitive. especially haret, zImage, startup.txt so start with them and proceed step by step.

0

Share this post


Link to post
Share on other sites

Posted

disks consistency and MBR are quite different. even is the partition has no faults if your mbr is broken, no matter how hard you try formating or repairing you will get nothing. You didn't changed anything on your storage, right ? a windows mobile new ROM flashing or hard reset etc can affect android ROM booting too. in case you did or in case everything else fails try install everything (android) from beginning. You kept your phone next to magnetic devices ? magnetism is verified can affect our phone very easily. many people reported damaged windows mobile ROM after exposing their phone next to devices produce mangetism. android is even more sensitive. especially haret, zImage, startup.txt so start with them and proceed step by step.

I started from the beginning:

- Backed up FAT32 partition

- Deleted the three partitions

- Redefined them

- Flashed your ROM

Started Haret under WM and hung booting.

But I remembered having read in a post (I can't recall where) that the autor said that he only could start Android being the phone conected with USB cable to PC.

I did it and to my surprise Android started. I repeated the same several times and is the only way to load Android, but this method does not seem very appropriate.

Can you tell me the reason?

Thanks again

0

Share this post


Link to post
Share on other sites

Posted

You also replaced haret, startup.txt and zImage as i told you ? i guess yes is the answer. so since you fixed your sd card i guess you should check your storage to find the error. so my suggestion is

1. try twisterV2 ROM, see instuctions here http://forum.xda-developers.com/showthread.php?t=2342764

2. in case can not boot too try to hard reset your phone (windows mobile) and then repeat installation. something seems to be destroyed in your wm ROM

i do not know which country you live, which language you talk, try flashing JI1 (wm 6.5.3) or JJ1 (wm 6.5). they are the latest.

0

Share this post


Link to post
Share on other sites

Posted (edited)

Where i can find the mini-tool you say on the point n. 4? I don't really know where to find it!

Thanks in advance :)

EDIT: I've found it!

By the way, for install version 4 i've to install all the other versions in order? I mean, first 1, after 2 and 3, 4? I'm trying to install the 4th version and i'm having troubles when i try to restore the ROM. Maybe you should try to explain it better.

Thank you!

Edited by blue blast
0

Share this post


Link to post
Share on other sites

Posted

No need to install previous version in order to install v4. just install itself. no problems on me. no problems on dozens of other users.

what to explain better ? i am not there. you see the messages and screens. tell me what message you got ? you are sure you followed the guide step by step ? see first post. it is full newbie guide i think. in case you need extra help pm me. do not load the thread with many posts

0

Share this post


Link to post
Share on other sites

Posted (edited)

You also replaced haret, startup.txt and zImage as i told you ? i guess yes is the answer. so since you fixed your sd card i guess you should check your storage to find the error. so my suggestion is

1. try twisterV2 ROM, see instuctions here http://forum.xda-dev...d.php?t=2342764

2. in case can not boot too try to hard reset your phone (windows mobile) and then repeat installation. something seems to be destroyed in your wm ROM

i do not know which country you live, which language you talk, try flashing JI1 (wm 6.5.3) or JJ1 (wm 6.5). they are the latest.

I am spanish. I don't think it has nothing to do with my ROM. I have WM 6.5 the latest release, because there is no more updates available in SAMSUNG web.

It hungs booting randomly, and the only way to get Android loaded is if USB cable is plugged to PC and does not always work. I don't know why.

Once started it works almost fine with minor glitches:

- Sometimes Wifi when inactivated does not find any network when is reactivated and forces a new load of Android to get it working again.

- Some problems with Play Store but easily bypassed.

- Bluetooth does not find any devices around.

I will try Twister2. I downloaded it and it seems it has the same kernel. I don't want to install in My Storage, I'd rather do it in my SD card using your startup.txt, but first I'm going to buy a Class 10 micro SD..

Thanks for your interest.

Edited by mjmmhm
0

Share this post


Link to post
Share on other sites

Posted

im havin problem with 4 versions installation goes good but i cannot get off unlocker . which key do i press to unlock is there any key programed to unlock pushing to the right screen is not workin .please healp me ! ???

0

Share this post


Link to post
Share on other sites

Posted

im havin problem with 4 versions installation goes good but i cannot get off unlocker . which key do i press to unlock is there any key programed to unlock pushing to the right screen is not workin .please healp me ! ???

try pressing lock key (right side upper) or end call key or home key (cube)

it will work. in case something is wrong with the installation try to repeat and follow carefully the instructions

0

Share this post


Link to post
Share on other sites

Posted (edited)

I got this error message ( `HARET`is not a valid pocket pc application ) !! what is the reason !? can I find help here !?

I cant start my android after I did all steps because this is the error message I got every time I run ( HARET.EXE ) . can some one help me !?

Edited by sparten
0

Share this post


Link to post
Share on other sites

Posted

you are sure you put haret on storage root folder ? if yes maybe the file is corrupted. try download it again. your phone can open other ppc made exe files ? test it. if not maybe yor wm needs to be repaired / reflashed

0

Share this post


Link to post
Share on other sites

Posted

thnx for reply argentinos . I recopy the files to my storage and it works ! ( I think it was corrupted files )

but now when I run haret.exe the mobile fixed at this screen without any changes !! can you help me !?

 

Photo_0795_copy.jpg
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.