• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

SAMSUNG I8000 (OMNIA2) ANDROID CM6NEW ROM V1

246 posts in this topic

Posted

seems to be startup.txt file problem. you have used my startup.txt ? maybe also corrupted. you did primary partition installation as i suggest ? you installed on sd card as i suggest or storage etc ? if try different installation you must change startup.txt .

if you are sure everything is ok about this, i suggest to wait a few minutes on this screen. first boot takes some minutes and many users thinking their phone stuck remove the battery. but the phone didn't stuck, just working. just make sure you do not belong on this case. wait at least 10-15 minutes before remove the battery. (time depends on how fast is your sd card is class 4 will take much time.)

0

Share this post


Link to post
Share on other sites

Posted

thnx for trying to help argentinos 

 

I replaced ( startup.txt ) with new one but my mobile still stuck at the same screen . yes I installed with my SD CARD . I waited for 30 minutes but no change ! 

yes I use all your steps ( format 2 partitions . one primary EXT4 1333 MB . and another one lunix swap 200 MB .and I made normal restore for android rom )

but 

every time I format ext4 and try to restore the rom . I find the ext4 converting to ext3 !!

 

2013_09_20_213920.jpg

 

tell me . do I miss something !? are we have to give name for each partition !?

 
0

Share this post


Link to post
Share on other sites

Posted (edited)

your picture explains everything. you didn't followed the steps as i said this is why you got this result. your startup.txt refers to a partition can not boot. refers to your linux swap partition instead of your ext3/ext4 partition.

 

on the installation instructions i wrote

"create  a) one partition primary fat32 (the sum of sd-card's mb minus 1533 mb), B) one partition primary ext4 for our android sized 1333 mb , γ) one partition primary linux swap with the rest 200 mb"

 

you haven't done this step as i said. you didn't create first partition as primary fat32 (not give names). so ext3/4 partition should be second partition (the one startup.txt is indicating as operating system partition). and so on linux swap should be third partition.

 

startup.txt writes

 

Set kernel zImage168
Set ramsize 180*1024*1024
Set mtype 1626
Set ramaddr 0x50000000
Set kernelcrc 1
Set CMDLINE "rootdelay=2 root=/dev/mmcblk0p2 init=/init"
boot

 

p2 = partition 2 (means operating system is on partition 2 of your sd card)

on your card partition No2 is linux swap. this is not operating system's partition.

 

solutions are

1. Repartition your card and this time follow the instructions

 

or else

2. change startup.txt and change mmcblk0p2 with mmcblk0p1. this way your system will also boot, but you will lose the 326 mb of your sd card (fat32 partition) for no reason.

 

so i suggest solution 1

Edited by argentinos
0

Share this post


Link to post
Share on other sites

Posted

thnx  argentinos for helping :) . I am running now android with my omnia II . nice mobile system but ّwifi cant find network !! I try to find solution . can you help !?

0

Share this post


Link to post
Share on other sites

Posted

go to settings/wifi

activate wifi and right after as soon as possible reboot your system

(do not close wifi. with open wifi reboot your system)

. you got a known bug of CM6. rare, but known. every time you can not log onto wifi

trust me it will really be rare. after go to windows mobile, enter android again and you will be able to normally log on to wifi

0

Share this post


Link to post
Share on other sites

Posted

done . thnx  dear for helping :)

0

Share this post


Link to post
Share on other sites

Posted

sorry, but what happened whit the live wallpapers?

 

sorry, for my bad english

0

Share this post


Link to post
Share on other sites

Posted

your english are not bad at all. after all english is not my native language too.

 

livewallpapers were deleted from ROM as other files too in order to make the ROM run much faster.

 

cyanogenmod key of success is speed and to achieve speed comparing with stock version you must either improve files structure (with demands more efforts) or remove some files - services that most users do not need them of the phone can work perfectly without them too

 

i got the files for live wallpapers from another ROM (twisterV2) uploded here where you can download

 

just boot to your system and using Root explorer or similar place the .apk files under system/app, afterwards select them and give them full permissions user, group others at on read, write, execute. then reboot and next time you will enter android your phone will be livewallpapers capable.

0

Share this post


Link to post
Share on other sites

Posted (edited)

How can i set ram higher? rom v4: 168MB ram. it not enough to use more apps. thanks

Edited by bingbing01
0

Share this post


Link to post
Share on other sites

Posted

it is not easy to set the RAM amount as much as your wish. you must rewrite and recompile kernel for this. can you do it ?

how many apps you want to use simultaneously ? i have installed about 20 apps on downloaded area plus many system apps and still had no memory problem ? you met some memory problem or you just express your fears judging by other phone that appear you the memory lack message ?

i hope in the near future we can see more than 168 RAM, although for now it is the most i have heard of. no mater what our phone can not support more than 256 RAM (hardware specs) unless we can do a software trick (like windows 7 etc) to use a part of sd fast card as virtual RAM. if you want to see 1/2BG of RAM and that fast performance on this old phone buy a new 4 core phone. our can get more than 1000 points (1034 on me) on antutu and thats all. never compare it with LG G2 or other hi end phones.

0

Share this post


Link to post
Share on other sites

Posted (edited)

Hello argentinos and thanks for the rom but i am having some issues.

(Problem 1) I followed all of your steps and managed to install and boot succesfully. But, once i restarted, the phone was stuck on the Chinese letters with the red eye boot image and it cannot go further.

I tried leaving it for 10mins there but it stays the same. Do you have any suggestions?


I reinstalled and the issue seemed to befixed, but for any instalation that i try, i get notification saying (Damaged SD Card - SD Card Damaged. You may have to reformat it.)

I tried to format the sd card but it doesnt do anything. It keeps saying that my sd card is damaged. Do you have any suggestions ?

I run some tests on my sd card and couldn't find anything wrong with it. Oh and its a class 10 card.

I also tried mounting the card and it still wont work.

** Last edit:

I am having (Problem 1) again.

Edited by marios32
0

Share this post


Link to post
Share on other sites

Posted (edited)

thanks for solve my question argentinos

 

the live wallpaper

work to 100%

Edited by guardianx
0

Share this post


Link to post
Share on other sites

Posted

chinese letters means your kernel can not find your partition for booting. can you take a picture or your sd card partitions under Mini tool and post it here ? it will explain many problems. You are sure you haven't modified the startup.txt, right ?

0

Share this post


Link to post
Share on other sites

Posted (edited)

I didn't see other chinese letters. Just the regular logo of the start up. I can't give you a picture now because i formated the sd after not being able to work things out.

But i can tell you that i checked for the size of each partition and they were the same exact number to the megabyte, that you said on your guide it needs to be.

Also there is no way i modified the startuptxt. I checked on that too and it was correct. (Checked on original file and the are the same.)

Edited by marios32
0

Share this post


Link to post
Share on other sites

Posted

ok so you checked the startup and everything ok. you also checked the partitions and you said ok. so an explanation might be corrupted files. try download again the ROM and repeat the installation.

 

if this will not help, then try to give me a picture on sd card under mini tool or else you are not helping me at all. and if you will not help me i can not help you too.

 

alternatively you can try another ROM (and method) from here http://forum.xda-developers.com/showthread.php?t=2342764

0

Share this post


Link to post
Share on other sites

Posted

I installed 2 times to check if it was corrupted files and i had the same problems. I will try to install again soon and i will post you a minitool snap of the sd card. Thanks for your time and replies.

Does haret startup and zimg need to be on phone storage or sd card storage though ? I as per the instructions put then on internal storage (phone).

0

Share this post


Link to post
Share on other sites

Posted (edited)

yes you did the right thing. haret, startup.txt, zImage must be placed into storage (phone), installation is on sd card (external removable card).

You are sure fat32 is partition 1 primary, ext3/4 is partition 2 primary and linux swap is partition 3 primary ?

Edited by argentinos
0

Share this post


Link to post
Share on other sites

Posted (edited)

Hi. I'm unable to open the ROM image. 

post-1028400-0-41132200-1383152360_thumb

 

I have followed all the instructions exactly. I have also read through this whole thread, and tried all the suggestions. Can you please create the image using free software like imgburn, 7-zip or something? Maybe you are trying to sell this program? j/k ;)

Edited by exekutive
0

Share this post


Link to post
Share on other sites

Posted

this software version is not paid and of course not cracked. you can use it without the need to pay money. i didn't created the program, other members of the forum i guess too, and we are also not working for the company. we are just trying to use an installation method newbie friendly. we found this method on the net and offering it as it is, no change from us. i ever asked money from anyone ? not even donation. everyone here is working on this old phone in order to help poor people that can not afford to buy a new phone (or people just love their phone and do not want to replace it) to continue tasting new services and new techologies. of course anyone that wants can buy the installation program and we encourage them to do so.

so please next time read carefully the instructions before decide that a method is not working  and generally ask before judging.

as for the image with imgburn or 7zip or else you can freely create it yourself, distribute it and explain the instructions to other users (especially newbies). noone has problem about this.

0

Share this post


Link to post
Share on other sites

Posted

j/k ;) = I was being sarcastic/joking with you. I don't judge you and I'm still very positive about this. Just a bit frustrated :)

 

I am actually very glad that other people have decided to support these old phones because I have no need for the newest $400 gadgets. And I am not savvy enough to create these myself.

 

I would really like to try this ROM but I just can't make it work. Please, I've followed all your instructions. I've messed around with the date on my computer... sept 2010 and 2011. Changed it before opening the program, changed it after, and still I get the same message. I know I'm not the only one with this problem, because several others have posted the same thing in this forum, and xda as well. But I have not seen any good solutions. I'm just trying to provide some useful feedback, that this image software is not so newbie friendly.

 

Maybe I should try the v3 for now, but is it possible to retain all my setting and upgrade to v4?

 

Thanks for your time.

0

Share this post


Link to post
Share on other sites

Posted

upgrading from one version to another is not possible yet, unless someone will use ubuntu or another linux os.

each version is offering newer apps, newer techonolgies support and about cm6new the goal is to give more ICS/JB (android 4.0.x / 4.x.x) look to our android 2.2.2. ROM

 

About the installation you can use version 3, version 2 or version 1 installer to flash your V4 ROM, many people dealed problems with V4 installer, while others had no problems. maybe has to do with some libraries (dll) in their computer. So my advice for now is download any previous version as well as V4, then use previous versions installer and flash V4. it worked with others, i think wil work with you.

 

Trust me this image software is the most user friendly i know. Maybe you think that 20 steps in order to flash the ROM are many, but they are so many to explain any detail possible to non experienced users and avoid easy questions. advanced users can make these steps with closed eyes. other programs you suggested are not that much that user friendly meaing that you should reboot your phone twice and restrict you to 976 mb of ROM size. modern apps need much space and soon you must use linux to increase ROM size.

Me and other members here are open to smart suggestions. i am telling you again that if you suggest another method, better than the existing of course we will adopt it. as for me i will try next CM6NEW version to be published also on image form and if possible also o tar.gz form for use with o2droid autoinstaller

 

i do now know how experienced you are and how much time you can devote on this phone, but trust me everyone here started from quite low point and with much reading and testing they are able to help others. you are welcomed to do the same. no need to be a computer programmer to help

0

Share this post


Link to post
Share on other sites

Posted

I just tried the image tool from v3... same result.

0

Share this post


Link to post
Share on other sites

Posted

you have tried any date of sept 2011 ? first set the date and after this try to open the installation program. just use the version provided. do not download another version from the internet. if version 3 also fails try v1 installer

0

Share this post


Link to post
Share on other sites

Posted (edited)

Yes, I set my date to Sept 10, 2011. I tried 'imagerecover.exe' from your v4, v3, v2 and v1. All same result.

 

EDIT: I just tried the same thing on my friend's computer. Still no change.

 

There were other people in this thread who reported the same problem as me: blue blast, mairu, SPL1, chonazo, srdannyr 2 more in the XDA forum. I wonder if they found a solution?

Edited by exekutive
0

Share this post


Link to post
Share on other sites

Posted (edited)

OK, finally I made it work. I installed a fresh trial copy of Image for Windows from the website (2.8.3). For some reason it worked on my friend's computer, but not mine. The only difference was running 64-bit version.
 
There was one extra option screen which isn't mentioned in the instructions:
post-1028400-0-29860900-1383198881_thumb
I just left the default options.
 
Step #16 says "reopen minitool an if after ext4 partition " but I didn't see a EXT4 partition, only EXT3. So I went back to step 6, re-partitioned the SD card and made sure I formatted it as EXT4.
post-1028400-0-21674000-1383199097_thumb
 
I flashed the ROM image again, and then ran the partition wizard, but the linux partition was EXT3 again.
 
post-1028400-0-78264200-1383199091_thumb
 
So I guess step 6 is a mistake and you should make it EXT3 instead of EXT4. Step 16 is also a mistake, and you should check the EXT3 partion. The rest was OK.
 
I find the white flashing screen on boot extremely annoying, and I don't particularly like the Chinese splash screen, but I am happy to have Android. Now I just have to fix the "Damaged SD card" problem, and change the ugly wallpaper. Hopefully there are also some widgets for appointments and message.
 
Also, the phone froze while the display went to sleep. I had to pull out the battery and reboot.
 
Cheers, and thanks for the support.
Edited by exekutive
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.