sarlyna

Camera not working, in CM10 nightly

7 posts in this topic

Hello. I'm Spanish, in huawei ascend mobile g300, I've set many times the roms for the reason of slowness and errors, before was infusion, cm9 and cm10 of Nightly and Experimental, in the end is CM10 from Nightly: http://getcm.thebronasium.com/?device=u8815

I was satisfied and I so happy with this rom, by how quickly and smoothly, except the camera, it does not work in many apps, screen is black but you can take pictures. I have no programming knowledge to install the camera driver for linux mobile (android 4.1.2 CM10) ... I can do? if I die for to prove another R7 CM10 rom, if I'm tired installing another rom .... i had gapps for ics, but Google Play could enter, and now I just installed gapps for jb, after this, the problem of camera persists.

I attached the photo of rom information and the camera. What solution has the problem of the camera?

Thank you. Best regards.

post-1014567-0-38698800-1372772161_thumb

post-1014567-0-62694300-1372772168_thumb

post-1014567-0-39814900-1372772334_thumb

0

Share this post


Link to post
Share on other sites

This is a well known problem. Can you download the logcat app from the play store, open it and press start recording/logging. Then cause the problem again, stop the recording and upload the results here.

1

Share this post


Link to post
Share on other sites

This is a well known problem. Can you download the logcat app from the play store, open it and press start recording/logging. Then cause the problem again, stop the recording and upload the results here.

Thanks for your reply, I have done what you asked.

I attach the log.

catlog.txt

0

Share this post


Link to post
Share on other sites

Nobody can give me a solution of camera? Did I wear another rom, on CM10 R7? (although I have not really wanted)?

Thank you very much.

0

Share this post


Link to post
Share on other sites

I would backup your apps and reflash the ROM with full wipes.

Factory Reset

Cache Partition

Data

Cust

System

Dalvick Cache

0

Share this post


Link to post
Share on other sites

Flash this Last time i checked third party cameras not workin at Daz builds.

0

Share this post


Link to post
Share on other sites

Thanks, Diehard. You've given me an idea install backup applications, I also have found application for APNs backup.

To backup applications, which have to do is:

-Install APP Backup & Restore.

- Backup app.

Backup APN:

-Install Apn backup&Restore.

-Backup APN.

Restore APN:

-Install Titanium Backup Pro

-Enter Titanium.

-Go to the tab Backup / Restore.

-Press in the seconds on APN Backup & restore

-Make "make system application"

-Go to app: APN backup & restore.

-Go to Settings> Enable ICS check.

-Restore APN.

To me has been restoring applications faster..Thanks for your time. The camera works with the same rom reinstalled.

post-1014567-0-36671800-1373132440_thumb

post-1014567-0-02040300-1373132481_thumb

Edited by sarlyna
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.