• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.
Sign in to follow this  
Followers 0

BSNL 3G network reception problem on Xolo X900

8 posts in this topic

Posted

I bought a Xolo X900 in October last year. I have a BSNL prepaid SIM card in my phone (All micro BSNL prepaid cards are 2G).

I have not been able to register my BSNL SIM on a 3G network ever in this handset. (I have tried a custom cut 3G BSNL SIM which also failed to register the 3G network). Initially, there were frequent total network loss. I mended it by instaling the Network app from the Play store which allowed me to set the reception mode to "GSM only". The problem recurrs if I try to set the reception mode to "WCDMA only" or "WCDMA preferred".

Interestingly, the same SIM (and all other BSNL SIM including 2G and 3G) registers the 3G network on my Nokia 5800 and also my 3G internet dongle (Huawei 1550E).

Has anybody else also faced the same problem? If yes, can it be overcome by the Xolo updates?

(BTW, I updated initially with the 27 MB update and not thereafter due to the fear of not being able to root my device ever, if required. The update had no effect on the network reception.)

Can the learned men in this forum throw some light on what can be the reason for such a behaviour by my Xolo X900?

0

Share this post


Link to post
Share on other sites

Posted

Yes, another unesscery took

0

Share this post


Link to post
Share on other sites

Posted (edited)

Dear BlueMoonRising and Thedarkphonetech,

Kindly understand the problem before dismissing it outright.

The problem is no more of the network drops (which occurred due to the default setting of "WCDMA preferred" and which was overcome by an app and setting the network registration mode to "GSM only". And this is the solution which BlueMoonRising is referring to, and which I provided for a fellow in another thread who is suffering from the problem as I was initially).

What I wish for is 3G (or HSDPA or WCDMA) network on my phone which I'm not able to acheive. The same SIM card in my Xolo X900 registers 3G network on my Nokia 5800 and my internet dongle. However, in Xolo X900, the SIM can work well only in "GSM only" mode and not in any other mode which involves WCDMA. If I set the mode to "WCDMA only" or "WCDMA preferred" network drops start to recur and the network strength bar trianlge is replaced by a small trianlge with a small cross in it.

I hope my point is clear now.

Edited by Protoplasm
0

Share this post


Link to post
Share on other sites

Posted

Dear BlueMoonRising and Thedarkphonetech,

Kindly understand the problem before dismissing it outright.

The problem is no more of the network drops (which occurred due to the default setting of "WCDMA preferred" and which was overcome by an app and setting the network registration mode to "GSM only". And this is the solution which BlueMoonRising is referring to, and which I provided for a fellow in another thread who is suffering from the problem as I was initially).

What I wish for is 3G (or HSDPA or WCDMA) network on my phone which I'm not able to acheive. The same SIM card in my Xolo X900 registers 3G network on my Nokia 5800 and my internet dongle. However, in Xolo X900, the SIM can work well only in "GSM only" mode and not in any other mode which involves WCDMA. If I set the mode to "WCDMA only" or "WCDMA preferred" network drops start to recur and the network strength bar trianlge is replaced by a small trianlge with a small cross in it.

I hope my point is clear now.

I didn't "dismiss it outright", I merely asked had you not already answered your own question. And yes your point is, at least now, clear.

BTW you don't need an app to enable 2G only, you can do it through settings. I have https://play.google.com/store/apps/details?id=com.painless.pc&feature=search_result#?t=W251bGwsMSwyLDEsImNvbS5wYWlubGVzcy5wYyJd installed with a button just for this as we have poor 3G where I live, so normally have it on 2G only unless I'm using the internet in a stronger area.

If you've already installed the first patch I would go ahead and install the latest one as well. Yes you would lose any chance of root but having a workable phone is presumably more important. I'm not sure if it affects the radio receiver/transmitter or not.

0

Share this post


Link to post
Share on other sites

Posted (edited)

Thanks BlueMoonRising for understanding the issue.

I now have the latest update installed and the 3G network coverage where I live is good (full strength as seen in my Nokia 5800). Still the problem persists.

Would that hold the phone as the culprit for not being able to receive 3G signals? or could there be any other software related issue?

Edited by Protoplasm
0

Share this post


Link to post
Share on other sites

Posted

Thanks BlueMoonRising for understanding the issue.

I now have the latest update installed and the 3G network coverage where I live is good (full strength as seen in my Nokia 5800). Still the problem persists.

Would that hold the phone as the culprit for not being able to receive 3G signals? or could there be any other software related issue?

Have you tried asking BSNL? I'm in the UK so have no knowledge of the company. Whether it's the phone or just a setting I really couldn't say.
0

Share this post


Link to post
Share on other sites

Posted

3G signal range is always lower than the 2G signals, try to move near BSNL tower and then retry.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.