• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

Compass not working at all

124 posts in this topic

Posted · Report post

I open this thread to help us all what is the state of this big problem with our mobile, as far as I know every rom has the compass not functioning, this makes navigation through gps impossible, and may cause problems also fixing satelites.

I would like to know if anybody has the compass working fine, and in that case wich is the rom you are using so we all can learn from each other.

I have the last rom updated via OTA from vowney.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Is there anyone with a working compass? I installed Tiny Compass (and several other apps) but it showed North no matter which direction I was standing

0

Share this post


Link to post
Share on other sites

Posted · Report post

nobody has a working compass, but I am afraid this forum is only to praise vowney ... not for sharing and solving problems ...

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Yes working compass on one of the V5's I have purchased but on the other one, that I have updated, it doesn't seem to be working.

Edited by Rico_89
0

Share this post


Link to post
Share on other sites

Posted · Report post

Yes working compass on one of the V5's I have purchased but on the other one, that I have updated, it doesn't seem to be working.

could you please post a screen shot of your software version info? I could try that version as compass is extremely important to me

0

Share this post


Link to post
Share on other sites

Posted · Report post

Yes working compass on one of the V5's I have purchased but on the other one, that I have updated, it doesn't seem to be working.

just received a V5 from pandawill for my son today, only updated with the vowney ota. no movement on compass at all, says "magnetic sensor error", or sensor not present or faulty", great send it back or not??, wonder if it needs to have networklocation apk installed to work?

first V5, compass works but it thinks north is east.

0

Share this post


Link to post
Share on other sites

Posted · Report post

could you please post a screen shot of your software version info? I could try that version as compass is extremely important to me

http://www.modaco.com/topic/363528-gps-lock-issue-try-this/page__st__40#entry2141572

just received a V5 from pandawill for my son today, only updated with the vowney ota. no movement on compass at all, says "magnetic sensor error", or sensor not present or faulty", great send it back or not??, wonder if it needs to have networklocation apk installed to work?

first V5, compass works but it thinks north is east.

Mine says the same thing but I don't think there's anything wrong with the sensor, just the update. My brother has a working compass and his build version is V1.10..

0

Share this post


Link to post
Share on other sites

Posted · Report post

just received a V5 from pandawill for my son today, only updated with the vowney ota. no movement on compass at all, says "magnetic sensor error", or sensor not present or faulty", great send it back or not??, wonder if it needs to have networklocation apk installed to work?

first V5, compass works but it thinks north is east.

all compasses as far as I know are malfunctioning, except the one previously reported, if you want a working compass you have to buy another phone, vowney is not capable of solving the issue, at least until now...

0

Share this post


Link to post
Share on other sites

Posted · Report post

all compasses as far as I know are malfunctioning, except the one previously reported, if you want a working compass you have to buy another phone, vowney is not capable of solving the issue, at least until now...

strange, as the older phone where the compass point moves (albeit wrongly) has the latest ROM from Vowney, the new V5 where I get the error also has the same ROM, as well as the error showing, the needle is fixed stationary. is yours like that with a pointer that does not move.

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

what date was that build released? can you find out?

Not sure if I can.. :(

Anyone running Tillaz's custom rom, and if so is the compass working?

Edited by Rico_89
0

Share this post


Link to post
Share on other sites

Posted · Report post

http://www.modaco.com/topic/363528-gps-lock-issue-try-this/page__st__40#entry2141572

Mine says the same thing but I don't think there's anything wrong with the sensor, just the update. My brother has a working compass and his build version is V1.10..

strange, as the older phone where the compass point moves (albeit wrongly) has the latest ROM from Vowney, the new V5 where I get the error also has the same ROM, as well as the error showing, the needle is fixed stationary. is yours like that with a pointer that does not move.

his build Number you say is V1.10.. mine is ALPS.JB2.MP.V1.3.. SO DO YOU MEAN HIS IS v1.1

0

Share this post


Link to post
Share on other sites

Posted · Report post

Not sure if I can.. :(

Anyone running Tillaz's custom rom, and if so is the compass working?

I have just asked this question in tillaz's rom thread ...

0

Share this post


Link to post
Share on other sites

Posted · Report post

strange, as the older phone where the compass point moves (albeit wrongly) has the latest ROM from Vowney, the new V5 where I get the error also has the same ROM, as well as the error showing, the needle is fixed stationary. is yours like that with a pointer that does not move.

his build Number you say is V1.10.. mine is ALPS.JB2.MP.V1.3.. SO DO YOU MEAN HIS IS v1.1

v 1.1 must be the rom, now we need a link to download and test it ... anybody can provide a working link?

0

Share this post


Link to post
Share on other sites

Posted · Report post

strange, as the older phone where the compass point moves (albeit wrongly) has the latest ROM from Vowney, the new V5 where I get the error also has the same ROM, as well as the error showing, the needle is fixed stationary. is yours like that with a pointer that does not move.

his build Number you say is V1.10.. mine is ALPS.JB2.MP.V1.3.. SO DO YOU MEAN HIS IS v1.1

Here's a pic with his build number.

http://img707.imageshack.us/img707/5555/6ckl.jpg

I have just asked this question in tillaz's rom thread ...

Ah great I was going to do the same.

0

Share this post


Link to post
Share on other sites

Posted · Report post

http://www.modaco.com/topic/363528-gps-lock-issue-try-this/page__st__40#entry2141572

Mine says the same thing but I don't think there's anything wrong with the sensor, just the update.

Rico, when you say your compass gives the same error as mine (MAGNETIC SESOR ERROR, no magnetic sensor or it is out of order),is the compass needle solid as a rock and does not move, even if you turn the phone?

0

Share this post


Link to post
Share on other sites

Posted · Report post

Rico, when you say your compass gives the same error as mine (MAGNETIC SESOR ERROR, no magnetic sensor or it is out of order),is the compass needle solid as a rock and does not move, even if you turn the phone?

Yes correct, never moves: here's an example of what I'm talking about.

Left: working V5 compass, Middle: working G300 compass, Right crapped out V5 compass.

1gma.jpg

I downloaded an app called "Android Hardware Info", and listed in the "Magnetic Field Sensor" list it says "Vendor Bosch" and lists the specs .. exactly the same as my brothers phone.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Yes correct, never moves: here's an example of what I'm talking about.

Left: working V5 compass, Middle: working G300 compass, Right crapped out V5 compass.

1gma.jpg

I downloaded an app called "Android Hardware Info", and listed in the "Magnetic Field Sensor" list it says "Vendor Bosch" and lists the specs .. exactly the same as my brothers phone.

Yep, my broken compass points exactly the same as yours "identical twin", guess there is no point in returning to pandawill as the next one is likely to be exactly the same??

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Yes correct, never moves: here's an example of what I'm talking about.

Left: working V5 compass, Middle: working G300 compass, Right crapped out V5 compass.

1gma.jpg

I downloaded an app called "Android Hardware Info", and listed in the "Magnetic Field Sensor" list it says "Vendor Bosch" and lists the specs .. exactly the same as my brothers phone.

thank you so much for the pictures, I thought there was no working v5 compass, the problem is that if the working one has the same software as the others (mine for instance) then it must be a hardware problem and your brother has got the exceptional working one... good for him and terrible for the rest of us

the phones arriving today at Spain have the same problem, so asking for a replacement today would be useless

Edited by elsita
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

thank you so much for the pictures, I thought there was no working v5 compass, the problem is that if the working one has the same software as the others (mine for instance) then it must be a hardware problem and your brother has got the exceptional working one... good for him and terrible for the rest of us

the phones arriving today at Spain have the same problem, so asking for a replacement today would be useless

No problem.. I have to say that because so many are having this issue it might be as you say a hardware fault.. I was reading about possible solutions that have worked for others, where they have pulled the micro sd card and moved a not so powerful magnet closer and closer to their device to unstick the sensor.. but it sounds a bit risky to me.

I wonder if it's possible for Vowney to come up with a fix for this as even the folks in China must be having the same problem.

Edited by Rico_89
0

Share this post


Link to post
Share on other sites

Posted · Report post

when you google compass not working it seems to be a common problem with phones using the mtk chipset, have not managed to spot a fix though.

0

Share this post


Link to post
Share on other sites

Posted · Report post

when you google compass not working it seems to be a common problem with phones using the mtk chipset, have not managed to spot a fix though.

the problem belongs to vowney not mediatek, I use a mediatek phone with the same micro and my compass works always perfect

0

Share this post


Link to post
Share on other sites

Posted · Report post

the problem belongs to vowney not mediatek, I use a mediatek phone with the same micro and my compass works always perfect

I didn't mean all mediatek phones , just that when you google bmm050 not working / compass not working, various phones that use mediatek have a similar problem.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.