PaulOBrien

Beta 13: MoDaCo.SWITCH HTC One support topic

1800 posts in this topic

Hi to everybody here and first thanks to admit me to the Switch Beta.

My One is SFR branded (french brand for Vodaphone) with S-On.

Before installing Switch, I first install SFR official 4.2.2 update. Then I rooted it following a french tutorial.

I did follow your instructions, and everything just run fine concerning different flashs I'd to do. And I rooted it too thinking the flash I've just comes to do erase the first root

The SFR layer disappear with the flash, and all the SFR apps disapeared too and even the boot slashcreen. No too bad for that point ;)

I just did one mistake :\ : I first have resync all my account and personalisation on the Sense ROM before switching to the GE one. My bad ...

Then I run Switch.

The One close correctly but directly boot on the Recovery Mode : there, I'm asked to say Yes or No to the installation of an Untrusted zip. If I say no, it restart and boot to Sense. If I say Yes, it boots correctly to the GE ROM. But every Switch I do drives me there. THe recovery Log say :

ClockwordMod Recovery V6.0.3.1

Finding update Package

Opening update Package

Verifying Package update

E:signature verification failed

then Installing Update once I've granted the installation.

Afer that I have to manually select Reboot System Now + Have to say No to the Fix and it then boot correctly to GE. And Vice Versa :)

Maybe it comes from the personnalisation of the Sense Rom I've made before running the Switch ? Maybe that come from a root problem (one root on the original ROM, the another root installing Switch)

0

Share this post


Link to post
Share on other sites
Hi to everybody here and first thanks to admit me to the Switch Beta.

My One is SFR branded (french brand for Vodaphone) with S-On.

Before installing Switch, I first install SFR official 4.2.2 update. Then I rooted it following a french tutorial.

I did follow your instructions, and everything just run fine concerning different flashs I'd to do. And I rooted it too thinking the flash I've just comes to do erase the first root

The SFR layer disappear with the flash, and all the SFR apps disapeared too and even the boot slashcreen. No too bad for that point ;)

I just did one mistake :\ : I first have resync all my account and personalisation on the Sense ROM before switching to the GE one. My bad ...

Then I run Switch.

The One close correctly but directly boot on the Recovery Mode : there, I'm asked to say Yes or No to the installation of an Untrusted zip. If I say no, it restart and boot to Sense. If I say Yes, it boots correctly to the GE ROM. But every Switch I do drives me there. THe recovery Log say :

ClockwordMod Recovery V6.0.3.1

Finding update Package

Opening update Package

Verifying Package update

E:signature verification failed

then Installing Update once I've granted the installation.

Afer that I have to manually select Reboot System Now + Have to say No to the Fix and it then boot correctly to GE. And Vice Versa :)

Maybe it comes from the personnalisation of the Sense Rom I've made before running the Switch ? Maybe that come from a root problem (one root on the original ROM, the another root installing Switch)

Switch to twrp recovery. Then you won't get those weird messages in recovery on switch.

0

Share this post


Link to post
Share on other sites

Thanks for your reply Leny.

All I've to do is just flash my recovery to TWRP one and that's all ?

0

Share this post


Link to post
Share on other sites
Thanks for your reply Leny.

All I've to do is just flash my recovery to TWRP one and that's all ?

Yes then when you switch it will still go into recovery but will automatically do what it has to do to switch roms with no weird messages or questions.

0

Share this post


Link to post
Share on other sites

You have to install the zip in that post too! The APK is the same one...

P

sorry, missed the zip

wasn't fully awake :D

Edited by descenpet
0

Share this post


Link to post
Share on other sites

This extremely well put together. And other than the SMS/MMS thing, I have zero problems. Well done sir.

Edited by tmlhodge
0

Share this post


Link to post
Share on other sites

Having the WiFi issues as well on my T-Mobile One. After I extract and push my kernel image and libs to the appropriate folder, I cannot switch back to the GPE rom (Bulletproof kernel).

0

Share this post


Link to post
Share on other sites
Having the WiFi issues as well on my T-Mobile One. After I extract and push my kernel image and libs to the appropriate folder, I cannot switch back to the GPE rom (Bulletproof kernel).

That sounds like this kernel isn't properly handling init.d as well. Use "adb shell su -c /etc/install_recovery.sh" and it should switch, after a failed switch. (or execute su -c... in a terminal emulator, which should probably work too)

1

Share this post


Link to post
Share on other sites

Hi, Very nice rom only one problem. When i click switch to the google rom it restarts, does the android is upgrading thing and then shows me sense 5 again even though i wanted it to switch.Can anyone help?

0

Share this post


Link to post
Share on other sites

Hi, Very nice rom only one problem. When i click switch to the google rom it restarts, does the android is upgrading thing and then shows me sense 5 again even though i wanted it to switch.Can anyone help?

See the hint in the first post or install the S-ON package!

P

0

Share this post


Link to post
Share on other sites

Only if you are s-on.

I have just reached S-OFF, is there a way that I can remove the S-ON package?
0

Share this post


Link to post
Share on other sites

after install the rom and boot in booth roms, all things are working fine for me. :D

Now i restore my titanium backup and will see.

I say thanks to you Paul. Your work is awesome!!!!!! :D :D :D :D :D

0

Share this post


Link to post
Share on other sites

I have just reached S-OFF, is there a way that I can remove the S-ON package?

Delete '/data/SWITCH/son'

Should work anyway... That's all the S-ON zip installs.

Edited by jackos2500
0

Share this post


Link to post
Share on other sites

Thanks Paul for giving me chance to become beta user for Switch.

Actually I downloaded the files few days ago but only now manage to give feedback. At that time it was still beta 5 and I didnt notice it's beta 8 now.

The best part is, I have not encounter any major issue so far, at least for my daily usage with this beta 5 :)..

1) Switching between sense and GE works fine

2) i use default launcher for both and of course no problem

3) wifi works fine for both ROM

the only problem i have is my text messages (SMS) in Sense do not appear in GE, and the same goes to my text messages in GE do not appear in Sense.

thanks Paul! :D

Edited by irenic
0

Share this post


Link to post
Share on other sites

Delete '/data/SWITCH/son'

Should work anyway... That's all the S-ON zip installs.

THANK YOU SO MUCH! AWESOME HELP

0

Share this post


Link to post
Share on other sites

Hey Paul, thank for invition for Betatesting :)

0

Share this post


Link to post
Share on other sites

You have to install the zip in that post too! The APK is the same one...

P

tried the zip but it didn't fix for me. still lost on switching. maybe my previous tries screwed up something in my system?

so i took the app_process from zip and manually copied it to /system/SWITCH/sense/bin/ and /system/SWITCH/gpe/bin/ then it works fine and survives through switching.

0

Share this post


Link to post
Share on other sites

Beta 8 is very smooth Paul, no problems with anything any more.

0

Share this post


Link to post
Share on other sites

I have just reached S-OFF, is there a way that I can remove the S-ON package?

Using a file explorer (such as root explorer) delete /data/SWITCH/son

:)

P

0

Share this post


Link to post
Share on other sites

Thanks for the advice, Seems to be perfectly working now. Very nice piece of software :)

0

Share this post


Link to post
Share on other sites

Just one question- Should i disable recovery flash and if so what would happen?

I know i'm a noob

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.