• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

Beta 13: MoDaCo.SWITCH HTC One support topic

1800 posts in this topic

Posted · Report post

Paul,

Google Now is being very weird on Beta 5. I flashed on top of Beta 1.

I can get any gesture combination on the GE ROM to access Now and only the stock sense hold down works on sense, not the swipe up.

I can still access it from search or the widget.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Paul,

Google Now is being very weird on Beta 5. I flashed on top of Beta 1.

I can get any gesture combination on the GE ROM to access Now and only the stock sense hold down works on sense, not the swipe up.

I can still access it from search or the widget.

See previous posts. This is an unfortunate side effect of splitting the settings storage out, the ge home fix will resolve this.

It only affects upgrades not new installs.

P

0

Share this post


Link to post
Share on other sites

Posted · Report post

The widget problem is getting on my nerves now :P

I'm using stock launchers for both GE and Sense - am I able to add excludes to keep the stock launcher settings separate?

0

Share this post


Link to post
Share on other sites

Posted · Report post

The widget problem is getting on my nerves now :P

I'm using stock launchers for both GE and Sense - am I able to add excludes to keep the stock launcher settings separate?

That's odd as technically they are different launchers already!

P

0

Share this post


Link to post
Share on other sites

Posted · Report post

Our first S-ON user has reported success to me on Twitter. :-)

P

Yup :D.

I have been testing for a little bit now and I've had none of the issues mentioned here so far, except that my widgets get removed when switching and the wallpaper is switched across GPe and Sense if it is a stock wallpaper.

I'll post any other issues I find when (and if!) they arise.

Keep up the good work Paul!!

0

Share this post


Link to post
Share on other sites

Posted · Report post

That's odd as technically they are different launchers already!

P

Yeah, as soon as I switch any widgets that were added are gone when I return. I'm using the Google Search widget and Catch Notes widget.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Yeah, as soon as I switch any widgets that were added are gone when I return. I'm using the Google Search widget and Catch Notes widget.

I'm using Nova on both and my widgets are surviving...

P

0

Share this post


Link to post
Share on other sites

Posted · Report post

will this eventually suit LTE device, sorry if this question was answered i haven't read all 6 pages

0

Share this post


Link to post
Share on other sites

Posted · Report post

will this eventually suit LTE device, sorry if this question was answered i haven't read all 6 pages

Do you mean CDMA?

P

0

Share this post


Link to post
Share on other sites

Posted · Report post

I'm using Nova on both and my widgets are surviving...

P

Yeah I tried Nova and sure enough with the exclude in place all is well. I'm guessing something has to be common between the sense and Google stock launchers that it doesn't like.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Do you mean CDMA?

P

no i mean 4G (LTE)

0

Share this post


Link to post
Share on other sites

Posted · Report post

ciao Paul, any way to add italian or spanish, or french? I only see languages from eastern europe. Not a problem, I can easily cope with english, but I am just curios...

0

Share this post


Link to post
Share on other sites

Posted · Report post

Yeah I tried Nova and sure enough with the exclude in place all is well. I'm guessing something has to be common between the sense and Google stock launchers that it doesn't like.

You could try putting exclusions on com.htc.launcher and com.android.launcher which I believe are the respective package names?

P

0

Share this post


Link to post
Share on other sites

Posted · Report post

no i mean 4G (LTE)

LTE is supported already, this is the ROM from LTE devices.

P

0

Share this post


Link to post
Share on other sites

Posted · Report post

no i mean 4G (LTE)

It already works on 4G devices I am using it on an m7_ul right now, so is Paul.

0

Share this post


Link to post
Share on other sites

Posted · Report post

ciao Paul, any way to add italian or spanish, or french? I only see languages from eastern europe. Not a problem, I can easily cope with english, but I am just curios...

Ciao Viskas! It's the WWE ROM (at least in Sense), so it should work. You can use MoreLocale 2 - to manually set a language.

P

0

Share this post


Link to post
Share on other sites

Posted · Report post

Yup :D.

I have been testing for a little bit now and I've had none of the issues mentioned here so far, except that my widgets get removed when switching and the wallpaper is switched across GPe and Sense if it is a stock wallpaper.

I'll post any other issues I find when (and if!) they arise.

Keep up the good work Paul!!

Thanks for testing the S-ON support! :)

P

0

Share this post


Link to post
Share on other sites

Posted · Report post

I think the wallpaper issue might be related to the fact that the current wallpaper is stored as a png located at '/data/system/user/<USER_NUMBER>/wallpaper'... Is there some way we could have different wallpapers for each ROM? Maybe a script to swap two different wallpapers when switching?

0

Share this post


Link to post
Share on other sites

Posted · Report post

I think the wallpaper issue might be related to the fact that the current wallpaper is stored as a png located at '/data/system/user/<USER_NUMBER>/wallpaper'... Is there some way we could have different wallpapers for each ROM? Maybe a script to swap two different wallpapers when switching?

Well, that's news to me!

I could certainly give that a try and see if it helps. I might work in a hook to a custom script so we can try different things in a quick and easy way on switch. Watch this space.

P

0

Share this post


Link to post
Share on other sites

Posted · Report post

- Switch to GPe ROM

- reboot to recovery

- via adb shell, run 'rm -r /data/system/users'

- reboot

Paul, when I am in adb shell I get a no such file or directory message.

I am sure I am miss typing something so please let me know what... thanks.

0

Share this post


Link to post
Share on other sites

Posted · Report post

- Switch to GPe ROM

- reboot to recovery

- via adb shell, run 'rm -r /data/system/users'

- reboot

Paul, when I am in adb shell I get a no such file or directory message.

I am sure I am miss typing something so please let me know what... thanks.

Try this instead when in via ADB shell:

mount /data
rm -r /data/system/users[/code]

P

0

Share this post


Link to post
Share on other sites

Posted · Report post

Been using it for a couple of hours, only thing getting on my nerves are widgets disappearing from Sense launcher. It does seem smooth now, no lag, must have been the initial boot causing it.

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Well, that's news to me!

I could certainly give that a try and see if it helps. I might work in a hook to a custom script so we can try different things in a quick and easy way on switch. Watch this space.

P

I certainly will!

With a little more digging I just found that there's a file called 'appwidgets.xml' in the same folder as the wallpaper which I think could be the source of our widget troubles...

Edited by jackos2500
0

Share this post


Link to post
Share on other sites

Posted · Report post

You could try putting exclusions on com.htc.launcher and com.android.launcher which I believe are the respective package names?

P

That didnt work unfortunately. I did find something interesting though:

On the Sense rom, I have the Google search bar on the first homescreen (middle, with Blinkfeed to the left) and Catch notes widget on the right-most homescreen.

Switched to Google rom. Added catch notes widget on the first right homescreen.

Switched back to Sense rom - the Google search widget is gone and in its place is the Catch notes widget!!

Any ideas?

0

Share this post


Link to post
Share on other sites

Posted · Report post

That didnt work unfortunately. I did find something interesting though:

On the Sense rom, I have the Google search bar on the first homescreen (middle, with Blinkfeed to the left) and Catch notes widget on the right-most homescreen.

Switched to Google rom. Added catch notes widget on the first right homescreen.

Switched back to Sense rom - the Google search widget is gone and in its place is the Catch notes widget!!

Any ideas?

Very odd indeed! It certainly warrants further investigation.

P

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.