• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

Beta 13: MoDaCo.SWITCH HTC One support topic

1800 posts in this topic

Posted

What am I missing ?! :(

Haven't used ADB in ages, says device found? then not found?

<!--url{0}-->

Thanks - Comes up as :not found

0

Share this post


Link to post
Share on other sites

Posted

Sorry, not very clear there. I don't mean the additional reboot on Switch, I mean the ROM loads and after a couple of minutes reboots. Happened once on sense, but a few times on GE. It then locks in a boot loop and needs a soft reboot. After that it runs fine.

Ah right, i've not seen that.

P

0

Share this post


Link to post
Share on other sites

Posted

Nope, doesn't. I have the same kernel running for both ROMs, did the changes on both, and they're loaded:


root@android:/ # ls -la /etc/init.d/00switch
lrwxrwxrwx root root 2013-07-22 10:45 00switch -> /system/SWITCH/sense/etc/install-recovery.sh

root@android:/ # ls -la /system/SWITCH/sense/etc/install-recovery.sh <
-rwxr-xr-x root root 104 2008-08-01 14:00 install-recovery.sh
[/code]

Kicking it off by 'adb shell .... ' works everytime, though. Will keep trying.

=> shouldn't that link point to /etc/install-recovery.sh, perhaps?

Hmmm, weird, I would have thought that would work.

Rather than symlinking, you could try copying the install-recovery.sh to the init.d dir...

P

0

Share this post


Link to post
Share on other sites

Posted

Another small thing to look at is the home button behaviour, it would be really nice to have it working the same in both ROM's. Currently the GE ROM uses a long press for Google Now and the Sense uses swipe up, they both work but it would be nicer to have consistency across both.

Maybe once custom kernels are sorted we can map the key individually.

0

Share this post


Link to post
Share on other sites

Posted

Rather than symlinking, you could try copying the install-recovery.sh to the init.d dir...

I copied it, to the same name, so init.d should kick in.


root@android:/ # ls -la /etc/init.d/00switch                                   

-rwxr-xr-x root     root          101 2013-07-22 11:18 00switch

Maybe the kernel doesn't handle init.d-stuff correctly, I'll try to find out about this.

0

Share this post


Link to post
Share on other sites

Posted

Hmmm, interesting. The answer to this might be to add an exclusion to com.android.providers.contacts, which in reality probably won't have any ill effects as contacts are synced down anyway.

P

same problem for me. In the sense version, contacts are there, but I can't find them with T9 dialer.

0

Share this post


Link to post
Share on other sites

Posted

You don't need root and yes, running '/data/SWITCH/sense/firstrun.sense' from the Terminal Emulator app should also work.

P

I get this....

u0_a206@android:/ $ /data/SWITCH/sense/firstrun.sense

Unable to chmod /data/SWITCH/busybox: Operation not permitted

mount: permission denied (are you root?)

mount: permission denied (are you root?)

dd: can't open '/dev/block/mmcblk0p33': Permission denied

rm: remove '/data/SWITCH/sense/firstrun.sense'?

0

Share this post


Link to post
Share on other sites

Posted

Hmm, ok, terminal app obviously doesn't work for that then. :-)

P

0

Share this post


Link to post
Share on other sites

Posted

I think a few other syncs are not working correctly too. I subscribed to this thread with tapatalk but don't get notifications when something new comes up. On my N4 they show up. With Falcon and G+ im unsure about this, maybe nothing was posted in between.

0

Share this post


Link to post
Share on other sites

Posted

Did you restore from backup? I know @lennyuk is looking at if that impacts push services.

P

0

Share this post


Link to post
Share on other sites

Posted

Another small FYI - If you restore apps with data from Titanium Backup it seems to cause little issues but if you just restore the app then set it up the results are far better. Obviously it is not every app but it is not just apps with online accounts, one that played up for me is Bar Launcher but wiping the app data fixed it.

0

Share this post


Link to post
Share on other sites

Posted

Did you restore from backup? I know @lennyuk is looking at if that impacts push services.

P

Yes, I used Koush's Helium. It used to work very well between my Hox and my N4. I will reinstall from Play Store and look if it helps. Next time I skip restoring when testing a ROM

0

Share this post


Link to post
Share on other sites

Posted

I am investigating apps that use Google's official push service.

For this I am testing with Twitter, Battlefiriends at Sea and tapatalk.

I have a suspicion that if you do not install these apps directly from the Play Store it doesn't register with the Push Service.

I have just cleared data on these three apps, uninstalled, rebooted then reinstalled and logged back in, I will monitor how they operate.

0

Share this post


Link to post
Share on other sites

Posted

I am investigating apps that use Google's official push service.

For this I am testing with Twitter, Battlefiriends at Sea and tapatalk.

I have a suspicion that if you do not install these apps directly from the Play Store it doesn't register with the Push Service.

I have just cleared data on these three apps, uninstalled, rebooted then reinstalled and logged back in, I will monitor how they operate.

Okay. I cleared Tapatalks Data and signed back in. This time it asked me to sign in to App engine or something. I think this did it. Will test.

0

Share this post


Link to post
Share on other sites

Posted

Okay. I cleared Tapatalks Data and signed back in. This time it asked me to sign in to App engine or something. I think this did it. Will test.

It said what now?

0

Share this post


Link to post
Share on other sites

Posted (edited)

Just a suggestion:

In your install_recovery.sh, you might test for the file's existence, before executing?


#!/system/bin/sh


# Run scripts

/data/SWITCH/gpe/firstrun.gpe

/data/data/com.modaco.flipswitch/flip

A simple [test -x $FILE && $FILE] would prevent unnecessary errors?

Edited by NeidRider
0

Share this post


Link to post
Share on other sites

Posted

So far so good (well more frigging amazing than good)!!

Installed following the steps and had no problems, everything runs super smooth and no problems changing between the two. I see some people have been having issues but for what ever reason I'm yet to stumble across anything.

My only question would be in regards to SMS sync between the two stock messaging apps. I realise they are different applications but was wondering if there was a way that an SMS message received on one Rom would automatically appear on the others SMS list when you switch. I'm using SMS Backup+ at the moment, which I think is working the way I want to, but its a bit of a pain. I dont really like using goSMS or handcent, prefer sticking to what ever stock messaging is provided.

Great work Paul and such a fantastic idea!

0

Share this post


Link to post
Share on other sites

Posted

Just a suggestion:

In your install_recovery.sh, you might test for the file's existence, before executing?


#!/system/bin/sh

# Run scripts
/data/SWITCH/gpe/firstrun.gpe
/data/data/com.modaco.flipswitch/flip
[/code]

A simple [test -x $FILE && $FILE] would prevent unnecessary errors?

I could do that I guess for tidiness. ;)

So far so good (well more frigging amazing than good)!!

Installed following the steps and had no problems, everything runs super smooth and no problems changing between the two. I see some people have been having issues but for what ever reason I'm yet to stumble across anything.

My only question would be in regards to SMS sync between the two stock messaging apps. I realise they are different applications but was wondering if there was a way that an SMS message received on one Rom would automatically appear on the others SMS list when you switch. I'm using SMS Backup+ at the moment, which I think is working the way I want to, but its a bit of a pain. I dont really like using goSMS or handcent, prefer sticking to what ever stock messaging is provided.

Great work Paul and such a fantastic idea!

This is coming in a future release, i'm working on the SMS DB translation tool.

P

1

Share this post


Link to post
Share on other sites

Posted

Another small thing to look at is the home button behaviour, it would be really nice to have it working the same in both ROM's. Currently the GE ROM uses a long press for Google Now and the Sense uses swipe up, they both work but it would be nicer to have consistency across both.

Maybe once custom kernels are sorted we can map the key individually.

Agreed I thought this but I think Paul is trying to get them both stock for now. Also this isnt an issue per say but anyway to get battery apps that display a % in the status bar to appear in one rom? On the sense one I use the HTC provided one but I use a custom one on the GE edition seen as it doesnt have a % meter.

0

Share this post


Link to post
Share on other sites

Posted

Really incredible piece of work Paul. New install w/root here... reinstalling apps , so far everything just works.

0

Share this post


Link to post
Share on other sites

Posted (edited)

Maybe the kernel doesn't handle init.d-stuff correctly, I'll try to find out about this.

I searched the corresponding thread on XDA about this kernel, and there's someone else mentioning that some init-script isn't executed as it's supposed to be, and another one is asking whether this kernel will have full init.d-support, with the dev answering "some time perhaps"...

So probably that's just the problem.

Edited by NeidRider
0

Share this post


Link to post
Share on other sites

Posted

Beta 6 update zip released - flash over the top of any version when in Sense mode. No wipe required - Switch at least once to activate the new features. This update adds an OTA updater, Switch version in now shown in the settings - about screen, FlipSwitch is updated, contact provider is now siloed, appwidget and wallpaper are also siloed.

P

0

Share this post


Link to post
Share on other sites

Posted

Agreed I thought this but I think Paul is trying to get them both stock for now. Also this isnt an issue per say but anyway to get battery apps that display a % in the status bar to appear in one rom? On the sense one I use the HTC provided one but I use a custom one on the GE edition seen as it doesnt have a % meter.

The best way to do this would be to install the app and add an exclusion file so seperate settings are kept for each ROM. That way you can have the app settings 'turned on' in one ROM but off in the other.

P

0

Share this post


Link to post
Share on other sites

Posted

Switched to 6 and everything is good! Got an error on initial boot for SwitchUp but one switch fixed it. Also, just a suggestion, will the final name be MoDaCo.SWITCH? I feel just Switch would be better or SwitchUp. But hey the version now is also free promotion so that's good!

0

Share this post


Link to post
Share on other sites

Posted

I kind of like MoDaCo.switch, and I think that mentioning the site in the name is good thing.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.