tillaz

[ROM] FusionX Huawei Y300 v1.0 [B199] [Full HWA]

2586 posts in this topic

Oh yeah, that. Tried it on my last phone-- your status bar radio icons will turn grey, presumably because all connections, beyond Talk, to Google's servers have been severed.

Hmmm.. interestingly before this bit of discussion started, I tried a wipe and reflash yesterday, and was getting grayed out icons all the time, without any of these Google services changes. Reverted to a twrp backup and no icon issues. I have modified hosts and turned off unused sync services. We'll see how today goes...

0

Share this post


Link to post
Share on other sites

quick update...

Google play services .apk (GsmCore.apk) is not actually the cause of the wake lock

i deleted the .apk from the ROM then flashed with a full wipe, signed in to Google then turned off wifi to stop the apk been downloaded again

you can see from the screenshot, the problem is still there... it must be "GoogleServicesFramework.apk" that is the problem

and the only update to this would be in the latest Gapps package for 4.2 or 4.3 :huh:

post-913969-0-47621900-1375857592_thumb.

0

Share this post


Link to post
Share on other sites

Hello ..this is what wakelock detector shows for me ...

i don´t have a heavy drain .. but over all battery life is not that good ..

*edit ..wait a moment ... have to upload new pic ...it was the wrong one i postet ...

wakelock.png

WOW ...holy s*** ...:-D

Edited by joba69
0

Share this post


Link to post
Share on other sites
quick update...

Google play services .apk (GsmCore.apk) is not actually the cause of the wake lock

i deleted the .apk from the ROM then flashed with a full wipe, signed in to Google then turned off wifi to stop the apk been downloaded again

you can see from the screenshot, the problem is still there... it must be "GoogleServicesFramework.apk" that is the problem

and the only update to this would be in the latest Gapps package for 4.2 or 4.3 :huh:

post-913969-0-47621900-1375857592_thumb.

4.3 update anyone :D jj tillaz you are awsemone for working on this rom

0

Share this post


Link to post
Share on other sites

quick update...

Google play services .apk (GsmCore.apk) is not actually the cause of the wake lock

i deleted the .apk from the ROM then flashed with a full wipe, signed in to Google then turned off wifi to stop the apk been downloaded again

you can see from the screenshot, the problem is still there... it must be "GoogleServicesFramework.apk" that is the problem

and the only update to this would be in the latest Gapps package for 4.2 or 4.3 :huh:

Hi Tillaz

If it helps I'm running stock B190, and, as you can see from my screenshot below, there is no sign of any google process using battery. In fact i have superb battery life.

post-731739-0-62519900-1375861680_thumb.

0

Share this post


Link to post
Share on other sites

Hi Tillaz

If it helps I'm running stock B190, and, as you can see from my screenshot below, there is no sign of any google process using battery. In fact i have superb battery life.

post-731739-0-62519900-1375861680_thumb.

the reason you don't see it on stock is because the battery stats are partially working and don't show full battery stats, also that looks like your phone has just been on standby for a day and a half and not even used, otherwise why it it saying the display has not been used at all? says you have no screen on time.

it also shows its been connected to WiFi most of that time, its when the phone is "not" on WiFi i see the problem,

i have been back on stock B190 a few times to compare hand it has the same problems.

use better battery stats to see the wake locks

http://forum.xda-dev...d.php?t=1179809

0

Share this post


Link to post
Share on other sites

Is HWA working by default on CM ports?

probably but there not ports there built from source, its also working on stock just disabled on the system.

0

Share this post


Link to post
Share on other sites

tillaz, I sent you a PM with the logcat. I tried reflashing the rom with setting the language English (UK) and the statusbar is still buggy.

0

Share this post


Link to post
Share on other sites

When about will available the b02?

0

Share this post


Link to post
Share on other sites

When about will available the b02?

soon, as i have just about gave up with huawei...

it totally baffles me why these company's don't just stick with pure AOSP

0

Share this post


Link to post
Share on other sites

tillaz, I sent you a PM with the logcat. I tried reflashing the rom with setting the language English (UK) and the statusbar is still buggy.

are you restoring data using titanium backup?

0

Share this post


Link to post
Share on other sites

are you restoring data using titanium backup?

Yes, I'm using lots of apps, so I need it. Is that the problem? :(

0

Share this post


Link to post
Share on other sites

Yes, I'm using lots of apps, so I need it. Is that the problem? sad.png

its normally the cause of most problems that i don't have lol

and if you problem is occurring after your backup is restored its for sure the cause.

you should install this app and make a backup, its what i use on my nexus 4 & Y300 and have no issues

http://www.solidfile...m/d/7e79a2d9bc/ (i would not update it from the market as this one has no restrictions)

0

Share this post


Link to post
Share on other sites

I agree tillaz, they tried to stamp the phone with there own touch.. All I see is a fail logo haha, its a shame. There good phones, have potential but like 50000 locks to unlock the potential if you get me haha :) good work though mate, busting your arse to unleash the beast!

0

Share this post


Link to post
Share on other sites

This bug with statusbar happends if you touch status bar with 2 fingers (not allways but maybe after 4-5 tries) so it happends probably if you touch it with bigger area of your finger and it detects 2 touches. You can also fix it with with touching with 2 fingers on statusbar.

0

Share this post


Link to post
Share on other sites

This bug with statusbar happends if you touch status bar with 2 fingers (not allways but maybe after 4-5 tries) so it happends probably if you touch it with bigger area of your finger and it detects 2 touches. You can also fix it with with touching with 2 fingers on statusbar.

lol, i can confirm this... nice work :)

i have no idea how i am going to fix it though :mellow:

0

Share this post


Link to post
Share on other sites

its normally the cause of most problems that i don't have lol

and if you problem is occurring after your backup is restored its for sure the cause.

you should install this app and make a backup, its what i use on my nexus 4 & Y300 and have no issues

http://www.solidfile...m/d/7e79a2d9bc/ (i would not update it from the market as this one has no restrictions)

Thanks, I'll give it a try. I hope that it will work.

This bug with statusbar happends if you touch status bar with 2 fingers (not allways but maybe after 4-5 tries) so it happends probably if you touch it with bigger area of your finger and it detects 2 touches. You can also fix it with with touching with 2 fingers on statusbar.

Wow, really :blink: But as I see it can't fix the problem every time.

0

Share this post


Link to post
Share on other sites

i'm going to upload the update in a few minis... can't be bothered with this phone at the moment :mellow:

0

Share this post


Link to post
Share on other sites

Wow, really blink.png But as I see it can't fix the problem every time.

use your thumb across the status bar, works after a few tries for me

0

Share this post


Link to post
Share on other sites

i'm going to upload the update in a few minis... can't be bothered with this phone at the moment :mellow:

Until that I'll make a GO backup :D Is that B02 or just a little update?

use your thumb across the status bar, works after a few tries for me

I tried it because of that, it's really working, but I had to try it about 20 times... So it's not a huge, but a really annoying bug.

Edited by Ducsidu
0

Share this post


Link to post
Share on other sites

Can we update the rom through OTA? Need any wipe?

0

Share this post


Link to post
Share on other sites

I can reproduce this every time with two fingers and can also fix it every time first time with two fingers. If it was anything based on cyanogenmod code i'd say it was linked to the one finger pulls down notification bar two fingers pulls down the toggle/tiles!

It's not something that has ever happened to me until someone mentioned the two finger thing so i don't think it's a bug to worry about.

EDIT:

Tried uninstalling Xposed framework but it still acts the same. Guess it's related to the system ui you ported over but like i said it's a minor bug no problems.

Edited by Frankish
0

Share this post


Link to post
Share on other sites

I can reproduce this every time with two fingers and can also fix it every time first time with two fingers. If it was anything based on cyanogenmod code i'd say it was linked to the one finger pulls down notification bar two fingers pulls down the toggle/tiles!

It's not something that has ever happened to me until someone mentioned the two finger thing so i don't think it's a bug to worry about.

EDIT:

Tried uninstalling Xposed framework but it still acts the same. Guess it's related to the system ui you ported over but like i said it's a minor bug no problems.

lol could be handy if you don't want anyone looking at your notification's hahah,

yeah, its definitely off porting the AOSP SystemUI, wont be from that CM feature as that's only in 4.2

Can we update the rom through OTA? Need any wipe?

yes, but a full wipe will be performed regardless of what you choose so grab the backup app on the second post and make a backup before updating.

(that's assuming you did the last patch successfully, which fixed the OTA updater)

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.