• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

CyanogenMod 10.1 Build R22 [02/10/14]

1522 posts in this topic

Posted · Report post

Can someone answer this, please?

Well this ROM looks to be work in progress. You'd want to get everything working right first and then you can focus on optimizing it.

0

Share this post


Link to post
Share on other sites

Posted · Report post

I' ve flashed this ROM two days ago and I didn't have any screen problems...screen was just as it was on stock...btw, nice job, hopefully we'll see bugfree versions soon....but even these are great :DD

How is the battery usage ?

0

Share this post


Link to post
Share on other sites

Posted · Report post

U are the best kra1o5,all g330 user are waiting for your next release

0

Share this post


Link to post
Share on other sites

Posted · Report post

Milky color display on y300. Anyone?

Can you will fix it???

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Milky color display on y300. Anyone?

Can you will fix it???

The swap-enabled kernel does this too. Give it a few days, you stop noticing/caring about it.

Out of interest, why is this a thing in various kernels?

Edited by KenBW2
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Kra, are you still going to release a build with ril working? just flashed this and it's really awesome. So smooth and fast XD

Also, there's a problem where there's no notification when i plug the phone into my computer. It's not a bug as such but it does mean i can't put any files on the phone. That may not be a problem with windows/linux users.

Edited by ShadeStorm98
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

How is the battery usage ?

sorry I can't tell you that because I didn't use this ROM that long, I just wanted to check how it works and feels...was using it for couple of hours and I wasn't paying attention on battery much...I will try it again today or tomorrow and then I will be able to tell you more

Edited by PetKos94
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Wrong thread

Edited by TangerineTractor
0

Share this post


Link to post
Share on other sites

Posted · Report post

Beta 1 is now available!

Happy flashing

4

Share this post


Link to post
Share on other sites

Posted · Report post

Thx Kra1o5, installing right now, I'll report back!

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Beta 1 is now available!

Happy flashing

Hi, I've the g330 u8825-1 from Huawei, can i flash your rom for test it?

Thanks a lot for your job! :lol:

Edited by YnGWiE27
0

Share this post


Link to post
Share on other sites

Posted · Report post

HI, I'm new to CM, I've my Y300 rooted and with unlocked bootloader, TRWP recovery, I've had full backup of the B174 stock ROM, is ok to do this:

1) install CWM no touch

2) wipe all

3) flash CM 10.1

4) flash GAPPS for 4.2

question: do I need to install a kernel after flashing CM?

Many thanks,

Max

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Edit: stupid question

Edited by TayoOnabule
0

Share this post


Link to post
Share on other sites

Posted · Report post

I can't watch youtube videos :(, Is there anyway to get passed this or is this issue only happening to moi.

0

Share this post


Link to post
Share on other sites

Posted · Report post

That's because video isnt working yet. You can install mxplayer from the play store, then make it a system app by using this and then use youtube from the browser, that should work :)

0

Share this post


Link to post
Share on other sites

Posted · Report post

thanks :).

0

Share this post


Link to post
Share on other sites

Posted · Report post

can i use VLC player instead of MXplayer?

0

Share this post


Link to post
Share on other sites

Posted · Report post

can i use VLC player instead of MXplayer?

Yes, you can.

Guys my next goal is Videos & after BT.

I added my sources link in the first post.

1

Share this post


Link to post
Share on other sites

Posted · Report post

Spanish guys : The troll is on again with the photoshopped screen as I read it on htcmania. :D You can check my previous jobs here on modaco or on xda (gt540, zte smarttab, g300).

You can download my build http://goo.im/devs/j...FICIAL-G510.zip it has a lot of non working parts , but ril and nfc are working.

Developers : This is my huaweiril2 whic was used to fix the ril. It logs a lot and not needed in production build.http://goo.im/devs/j...HuaweiRIL2.java

How to fix ril .

First be sure you have ro.telephony.ril.v3=qcomdsds in your system prop . This is needed as our ril libs are made for multisim and have to send sub1 as main ril socket.

Qualcomsharedril is not suitable for our device as it has mQANElements=5 by default and we need 4. The main RIL has 4 as default.It is used by responseOperatorInfos(Parcel p) The second thing why it is not suitable it uses too many elements in responseIccCardStatus(Parcel p) by default (no sim pin request , invalid apptype in radiolog) . It can be switched off by using skippinpukcount oldril feature , but main RIL is fine with this too by default. Datacall routines are also fine in main ril.

The only reason why we should need a custom ril is to fix the shown baseband version. Of course if no other bug is found .

The non working state drops first this in radiolog :

W/RILC ( 144): RIL_onUnsolicitedSendResponse called before RIL_register

E/RILD ( 144): isMultiSimEnabled: prop_val = 0 enabled = 0

D/RILC ( 144): QCRIL_RPC

D/RILC ( 144): QCRIL_RPC

E/RILC ( 144): RIL_register: RIL version 7

While with the working version contains :

E/RILD ( 186): **RIL Daemon Started**

E/RILD ( 186): **RILd param count=1**

E/RILD ( 186): RIL_Init argc = 5 client = 0

E/RILD ( 186): isMultiSimEnabled: prop_val = 0 enabled = 0

E/RILC ( 186): RIL_register: RIL version 7

E/RILC ( 186): s_registerCalled = 1, s_started = 1, RIL_getMaxNumClients = 1

No custom ril needed in framework , we can use the main ril.java.

Copy the ril libfiles from stock rom. I used these files from stock VF rom : Copy libqcci_legacy.so also as it used by atserver.

check your init files to have the following services:

in on boot section

pcm-bridge is not needed as pcm-bridge does not exist in stock rom (at least in my stock rom)

service atserver /system/bin/atserver

class core

oneshot

service netmgrd /system/bin/netmgrd

class main

service bridgemgrd /system/bin/bridgemgrd

class main

user radio

group radio

disabled

service port-bridge /system/bin/port-bridge /dev/smd0 /dev/ttyGS0

class main

user system

group system inet

disabled

service qmiproxy /system/bin/qmiproxy

class main

user radio

group radio

disabled

service qmuxd /system/bin/qmuxd

class main

user radio

group radio

In post-fs section

service ril-qmi /system/bin/sh /init.qcom.ril.path.sh

class main

user root

oneshot

in on emmc-fs section (you need BOARD_WANTS_EMMC_BOOT := true in boardconfig)

write /sys/module/block2mtd/parameters/block2mtd /dev/block/mmcblk0p14

on property:sys.radio.shutdown=true

exec /system/bin/sh /system/etc/init.qcom.efs.sync.sh

sorry for the long post.

Sorry for being Italian I work in Italy? Mainly works on Y300-0100

0

Share this post


Link to post
Share on other sites

Posted · Report post

Tray with this player!

https://play.google.com/store/apps/details?id=com.wondershare.player

It's good & free!

There's PowerCam is the best quality photo camera app on market & again totally free!

Player supports loot of goodies like integrated browser, DLNA, downstreaming for watching later & so on... It's not as fast as MX bat it's good in of for online videos at 720p.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Is anyone else getting random reboots? should i just re-flash?

0

Share this post


Link to post
Share on other sites

Posted · Report post

Great job with this ROM!

But I got one problem. Everything wokrked ok but I got soft reboot (when I opened camera from lockscreen) and since then I got many FCs and soft reboots. So I wiped everything again and reinstalled ROM with gapps and everything work good again. I hope it is very rare bug. Good luck with future work on this ROM.

0

Share this post


Link to post
Share on other sites

Posted · Report post

i trying this cyano and it seem responds well.. but sometimes sim is refused and system must be restart..and when plug to pc the phone unmount sd but dont remount..

0

Share this post


Link to post
Share on other sites

Posted · Report post

just to clarify things, this is 4.2.2 right?

0

Share this post


Link to post
Share on other sites

Posted · Report post

just to clarify things, this is 4.2.2 right?

yep, go to settings, about phone, there is writen "android version 4.2.2"
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.