• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

Xiaocai X9 - Updated. Root info. Benchmarks etc.

281 posts in this topic

Posted

As far as I know there are only two ROMs, that's the THL 100 linked in the first post and the stock ROM.

0

Share this post


Link to post
Share on other sites

Posted

Glad that is working ok for you. I only did a little work on the w100 port Ludoo did the major work on the initial port so i can't take the credit. I just tweaked it.

I won't update it really unless there is a major bug to fix. I think maybe GPS in maps might not be working too well!

0

Share this post


Link to post
Share on other sites

Posted (edited)

I won't update it really unless there is a major bug to fix. I think maybe GPS in maps might not be working too well!

 

Why do you think so? Is there anything I can do to fix this? So far I think it works quite good.

EDIT: Just tested again and indeed it's searching it's position for some minutes now....

Edited by Arnie-75
0

Share this post


Link to post
Share on other sites

Posted

Using a file explorer with root capabilities (i use es file explorer) try deleting gps.conf from /system/etc/. I think this is the issue. Then try redownloading EPO data etc then try maps. See if it gets a fix?

0

Share this post


Link to post
Share on other sites

Posted

Deleted it. Is it OK that this file does not reappear even after downloading EPO data agin? It's gone, even after restarteing. I got a fix after restarting, but that's what I got some time before deleting gps.conf.

0

Share this post


Link to post
Share on other sites

Posted

It doesn't really need the gps.conf and it's working for me now i've deleted it too. Got a fix really quickly. The only reason i added it was to try and get an even quicker fix but it only seems to work for a bit then dies.

I'll remove the gps.conf from my rom and re-upload as soon as i can.

0

Share this post


Link to post
Share on other sites

Posted

OK, thanks.

0

Share this post


Link to post
Share on other sites

Posted (edited)

Could you please write a message here when you have deleted the files and updated your image? I would like re-download it and save it as a backup then.

Edited by Arnie-75
0

Share this post


Link to post
Share on other sites

Posted

Thank you.

0

Share this post


Link to post
Share on other sites

Posted

My progress on an AOSP'ish rom .....

 

Any news about ur rom?  

 

cant wait to try it out  ^_^

0

Share this post


Link to post
Share on other sites

Posted

Any news about ur rom?

cant wait to try it out ^_^

I was wondering this too but I think he either got stuck with the dialer issue he had or he is just plain busy with the real world!

0

Share this post


Link to post
Share on other sites

Posted (edited)

Flashing stock CaiOS rom.

Link to latest official update 1.05 rar. http://pan.baidu.com/share/link?shareid=3070761045&uk=1678349277&qq-pf-to=pcqq.c2c

Link to the version supplied when buying the phone. http://pan.baidu.com/share/link?shareid=3126338295&uk=3811752623

...

 

Hi

both of them are english / chinese only, right ?

Edited by peter0010
0

Share this post


Link to post
Share on other sites

Posted (edited)

Hi

both of them are english / chinese only, right ?

I couldn't be sure what languages are included as i only ever use English i can check for you though?

Lot's of languages included in the shipped 1.03 rom.

The 1.05 is English and Chinese only.

post-449642-0-51591100-1380173054_thumb.

post-449642-0-68874100-1380173055_thumb.

post-449642-0-62791000-1380173056_thumb.

post-449642-0-65650000-1380173057_thumb.

post-449642-0-71533300-1380173058_thumb.

Edited by Frankish
0

Share this post


Link to post
Share on other sites

Posted (edited)

yea thanks but i meant your linked version of 1.03 ( not the pre installed )

 

 

i've just tested it - this 1.03  version has only chinese and english inside

Edited by peter0010
0

Share this post


Link to post
Share on other sites

Posted

I wonder why? That's strange I guess it's some changes they made when they add play store etc. I still have a backup of my stock rom.

0

Share this post


Link to post
Share on other sites

Posted (edited)

I just remapped the middle button in between the volume keys to camera shutter.

 

If you want you could include those files in your rom (probably better than a useless button ;))

 

You could also Change Key 164 in both of the files with a different action

 

cwm zip:

https://mega.co.nz/#!OJtxTLYB!efOKlU4KLJE4c7DQK8tidmpnUqxB91QhVLp4dwEsRz0

 

manual:

https://mega.co.nz/#!bAMj2S7a!NRyzYDX7IaTScUA1sBH49z6f8xsSaYawj06oFYCa8Ak

 

the files are located in /system/usr/keylayout permission as always 644 and owner root:root

 

Long press opens the camera, press in camera app takes a picture
 

Edited by peter0010
0

Share this post


Link to post
Share on other sites

Posted

How did you do this? Can I install this on a running THL 100 ROM?

0

Share this post


Link to post
Share on other sites

Posted (edited)

Yes, it was tested with the W100 Port from Frankish. (Just to be sure make a backup ;))

 

I just installed a KeyTest.apk looked for the scancode of that button and edited the 2 files ;)

 

 

@Frankish you dont happen to know how to activate the haptic feedback for the softkeys (home, menu, back)?

Edited by peter0010
0

Share this post


Link to post
Share on other sites

Posted

Thanks, works great!

0

Share this post


Link to post
Share on other sites

Posted

Peter it seems to be a bug as I can't enable them to vibrate! I've never noticed as I usually turn it off. Hmm..

0

Share this post


Link to post
Share on other sites

Posted

Frankish, I woild also appreciate if you could include the camera button to your image.

0

Share this post


Link to post
Share on other sites

Posted

If I go changing it to camera someone will want me to change it to music again and then someone will want it for messaging etc. I will possibly upload multiple different ones in a flash able zip format so people can make their own minds up on what it does.

0

Share this post


Link to post
Share on other sites

Posted

That might be true. On the other hand the middle key currently has no function at all, so any function included might be better than nothing.

0

Share this post


Link to post
Share on other sites

Posted

Ahh it is default music player but I forgot to add the function as it is a W100 port.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.