• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.
Sign in to follow this  
Followers 0

G300 possessed by the devil...

11 posts in this topic

Posted

Hi All,

I've experienced some odd behaviour with my G300, and thought I'd seek your advice to see if you've seen similar...

1) My G300 is brand new, and yet the battery acts crazy... From say full charge to even a mid charge.

ex: If I charged my battery to 100%, if I shut down to CWM Recovery it'll show 75% (this is whilst plugged into the mains) If I reboot again and load CWM again, it will show 100% for a few seconds and then drop down to 70's% again. When its not plugged into the mains, the battery seems to deplete normally...

If the battery is showing a level of say 60% in the OS, if I plug my charger in, walk away and come back in a couple of minutes, it will show summit like 35%... I've no idea why it looses power when connected to mains?? lol

I'm currently trying to run the battery completely flat and try a full charge again...

My Bootloader is unlocked via the unofficial method, by an App that Roots and unlocks the Bootloader within the same App. Could this be causing the unstableness...??

Whats the best thing to do, keep using the Windows App to Root/Unlock Bootloader. Or shall I apply for the official BootLoader unlock?

http://www.huaweidevice.com/worldwide/servicePolicy.do?method=preUnlock

Whats the Pro's and Con's of the above...?? App vs official Website?

As Ive heard the official method can cause problems too...??

If I do get an official unlock, do I need to return my phone to stock firmware to apply it, or can I do it now whilst running CM10.1 ?

Thanks, Lister

0

Share this post


Link to post
Share on other sites

Posted

Maybe it helps cleaning battery stats with SDmaid , problem is issue with rom I think . ,it's on google play market . You have to be rooted .

0

Share this post


Link to post
Share on other sites

Posted

Hi All,

I've experienced some odd behaviour with my G300, and thought I'd seek your advice to see if you've seen similar...

1) My G300 is brand new, and yet the battery acts crazy... From say full charge to even a mid charge.

ex: If I charged my battery to 100%, if I shut down to CWM Recovery it'll show 75% (this is whilst plugged into the mains) If I reboot again and load CWM again, it will show 100% for a few seconds and then drop down to 70's% again. When its not plugged into the mains, the battery seems to deplete normally...

If the battery is showing a level of say 60% in the OS, if I plug my charger in, walk away and come back in a couple of minutes, it will show summit like 35%... I've no idea why it looses power when connected to mains?? lol

I'm currently trying to run the battery completely flat and try a full charge again...

My Bootloader is unlocked via the unofficial method, by an App that Roots and unlocks the Bootloader within the same App. Could this be causing the unstableness...??

Whats the best thing to do, keep using the Windows App to Root/Unlock Bootloader. Or shall I apply for the official BootLoader unlock?

http://www.huaweidev...ethod=preUnlock

Whats the Pro's and Con's of the above...?? App vs official Website?

As Ive heard the official method can cause problems too...??

If I do get an official unlock, do I need to return my phone to stock firmware to apply it, or can I do it now whilst running CM10.1 ?

Thanks, Lister

I would unlock officially. You might as well, as then it can rule out one cause for the problem. You can find the tutorial link below :)
0

Share this post


Link to post
Share on other sites

Posted

Fully charge the battery turn off and pull/replace the battery then charged for a extra 10mis after it says full. This should fully calibrate the battery and it should work OK. As its a new battery you phone probably hasn't got the full stats yet.

Hope this sorts you're problem J:D

0

Share this post


Link to post
Share on other sites

Posted

Hi All,

Thanks for all the suggestions, and so promptly too...

1) I have run / wiped the Battery stats on this before, a couple of days ago... It was at 100% when I did it, but it wasnt from a completely flat battery... It was say from around 40-60% charge, and then charged from there upto 100%.... So perhaps I should of let it get completely flat before charging to 100% and then wiping...

2) I shall do a full re-charge from zero, and then unplug and charge some more.... to let it calibrate. Do I wipe it then, after it reaches 100%

3) Ok, I think I shall do an official unlock of Bootloader then... Are there any Pro's / Con's to doing this?? Is it best to do the official unlock over the hack-app method. (This doesnt change the baseband 2030 does it?? Just the bootloader.....)

Thanks guys,

Lister

0

Share this post


Link to post
Share on other sites

Posted (edited)

3) Ok, I think I shall do an official unlock of Bootloader then... Are there any Pro's / Con's to doing this?? Is it best to do the official unlock over the hack-app method. (This doesnt change the baseband 2030 does it?? Just the bootloader.....)

Pros:

It reduces the amount of Random Reboots

It can increase the stability of the phone

In some cases, it can give a better signal

It is free!

Cons:

It can take a while to get the code.

It is a little bit fiddly to unlock.

You cannot change the Huawei Ascend splash screen.

Edited by george109
0

Share this post


Link to post
Share on other sites

Posted

Wipe battery stats when battery is 100% charged !

0

Share this post


Link to post
Share on other sites

Posted

1) My G300 is brand new, and yet the battery acts crazy... From say full charge to even a mid charge.

 

Unfortunately this seems to be completely "normal" with the G300. Mine here was showing 48%, then jumped to 14%. Once connected to the charger, it immediately jumped up to 43% again. It seems that the SoC logic is just useless on the G300. I did comment on that last year, but I think it is getting worse over time.

 

And no, erasing the battery calibration is not the answer - it should neither be necessary, nor helpful, nor does it actually solve the problem.

0

Share this post


Link to post
Share on other sites

Posted

Where is the "main" (?) battery reporting logic - hardware, kernel, ROM, somewhere else, all of the above? :)

0

Share this post


Link to post
Share on other sites

Posted

Huawei's battery is really not good enough.I always use battery from PISEN from the internet.

0

Share this post


Link to post
Share on other sites

Posted

I have some similar problems. When batery 100% charged and unpluged, drop 15% in 10 minutes without using phone. And then continue to drop normaly. I deleted batery stats and use Batery cslibration from Google Play but nothing change. Did anybody have idea how to solve?

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.