• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.
Sign in to follow this  
Followers 0

Nexus 4 CM10.2 nightlies - will not send SMS (can receive)?

5 posts in this topic

Posted

With recent CM10.2 nightlies my N4 will not send SMS, though it can receive. I can't see any obvious fixes or bug reports floating around in the forums. I was wondering if anyone else is experiencing this? A factory reset/various wipes have had no effect.

The SIM involved (Orange UK) works fine in a different phone that is not running CM10.2 . A 3UK SIM in the N4 also won't send SMS messages, so I guess it has to be the ROM. I even got a new SIM off Orange for the N4 to check, but the problem persists.

There were no issues with CM10.1 and SMS on the phone previously.

0

Share this post


Link to post
Share on other sites

Posted (edited)

Hi,

The nightlies toward the end of last week wouldn't boot on my phone and were apparently b0rked (around 10.2-20120905 if I remember right)

I'm running 10.2-20130911 - served up last evening and no problems with SMS. Just sent myself one to confirm (couldn't remember if I'd sent any since Cyandelta updated me last night) and that went and arrived fine.

Suspect therefore that it ain't the ROM, though depending on which nightly you're running there may have been a problem previously (have to say, the only issue I've had with the nightlies lately was the 2 or 3 last week mentioned above that just didn't boot)

You've not installed anything else wonky that might be messing things up? Only things like Cerberus should survive some wipes and have the capacity to screw with messaging, but even that shoudn't survive full wipes / factory resets I think

So - which nightly are you using?

Sounds like you've done the obvious things in installing with a full wipe etc (I never normally do this but when things go awry I do - does no harm every couple of months to have a clear out and try something fresh anyway I reckon)

Maybe if you don't fancy starting from scratch, revert to your last known good nandroid - perhaps one on CM 10.1 to confirm sms still works ok with that (and it's not something odd like your micro-sim being slight misalligned all of a sudden, but that sounds unlikely given that you've had the sim in and out and tried different ones, presumably precut by Orange rather than butchered with a rusty spoon, as is my usual approach!), then flash the current nightly and go from there.

Bit of a stupid one to suggest maybe, but did you check the md5 on the nightly download? (would be weird to find a problem here and for it still to boot)

Easy one to check, try installing a different messaging app - maybe there's something wonky with your messaging settings

If messaging works ok on cm10.1 then you might try a different JB4.3 build? Maybe Paranoid Android?

EDIT - I'm clutching at straws here, but it couldn't be anything to do with your apn settings having somehow changed could it?

maybe have a look in settings>More>Mobile Networks>Access point names to check the settings tally with whatever they should be. Very unlikely to be the cause though since your data and voice work

Edited by The Soup Thief
0

Share this post


Link to post
Share on other sites

Posted (edited)

Hi,

The nightlies toward the end of last week wouldn't boot on my phone and were apparently b0rked (around 10.2-20120905 if I remember right)

I'm running 10.2-20130911 - served up last evening and no problems with SMS. Just sent myself one to confirm (couldn't remember if I'd sent any since Cyandelta updated me last night) and that went and arrived fine.

Suspect therefore that it ain't the ROM, though depending on which nightly you're running there may have been a problem previously (have to say, the only issue I've had with the nightlies lately was the 2 or 3 last week mentioned above that just didn't boot)

You've not installed anything else wonky that might be messing things up? Only things like Cerberus should survive some wipes and have the capacity to screw with messaging, but even that shoudn't survive full wipes / factory resets I think

So - which nightly are you using?

Sounds like you've done the obvious things in installing with a full wipe etc (I never normally do this but when things go awry I do - does no harm every couple of months to have a clear out and try something fresh anyway I reckon)

Maybe if you don't fancy starting from scratch, revert to your last known good nandroid - perhaps one on CM 10.1 to confirm sms still works ok with that (and it's not something odd like your micro-sim being slight misalligned all of a sudden, but that sounds unlikely given that you've had the sim in and out and tried different ones, presumably precut by Orange rather than butchered with a rusty spoon, as is my usual approach!), then flash the current nightly and go from there.

Bit of a stupid one to suggest maybe, but did you check the md5 on the nightly download? (would be weird to find a problem here and for it still to boot)

Easy one to check, try installing a different messaging app - maybe there's something wonky with your messaging settings

If messaging works ok on cm10.1 then you might try a different JB4.3 build? Maybe Paranoid Android?

EDIT - I'm clutching at straws here, but it couldn't be anything to do with your apn settings having somehow changed could it?

maybe have a look in settings>More>Mobile Networks>Access point names to check the settings tally with whatever they should be. Very unlikely to be the cause though since your data and voice work

Nailed it - courtesy of some friendly folk on xda.

Voice+ is installed in CM 10.2 but it doesn't show up in the app drawer for non-Google Voice countries like the UK. However, it was still active and attempting to route SMS via (non-existent) Google Voice. When I freeze/disable Voice+ SMS starts sending again.

No issues for you in Ireland (?), though, odd...

Edited by professordes
0

Share this post


Link to post
Share on other sites

Posted (edited)

no issues on 3UK for me either, but noted in case there are future probs!

the borked roms last week were a PITA but a small price to pay for daily crackflashing.

Edited by comicbookguy
0

Share this post


Link to post
Share on other sites

Posted

How queer! Glad you got it sorted. No, it didn't cause me any problems here - I use an MVNO on the 02 network (just taken over by 3 apparently, so there goes the neighbourhood :P )

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.