• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

Modified SystemUI without Tesco button

46 posts in this topic

Posted · Report post

Hi, I had this issue the first time I tried to adb too. When you type su it's supposed to give you a different command prompt, but I just got blank lines like you did, and it turned out to be because adb hadn't been authorised for root access (by the SuperSU app). Did you check the Hudl's screen at this point in case there was a pop-up? In my case the problem seemed to be because I was using a secondary user account, so I didn't get a pop-up from SuperSU, but when I tried again as the primary user it worked (and once I'd done that, the next time as the secondary user worked too).

 

It's funny you should mention that, about the SuperSU popup on the screen, because that's exactly what i was thinking after i had posted on here. I tried the process again, and sure enough, it came up with a permissions request. I accepted, and everything went fine. No more Tesco button! :D

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

have deleted the ROMaster Composite ADB Interface entry, and now getting "hudl" and "Unknown device"  like tescohudl was....

 

WHen i select Android device from the list of device types for which to choose a driver for, it says there are none compatible.

 

ANyone able to point me in the right direction for the right drivers?

 

 

Edit:

Uninstalled both, disconnected and reconnected - drivers for "hudl" installed, but for "hudl" they didn't install.

 

I now have one hudl under Portable devices (mtp device), and another under "other devices" which isn't installed correctly. WHen i try to update drivers, there isn't a compatible one, so looks liek i'm still in the same place.

 

Will need to try and dig out drivers from elsewhwere.....

Edited by QLF
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

have deleted the ROMaster Composite ADB Interface entry, and now getting "hudl" and "Unknown device"  like tescohudl was....

 

WHen i select Android device from the list of device types for which to choose a driver for, it says there are none compatible.

 

ANyone able to point me in the right direction for the right drivers?

 

 

Edit:

Uninstalled both, disconnected and reconnected - drivers for "hudl" installed, but for "hudl" they didn't install.

 

I now have one hudl under Portable devices (mtp device), and another under "other devices" which isn't installed correctly. WHen i try to update drivers, there isn't a compatible one, so looks liek i'm still in the same place.

 

Will need to try and dig out drivers from elsewhwere.....

 

1. Right click the device which hasn't installed properly.

2. Click 'Update driver software'.

3. Now click 'Browse my computer for driver software'.

4. Finally, click 'Let me pick from a list of device drivers on my computer'.

 

In this menu, i think you are looking for one called 'Android' or something. Inside there is a driver called 'Android composite ADB interface'. If it isn't inside Android, have a look around in the other sections, it should be there somewhere. If you can't find it, i suggest uploading a screenshot so we can have a look.

 

I'm basically repeating what Jazman has already said!

 

I take it you do actually have ADB set up on your computer, right?

Edited by TescoHudl
0

Share this post


Link to post
Share on other sites

Posted · Report post

Is this a comedy skit? :p

0

Share this post


Link to post
Share on other sites

Posted · Report post

lol - yes. I do have adb setup. See the screenshot below - I have followed all the steps, but the driver seems to be missing for some reason, so not available from the android list - off to google a link to download it again, but would be useful to have the exact name if someone can provide?

post-797054-0-23360600-1381682220_thumb.

0

Share this post


Link to post
Share on other sites

Posted · Report post

lol - swapped from MTP to PTP = installed driver and working fine :)

 

Thanks all for the help!

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Ok, after rebulding my hudl to v1.3, obtaining root, can some nice chap please explain what was changed in the SystemUI.apk so that I can mirror those changes on my v1.3 version?

(No longer a requirement due to using "full!screen" app.)

Edited by CaptainMidnight
0

Share this post


Link to post
Share on other sites

Posted · Report post

Has anyone tried this with ROM 20131016.200812?

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Not quite sure what you are asking - are you asking if you can used the original modified systemUI.apk with the updated HUD i.e. after the v1.3 update etc etc? (sorry of course you were doh!)

Well that all depends on whether that file was changed by said update/ROM version compared to the original and if any updates / bug fixes were added to it. I'm currently having a look at that hence my questionn above aimed at people that do this stuff all the time - for me its currently working it's way up my list of things to do.

Edited by CaptainMidnight
0

Share this post


Link to post
Share on other sites

Posted · Report post

What I have found in my rebuild is if you have disabled all the Tesco apps anyway the soft button doesn't do anything anyway - that was the tescolauncher app from memory.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Finally, after a lot of other life stuff happening, I've had some time to look at this for v1.3 builds. Looks like the SystemUI.apk wasn't replaced/patched etc in the v1.3 build, therefore Paul's original v1.0 SystemUI.apk should work on our v1.3 builds and remove the [T] button.

 

Currently testing this theory..................... :ninja:

0

Share this post


Link to post
Share on other sites

Posted · Report post

Yes confirmed this is working in v1.3 aka build JDQ39.20131016.200812.

 

No [T] button  ;) 

0

Share this post


Link to post
Share on other sites

Posted · Report post

Yes confirmed this is working in v1.3 aka build JDQ39.20131016.200812.

 

No [T] button  ;) 

 

Also confirmed with latest 1.3 update, thanks OP

0

Share this post


Link to post
Share on other sites

Posted · Report post

Thanks for the step by step guide Paul - great to see the [T] button gone from my Hudl (mine was also JDQ39.20131016.200812)  I was a bit silly though, and didn't back up the SystemUI.apk file before overwriting... does anyone know where I can reliably download the stock Tesco firmware (or can someone please share with me the original SystemUI.apk)?

 

Thanks, Mark

0

Share this post


Link to post
Share on other sites

Posted · Report post

Belated thanks to GreyRider for the reply to my question back in March!

 

My Hudl has been nagging me to install an update for a few months now... wondering whether to go ahead (and then whether I can safely use the SystemUI.apk)

1

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Belated thanks to GreyRider for the reply to my question back in March!

 

My Hudl has been nagging me to install an update for a few months now... wondering whether to go ahead (and then whether I can safely use the SystemUI.apk)

 

What build version are you on currently (settings > about tablet)? When the hudl update 1.3.1 update was released (build no. JDQ39.20140424.153851) I compared the updated SystemUI.apk to the original that I modified and there were no changes. As such, I've been using the modified SystemUI.apk on this build with zero problems.

 

If you're currently on the 20131016.200812 build then the update is likely to be the 1.3.1 update. If you're currently on the 20140424.153851 build (which I believe is the latest) and you're receiving an update I would be keen to know!

 

To update, I would put the original SystemUI.apk back, then once updated replace it with the modified one. The update is likely to fail with the modified file in place. You may well have to re-root once updated to be able to push the modified file into place

Edited by flurry
1

Share this post


Link to post
Share on other sites

Posted · Report post

Just reading through this and one question I thought of......

Why not just change the launcher to Nova, or one if the many other launchers to get rid of all the Tesco stuff?

1

Share this post


Link to post
Share on other sites

Posted · Report post

Just reading through this and one question I thought of......

Why not just change the launcher to Nova, or one if the many other launchers to get rid of all the Tesco stuff?

 

because it's on the stock navigation bar on the hudl 1, so the launcher doesn't change it. On the hudl2 your idea would work

2

Share this post


Link to post
Share on other sites

Posted · Report post

Thanks Flurry, I'm on 1.3 (JDQ39.20131016.200812) - looks like this is the 1.3.1 update so it sounds like I'm safe to go ahead and apply it! Thanks

0

Share this post


Link to post
Share on other sites

Posted · Report post

Thanks Flurry, I'm on 1.3 (JDQ39.20131016.200812) - looks like this is the 1.3.1 update so it sounds like I'm safe to go ahead and apply it! Thanks

 

Indeed, sounds like you'll be fine as long as you put the original unmodified SystemUI.apk back in place before updating.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.