• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.
Sign in to follow this  
Followers 0

[Other] [G510] 0100 Request < Have that phone please look...

39 posts in this topic

Posted (edited)

Hey guys,

 

Edited the post, thought it was a bit unclear what my issue was.

I'll describe the situation as it is now. Maybe someone can use this post if he or she has the same issue... :)

 

* sidenote *

When you normally boot up the device, you get the first huawei logo (kernel logo is suppose), and then it goes to the bootanimation. My kernel logo is a white screen with a Chinese letter, '3G', and some orange logo next to it. Don't know but I can't get rid of that, and I know for sure I didn't have that before

 

[bREAKTHROUGH] 

This amazing man helping me out with my issue came with the idea of replacing the mmcblk0p6 and mmcblk0p7 blocks. I need a rip from 0100 B171 firmware to get mine back in order...hopefully. If someone could provide me with that I would be most thankful! I can't flash those roms on my device anymore...

This is how you can do that....If someone would be nice enough to upload them for me...

[I got idea. Dump mmcblk0p6 and p7 and compare it from the one from b171

The size of file is 4096. One of them is bootloader i think

//
Using terminal emul 
su
cat /proc/partitions
And you will get list of all partitions on your phone. Than you can dump on sd card files that you want by next command example

dd if=/dev/block/mmcblk0p6 of=/sdcard/p6.img]

 

Initial Issue:

I have a g510-0100,live in the netherlands, and flashed the lewa OS rom when I got it, which is a unicom rom.

Now, I wanted to flash the latest CM10.2 rom. 

 

Flashing goes all right, boots up just fine. here comes the problem:

 

NO sim recognition. In about phone, it shows correct IMEI, and it tells the dbm (or something) of the signal.

It still doesnt connect to my network and shows 'error while looking for networks' when I manually want to scan for them. 

 

Any ideas how to solve this issue?

 

I tried flashing both lewa and european basebands, that didnt help.

 

Initial Ideas on how to resolve the problem: THIS DIDN'T WORK

* Change the IMEI to match exactly to the one behind the battery on the phone.

This would mean I had to stick with stock chinese firmware, root it, install terminal and change it.

Didn't do this because I saw alot of comments that it wasn't working etc.

 

Second Idea: THIS DIDN'T WORK

* Someone on the forum was so kind to send me a link to firmware that was supposed to work with my phone, and that came in an update.app

This would mean I was back to the stock firmware and correct baseband etc. Problem lies in the flashing, which stops at step 2

                            'Update Failed' 

 

In the manual that came with the zip I read that it could only update a specific set of firmware numbers. I changed my firmware numbers in the build prop to match one of those. Flashing again,the bar got just a little bit further, but returned the error again.

 

Third Idea: THIS DIDN'T WORK

Unpack the supposedly working update app, and fastboot flash the kernel/baseband. I tried to do this already, but I dont know the correct command for flashing a baseband. These are the ones I tried, but returned an error

 

fastboot flash radio ***.img

fastboot flash baseband ***.img

 

I don't know the partition name for the baseband, it returns with the 'remote: permission denied'  error.

 

Latest bright Idea:

I'll be making a flashable .zip file combining files from the 0010 firmware with 0100 ones. see how that goes.

Edited by Brick3d
0

Share this post


Link to post
Share on other sites

Posted

mount("vfat", "VFAT", "/dev/block/mmcblk0p3", "/fat");

package_extract_file("AMSS.MBN", "/fat/image/AMSS.MBN");

package_extract_file("AMSSHD.MBN", "/fat/image/AMSSHD.MBN");

ui_print("Instalacion completa");

ui_print("Por favor reinicia");

Baseband partition

0

Share this post


Link to post
Share on other sites

Posted (edited)

I flashed the baseband.img already with CWM, but that didnt help either. When unpacking the update.app, The program recognizes a few of the .img files.

* baseband

* recovery

* userdata

* cust

* boot

* system

 

Next to those, there is about 20 small files, mostly with E00* and F00* sequences...and I think my problem is with that. The program doesnt know what they are, so I dont know where they should be written to. I'll make a zip of all the .img files which the program does know, and flash it...I don't know any other options.

Edited by Brick3d
0

Share this post


Link to post
Share on other sites

Posted

What was inside lewa rom beside boot.img? Any other files?

0

Share this post


Link to post
Share on other sites

Posted (edited)

What was inside lewa rom beside boot.img? Any other files?

dont really remember about the lewa os, i think only boot.img. but i also flashed 0010 firmware, which had all the files a normal update.app would have. I had come to think there must be some info inside the update.app about where to install what .img file, but i cant seem to find any.

 

EDIT: Odd. even after flashing these .img files:

system

userdata

custom

recovery

boot

baseband

 

the wite boot screen before the bootanimation is still there, so there must be something im missing...

Edited by Brick3d
0

Share this post


Link to post
Share on other sites

Posted

This is the error message in my sd card .txt

 

 
filename = /mmc1/dload/update.app 
call RCV_MODULE_END_EVENT failed,module = OEMSBL_VER_LIST
CMD=0xf,moduleaddr = 0xd2000000, len_tmp=0x4000
 
While reading more I start to see more and more people talking about ' fried memory modules','huawei restore' , ' replace motherboard'....I'm not sure if that applies to me too, it better not lol
0

Share this post


Link to post
Share on other sites

Posted

DONT RUSH WITH FLASHING. WAIT A MOMENT...

0

Share this post


Link to post
Share on other sites

Posted (edited)

DONT RUSH WITH FLASHING. WAIT A MOMENT...

so far I havent flashed anything else. Right now im on the firmware you gave me (the cwm flashable zip i made from the .app). Im still stuck without a sim card, but if I only use the system.img from 0100 and use all others from 0010, i can at least narrow down the problem.

 

ill wait

Edited by Brick3d
0

Share this post


Link to post
Share on other sites

Posted (edited)

ERROR MASAGE INDICATE THAT YOUR ORIGINAL PHONE FIRMWARE IS NOT SME AS THE ONE YOU WANT TO INSTALL. SO YOU HAVE TOI KNOW YOUR ORIGINAL FIRMWARE VERSION ....BXXX. FIND OUT AND DOWNLOAD RIGHT ONE.. IKNOW THIS BECAUSE I HAD THIS PROBLEM..

Edited by Y300-0100
0

Share this post


Link to post
Share on other sites

Posted

ERROR MASAGE INDICATE THAT YOUR ORIGINAL PHONE FIRMWARE IS NOT SME AS THE ONE YOU WANT TO INSTALL. SO YOU HAVE TOI KNOW YOUR ORIGINAL FIRMWARE VERSION ....BXXX. FIND OUT AND DOWNLOAD RIGHT ONE..

well i had a netherlands one. b171 if i remember correctly (the stock rom that came out of the box). I have changed the build.prop to match to a version that SHOULD be upgradable, but that doesnt work...

 

the only issue i have with this chinese firmware is that I cant use my sim card on custom roms, and the original firmware is dual sim...and i only have 1 slot.

0

Share this post


Link to post
Share on other sites

Posted (edited)

 

* sidenote *

When you normally boot up the device, you get the first huawei logo (kernel logo is suppose), and then it goes to the bootanimation. My kernel logo is a white screen with a Chinese letter, '3G', and some orange logo next to it. Don't know but I can't get rid of that, and I know for sure I didn't have that before

According to this there is a probability that inside the ROM that mess up your phone there was a file that write new bootloader (or OEMSBL) but cant be sure without ROM you used. But surely write something on some partition.

 

//

You should check your bootloader version. I dont know for G510-0100 but for Y300-0100

 

 

fastboot oem get-bootinfo

... INFO
*******************************************
INFO    Bootloader Lock State: UNLOCKED
 
INFO    System State: Bootloader in UNLOCKED state
INFO    Bootloader Version: 001.001.000
INFO
*******************************************
OKAY
Edited by Y300-0100
0

Share this post


Link to post
Share on other sites

Posted (edited)

Hm, I looked it up, and I get the exact same messa

 

According to this there is a probability that inside the ROM that mess up your phone there was a file that write new bootloader (or OEMSBL) but cant be sure without ROM you used. But surely write something on some partition.

 

//

You should check your bootloader version. I dont know for G510-0100 but for Y300-0100

I checked it, and I'm getting the exact same thing as you posted...

This is the filename of the .zip that messed it all up

 

华为Ascend_G510固件( G510-0010%2CAndroid_4.1%2CEmotion_UI%2CV100R001C17B182%2C中国联通,05011EUB)

That is the chinese 510-0010b182 update.app

Edited by Brick3d
0

Share this post


Link to post
Share on other sites

Posted (edited)

I'm confused. Literally ALL over the forums, there is an indication that the first logo you get to see (which is that white orange picture for me) is the kernel logo.

There are ways to change this image by modding the boot.img. 

 

Now; If that's the case, that would mean the boot.img is not correctly installing from the 3+ custom roms i've tried to install. 

That could mean a corrupt zip file. Thats not likely because everyone else can use it properly. 

Thus meaning that there is a kernel related problem with my device. Either the mount name has changed or the system doesnt hook on to the kernel correctly.

 

fairly simple right?

 

Then comes this:

How is it then possible for me to flash CM10.2 (android 4.3.2) without issues. I suppose that boot.img is CM specific (since its based on other sources and not 4.1.1 update.apps).

 

If that's the case, it means that the kernel is flashing.

 

Now im confused.

 

My understanding is that there are some parts left out from the kernel that are still present in the phone, even when flashing custom roms etc that make the sim card malfunction...

 

 

that is for the boot logo...now here's this again...

 

I made a CWM zip containing ALL .img files from the chinese firmware (boot,cust,recovery,baseband), except system.img.,,

 

when booting this rom, the sim also doesnt work =D

Edited by Brick3d
0

Share this post


Link to post
Share on other sites

Posted (edited)

How did you manage to install 0010 on 0100?

Did you use update metod dload/update.app?

Edited by Y300-0100
0

Share this post


Link to post
Share on other sites

Posted (edited)

I got idea. Dump mmcblk0p6 and p7 and compare it from the one from b171

The size of file is 4096. One of them is bootloader i think

//

Using terminal emul

su

cat /proc/partitions

And you will get list of all partitions on your phone. Than you can dump on sd card files that you want by next command example

dd if=/dev/block/mmcblk0p6 of=/sdcard/p6.img

Sending from mobile phone .sorry for bad english..

Edited by Y300-0100
0

Share this post


Link to post
Share on other sites

Posted (edited)

I got idea. Dump mmcblk0p6 and p7 and compare it from the one from b171

The size of file is 4096. One of them is bootloader i think

//

Using terminal emul

su

cat /proc/partitions

And you will get list of all partitions on your phone. Than you can dump on sd card files that you want by next command example

dd if=/dev/block/mmcblk0p6 of=/sdcard/p6.img

Sending from mobile phone .sorry for bad english..

Im quite new to the terminal, but I'll try it. I am now on the chinese firmware. Just rooted, debloated, and tweaked it to my liking. Which files do i need to compare? 

 

those dumps from both CM and the chinese rom? yes i used the sdcard/dload/update.app

 

So, i have acces to the chinese firmware dumps. How can i get the b171 files, because i cant get another system working on the phone as of now...

 

your english is perfectly fine dont worry :)

Edited by Brick3d
0

Share this post


Link to post
Share on other sites

Posted

1St forget about roms, custom,cm etc. Its not isue.

U can dump files from your pc.

Adb shell

Su

Than others commands.

Split update.app and u will see files same size as one u made dump

P6 and p7 are ones u need. If u open them with notepad++ in one of them u will see OEMSBL VER. That is how u can see diference.

I have found instructions for flashing those two files using adb. I cant remmember was it for g300 or g330

But procedure is same. I am not on my pc now so i cant give u more guide lines right now but i think that your problem can be solved...

0

Share this post


Link to post
Share on other sites

Posted (edited)

1St forget about roms, custom,cm etc. Its not isue.

U can dump files from your pc.

Adb shell

Su

Than others commands.

Split update.app and u will see files same size as one u made dump

P6 and p7 are ones u need. If u open them with notepad++ in one of them u will see OEMSBL VER. That is how u can see diference.

I have found instructions for flashing those two files using adb. I cant remmember was it for g300 or g330

But procedure is same. I am not on my pc now so i cant give u more guide lines right now but i think that your problem can be solved...

 

 

Ok I will compare them. Can I just open the .img files with notepad++? :S

I have found the terminal command to flash that block already :) found it at another forum from someone who restored his DMR (sony stuff i believe) by doing the same thing,..

Edited by Brick3d
0

Share this post


Link to post
Share on other sites

Posted

Ok I extracted both p6 and p7. Now, when opening p6 with notepad++, i get alot of numbers, [nul] value, etc....nothing unexpected.

but when im opening p7.img, i get a single line of [nul] [nul] and so on. 4096 kbit of 0 data....seems odd to me

0

Share this post


Link to post
Share on other sites

Posted (edited)

Different structure in compared to Y300 edit NO its same...

untitled.jpg

 

U have to identify bootloader and radio OEMSBL

Bad news I can not find instruction for flash bootloader and radio OEMSBL

Maybe I should contacting Dazz. I think he was involved in the instructions for bootloader

untitled1.jpg

 

Once you realize which files you are missing  you need to find someone who has G510-0100 and that he is willing to send it to you... because there is also procedure to write those files back to phone...

Edited by Y300-0100
0

Share this post


Link to post
Share on other sites

Posted (edited)

Hey guys.

How about some help here for Brick3d.

I can not by myself...

Edited by Y300-0100
0

Share this post


Link to post
Share on other sites

Posted

Another idea.

 

Since u was able to upgrade (frankly do not know how) ur G510-0100 (C02B171) with G510-0010 (C17B182), probably because apps boot version. Now u cant downgrade (to lower B number) but perhaps u can upgrade with G510-0251 V100R001C76B185a ( http://rapidshare.com/files/2608271037/Ascend_G510(G510-0251_Android_4.1_Emotion_UI_V100R001C76B185a_Brazil-Vivo_05011SHB).rar ) Higher B number.

 

I dont know device spec for G510-0251? is it dual sim baseband, frequency band etc?.

 

I dont know, just an a idea???

0

Share this post


Link to post
Share on other sites

Posted (edited)

I actually think its a nice idea! thanks. I believe the difference between 0010 and 0251 was that 0251 was specificly made for vietnamese/phillipines/rest of asia. Ill find one and flash the EU baseband over it. But, I'm not sure that it's going to improve it, since I think that 0251 is also dual sim...Btw, about phone tells me my baseband is 2030...can you confirm that? that version number doesnt change, even if I flash another baseband, so i suppose its ok. At least for now I have my sim card back. thank you again for all your help!!

 

I have found a spanish 0100 B171 rom :) I'll download that later today and see how it goes. I think that is the same rom as provided in Holland, at least that gets closer to the goal. I can unpack that one and compare the p6 and p7 .img files.

 

Edit: tried downloading it really quick, but the download is capped at 20 kbp/s for me....8 hours remaining...

Edited by Brick3d
0

Share this post


Link to post
Share on other sites

Posted (edited)

Well yes I have got it working, but its still multisim...and i have single sim. Ik at school now, so i cant look into the img files right now. Ill extract the 0251 update app when i get back home. Would it be safe to just replace those 2 img files with the ones in my system now?

Edited by Brick3d
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.