• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.
Sign in to follow this  
Followers 0

Problem in recompiling systemui.apk

16 posts in this topic

Posted (edited)

Hi guys, i am trying to recompile systemui.apk but i can't i have always this error, with apk multi tool or apktool is the same, i have the same error..sorry if i did something wrong, but i am a noob with this things and this is the first time that i recompile an apk

post-1023425-0-76998800-1382456642_thumb

Edited by fonz93
0

Share this post


Link to post
Share on other sites

Posted

If you modified public.xml then undo the changes you made to that file and compile. apktool will generate the values for you, so if you decompile the new APK then you could update any smali const values with what's been generated in public.xml.

0

Share this post


Link to post
Share on other sites

Posted

mmm sorry i dont understand nothing ahahahaha, btw i didnt modified public.xml, i have modified only a file that is status_bar_expanded, nothing more

0

Share this post


Link to post
Share on other sites

Posted (edited)

That error - "entry index is larger than available symbols" is normally generated when public.xml has been modified, or if theres a missing file.

 

What I'm saying is that if you had of manually typed stuff into public.xml then that's not required since apktool will update that info itself.

 

When decompiling systemui did it complete without any error and did you add the framework-res.apk file?

java -jar apktool.jar if framework-res.apk

EDIT: The other error "declared here is not defined" could be caused by an invalid .9.png image file or invalid xml file.

Edited by H3ROS
0

Share this post


Link to post
Share on other sites

Posted (edited)

no errors in decompiling

i didnt modify public.xml and yes i did this from cmd:

 

apktool if framework-res.apk

apktool d SystemUI.apk

apktool b SystemUI system.apk

 

and also this:

 

apktool if framework-res.apk

apktool if framework-res-hwext.apk

apktool d SystemUI.apk

apktool b SystemUI system.apk

 

but nothing, same error, im sorry if im wasting your time, i am a novice with this..

Edited by fonz93
0

Share this post


Link to post
Share on other sites

Posted

My guess is that you've told the XML file to use something that doesn't actually exist. That'd explain the "declared here is not defined" error.

0

Share this post


Link to post
Share on other sites

Posted

and so what i have to do?

0

Share this post


Link to post
Share on other sites

Posted

I don't know what you've changed within the file, so I can't make a suggestion other than to add whatever is missing.

 

If you posted the files contents before your change and after your change then I might be able to tell you what's wrong.

0

Share this post


Link to post
Share on other sites

Posted (edited)

ok 

 

the modified line is this:<FrameLayout android:id="@id/notification_panel" android:background="@drawable/notification_panel_bg" 

 

to this: <FrameLayout android:id="@id/notification_panel" android:background="#3F000000"

 

i am trying to set transparent notification bar

 

 

edit: i tried to recompile without modify anything and i have the same error

 

 

Edit2: i tried to edit system ui of another stock based rom (fusionx) and it worked... now i understand that i had errors in decompiling like:

I: error...

W:error...

I:error..

if you need i can do a screen...

status_bar_expanded - after change -.xml

status_bar_expanded - before -.xml

public.xml

Edited by fonz93
0

Share this post


Link to post
Share on other sites

Posted

You only need to delete public.xml from values folder before recompile(Don't worr, this doesn't affect to final apk)

0

Share this post


Link to post
Share on other sites

Posted

You only need to delete public.xml from values folder before recompile(Don't worr, this doesn't affect to final apk)

ok i did it, now compiled without errors, thanks a lot :)

0

Share this post


Link to post
Share on other sites

Posted (edited)

ok i did it, now compiled without errors, thanks a lot :)

And does the recompiled SettingsUI.apk work at all? I tried and I'm left with no status bar :(

Edited by fpb
0

Share this post


Link to post
Share on other sites

Posted

And does the recompiled SettingsUI.apk work at all? I tried and I'm left with no status bar :(

Yes, i dont know why... maybe the huawei systemui cant be modified with the same methods of others stock rom, i had an error while running systemui, i think was animation drawable.xml, something like this

0

Share this post


Link to post
Share on other sites

Posted

@fonz93 how you are able to install framework-res.apk in apktool? i got error =.="

0

Share this post


Link to post
Share on other sites

Posted

what error?dont forgot to install also framework-res-hwext.apk, i dont know if its needed but for security i install it always 

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.