• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

KitKat for liquid?

24 posts in this topic

Posted

Google has announced dat kitkat will be compatible with all low end smart phones with same specs as the liquid! So is there a chance for us to get a bite of the kitkat?

0

Share this post


Link to post
Share on other sites

Posted

Maybe when cyanogenmod release its kitkat

0

Share this post


Link to post
Share on other sites

Posted

These phone surely don't have the same chipset (QSD8250) as the acer liquid. AFAIK it's the only device with that chipset which has gone so far (getting CM10).

But now, the main problem is the kernel. For exemple, to get CM10.1 (Android 4.2) on the acer liquid, we have to update the graphics driver, which need an huge amount of changes to backport it to the 2.6.29.6 kernel. (which the liquid use). In fact, in order to get Android 4.2, and more especially 4.3 and now 4.4, we need to get at least a 3.0 (3.0.100 for exemple) kernel to work on it. Currently, the most up to date kernel we have is the 2.6.35, and doesn't work perfectly and only with the original Android 2.2 ROM. So it needs really a lot of work but the acer liquid community isn't active as the CM9 ages (which also needed a lot of work).

0

Share this post


Link to post
Share on other sites

Posted

piernov, agree with you

0

Share this post


Link to post
Share on other sites

Posted

However I've seen that 4.4 has been ported to HTC HD2 with a 2.6.29 kernel !

And it's quite working !!

0

Share this post


Link to post
Share on other sites

Posted

There are tons of Low end device 

 

Check the androidarmv6 team

 

they ported CM10.1 cm10.2 cm11 to a ton of Low end devices with 2.6.35 Kernels

 

and all are quite working good

 

but indeed graphics driver need updates and takes ton of times

 

even on high end device

acer cloudmobile we gave up on it

1

Share this post


Link to post
Share on other sites

Posted

There are tons of Low end device 

 

Check the androidarmv6 team

 

they ported CM10.1 cm10.2 cm11 to a ton of Low end devices with 2.6.35 Kernels

 

and all are quite working good

 

but indeed graphics driver need updates and takes ton of times

 

even on high end device

acer cloudmobile we gave up on it

So its portable on Acer Liquid.

Will you be working on new Android 4.4 rom?

0

Share this post


Link to post
Share on other sites

Posted

So its portable on Acer Liquid.

Will you be working on new Android 4.4 rom?

its portable offcourse

u only need the knowledge of kernels and such wich i dont have adn i wont be working on it as i gave up on it :/

0

Share this post


Link to post
Share on other sites

Posted

But we only have a 2.6.29.6 kernel working. We also have a 2.6.32, but it's far from working with Android 4.x. And the 2.6.35 doesn't even fully work with a stock ROM. (didn't look at it, but some problems might come from the fact that using 2.6.35 kernel should require Android 2.3)

Currently with the 2.6.29.6, we have KGSL 3.8. I think we would need to update it to 3.14 along with the binary blobs to be able to boot a newer Android.

I already took a look at that, but I'm not a kernel dev at all, nor even a good C programmer… So when I tried to backport a newer version of the graphics driver, it was just failing.

(by the way, the newer graphic driver also uses newer functionnality from 2.6.35 kernel and maybe above for exemple so they need to be rewritten to work on 2.6.29.6)

Graphic driver may not be the only thing needing update.

To conclude, yes it's portable of course, but it needs good knowledges of kernel development, lot of time and a huge amount of work.

And better than trying to backport all the time stuff for 2.6.29.6 kernel, we should rather try to get a fully working 2.6.35, then 2.6.38, then 3.0 kernel. Then starting from here we would normally have all the needed stuff to run Android 4.4 on our device. (but, after that we should also try to update to 3.4 since 3.0 is now deprecated, if we want to be able to update Android in the future)

1

Share this post


Link to post
Share on other sites

Posted (edited)

Hi all

 

I'm trying to compile cm11 for acer liquid a1 with RomzesRover github ----> Here

 

I have added some line on BoardConfig.mk

 

# Neon stuff
TARGET_ARCH := arm
TARGET_ARCH_VARIANT := armv7-a-neon
ARCH_ARM_HAVE_TLS_REGISTER := true
ARCH_ARM_HAVE_ARMV7A_BUG := true
ARCH_ARM_HAVE_NEON := true
TARGET_USE_SCORPION_BIONIC_OPTIMIZATION := true
TARGET_CPU_VARIANT := cortex-a8
TARGET_ARCH_LOWMEM := true

 

 

I have this error --->
 

 

target thumb C++: libandroid_runtime <= frameworks/base/core/jni/android_hardware_Camera.cpp
target thumb C++: libandroid_runtime <= frameworks/base/core/jni/android_hardware_camera2_CameraMetadata.cpp
target thumb C++: libandroid_runtime <= frameworks/base/core/jni/android_hardware_SensorManager.cpp
frameworks/base/core/jni/android_hardware_Camera.cpp: In function 'void android_hardware_Camera_setLongshot(JNIEnv*, jobject, jboolean)':
frameworks/base/core/jni/android_hardware_Camera.cpp:398:34: error: 'CAMERA_CMD_LONGSHOT_ON' was not declared in this scope
frameworks/base/core/jni/android_hardware_Camera.cpp:400:34: error: 'CAMERA_CMD_LONGSHOT_OFF' was not declared in this scope
frameworks/base/core/jni/android_hardware_Camera.cpp: In function 'void android_hardware_Camera_setMetadataCb(JNIEnv*, jobject, jboolean)':
frameworks/base/core/jni/android_hardware_Camera.cpp:719:34: error: 'CAMERA_CMD_METADATA_ON' was not declared in this scope
frameworks/base/core/jni/android_hardware_Camera.cpp:721:34: error: 'CAMERA_CMD_METADATA_OFF' was not declared in this scope
target thumb C++: libandroid_runtime <= frameworks/base/core/jni/android_hardware_SerialPort.cpp
frameworks/base/core/jni/android_hardware_camera2_CameraMetadata.cpp: In function 'jlong CameraMetadata_allocateCopy(JNIEnv*, jobject, jobject)':
frameworks/base/core/jni/android_hardware_camera2_CameraMetadata.cpp:163:39: warning: converting to non-pointer type 'jlong {aka long long int}' from NULL [-Wconversion-null]

 

 

and my compilation end here.....

 

Edit:

I have comment  # this line (398, 400,719,721)

 

Continue with compilation

 

Edit 2:

I have delete file into this directory of reposity

 

cm11/device/acer/salsa/overlay/frameworks/base/core/res/res/values

 

Restart

 

 

 

Bye

Edited by lucky76
0

Share this post


Link to post
Share on other sites

Posted (edited)

EDIT: Sorry, it seems I was wrong.

Edited by piernov
0

Share this post


Link to post
Share on other sites

Posted (edited)

Hi all

 

I'm trying to compile cm11 for acer liquid a1 with RomzesRover github ----> Here

 

I have added some line on BoardConfig.mk

 

# Neon stuff

TARGET_ARCH := arm

TARGET_ARCH_VARIANT := armv7-a-neon

ARCH_ARM_HAVE_TLS_REGISTER := true

ARCH_ARM_HAVE_ARMV7A_BUG := true

ARCH_ARM_HAVE_NEON := true

TARGET_USE_SCORPION_BIONIC_OPTIMIZATION := true

TARGET_CPU_VARIANT := cortex-a8

TARGET_ARCH_LOWMEM := true

 

 

I have this error --->

 

 

and my compilation end here.....

 

Edit:

I have comment  # this line (398, 400,719,721)

 

Continue with compilation

 

Edit 2:

I have delete file into this directory of reposity

 

cm11/device/acer/salsa/overlay/frameworks/base/core/res/res/values

 

Restart

 

 

 

Bye

 

http://forums.androidcentral.com/lg-optimus-s-rooting-roms-hacks/331332-4-4-kitkat-7.html

"The fix for the camera and other errors are in the folders I forked in my repo:

android_external_chromium_org

android_frameworks_base

android_frameworks_av"

 

Just googled, no guarantees that it'll do the trick

Edited by zabulus
0

Share this post


Link to post
Share on other sites

Posted (edited)

http://forums.androidcentral.com/lg-optimus-s-rooting-roms-hacks/331332-4-4-kitkat-7.html

"The fix for the camera and other errors are in the folders I forked in my repo:

android_external_chromium_org

android_frameworks_base

android_frameworks_av"

 

Just googled, no guarantees that it'll do the trick

 

 

Thanks

 

I see but have fixed for moment with //.....

 

The compilation continue........

 

The last error

 

 

target thumb C++: libLLVMAsmPrinter <= external/llvm/lib/CodeGen/AsmPrinter/DwarfDebug.cpp

device/acer/salsa/overlay/frameworks/base/core/res/res/values/config.xml:107: error: Resource at config_button_brightness_support appears in overlay but not in the base package; use <add-resource> to add.

make: *** [/home/lucky76/cm11/out/target/common/obj/APPS/framework-res_intermediates/package-export.apk] Errore 1

make: *** Eliminazione del file "/home/lucky76/cm11/out/target/common/obj/APPS/framework-res_intermediates/package-export.apk"

 

I have added some file into this directory

 

device/acer/salsa/overlay/frameworks/base/core/res/res

 

 

 

Edit: Other error

 

 

target thumb C++: audio_policy.salsa <= device/acer/salsa/libaudio/AudioPolicyManager.cpp

Import includes file: /home/lucky76/cm11/out/target/product/salsa/obj/SHARED_LIBRARIES/camera.qsd8k_intermediates/import_includes

In file included from device/acer/salsa/libaudio/AudioHardware.h:30:0,

                 from device/acer/salsa/libaudio/AudioHardware.cpp:37:

device/acer/salsa/libaudio/msm_audio_qcp.h:32:29: fatal error: linux/msm_audio.h: No such file or directory

compilation terminated.

make: *** [/home/lucky76/cm11/out/target/product/salsa/obj/SHARED_LIBRARIES/audio.primary.salsa_intermediates/AudioHardware.o] Errore 1

make: *** Attesa per i processi non terminati....

 

 

 

 

 

 

 

Happy New Year All.......

Edited by lucky76
1

Share this post


Link to post
Share on other sites

Posted

Hi all

Last night i have compiled cm11.....

Tonight i'll must see if booting....

300 MB system

2.3 MB boot

1.8 MB kernel

I have used RomzesRover github

Bye

0

Share this post


Link to post
Share on other sites

Posted

Hi all

Last night i have compiled cm11.....

Tonight i'll must see if booting....

300 MB system

2.3 MB boot

1.8 MB kernel

I have used RomzesRover github

Bye

Good luck!!! I hope we can see kit kat working on liquid :D
0

Share this post


Link to post
Share on other sites

Posted

Good luck!!! I hope we can see kit kat working on liquid :D

Thank you....

 

Not good news not booting. :(

 

I have changed some thing and now i start new compiling.....

0

Share this post


Link to post
Share on other sites

Posted

Thank you....

Not good news not booting. :(

I have changed some thing and now i start new compiling.....

Okey :(

Keep on doing such a good work :D

0

Share this post


Link to post
Share on other sites

Posted

Any news???

0

Share this post


Link to post
Share on other sites

Posted

Hi end222

 

In this days i have compiled Kitkat 4.4.2 cm11 for Huawei Sonic u8650 with 256mb ram.........

 

I have more bug and is very slow but booting ihihihi.

 

I have posted some pic in Huawei Ideos X3 forum.

 

Bye

0

Share this post


Link to post
Share on other sites

Posted

In this days i have compiled Kitkat 4.4.2 cm11 for Huawei Sonic u8650 with 256mb ram.........

Great News will be waiting for Kitkat

0

Share this post


Link to post
Share on other sites

Posted

Great News will be waiting for Kitkat

I hope so :D
0

Share this post


Link to post
Share on other sites

Posted

Kitkat is complate or not?

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.