• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.
Sign in to follow this  
Followers 0

[Help] Weak data signal

13 posts in this topic

Posted

Hello, everyone! I'm posting because, since I've flashed a rom, I've had weak data signal. I realize that people with my same network provider have the H symbol when I'm usually stuck at E.

 

An important detail is that I'm Argentinian. I've already flashed the LA modems, and I have 3G connection, the problem is that I very rarely catch it.

 

 I've read some solutions people tend to give, but I'm afraid of doing something I'm not supposed to do and screw everything up.

 

Could changing roms have something to do with this? Is there a way I can improve my signal or even "check" if it's normal?

 

Thanks in advance!

0

Share this post


Link to post
Share on other sites

Posted

That guy's problem was that he didn't have 3G connection, and the LA modems were his solution. I do have 3G but not as often as I used to have.

I'm wondering is this would make a difference, but I'm afraid of screwing it up:

Some stock ROMs reset some internal config settings.

Before going thru the rigmarole of installing LA modems the OP could try a simple check:

Dial *#*#4636#*#* -select Phone information -scroll down and select Set preferred network type

In areas where GSM is on 900/1900 and UMTS on 900/2100 you should select GSM auto (PRL)

then reboot.

hth

Do someone know what's it for?

Thanks for helping!

0

Share this post


Link to post
Share on other sites

Posted

It's possible that flashing a ROM also flashed a RIL (Radio Interface Layer) that has impacted your 3G performance.

But it may be difficult to tell.

And you would want to be careful in flashing RILs in an attempt to rectify the situation.

What about getting a stock Huawei update.app for your region and force updating that as it should put everything back defaults including the RIL?

I don't know if/where you can get such an update.app though - unless the stock B952 suffices? I just don't know enough about the specifics of LA frequencies and RILs to advise.

0

Share this post


Link to post
Share on other sites

Posted

It's possible that flashing a ROM also flashed a RIL (Radio Interface Layer) that has impacted your 3G performance.

But it may be difficult to tell.

And you would want to be careful in flashing RILs in an attempt to rectify the situation.

What about getting a stock Huawei update.app for your region and force updating that as it should put everything back defaults including the RIL?

I don't know if/where you can get such an update.app though - unless the stock B952 suffices? I just don't know enough about the specifics of LA frequencies and RILs to advise.

Hmm I'll se if I can get one of those updates. I have a backup of the original rom, would that help?

Let's see if somebody else answers, anyways.

Thank you!

0

Share this post


Link to post
Share on other sites

Posted

I've found this in a forum, which is supposed to improve data signal:

You have to add these lines to the build.prop:

ro.ril.hep=1

ro.ril.hsxpa=2

ro.ril.enable.dtm=1

ro.ril.gprsclass=12

ro.ril.hsdpa.category=8

ro.ril.enable.a53=1

ro.ril.hsupa.category=5

ro.ril.enable.3g.prefix=1

Would that change something? Probably do harm?

0

Share this post


Link to post
Share on other sites

Posted

Just to reiterate the usual mantra - always do a full CWM/TWRP backup before making any changes.

0

Share this post


Link to post
Share on other sites

Posted

Just to reiterate the usual mantra - always do a full CWM/TWRP backup before making any changes.

 

Yeah of course, but do you think I should try those build.prop changes? Does a nandroid backup restore build.prop changes?

0

Share this post


Link to post
Share on other sites

Posted

^ Yes

0

Share this post


Link to post
Share on other sites

Posted

Nandroid backup backs up everything.

It takes a full image of your current setup so you can go back to it if necessary.

0

Share this post


Link to post
Share on other sites

Posted

I've added those strings, but nothing seems to have changed. The original post says it should helpe 3G and edge, which I still don't see so often...

 

Any other idea? Any way of checking that RIL thing?

 

As I said before, I have a backup of the stock rom that came with the phone, just rooted. Could I get something from there?

 

Thanks again

0

Share this post


Link to post
Share on other sites

Posted

Any other idea? Any way of checking that RIL thing?

 

The IMEI SV in System Settings > About Phone > Status > Additional Status Info (at least on GB - may be elsewhere on another ROM) should indicate the last official update.app applied and this MAY indicate the last RIL installed e.g.:

 

http://www.modaco.com/topic/357975-archive-ril-for-all-stock-based-ics-roms/page-4#entry2086510

 

But I'm not sure if this is really going to tell you anything.

 

Why don't you backup your current setup and restore your original stock ROM backup and see if 3G works better there?

0

Share this post


Link to post
Share on other sites

Posted

The IMEI SV in System Settings > About Phone > Status > Additional Status Info (at least on GB - may be elsewhere on another ROM) should indicate the last official update.app applied and this MAY indicate the last RIL installed e.g.:

 

http://www.modaco.com/topic/357975-archive-ril-for-all-stock-based-ics-roms/page-4#entry2086510

 

But I'm not sure if this is really going to tell you anything.

 

Why don't you backup your current setup and restore your original stock ROM backup and see if 3G works better there?

 

It says: "IMEI SV 48". I have no idea what that means.

 

I'll try restoring and checking if it works better tomorrow!

 

Thanks for your help!

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.