• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

How to flash to the standard UK ROM

108 posts in this topic

Posted

Cheers mate,

I saw that site earlier, is that an official Motorola owed site, looks a bit like a repository someone has collated...?

0

Share this post


Link to post
Share on other sites

Posted

Yes it's an unofficial repository.  However, with a locked bootloader the phone will not accept anything other than Motorola signed image files so it's safe as houses.

1

Share this post


Link to post
Share on other sites

Posted

Thanks Paul ;)

 

What is the difference between the r2 and r3?  Does it just eliminate the dirty flash?

 

Cheers again!

0

Share this post


Link to post
Share on other sites

Posted

Basically yeah.

P

0

Share this post


Link to post
Share on other sites

Posted

Yes it's an unofficial repository.  However, with a locked bootloader the phone will not accept anything other than Motorola signed image files so it's safe as houses.

 

Brilliant!

Thank you for putting up with my inane questions. :)

0

Share this post


Link to post
Share on other sites

Posted

Basically yeah.

P

Ta... no need for me to reflash then if I've done r2 and a Factory Data Reset. :)

0

Share this post


Link to post
Share on other sites

Posted

I can't get the Motorola website to accept my bootloader unlock code, so i'm going to flash the UK stock ROM over my Tesco ROM and then try it again. Hopefully the unlock code from the stock ROM will work and allow me to unlock the bootloader.

 

Before i flash the stock ROM i wanted to make a backup of the Tesco ROM in case the device malfunctions at some point and i need to return it. But i don't know how would i do this? In the event that something goes wrong with the phone, is it returned to Motorola or Tesco's?

 

I know that unlocking the bootloader will void the warranty, but if i still can't get the Motorola website to accept my unlocking code, no damage will be done.

 

Hopefully someone will be able to tell me if backing up the Tesco ROM is necessary before flashing the stock ROM, and if so, how would i do it?

 

Cheers!!

0

Share this post


Link to post
Share on other sites

Posted

Hi Paul

 

Thanks your work on this, much appreciated!  :)

 

Just a quick question, 

 

I bought my Moto G from Tesco today.

 

I've downloaded your file and unzipped it on my windows 7 machine.

 

I then put the phone in boot loader and plugged it into the computer and a dialog comes up stating device not recognised - and in device manager there is a yellow triangle with Falcon S as the usb device - with driver not found.

 

When I clicked on the flash-windows.bat the dialog box appears saying waiting for device.

 

 

 

Can you tell me which driver I need to get Windows to recognise my Moto G?

 

Many thanks in advance  :D

0

Share this post


Link to post
Share on other sites

Posted

Try connecting the phone while it's turned on normally so windows can installthe drivers. Then try the steps again.

0

Share this post


Link to post
Share on other sites

Posted

Thank you Paul. This worked like a treat. :)

I had to run the batch file from command line though. (Win 8.1 64 bit)

Thanks again, great job.

BTW The recovery on this device is awesome. :)

0

Share this post


Link to post
Share on other sites

Posted

My windows can't find the drivers. I tried connecting normally and it works, but hen in bootloader i get the falcn device but no luck :(

 

Also is everyone's moto g restarting when connected to USB? It doesn't want to stay off :D

0

Share this post


Link to post
Share on other sites

Posted

Hi everyone

After flashing I am getting this is error message each the I try to install an apk file "There was a problem parsing the package" these files actually worked fine on the tesco ROM

Tried check unknown source in setting unchecked verify app.... Clear cache .... Used apk manager and none of these seems to work

Any help/ suggestion most welcome

0

Share this post


Link to post
Share on other sites

Posted

My windows can't find the drivers. I tried connecting normally and it works, but hen in bootloader i get the falcn device but no luck :(

 

Also is everyone's moto g restarting when connected to USB? It doesn't want to stay off :D

Same happen to me.. Just reinstall/repair then restart windows and of should work
0

Share this post


Link to post
Share on other sites

Posted

Same happen to me.. Just reinstall/repair then restart windows and of should work

Many thanks for the reply Moezt

 

I've got the same problem - installed drivers fine in normal mode and drivers not found in bootloader.

 

what do you mean by reinstall/repair?

 

 

pete

0

Share this post


Link to post
Share on other sites

Posted

To start repair just double click again on the file you've downloaded from Motorola website

0

Share this post


Link to post
Share on other sites

Posted

Can someone confirm this is normal behaviour?

1. Connect phone to PC to charge

2. Power the phone off

3. Wait

4. The phone reboots itself

 

Another scenario

1. Connect phone to charge to a random USB wall adapter

2. same

3. same

4. same

 

Another scenario

1. Connect the phone to charge to an LG (from nexus 5) wall adapter

2. same

3. same

4. Battery charging graphic is shown as expected

 

Thanks

0

Share this post


Link to post
Share on other sites

Posted

Make a separate post for this dude.

Can someone confirm this is normal behaviour?

1. Connect phone to PC to charge

2. Power the phone off

3. Wait

4. The phone reboots itself

 

Another scenario

1. Connect phone to charge to a random USB wall adapter

2. same

3. same

4. same

 

Another scenario

1. Connect the phone to charge to an LG (from nexus 5) wall adapter

2. same

3. same

4. Battery charging graphic is shown as expected

 

Thanks

0

Share this post


Link to post
Share on other sites

Posted

Ye I guess I will have to :D completely forgot this thread was for flashing :D

0

Share this post


Link to post
Share on other sites

Posted (edited)

Can't get this to work for some reason. File downloaded and unzipped. Downloaded Moto device manager for the drivers. Plugged in USB cable and put into fastboot mode. 

 

Went into the folder of the DL firmware, right click the Flash-Windows batch file, run as Admin, confirm with pop up box, but stops there.

 

Looks like a command prompt box flashes up for a second, but then disappears and nothing happens.

 

Anyone any ideas? Thanks

Edited by mario999
0

Share this post


Link to post
Share on other sites

Posted

Anyone any ideas? Thanks

Run the batch file in DOS window (start menu, click RUN, type: cmd type: cd C:\folder with flash windows bat, type: flash-windows

0

Share this post


Link to post
Share on other sites

Posted

Run the batch file in DOS window (start menu, click RUN, type: cmd type: cd C:\folder with flash windows bat, type: flash-windows

 

Thanks. Figured it out, just needed to double click the file and it worked. 

 

Also when done the phone shows cmd:erase user data. This is the point when you just have to reboot. 

 

All working fine now.

0

Share this post


Link to post
Share on other sites

Posted

In the past I have changed the rom on a ZTE Blade and Huawei G300.

 

Not sure what I will gain changing the rom on the Moto G.  I bought it from Tesco, unlocked it for £2.04 but the phone is just the same as a non Tesco one.

0

Share this post


Link to post
Share on other sites

Posted (edited)

The key issue is whether the Moto G with Tesco Stores Ltd ROMs will get the KitKat update the same time as models with the standard UK retail ROM - the jury's out. Given there is absolutely no difference between the two versions aside from the inclusion of TescoSL in the ROM name, it remains to be seen if this will be a barrier to an automatic upgrade or whether Tesco need to do something specific - I don't think there is anything 'special' about the Tesco ROM which would require any additional work to be done - there's no Tesco specific branding or apps to worry about.

 

I'm gonna hang back on doing this for now and will review in January when the KitKat upgrade is rolled out.

Edited by clayts450
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.