• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.
Sign in to follow this  
Followers 0

Moto G battery ran out - now won't switch on

16 posts in this topic

Posted

Hi All,

Yesterday, after the Moto G was on for almost 1.5 days, the battery ran out and powered off. The first thing I did was stick it on the charger for a couple hours, but the phone remained off, and wouldn't power on afterwards. I also left it on charge overnight to see if it would do something, but it's still lifeless.

Anyone else experience this issue, and have any ideas to suggest trying? Thanks in advance!

-J

0

Share this post


Link to post
Share on other sites

Posted

Why are you not taking it back to the shop?  This is a brand new phone and should not be happening.

0

Share this post


Link to post
Share on other sites

Posted

Unlocked / Rooted or stock ?

0

Share this post


Link to post
Share on other sites

Posted

I have organised a replacement, but it is a bit concerning, as I've read 2 other similar reports on this so far. Was rooted using Paul's second method (temp custom recovery) however the phone was working perfectly up until the battery ran dry.

0

Share this post


Link to post
Share on other sites

Posted

My phone wouldn't charge yesterday, and I discovered it was due to the Micro-USB cable I was using.  It seems that not all Micro-USB cables are created equal.

 

In my case, I thought the phone was charging (the screen came on when the cable was plugged in), but actually it wasn't (and if I'd have looked closely, I would have seen that the battery icon was't indicating charging).

 

Changing the cable for a different one cured the problem.  Note that I haven't tried the cable it came with; I suppose I should have done...

0

Share this post


Link to post
Share on other sites

Posted

Just an update, I left the phone for one day, and it magically came back to life and started charging after trying it again. It seems to a common problem, as I just went off the suggestion from some others on XDA. Pro tip: don't let the moto g run flat!

0

Share this post


Link to post
Share on other sites

Posted

Hey man Listen I fix this issue with my phone. 

Here are the steps.
- leave the phone for 24 hours means no touch, do not try to power up the phone, or do not even charge the phone in these 24 hours.
- after the 24 hours press the power button then LED will blink 3 times.. 
- then immediately put the phone back on charge (Use original charger only).  

- then let the phone charge about 25 mins then start up the phone 

 

 

It must start up.
In case it won't then replace it

0

Share this post


Link to post
Share on other sites

Posted

Hi Guys!

 

My Moto also went dead on connecting to USB cable. i was copying some files to my phone and boom!!! the phone was dead in a couple of mins... and now i'm trying to revive it..

 

Going to try out ur suggestions.

 

- not going to touch my phone for 24 hrs [bt y... ;(]

- charge it after that for 2 hrs 

- power it up.

- and cross my fingers

 

Thanks guys for your valuable inputs!!! Keeping fingers crossed! ;)

0

Share this post


Link to post
Share on other sites

Posted (edited)

So did it work?

 

I've just had the same thing with my phone, where it kept rebooting whenever I plugged in or unplugged the USB it reset the last two days, and now today it has died and won't  switch on it was down on charge but I had started recharging it. I've had this phone since January.

 

If it doesn't work does anybody know what Tescos policy is on replacements?

Of course the law of sod means the receipt for the phone sitting in the house 350 miles south of where I bought it but we are moving house this week so I can bring it up and change it if it has to be the same shop.

Edited by eLJay
0

Share this post


Link to post
Share on other sites

Posted (edited)

Motorola Mobility support (UK):

 

0870 901 0555

Very courteous, precise and efficient. The replaced my faulty back shell in 2 days VIA UPS :O - you can spend 6x that amount of time dithering about it on forums. Call them, job sorted in ten mins, and they are so polite and professional (they are located in Edinburgh)

Edited by glossywhite
0

Share this post


Link to post
Share on other sites

Posted (edited)

Followed the advice on the first thread posted above.

Held the power button for at least 2 minutes and put it on the charger.

Now it's charging.

Phew.

 

The other tell tale signs were one of the services reported it wasn't working and

test options came up for it and it also wouldn't connect to the phone provider.

Edited by eLJay
0

Share this post


Link to post
Share on other sites

Posted

Mine did that this weekend, connected to PC and LED came on but flashed funny, connected to wall charger and LED flashed normal, and powered on after holding power button in for around 90 secs to 2 mins.

0

Share this post


Link to post
Share on other sites

Posted

Hi Guys

(late post but....)

 

According to Motorola the answer to a zero charge battery is....

  1. Plug it into the charger 
  2. Hold the VOL DOWN key
  3. While still holding the VOL DOWN key, press and hold the POWER key
  4. Hold both keys down for over 120 seconds.  This is more than two minutes and will seem like a long time. You might want to time yourself to make sure you hold it longer than two minutes. 
  5. After holding the keys down for more than two minutes, release them.
  6. The Flash Boot screen will display, and the Normal Reboot option will be highlighted
  7. Press the VOL UP key and the device will start a normal reboot.

Better than waiting 24 hours ;)

0

Share this post


Link to post
Share on other sites

Posted (edited)

I noticed only some of my chargers seem to cause this issue so I think it may be an issue over the current delivered by certain chargers.

In fact one charger I tried caused it to happen every time.

One way I have found around it seems to be to use a power only charging cable rather than one that includes data.

So it may be an issue over the charger delivering insufficient current when it sees the data connection or the phone reporting it's requirements incorrectly.

Edited by eLJay
0

Share this post


Link to post
Share on other sites

Posted (edited)

Some USB cables have also been known to be an issue.

 

Edit: Sorry I see that this has already been high lighted in an earlier post.

Edited by bill48er
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.