Jump to content
KonstaT

[DEV][ROM][2.7.] CyanogenMod 11 (Android 4.4.4)

Recommended Posts

Hello
Firstly I would like very much to thank you for this great ROM :D
I have one question: is it possible to display the headphones icon when they are connected?
??

Greetings from Poland :)

Share this post


Link to post
Share on other sites

hello, with previous build my batery lasted for 2 days,now when i installed latest rom it only last for 1 day and i use same apps like i did before,is that normal or i need to change batery?

My battery last 10-20 days on my usage. What's the point? There's no known issues with battery drain.

 

However, I noticed that if I select frequently visited pages as a homepage in stock browser, it doesn't work (blank page shown).

Can I do something about it?

Sounds terrible. It must be difficult to live without such useful feature. :P (frequent, but still random homepage - seriously?)

 

WiFi doesn't work, please help! :(

HALP! 'Doesn't work' has never been enough around here. It's known to work.

 

I have a question. It's not a fatal error bug or anything, but it's really bugging me. Does anyone else have a problem with disapearing shortcuts from home screen or even disappearing apps when you switch off your phone and then turn it on. Disappearing shortcuts happen to me every time I switch off and then switch on my phone, and once even my apps disappeared completely so I had to download them again. I should also mention it's always the same three apps in question Aldiko, Clumsy Bird and a sports news app from my country.

 

Part 2 of the question, is it possible that this rom saves apps on SD card? If so than that could answer why my apps disappeared completely (because I was deleting stuff from my SD card and could've accidentally delete the apps), but not the shortcut dissapearing problem.

Settings -> Apps -> ON SD CARD -> 'App name' -> Move to SD card/phone.
 
Are the disappearing apps ones that are on sdcard?

 

I have one question: is it possible to display the headphones icon when they are connected???

This has been removed from Android since gingerbread.
 
And why on earth would anyone need this anyway? How about you look about centimeter higher. There's visual confirmation if you have headphones plugged in or not!
  • Upvote 1

Share this post


Link to post
Share on other sites

Hello

 

I have a problem with the newest version: I did a fresh install of the newest release, and now I can't install The Room 2 anymore. All other apps install perfectly, but this doesn't. Also, the app is not from the market, since I bought it in the Humble Bundle. At first I recovered it from a backup and that failed. After that I tried to install it via the apk, but it didn't install. I thought that maybe the restoring did something that now prevented the app from installing, so I did a fresh install of the ROM and as the first thing tried to install the game, but still it would not install. Previously I was using the 14.1. release. 

 

Has anyone had the same issue? Can you install the game in question? Is there a way to see the application installation log to maybe get a clue about the problem?

 

Thank you very much.

Share this post


Link to post
Share on other sites

Hello

 

I have a problem with the newest version: I did a fresh install of the newest release, and now I can't install The Room 2 anymore. All other apps install perfectly, but this doesn't. Also, the app is not from the market, since I bought it in the Humble Bundle. At first I recovered it from a backup and that failed. After that I tried to install it via the apk, but it didn't install. I thought that maybe the restoring did something that now prevented the app from installing, so I did a fresh install of the ROM and as the first thing tried to install the game, but still it would not install. Previously I was using the 14.1. release. 

 

Has anyone had the same issue? Can you install the game in question? Is there a way to see the application installation log to maybe get a clue about the problem?

 

Thank you very much.

ZTE Blade 3 can't really play games and therefore it's unsupported by many. That could be the problem... I didn't buy this humblebundle cos it has no steam games in it xD 

 

Btw, did u enable "Unknown sources" in Security Settings ? Try disabling the "Verify apps" option as well ....

Share this post


Link to post
Share on other sites

Hi Konstat!

 

Just wanted to say hallo. Now i have Sony Xperia M (C1905). I gave my old ZTE Blade III to my wife, so now she's working on your rom (cm10) and she's very happy about that :) All the instructions, files and support provided from Xperia M devs/users is nothing comparing to what You gave us. Cheers and keep going with your great work!

Share this post


Link to post
Share on other sites

ZTE Blade 3 can't really play games and therefore it's unsupported by many. That could be the problem... I didn't buy this humblebundle cos it has no steam games in it xD 

 

Btw, did u enable "Unknown sources" in Security Settings ? Try disabling the "Verify apps" option as well ....

 

I think that it's not about support, since the game ran perfectly on the 14.1. release. I have enabled Unknown Sources and disabled Verify apps, of course. And as I have less applications installed, than before installing the newest version, it isn't about space either. I think I could be able to solve the problem, if only I could get hold of installation logs and know why it fails. Does anyone know a working app for that? From what I read the Log Viewer doesn't work on JB and newer.

Share this post


Link to post
Share on other sites

When the new update?

I'm building one but Linux is a lot of hassle, I caught 3 kernel panics (ubuntu 14.04 not supported by Virtualbox yet I guess lmfao), 40 application crashes within 1 hour, it takes 10 reboots to get it running (waiting for root device bullshit error)

 

I still can't get it why CM10 is so smoother than cm10.1, cm10.2 and cm11 ...

Because it has fewest hacks and was somehow supported for our SoC ? Kitkat is rly smooth tbh ... Google worked on optimizations in Kitkat but it's still slow as badword compared to other platforms xDDD BECAUSE ANDROID SUCKS ANY1 UNDERSTANDS ? Putting a "VM" (dalvik) with Java (extremely unoptimized, look at Minecraft and how a game with such graphics is lagging on lowend devices) on ARM mobile device won't ever be fast... and it drains battery .. Linux does ... bcos it can't manage a s... it does use CPU more effectively than Windows (=good score in benchmarks) but also drains more power and requires a GOOD CPU to run well ......

 

I think that it's not about support, since the game ran perfectly on the 14.1. release. I have enabled Unknown Sources and disabled Verify apps, of course. And as I have less applications installed, than before installing the newest version, it isn't about space either. I think I could be able to solve the problem, if only I could get hold of installation logs and know why it fails. Does anyone know a working app for that? From what I read the Log Viewer doesn't work on JB and newer.

logcat should work ...
Open Terminal, type su, confirm the dialog, then type: logcat >> /sdcard/sdcard.txt
then you can find sdcard.txt file in the root of your sd card ...
 
My rant I wanna show cos I got it after building the ROM:
"Simply: Never get anything that has to do with Linux (or at least avoid Android) ... I have Windows 8.1 on my old dating PC and it's running considerably faster and more stable than any Linux I've ever had (I had Archlinux, ubuntu, slackware and debian - debian 6.0 was the most stable OS I tried but it isn't intended for daily use because of the outdated packages ... debian 7 is crap) ... .... and planning to get Nokia Lumia (or M$ Phone xD )"

Share this post


Link to post
Share on other sites

ke5MkP6.png

The build is pretty much done as I'm checking now :)

U see ? Windows 8.1 x64 with Xubuntu 14.04 VM .... Lienucks sucks, I'd never put that s*** on my PC again ... when I ran Steam on Linux, then few other apps, the scheduler failed completely to handle such "multitasking scenario" ... it was lagging, freezing every now and then .. simply ... it's a rly bad OS. Brainfuck scheduler from ck/pf kernel kinda solved most of the issues.... but still .. :(

 

I'll upload the build when I get closer to my computer :)

 

@KonstaT If u stop by what is in here? https://github.com/KonstaT/android_device_zte_atlas40/tree/ics_chocolate_rb4.2 cos it looks like something useful... or ? :D

 

Here it is:

https://www.mediafire.com/?5xmpk3l545wghvt

 

The only thing I noticed is a new mobile network toggle in Settings app. I uploaded the flashable zip with "OTA" in its name as the other one failed to flash because of "unexpected end of zip file" ... I have no mobile signal again... few restarts usually fix it.....

Edited by plantroon

Share this post


Link to post
Share on other sites

This ROM is amazing my ZTE Blade 3 now runs great and the battery lasts much longer than the Stock ROM.

I need to use Swap, but the current kernel does not allow it. Could you add support for Swap to the kernel? Please and thank you very much.

Edited by gpablo1

Share this post


Link to post
Share on other sites

This ROM is amazing my ZTE Blade 3 now runs great and the battery lasts much longer than the Stock ROM.

I need to use Swap, but the current kernel does not allow it. Could you add support for Swap to the kernel? Please and thank you very much.

Kernel in this ROM is capable of swap ... You won't get much performance gain by enabling swap. Android 4.4 / Kitkat uses zramswap which is a compressed part of RAM used as swap = much faster but takes more CPU cycles for the compression - still faster than swaping to disk/storage.

Share this post


Link to post
Share on other sites

to KonstaT

when the new update from 4.4.2 rom?

KonstaT doesn't really care about shitty Blade 3 anymore... it's time consuming to build a ROM (it took me tens of hours)

 

When the new update?

Are you blind or you can't read or what ?

Edited by plantroon

Share this post


Link to post
Share on other sites

Can I install this new rom over build cm-11-2014 03 20?

or new clean install?

 

and it what's new?

Edited by D4NY3L

Share this post


Link to post
Share on other sites

to KonstaT

when the new update from 4.4.2 rom?

1st RULE: NEVER ask for ETA.

2nd RULE: Read 1st rule.

3rd RULE: Read 2nd rule.

Share this post


Link to post
Share on other sites

Can I install this new rom over build cm-11-2014 03 20?

or new clean install?

 

and it what's new?

As only few things were updated, you can. Some Settings were moved to different places... other than that I didn't notice anything special

http://www.cyanogenmod.org/blog/this-week-in-cm-apr-26-2014

Edited by plantroon

Share this post


Link to post
Share on other sites

I feel like I broke VoIP :D:D The phone reboots upon starting a call in Hangouts. Skype works fine though. Can any1 test Viber and other VoIP services? (I have no contacts to call on there :( )

Share this post


Link to post
Share on other sites

What's the difference between clean install and installing over existing CM11 rom? I'm kinda new to this entire thing so....

Share this post


Link to post
Share on other sites

ke5MkP6.png

The build is pretty much done as I'm checking now :)

U see ? Windows 8.1 x64 with Xubuntu 14.04 VM .... Lienucks sucks, I'd never put that s*** on my PC again ... when I ran Steam on Linux, then few other apps, the scheduler failed completely to handle such "multitasking scenario" ... it was lagging, freezing every now and then .. simply ... it's a rly bad OS. Brainfuck scheduler from ck/pf kernel kinda solved most of the issues.... but still .. :(

 

I'll upload the build when I get closer to my computer :)

 

@KonstaT If u stop by what is in here? https://github.com/KonstaT/android_device_zte_atlas40/tree/ics_chocolate_rb4.2 cos it looks like something useful... or ? :D

 

Here it is:

https://www.mediafire.com/?5xmpk3l545wghvt

 

The only thing I noticed is a new mobile network toggle in Settings app. I uploaded the flashable zip with "OTA" in its name as the other one failed to flash because of "unexpected end of zip file" ... I have no mobile signal again... few restarts usually fix it.....

 

God bless your soul, sir.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×